Installs, upgrades, downgrades on Opensuse all fail with Segfault

Post here those questions, bug reports and suggestions for SoftMaker Office 2021 for Linux that do not fit in any of the application-specific subforums.
Post Reply
vtpoet
Posts: 177
Joined: Mon Dec 30, 2013 4:55 am

Installs, upgrades, downgrades on Opensuse all fail with Segfault

Post by vtpoet »

Seems that something has changed in Opensuse. It's no longer possible to install, reinstall, or upgrade Softmaker. They all end with a segfault.

Code: Select all

Updating theme hicolor /2 of 2/
Registering MIME types...
Creating /etc/SoftMaker folder...
Installing for user vtpoet
And then everything locks up until one ctrl-c's out of the installation with a segfault. This bug occurs with older versions of SO that previously installed correctly.

Host: neugerig Kernel: 6.0.12-1.ga6c4f4e-default arch: x86_64 bits: 64
Desktop: GNOME v: 45.1 Distro: openSUSE Tumbleweed 20231108

softmaker-office-2021-1046.x86_64.rpm & softmaker-office-2021-1068.x86_64.rpm BTW
payamf
Posts: 4
Joined: Mon Nov 13, 2023 7:44 am

Re: Installs, upgrades, downgrades on Opensuse all fail with Segfault

Post by payamf »

I'm running into the exact same issue on OpenSuse Tumbleweed.
Was previously running version 1064 when I got notification about version 1068.

Code: Select all

Installing that stops at this point
Extracting resource files...
Using existing xdg-utils
Create MIME
Adding document icons. This may take a few minutes...
Updating theme Adwaita /1 of 2/
Updating theme breeze /1 of 2/
Updating theme breeze-dark /1 of 2/
Updating theme hicolor /1 of 2/
Updating theme Adwaita /2 of 2/
Updating theme breeze /2 of 2/
Updating theme breeze-dark /2 of 2/
Updating theme hicolor /2 of 2/
Registering MIME types...
Creating /etc/SoftMaker folder...
Installing for user root
vtpoet
Posts: 177
Joined: Mon Dec 30, 2013 4:55 am

Re: Installs, upgrades, downgrades on Opensuse all fail with Segfault

Post by vtpoet »

Yup. Softmaker is dead as a doornail on Tumbleweed.
payamf
Posts: 4
Joined: Mon Nov 13, 2023 7:44 am

Re: Installs, upgrades, downgrades on Opensuse all fail with Segfault

Post by payamf »

I have contacted Softmaker support to at least get access to a previous version of the rpm (1064 I believe).
It's not on their server and I have not heard back from them.
Anybody have and older rpm?
vtpoet
Posts: 177
Joined: Mon Dec 30, 2013 4:55 am

Re: Installs, upgrades, downgrades on Opensuse all fail with Segfault

Post by vtpoet »

I have an older RPM but it also segfaults. As far as I can tell, as of now SO is pretty much dead in the water as regards Tumbleweed.
vtpoet
Posts: 177
Joined: Mon Dec 30, 2013 4:55 am

Re: Installs, upgrades, downgrades on Opensuse all fail with Segfault

Post by vtpoet »

H̶e̶y̶.̶ ̶G̶o̶o̶d̶ ̶n̶e̶w̶s̶.̶ ̶I̶ ̶u̶n̶i̶n̶s̶t̶a̶l̶l̶e̶d̶ ̶S̶O̶ ̶v̶i̶a̶ ̶Y̶A̶S̶T̶,̶ ̶t̶h̶e̶n̶ ̶r̶e̶i̶n̶s̶t̶a̶l̶l̶e̶d̶.̶ ̶F̶o̶r̶c̶e̶s̶ ̶o̶n̶e̶ ̶t̶o̶ ̶r̶e̶-̶r̶e̶g̶i̶s̶t̶e̶r̶ ̶t̶h̶e̶ ̶p̶r̶o̶d̶u̶c̶t̶ ̶a̶n̶d̶ ̶o̶n̶e̶ ̶l̶o̶s̶e̶s̶ ̶a̶l̶l̶ ̶c̶u̶s̶t̶o̶m̶i̶z̶a̶t̶i̶o̶n̶s̶,̶ ̶b̶u̶t̶ ̶t̶h̶e̶ ̶w̶o̶r̶k̶a̶r̶o̶u̶n̶d̶ ̶g̶e̶t̶s̶ ̶y̶o̶u̶ ̶a̶ ̶f̶u̶n̶c̶t̶i̶o̶n̶i̶n̶g̶ ̶S̶O̶.̶

Oops. Never mind. I accidentally installed Freeoffice. Couldn't upgrade to Softmaker Office. Removed and am trying to install Softmaker Office. Looks like it's locking up again.
SuperTech
SoftMaker Team
SoftMaker Team
Posts: 2909
Joined: Wed Mar 11, 2020 5:31 pm

Re: Installs, upgrades, downgrades on Opensuse all fail with Segfault

Post by SuperTech »

Thank you for reporting this problem. I have forwarded the details to our developer team.
User avatar
bernado82
Posts: 10
Joined: Mon May 18, 2020 5:49 pm
Location: France
Contact:

Re: Installs, upgrades, downgrades on Opensuse all fail with Segfault

Post by bernado82 »

@vtpoet
Your Tumbleweed seems not really up to date, actual version looks like this:

Operating System: openSUSE Tumbleweed 20231117
KDE Plasma Version: 5.27.9 (I'm using KDE Plasma, not Gnome)
KDE Frameworks Version: 5.112.0
Qt Version: 5.15.11
Kernel Version: 6.6.1-1-default (64-bit)

Have you considered upgrading to SoftMaker Office 2024 or NX? It works on openSUSE Tumbleweed and Leap 15.5!

Image

You can install trial versions of Office 2024 and NX alongside version 2021 (but perhaps the file's association will be assigned to the new one?).

Image

@payamf

I'm seeing many older builds available for SoftMaker Office 2021 in YaST Software:

Image
Last edited by bernado82 on Tue Nov 21, 2023 9:43 am, edited 1 time in total.
Image
ChipTunes etc... is my public playlist for Spotify (a truncated version is on Deezer also) with nearly 1800 titles and over 110 hours of listening, go to: open.spotify.com/playlist/1juVxm3beomqM38isNZRIj
payamf
Posts: 4
Joined: Mon Nov 13, 2023 7:44 am

Re: Installs, upgrades, downgrades on Opensuse all fail with Segfault

Post by payamf »

@bernado82

Thanks so much. I had not thought of installing an older version from the repository.
I was able to successfully install version 1064.

I also downloaded a copy to archive just in case. First command lists the available packages in the repository. The second one downloads the specific version, and the third and forth find and copy it from cache to my home directory
zypper pa -ir SoftMaker
sudo zypper -v install -f --download-only 'softmaker-office-2021=2021-1064'
find /var/cache/zypp/packages/ -name "softmaker-office*"
cp /var/cache/zypp/packages/SoftMaker/x86_64/RPMS/softmaker-office-2021-1064.x86_64.rpm ~/.
payamf
Posts: 4
Joined: Mon Nov 13, 2023 7:44 am

Re: Installs, upgrades, downgrades on Opensuse all fail with Segfault

Post by payamf »

I find this weird.
After installing version 1064 through YAST, I decided to be adventurous. I retried installing 1068 using zypper. Same results as before (stalled install).
Killed zypper, rebooted, uninstalled leftover 1064 and 1068 using zypper. Tried installing 1064 (not 1068!) through zypper. It stalled just like version 1068.
Killed zypper, rebooted, uninstalled leftover 1064 using zypper. Successfully installed 1068 through YAST!


Summary:
Installing manually using zypper has stopped working, for any version, it seems.
Installing using YAST software management worked for both versions I tried (1064, 1068).
I now have the latest version installed and working.

Thanks everybody.
miguel-c
SoftMaker Team
SoftMaker Team
Posts: 1230
Joined: Wed Jun 05, 2019 12:02 pm

Re: Installs, upgrades, downgrades on Opensuse all fail with Segfault

Post by miguel-c »

The developers have found a solution:
You should use sudo -E instead of just sudo

We will update the instructions on our website.
Post Reply

Return to “SoftMaker Office 2021 for Linux (General)”