Incorrect table & figure numbering

Post Reply
JohnWasilewski
Posts: 350
Joined: Sun Jan 13, 2008 1:06 am
Location: UK

Incorrect table & figure numbering

Post by JohnWasilewski » Thu Sep 24, 2020 3:31 pm

Please see the email I have sent you today with a document attached.
Email sent: 24 Sep 2020, at 14:33 UK time.

In the document I have sent you, I have used ‘Insert caption’ always - for all Figures and Tables, but TM has given me two table captions, both called ’Table 1’.

Could you please correct the software to prevent this from happening, but please also tell me now, as I can’t wait for this to be fixed in software updates, how can I fix this now, in the document I am currently working on?
---
John
Last edited by JohnWasilewski on Wed Sep 30, 2020 7:11 pm, edited 1 time in total.

SuperTech
SoftMaker Team
SoftMaker Team
Posts: 1416
Joined: Wed Mar 11, 2020 5:31 pm

Re: Incorrect table numbering

Post by SuperTech » Sat Sep 26, 2020 6:33 pm

Thanks for reporting this problem. I checked your document. Please share on which two pages TextMaker is captioning two tables as 'Table 1' and their screenshots.

JohnWasilewski
Posts: 350
Joined: Sun Jan 13, 2008 1:06 am
Location: UK

Re: Incorrect object numbering

Post by JohnWasilewski » Sun Sep 27, 2020 7:17 pm

I cannot post screenshots here because of the sensitive nature of the document but the two tables, both called 'Table 1', are on page 12 and page 21. Also, very simple, just try to insert a cross reference to a table and look at the list of table numbers in the dialog box. You are offered Table 1, Table 2, Table 3 and Table 1.

And in case it might change after saving a file, I have just done this by opening hte email I sent you, opening the document attached to it and using the methods described above to investigate.

Couldn't you find it in either of these ways??
---
John

JohnWasilewski
Posts: 350
Joined: Sun Jan 13, 2008 1:06 am
Location: UK

Re: Incorrect table & figure numbering

Post by JohnWasilewski » Wed Sep 30, 2020 7:18 pm

HELP please!
This problem is getting far, far worse now.

In addition to two tables, both called 'Table 1', TM has numbered no fewer than
EIGHT of my 28 captioned figures, all as 'Figure 1'.

See partial screenshot:
Screenshot 2020-09-30 at 18.15.27.png
I have sent you this document, although it is getting very large now, at 16.5MB
The email was sent today, 30 Sep 2020, at 18:24 UK time.
---
John

SuperTech
SoftMaker Team
SoftMaker Team
Posts: 1416
Joined: Wed Mar 11, 2020 5:31 pm

Re: Incorrect table & figure numbering

Post by SuperTech » Thu Oct 01, 2020 2:56 pm

Thanks for sending the document. I have checked your document and found the followings:

1. The first line in this content page is manual and not a part of the Table of figures so you can verify it by right-clicking on this line and you will not get the option "Update table of figures".

2. Second line downward, please right click and select "Update table of figures", you will see TextMaker will correct everything here.

Thanks for reporting these problems but as you are getting multiple such issues, I recommend you please completely uninstall all versions of SoftMaker Office and install SoftMaker Office 2021 again.

JohnWasilewski
Posts: 350
Joined: Sun Jan 13, 2008 1:06 am
Location: UK

Re: Incorrect table & figure numbering

Post by JohnWasilewski » Thu Oct 01, 2020 5:50 pm

U N S U C C E S F U L

My latest version of the document has had the contents pages regenerated so the bad first lines you mention have gone.

I have tried to correct the numerous repeat captions, 'Figure 1' by deleting those captions and using TM to add new captions to replace them. This has generally worked, with correct caption numbers appearing but I found that the Table of Figures was still completely messed up iith many 'Figure 1' entries - including the ones for which I had re-done the captions. Then, as soon as I have updated teh Table of Figures, the result has been no change for the Contents - Table of Figures still defective, but the Figures themselves, the bad ones, have all changed back to 'Figure 1' as well.

I have therefore DELETED the table of Figures, then gone back over the defective Figure 1 captions, deleted them, and replaced them with new, correct ones. However, after I have then continued working with teh document - writing and editing, I have discovered that all teh Figure numbers I replaced with correct ones, have all revereted to 'Figure 1'.

After this, your message appeared, so I have done what you suggest. I have done exactly this:
1 Uninstall SMO2021 (and I don't have SMO2018 on this Mac)
2 Reboot
3 Install latest SMO2021
4 Start TM2021
5 Open my document
6 Examine the Defective Figure 1s
7 Try using Fn-F9 on some of them - no effect
8 Go to the Contents page (where there is no T of Figures)
9 Use Tools>Generate table of Figures
--> Immediate CRASH of TM2021
10 Use the Restart-after-crash dialog to send a crash report, with the doc.

So, SoftMaker, I am in a complete panic now. I have to send off my final report to clients TONIGHT. Nothing you have done or told me so far has done anything to correct this problem, which you must surely understand is verey serious for me. And it is impossible to make SM show either correct Figures captions, or, most importantly, correct cross references to many of them. This is dire.

What I'm going to do is change the defective Figure numbers manually (to plain text), then bookmark them, then edit the many cross references to point to the bookmarks. A large amount of work I should not have to do, but I cannot keep losing more and more time trying to make TM2021 work properly.

I have just sent you one more copy of my current document.
Emailed, 1 Oct 2020, at 16:54 UK time

Will you please, PLEASE, stop asking me for more copies and more explanations, and page numbers, but investigate this yourselves, and have your developers FIX IT. If there is something I am doing that is causing it, please have your developers provide error traps to prevent this, so that it WORKS.
---
If you want to speak to me, you have my UK number.
---
John

SuperTech
SoftMaker Team
SoftMaker Team
Posts: 1416
Joined: Wed Mar 11, 2020 5:31 pm

Re: Incorrect table & figure numbering

Post by SuperTech » Thu Oct 01, 2020 6:14 pm

Please check the updated file which I sent you through email. What steps I followed:
1. I opened your original file.
2. Scroll to Table of Figures.
3. Right-clicked inside the table of figures > Clicked Update table of figures.

And I think this fixed the file. Please check.

I have already forwarded the crash report and file to our development team for further investigation of this problem.

JohnWasilewski
Posts: 350
Joined: Sun Jan 13, 2008 1:06 am
Location: UK

Re: Incorrect table & figure numbering

Post by JohnWasilewski » Thu Oct 01, 2020 8:56 pm

Yes, in that first version I sent you of the document, the Table of Figures was still working. In THAT document version, I had reported to you that i was getting to TABLE captions, both called 'Table 1'.

It was only later that the problem migrated from Tables captions to Figures captions.
Would you please move onto the more recent versions I have sent by email.
Look in particular for the most recent one. It is version 0.86. Multiple copies of Figure 1.

You seem to be getting nowhere at all with this.
PLEASE LOOK AT all the emails I have sent to Forum (at) Softmaker.de and to Support (at) Softmaker.de
with repeat copies of documents with defective multiple Figure 1 captions.
---
John

SuperTech
SoftMaker Team
SoftMaker Team
Posts: 1416
Joined: Wed Mar 11, 2020 5:31 pm

Re: Incorrect table & figure numbering

Post by SuperTech » Thu Oct 01, 2020 11:55 pm

As I mentioned earlier, I have already forwarded the crash report and file to our development team for further investigation of this problem.

JohnWasilewski
Posts: 350
Joined: Sun Jan 13, 2008 1:06 am
Location: UK

Re: Incorrect table & figure numbering

Post by JohnWasilewski » Fri Oct 02, 2020 12:06 am

OK thanks mate.

Even if you seem not to have been able to find in my documents exactly what I have been asking you to look into, I hope you have impressed on your developers that that this does appear to be a serious problem that urgently needs to be fixed. If your developers would like further information, I will be happy to provide it. Would you please pass on to them my suggestion that I suspect some kind of corruption must have occurred somewhere in the document, which is not visible
in the display but totally screws up the Figure numbering system or index. I suspect this because it was working correctly for a long time and then suddenly it started malfunctioning all the time, including causing TM crashes.

Thank you for trying. I'm sorry you have not yet solved it, and I am sorry also if I have given you a hard time. I'll leave it alone now, unless I discover anything else i can tell you.
---
Yours sincerely,
John

SuperTech
SoftMaker Team
SoftMaker Team
Posts: 1416
Joined: Wed Mar 11, 2020 5:31 pm

Re: Incorrect table & figure numbering

Post by SuperTech » Tue Nov 03, 2020 1:25 pm

Our development team has fixed this problem and the solution will be included in the next service pack of SoftMaker Office.

Thank you

Post Reply

Return to “TextMaker 2021 for Mac”