Dependency problem on OpenSuse Tumbleweed [SOLVED]

Post here those questions, bug reports and suggestions for SoftMaker Office 2018 for Linux that do not fit in any of the application-specific subforums.

Moderator: SoftMaker Team

Post Reply
fawkesjr
Posts: 9
Joined: Thu Oct 25, 2018 8:07 pm

Dependency problem on OpenSuse Tumbleweed [SOLVED]

Post by fawkesjr » Mon Oct 29, 2018 9:00 am

I am trying to install Softmaker 2018 on my OpenSuse Tumbleweed, but I have a dependency problem that I can't solve myself.

When I run the command "sudo zypper in softmaker-office-2018-938.x86_64.rpm" the terminal shows the following reply:
"Problema: nada fornece libidn.so.11()(64bit) que é necessário a softmaker-office-2018-2018-938.x86_64"
In a free translation: Problem: libidn.so.11()(64bit) is necessary to softmaker-office-2018-938.x86_64"

I can't find that package in the repository. How can I solve it?
Last edited by fawkesjr on Sat Nov 10, 2018 6:02 am, edited 1 time in total.

kgha
Posts: 62
Joined: Sat Sep 01, 2012 6:52 pm

Re: Dependency problem on OpenSuse Tumbleweed

Post by kgha » Mon Oct 29, 2018 1:53 pm

I have no experience of OpenSuse, but could this be what you need?
https://software.opensuse.org/package/libidn
Donät know why it doesnät show up in your repo.

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2944
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: Dependency problem on OpenSuse Tumbleweed

Post by martin-k » Mon Oct 29, 2018 2:03 pm

libidn.so.11 was replaced by libidn.so.12, but nobody at the common distribution thought it would be worthwhile to keep backward compatibility. ;-)

We will update SoftMaker Office, but in the meantime you can create a symbolic link in the lib64 folder:

Code: Select all

ln -s libidn.so.12 libidn.so.11
Martin Kotulla
SoftMaker Software GmbH

fawkesjr
Posts: 9
Joined: Thu Oct 25, 2018 8:07 pm

Re: Dependency problem on OpenSuse Tumbleweed

Post by fawkesjr » Mon Oct 29, 2018 5:47 pm

I tried both solution, but none worked for me. Sorry. Do you have any other ideas? Is there any extra information that you need?

fawkesjr
Posts: 9
Joined: Thu Oct 25, 2018 8:07 pm

Re: Dependency problem on OpenSuse Tumbleweed

Post by fawkesjr » Mon Oct 29, 2018 6:02 pm

martin-k wrote:
Mon Oct 29, 2018 2:03 pm
libidn.so.11 was replaced by libidn.so.12, but nobody at the common distribution thought it would be worthwhile to keep backward compatibility. ;-)

We will update SoftMaker Office, but in the meantime you can create a symbolic link in the lib64 folder:

Code: Select all

ln -s libidn.so.12 libidn.so.11
I entered in lib64 folder and could not find libidn.so.12. Is that the reason why your solution didn't work?

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2944
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: Dependency problem on OpenSuse Tumbleweed

Post by martin-k » Mon Oct 29, 2018 7:14 pm

Install libidn with your package manager, then try the ln command.
Martin Kotulla
SoftMaker Software GmbH

fawkesjr
Posts: 9
Joined: Thu Oct 25, 2018 8:07 pm

Re: Dependency problem on OpenSuse Tumbleweed

Post by fawkesjr » Mon Oct 29, 2018 7:58 pm

martin-k wrote:
Mon Oct 29, 2018 7:14 pm
Install libidn with your package manager, then try the ln command.
I could not install libidn from https://software.opensuse.org/package/libidn because of an unespecified error. So I tried to install libidn using this https://software.opensuse.org/package/libidn I followed the instructions, but realized that gcc was not installed, so I installed it. After that the installation showed no error message and I did the ln command you told me to do. Tried to run rpm -i softmaker... and the terminal showed me the same dependency error message.

Any new ideias?

Sorry if I did anything wrong, I am new in opensuse and I have never had this kind of problem before.

sven-l
SoftMaker Team
SoftMaker Team
Posts: 8123
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Dependency problem on OpenSuse Tumbleweed

Post by sven-l » Mon Nov 05, 2018 4:56 pm

Someone solved the issue in the German forum:
https://forum.softmaker.de/viewtopic.ph ... dn#p117219

We are working on a solution for future service packs.
Sven Leßmann
SoftMaker Software GmbH

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2944
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: Dependency problem on OpenSuse Tumbleweed

Post by martin-k » Thu Nov 08, 2018 10:39 am

Service pack 940 has been released today and resolves this problem.
Martin Kotulla
SoftMaker Software GmbH

fawkesjr
Posts: 9
Joined: Thu Oct 25, 2018 8:07 pm

Re: Dependency problem on OpenSuse Tumbleweed

Post by fawkesjr » Sat Nov 10, 2018 6:01 am

I tried to install again today with the new pack and everything is ok now.

Thank you very much for your support. I hope to use SoftMaker as my main office soon.

Post Reply

Return to “SoftMaker Office 2018 for Linux (General)”