Spell check language keeps changing

Questions and answers about TextMaker 2018 for Windows
Post Reply
Kev
Posts: 5
Joined: Tue Feb 05, 2019 9:15 am

Spell check language keeps changing

Post by Kev » Fri Mar 12, 2021 7:20 am

I have always had a problem with the spell checker. I posted 2 years ago but got no help and now I've noticed a bit more detail about it.
I use both English and Japanese, but English is chosen as the default language in Options.
Any document I create starts in English on the Review tab under "Spelling", but the moment I click on the document, it changes to Japanese. When I click on the "Spell check" arrow, and then "options", it shows English is still the default language. So, I go back to the review tab, click on "Spelling", change it back to English and start typing... but it has gone back to Japanese instantly.
It still types in English but the spelling checker has changed itself to Japanese and so English doesn't get checked at all.
My OS is English, and Japanese is added as a Windows language pack.

Jossi
SoftMaker Volunteers
SoftMaker Volunteers
Posts: 1096
Joined: Fri Dec 05, 2003 10:47 pm
Location: Luebeck, Germany

Re: Spell check language keeps changing

Post by Jossi » Fri Mar 12, 2021 11:06 am

Language is also a part of character style, and character style can be a part of paragraph style. Maybe your default character or paragraph style has Japanese as language. When you open the right sidebar, you can check each character and paragraph style in use in your document by selecting one and clicking "Edit...".

Kev
Posts: 5
Joined: Tue Feb 05, 2019 9:15 am

Re: Spell check language keeps changing

Post by Kev » Wed Mar 17, 2021 6:33 am

Thanks for that information. I see under "character" that the language is "default" (English UK) at the start of the document but then I scroll down it changes to "Japanese", on some letters and back to "Default" again later down. I also notice that it sometimes shows "English US". So I'm wondering how it gets changed in different parts of the document.
Anyway, being aware of this means that I can quickly correct it when it occurs. Thanks.

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2882
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: Spell check language keeps changing

Post by martin-k » Wed Mar 17, 2021 10:31 am

It seems you have a text that uses Japanese, but you have not turned on extended support for Asian scripts (see Options dialog).

When you do that, the Character formatting dialog will change, offering to set different font for Western, Asian and Complex scripts. I think this will make clearer what is going on.
Martin Kotulla
SoftMaker Software GmbH

Kev
Posts: 5
Joined: Tue Feb 05, 2019 9:15 am

Re: Spell check language keeps changing

Post by Kev » Thu Mar 18, 2021 9:39 am

Thanks, I'll work with that and see how it goes.

Post Reply

Return to “TextMaker 2018 for Windows”