RESOLVED After installation, SoftMaker Office won't run, & can't be uninstalled

Post here those questions, bug reports and suggestions for SoftMaker Office 2018 for Windows that do not fit in any of the application-specific subforums.
Post Reply
Posts: 3
Joined: Tue Jul 12, 2016 5:54 pm

RESOLVED After installation, SoftMaker Office won't run, & can't be uninstalled

Post by ericscoles » Sat Sep 07, 2019 11:51 pm


Due to the migration glitches mentioned below, the location of the Documents folder was set incorrectly on the new system. Once that was changed, TextMaker started successfully; however, all configuration information had been lost (was never saved, apparently).

I've installed SoftMaker Office 2018 for windows on a new Windows 10 laptop (but see below); it will not run, and cannot be uninstalled using the Apps & features pane in Windows 10 Settings.
  • When attempting to start a SoftMaker Office app, no errors are recorded or reported -- failure is silent.
  • When attempting to uninstall Softmaker Office 2018, the error 'Invalid drive d:\' is returned, & uninstall exits.
I had attempted to migrate from another laptop using Transwiz, which brought across none of the software. When I first tried to reinstall SoftMaker Office on the new system, it failed with an error indicating it was trying to access the template files on D:. I removed the local config folders, & was able (I thought) to successfully install, after which I activated, configured, and then exited via TextMaker.

Now, whenever I try to start one of the SoftMaker Office apps, I get a silent failure. Uninstall also fails as I've described above.

What I've tried so far:
  • Searched the registry for SoftMaker-related keys where the value includes a reference to D:.
What I'm looking for:
  • A way to completely & safely uninstall SoftMaker Office, so I can reinstall from scratch. OR:
  • A way to fix the problem.

Post Reply

Return to “SoftMaker Office 2018 for Windows (General)”