Problem with Brazilian Portuguese characters

Post here those questions, bug reports and suggestions for SoftMaker Office 2018 for Linux that do not fit in any of the application-specific subforums.

Moderator: SoftMaker Team

kgha
Posts: 62
Joined: Sat Sep 01, 2012 6:52 pm

Re: Problem with Brazilian Portuguese characters

Post by kgha » Mon Jun 04, 2018 4:00 pm

The very same problem is present for (some) users of SM2016: viewtopic.php?f=260&t=16658
It persisted in the 2018 Beta version, I reported it here on the forum but it never received a comment from the developers: viewtopic.php?f=294&t=17394
This is also the main reason why I haven't upgraded my 2016 version. I did try the FreeOffice 2018 version, only to find that it was the same there. My post about it never received any comments either: viewtopic.php?f=321&t=17744

sminfo.txt file attached.
Attachments
sminfo.txt
(7.95 KiB) Downloaded 57 times

vtpoet
Posts: 122
Joined: Mon Dec 30, 2013 4:55 am

Re: Problem with Brazilian Portuguese characters

Post by vtpoet » Mon Jun 04, 2018 5:20 pm

Just this morning I noticed that Softmaker upgraded despite my having locked it in Synaptic. I didn't notice until my compose key stopped working. Before downgrading and disabling the PPA (this time), I did some experimenting.

The compose key still functioned, but unpredictably: I could still produce the following: ä, ö, ü, (caplocks + "a) but could not produce the em-dash —, which I use regularly. The following combination caplocks + --- should normally produce the em-dash. Instead it produced this: -- (as if Softmaker had somehow swallowed one of the dashes). Could smart text be interfering? That's my goto theory right now.

Don't know how relevant this is to the other problems, but downgrading immediately fixed the problem. Somewhere and for some reason the newest versions of Softmaker for Linux (will test in windows) are interfering with the compose key.

vtpoet
Posts: 122
Joined: Mon Dec 30, 2013 4:55 am

Re: Problem with Brazilian Portuguese characters

Post by vtpoet » Mon Jun 04, 2018 5:25 pm

kgha wrote:
Mon Jun 04, 2018 4:00 pm
The very same problem is present for (some) users of SM2016: viewtopic.php?f=260&t=16658
It persisted in the 2018 Beta version, I reported it here on the forum but it never received a comment from the developers: viewtopic.php?f=294&t=17394
This is also the main reason why I haven't upgraded my 2016 version. I did try the FreeOffice 2018 version, only to find that it was the same there. My post about it never received any comments either: viewtopic.php?f=321&t=17744

sminfo.txt file attached.
Hey kgha, I didn't do this and should have. If you are still running the offending version of SO, you can use the following parameters in linux to capture what might be going on:

Run TextMaker with the -debug parameter

1.) @ terminal enter textmaker18 -debug

2.) This will log the launch of the software in the file tmlog.txt

And you can also run Textmaker with strace

1.) strace -f textmaker18 2>output.txt

If it's too late, I might have time to try this myself, but as always there's other things I would rather be doing. :roll: And you too probably...

vtpoet
Posts: 122
Joined: Mon Dec 30, 2013 4:55 am

Re: Problem with Brazilian Portuguese characters

Post by vtpoet » Mon Jun 04, 2018 9:02 pm

So, some more information which might be helpful to the Softmaker devs.

Other linux applications have been known to stop functioning with the compose key:

https://unix.stackexchange.com/question ... ompose-key

The solution from the site above:
The solution is to set xim to be used as the default input method by all an applications. The obvious solution would be to set it in the ~/.xsessionrc like

export GTK_IM_MODULE=xim
export XMODIFIERS=@im=xim
export QT_IM_MODULE=xim

But for unknown reasons it just breaks the Compose key for those applications that worked wrong. To do it right you have to call the im-config, and choose there xim as the default input method.
And possibly related:

https://bugs.launchpad.net/ubuntu/+sour ... ug/1573755

And an old report of the same problem on LO:

https://ask.libreoffice.org/en/question ... ther-apps/

So, with a little Googling, this bug is identifiable. Hopefully, if SO's devs have been ignoring the problem (and I don't know that they have been) these reports might give them a place to look as far as SO's buggy behavior with Compose Keys is concerned.

kgha
Posts: 62
Joined: Sat Sep 01, 2012 6:52 pm

Re: Problem with Brazilian Portuguese characters

Post by kgha » Tue Jun 05, 2018 10:39 am

Well, the compose key issue is one thing. SM's weird behavior (in Linux) when it comes to accented characters (the OP topic) is another. A paid-for, commercial programme that's 'intuitive to use' and 'seamlessly compatible' should just work. Even if accents are very rare in German (SM's 'native language') they are not uncommon in Scandinavian languages, English, Dutch - not to mention French, Spanish, Portuguese, Italian...
I can of course use the 'insert symbol' button, but it's incredibly cumbersome compared to simply pressing two keys on the keyboard.
SM beats all other office suits for Linux when it comes to handle docx files, which makes this particular flaw disappointing. Please fix it. Or, at least, please let us know that the developers are trying to do something about it.

sven-l
SoftMaker Team
SoftMaker Team
Posts: 8123
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Problem with Brazilian Portuguese characters

Post by sven-l » Tue Jun 05, 2018 11:06 am

Until now we could not reliable reproduce the issue with the accented characters here. Not even with KDE (it seems most users who report this issue use KDE). It would be nice to have more detailed information about the affected systems because not all information can be found in the sminfo.txt or other log files:

1. Which distribution exactly is used (32bit or 64bit)?
2. When you installed the Linux, which system language, which regional settings and (most important) which keyboard settings and drivers have you chosen in the setup?
3. Have you installed any additional tools that affect or control the keyboard?
4. Which keys exactly did you type in TextMaker to write an accented character?

We need all information you have in order to reproduce and fix the issue. Thank you!
Sven Leßmann
SoftMaker Software GmbH

sven-l
SoftMaker Team
SoftMaker Team
Posts: 8123
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Problem with Brazilian Portuguese characters

Post by sven-l » Tue Jun 05, 2018 11:11 am

vtpoet wrote:
Mon Jun 04, 2018 5:20 pm
...but downgrading immediately fixed the problem. Somewhere and for some reason the newest versions of Softmaker for Linux (will test in windows) are interfering with the compose key.
Have you downgraded on the exact same system?
Sven Leßmann
SoftMaker Software GmbH

kgha
Posts: 62
Joined: Sat Sep 01, 2012 6:52 pm

Re: Problem with Brazilian Portuguese characters

Post by kgha » Tue Jun 05, 2018 3:09 pm

sven-l wrote:
Tue Jun 05, 2018 11:06 am
Until now we could not reliable reproduce the issue with the accented characters here. Not even with KDE (it seems most users who report this issue use KDE). It would be nice to have more detailed information about the affected systems because not all information can be found in the sminfo.txt or other log files:

1. Which distribution exactly is used (32bit or 64bit)?
2. When you installed the Linux, which system language, which regional settings and (most important) which keyboard settings and drivers have you chosen in the setup?
3. Have you installed any additional tools that affect or control the keyboard?
4. Which keys exactly did you type in TextMaker to write an accented character?

We need all information you have in order to reproduce and fix the issue. Thank you!
1: Slackware -current 64bit, MATE desktop (no KDE stuff installed)
2: System language English, no particular regional settings except for clock (CET), Swedish keyboard:

Code: Select all

bash-4.4$ setxkbmap -print -verbose 10
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /etc/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     se
options:    terminate:ctrl_alt_bksp
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+se+inet(evdev)+terminate(ctrl_alt_bksp)
geometry:   pc(pc105)
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+se+inet(evdev)+terminate(ctrl_alt_bksp)"	};
	xkb_geometry  { include "pc(pc105)"	};
};
3: No other tools installed affecting the keyboard

4: Example, acute/grave accents: the accent key is the same on Swedish and German keyboards. I hit the accent key (shift+key for grave accent) and then the letter key, e.g. " '+e " which ought to come out as é (as here, and in every other program) but in Textmaker comes out as 'e. Same with à bientôt (`a bient^ot), while Citroën comes out as Citroen.

vtpoet
Posts: 122
Joined: Mon Dec 30, 2013 4:55 am

Re: Problem with Brazilian Portuguese characters

Post by vtpoet » Wed Jun 06, 2018 12:00 am

sven-l wrote:
Tue Jun 05, 2018 11:11 am
vtpoet wrote:
Mon Jun 04, 2018 5:20 pm
...but downgrading immediately fixed the problem. Somewhere and for some reason the newest versions of Softmaker for Linux (will test in windows) are interfering with the compose key.
Have you downgraded on the exact same system?
Yes. Downgraded on the exact same system:


1. Which distribution exactly is used (32bit or 64bit)?

System: Host: ThinkPad Kernel: 4.10.17-041017-generic x86_64 bits: 64 Desktop: KDE Plasma 5.12.5
Distro: Ubuntu 18.04 LTS
Machine: Device: laptop System: LENOVO product: 20HF0012US v: ThinkPad T470s serial: N/A
Mobo: LENOVO model: 20HF0012US v: SDK0J40697 WIN serial: N/A
UEFI: LENOVO v: N1WET31W (1.10 ) date: 04/17/2017

2. When you installed the Linux, which system language, which regional settings and (most important) which keyboard settings and drivers have you chosen in the setup?

System Language: English
Regional Setting: New York US
Keyboard Settings: English (intl. with AltGr dead keys) & German (de)

3. Have you installed any additional tools that affect or control the keyboard?

Set Compose Key to CapsLock

4. Which keys exactly did you type in TextMaker to write an accented character?

So, interestingly, the em-dash was the key affected by the upgrade. As I wrote, invoking the em-dash requires: CapsLock + ---

That gets you: —

Currently using:

apt policy softmaker*
softmaker-office-2018:
Installed: 2786
Candidate: 2786
Version table:
*** 2786 100
100 /var/lib/dpkg/status

If I upgrade, the compose key for the em-dash stops working. This is reproducible %100 of the time. When I press the first of the three dashes after Capslock, it doesn't appear, then the second two appear.

sven-l
SoftMaker Team
SoftMaker Team
Posts: 8123
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Problem with Brazilian Portuguese characters

Post by sven-l » Wed Jun 06, 2018 10:15 am

vtpoet wrote:
Wed Jun 06, 2018 12:00 am
sven-l wrote:
Tue Jun 05, 2018 11:11 am
vtpoet wrote:
Mon Jun 04, 2018 5:20 pm
...but downgrading immediately fixed the problem. Somewhere and for some reason the newest versions of Softmaker for Linux (will test in windows) are interfering with the compose key.
Have you downgraded on the exact same system?
Yes. Downgraded on the exact same system:


1. Which distribution exactly is used (32bit or 64bit)?

System: Host: ThinkPad Kernel: 4.10.17-041017-generic x86_64 bits: 64 Desktop: KDE Plasma 5.12.5
Distro: Ubuntu 18.04 LTS
Machine: Device: laptop System: LENOVO product: 20HF0012US v: ThinkPad T470s serial: N/A
Mobo: LENOVO model: 20HF0012US v: SDK0J40697 WIN serial: N/A
UEFI: LENOVO v: N1WET31W (1.10 ) date: 04/17/2017

2. When you installed the Linux, which system language, which regional settings and (most important) which keyboard settings and drivers have you chosen in the setup?

System Language: English
Regional Setting: New York US
Keyboard Settings: English (intl. with AltGr dead keys) & German (de)

3. Have you installed any additional tools that affect or control the keyboard?

Set Compose Key to CapsLock

4. Which keys exactly did you type in TextMaker to write an accented character?

So, interestingly, the em-dash was the key affected by the upgrade. As I wrote, invoking the em-dash requires: CapsLock + ---

That gets you: —

Currently using:

apt policy softmaker*
softmaker-office-2018:
Installed: 2786
Candidate: 2786
Version table:
*** 2786 100
100 /var/lib/dpkg/status

If I upgrade, the compose key for the em-dash stops working. This is reproducible %100 of the time. When I press the first of the three dashes after Capslock, it doesn't appear, then the second two appear.
Ok, thank you! We can now reproduce the problem with compose key + - - - (3x minus key). We will report this to the developers.
Sven Leßmann
SoftMaker Software GmbH

n-p
SoftMaker Team
SoftMaker Team
Posts: 15
Joined: Mon Nov 23, 2015 2:53 pm

Re: Problem with Brazilian Portuguese characters

Post by n-p » Wed Jun 06, 2018 1:09 pm

kgha wrote:
Tue Jun 05, 2018 3:09 pm
1: Slackware -current 64bit, MATE desktop (no KDE stuff installed)

2: System language English, no particular regional settings except for clock (CET), Swedish keyboard:

3: No other tools installed affecting the keyboard

4: Example, acute/grave accents: the accent key is the same on Swedish and German keyboards. I hit the accent key (shift+key for grave accent) and then the letter key, e.g. " '+e " which ought to come out as é (as here, and in every other program) but in Textmaker comes out as 'e. Same with à bientôt (`a bient^ot), while Citroën comes out as Citroen.
We tried reproducing the issue with your very environment. We set up a test environment as follows:

1. OS: Slackware 14.2 (64-bit) with MATE 1.20.1

2. System language: en_US; keyboard language: Swedish

3. No additional tools were installed.

4. Both typing accented characters via "<accent key>+<character>" and using the compose key worked without any problems. For example, "´+e" becomes "é" and "SHIFT+´+e" becomes "è".

So unfortunately, we were still not able to reproduce the problems you describe.

Please find a screenshot attached which shows the specs of our test system. Maybe you could have a look and check if you find any differences compared to your system so we can figure out what might cause the problems.
Attachments
slackware_screenshot.PNG

n-p
SoftMaker Team
SoftMaker Team
Posts: 15
Joined: Mon Nov 23, 2015 2:53 pm

Re: Problem with Brazilian Portuguese characters

Post by n-p » Wed Jun 06, 2018 1:17 pm

@kgha: Could you please also check the status of the checkbox "Use XIM" in the "System" tab of the TextMaker options?
Is it checked, unchecked or grayed out?

kgha
Posts: 62
Joined: Sat Sep 01, 2012 6:52 pm

Re: Problem with Brazilian Portuguese characters

Post by kgha » Wed Jun 06, 2018 5:50 pm

Thanks, n-p, for your efforts.

I see no significant differences in outputs of cat /etc/*-release and file /sbin/init :

Code: Select all

bash-4.4$ cat /etc/*-release
NAME=Slackware
VERSION="14.2"
ID=slackware
VERSION_ID=14.2
PRETTY_NAME="Slackware 14.2 x86_64 (post 14.2 -current)"
ANSI_COLOR="0;34"
CPE_NAME="cpe:/o:slackware:slackware_linux:14.2"
HOME_URL="http://slackware.com/"
SUPPORT_URL="http://www.linuxquestions.org/questions/slackware-14/"
BUG_REPORT_URL="http://www.linuxquestions.org/questions/slackware-14/"
VERSION_CODENAME=current

bash-4.4$ file /sbin/init
/sbin/init: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, stripped

I can disable/enable XIM, makes no difference.

Don't know if the information in this old post is of any help - a 'workaround' that unfortunately creates other problems:
viewtopic.php?f=260&t=16658#p56775

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2870
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: Problem with Brazilian Portuguese characters

Post by martin-k » Wed Jun 06, 2018 6:51 pm

The side effect is because UTF8 was not added.

Can you try this:

export LANG=sv_SE.UTF-8
textmaker18
Martin Kotulla
SoftMaker Software GmbH

kgha
Posts: 62
Joined: Sat Sep 01, 2012 6:52 pm

Re: Problem with Brazilian Portuguese characters

Post by kgha » Wed Jun 06, 2018 7:55 pm

Holy mackerel, it works! Thanks, martin-k, I just wish that someone had told me this earlier!
I get a warning which I guess can be disregarded:

Code: Select all

(process:28031): Gtk-WARNING **: 19:47:57.949: Locale not supported by C library.
	Using the fallback 'C' locale.
I've added the line to the /usr/bin/textmaker16 file so now it starts as desired. And I can seriously reflect on upgrading from SM2016

Still a mystery why this workaround is necessary, though.

Post Reply

Return to “SoftMaker Office 2018 for Linux (General)”