SMO2018/2021 clash with 'apt-get update'

Post here those questions, bug reports and suggestions for SoftMaker Office 2021 for Linux that do not fit in any of the application-specific subforums.
Post Reply
JohnWasilewski
Posts: 350
Joined: Sun Jan 13, 2008 1:06 am
Location: UK

SMO2018/2021 clash with 'apt-get update'

Post by JohnWasilewski » Tue Jun 09, 2020 1:18 pm

I have a Linux Zorin system (Ubuntu derivative), which uses .deb install files. After installing SMO-2121 by following the Debian-installation instructions on https://www.softmaker.com/en/tips-linux, I have been finding that

Code: Select all

sudo apt-get update
returns this error message

Code: Select all

E: Repository 'http://shop.softmaker.com/repo/apt wheezy InRelease' changed its 'Label' value from 'SoftMaker Office 2018' to 'SoftMaker Office'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
Please could I have a further Linux CLI terminal command to clear this?
---
John
Last edited by JohnWasilewski on Wed Jul 01, 2020 1:22 pm, edited 1 time in total.

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2882
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: SMO2018/2021 clash with 'apt-get update'

Post by martin-k » Tue Jun 09, 2020 1:31 pm

Yes, that was a bit of a surprise for us. Just a small rewording causes Linux to throw an incomprehensible warning :-(

Please run sudo apt update and confirm.
Martin Kotulla
SoftMaker Software GmbH

freelsjd
Posts: 12
Joined: Thu Nov 19, 2015 12:08 am

Re: SMO2018/2021 clash with 'apt-get update'

Post by freelsjd » Tue Jun 09, 2020 2:17 pm

Same error and message here. While at it, perhaps with Debian anyway, the folder name "wheezy" is very much out of date. The current release is "buster" and some release in between also. Debian is released approximately every 2 years. Check update from the app directly works fine.

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2882
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: SMO2018/2021 clash with 'apt-get update'

Post by martin-k » Tue Jun 09, 2020 2:21 pm

The name "wheezy" in our repository has no meaning whatsoever. While historically it was set by us to indicate compatibility with Debian Wheezy, it can be any arbitrary name, even pretzel or sauerkraut :-)

We cannot change it anymore because the add_apt_repo.sh script references it.
Martin Kotulla
SoftMaker Software GmbH

JohnWasilewski
Posts: 350
Joined: Sun Jan 13, 2008 1:06 am
Location: UK

Re: SMO2018/2021 clash with 'apt-get update'

Post by JohnWasilewski » Tue Jun 09, 2020 3:07 pm

I have tried two solutions:

1

Code: Select all

$ sudo aptitude update
:
:
E: Repository 'http://shop.softmaker.com/repo/apt wheezy InRelease' changed its 'Label' value from 'SoftMaker Office 2018' to 'SoftMaker Office'
E: Failed to download some files
W: Failed to fetch http://shop.softmaker.com/repo/apt/dists/wheezy/InRelease: 
E: Some index files failed to download. They have been ignored, or old ones used instead.

2
(Note the user intervention 'y' after the [y/N] prompt in the 7th-last line)

Code: Select all

$ sudo apt update
:
:
E: Repository 'http://shop.softmaker.com/repo/apt wheezy InRelease' changed its 'Label' value from 'SoftMaker Office 2018' to 'SoftMaker Office'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
Do you want to accept these changes and continue updating from this repository? [y/N]  y
Get:31 http://shop.softmaker.com/repo/apt wheezy/non-free amd64 Packages [825 B]
Fetched 3,137 B in 12s (268 B/s)                                               
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up-to-date.
After this, repeating either sudo apt update OR sudo-apt-get update OR sudo-aptitude update no longer throws an error.
---
John

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2882
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: SMO2018/2021 clash with 'apt-get update'

Post by martin-k » Tue Jun 09, 2020 3:15 pm

JohnWasilewski wrote:
Tue Jun 09, 2020 3:07 pm
(Note the user intervention 'y' after the [y/N] prompt in the 7th-last line)
That's what I mean with "confirm" when I wrote "Please run sudo apt update and confirm."
Martin Kotulla
SoftMaker Software GmbH

JohnWasilewski
Posts: 350
Joined: Sun Jan 13, 2008 1:06 am
Location: UK

Re: SMO2018/2021 clash with 'apt-get update'

Post by JohnWasilewski » Tue Jun 09, 2020 3:59 pm

Sorry Martin - I did misunderstand you.
I thought you meant 'confirm the same problem with apt as with apt-get.'
My silly mistake.
J.

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2882
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: SMO2018/2021 clash with 'apt-get update'

Post by martin-k » Tue Jun 09, 2020 4:06 pm

Ah, my bad. Ambiguous wording ;-)
Martin Kotulla
SoftMaker Software GmbH

freelsjd
Posts: 12
Joined: Thu Nov 19, 2015 12:08 am

Re: SMO2018/2021 clash with 'apt-get update'

Post by freelsjd » Tue Jun 09, 2020 5:54 pm

Seems to work fine here now. Thanks.

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2882
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: SMO2018/2021 clash with 'apt-get update'

Post by martin-k » Tue Jun 09, 2020 5:54 pm

:-)
Martin Kotulla
SoftMaker Software GmbH

freelsjd
Posts: 12
Joined: Thu Nov 19, 2015 12:08 am

Re: SMO2018/2021 clash with 'apt-get update'

Post by freelsjd » Tue Jun 09, 2020 5:59 pm

martin-k wrote:
Tue Jun 09, 2020 2:21 pm
The name "wheezy" in our repository has no meaning whatsoever. While historically it was set by us to indicate compatibility with Debian Wheezy, it can be any arbitrary name, even pretzel or sauerkraut :-)

We cannot change it anymore because the add_apt_repo.sh script references it.
I hear you and I understand. However, from a USER standpoint, this is confusing. If I put anything except wheezy in that location, it will not update. wheezy is the name of a very old debian distribution that very few people still use, and not sure if it is still supported by the debian project for security patches. This could possibly cause a potential debian customer to think your software is "old", which of course it is NOT !

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2882
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: SMO2018/2021 clash with 'apt-get update'

Post by martin-k » Tue Jun 09, 2020 6:01 pm

I see the problem but this is something we cannot change anymore, and again, it's just optics.
Martin Kotulla
SoftMaker Software GmbH

Post Reply

Return to “SoftMaker Office 2021 for Linux (General)”