Unable to print anything

Post Reply
Posts: 1
Joined: Sat Mar 27, 2021 9:07 pm

Unable to print anything

Post by SeonaidMairi » Sat Mar 27, 2021 9:38 pm

I have just purchased TextMaker 2021 for Mac as, after upgrading to Mac Big Sur 11.2.3 my old version of Microsoft Word would no longer work. However, I find I am totally unable to print anything from TextMaker. I have tried choosing both the actual printer and the Apple Print Dialogue from the Print menu. Nothing at all happens unless I choose Apple Print Dialogue; then the print command appears to have been accepted, but nothing appears in the print queue and nothing prints. I have tried exporting the document to PDF but that doesn't work either. I am trying to print wirelessly to an Epson XP-860 series printer and have never had any difficulty printing to it from any other programme.

SoftMaker Team
SoftMaker Team
Posts: 1415
Joined: Wed Mar 11, 2020 5:31 pm

Re: Unable to print anything

Post by SuperTech » Wed Mar 31, 2021 9:17 pm

As you are unable to export to PDF, it seems the problem is not related to printer but related to operating system and permissions. Please try these steps and then check printing again:
a) Go to 'System preferences" in mac.
b) Click on the security/privacy icon.
c) In the left-hand column find "Full disk access”.
d) In the bottom left corner unlock the lock which allows you to make a change.
e) Now on the right panel check the box "T" for TextMaker 2021 application.
g) Now lock the lock again down the left-hand corner.
h) Proceed back to TextMaker application and try to print and Export to PDF to check if that worked or not.

Post Reply

Return to “TextMaker 2021 for Mac”