I can't persistently disable automatic hyphenation.

Questions and answers about FreeOffice TextMaker 2018 for Linux
Post Reply
jairoraiol
Posts: 13
Joined: Fri Aug 09, 2019 4:48 am

I can't persistently disable automatic hyphenation.

Post by jairoraiol » Sat Sep 21, 2019 6:26 pm

First of all, I want to say that I admire this work very much.
Also, I already have the updated SoftMaker FreeOffice 2018 (rev 971.0912).

I can't persistently disable automatic hyphenation.

Each time I open TextMaker, automatic hyphenation is enabled again.


Grateful for the attention.

Jairo Raiol

OS: 64-bit Linux (BSD)
Language: Portuguese (Brazil)

miguel-c
SoftMaker Team
SoftMaker Team
Posts: 586
Joined: Wed Jun 05, 2019 12:02 pm

Re: I can't persistently disable automatic hyphenation.

Post by miguel-c » Sat Sep 21, 2019 6:46 pm

Hi, don't take me wrong, but it's better to search before asking questions :D :
https://forum.softmaker.com/search.php? ... yphenation

jairoraiol
Posts: 13
Joined: Fri Aug 09, 2019 4:48 am

Re: I can't persistently disable automatic hyphenation.

Post by jairoraiol » Sat Sep 21, 2019 9:36 pm

miguel-c wrote:
Sat Sep 21, 2019 6:46 pm
Hi, don't take me wrong, but it's better to search before asking questions :D :
https://forum.softmaker.com/search.php? ... yphenation
Hi, don't get me wrong either, but I rarely do research before, as my time is so short and I don't think this can negatively affect your work.

Unfortunately this reading was not helpful.

If FreeOffice development is not focused on the user workflow, then I might disregard the use of this promising software.

FreeOfice seems to have potential to replace the Chinese office suite, but I'm starting to get discouraged.


Grateful for any consideration.

Jairo Raiol

miguel-c
SoftMaker Team
SoftMaker Team
Posts: 586
Joined: Wed Jun 05, 2019 12:02 pm

Re: I can't persistently disable automatic hyphenation.

Post by miguel-c » Sat Sep 21, 2019 11:22 pm

FreeOffice is free. A little bit of researching is expected, otherwise we wouldn't be able to maintain this forum.

jairoraiol
Posts: 13
Joined: Fri Aug 09, 2019 4:48 am

Re: I can't persistently disable automatic hyphenation.

Post by jairoraiol » Sun Sep 22, 2019 3:51 am

miguel-c wrote:
Sat Sep 21, 2019 11:22 pm
FreeOffice is free. A little bit of researching is expected, otherwise we wouldn't be able to maintain this forum.
I'm sorry, I don't think I made it clear what I did.

I clicked on the link you posted, read it, but didn't get a solution to the problem I'm having.

And I also got the idea that user workflow is not so important to developers.

I respect your work very much, but I believe that developing in partnership with the user will benefit everyone.


Anyway, I'm rooting for your success.

Jairo Raiol

miguel-c
SoftMaker Team
SoftMaker Team
Posts: 586
Joined: Wed Jun 05, 2019 12:02 pm

Re: I can't persistently disable automatic hyphenation.

Post by miguel-c » Sun Sep 22, 2019 5:22 pm

This is how hyphenation works:
1. There is a paragraph setting for hyphenation. Each paragraph may have it on or off.
2. This is also available through the paragraph style.
3. As a master override switch, there is a global setting "Hyphenate". When off, the paragraph or paragraph style setting is ignored.
This "global" setting is per-document.
if you create a new document, it inherits the global setting from the template file, but after that, the connection between document and template is cut.

So, after this explanation, if you wish that all of your future new documents have hyphenation off:
1.create a new blank document
2.right click the blank area
3. Paragraph style
4. Normal
5. Edit...
6. Text Flow
7. Hyphenation: None
8. Save the document as your default template: normal.tmvx

We'd like to have a better way, but unfortunately there are many constraints envolved. Maybe in the future.

jairoraiol
Posts: 13
Joined: Fri Aug 09, 2019 4:48 am

Re: I can't persistently disable automatic hyphenation.

Post by jairoraiol » Sun Sep 22, 2019 10:23 pm

miguel-c wrote:
Sun Sep 22, 2019 5:22 pm
This is how hyphenation works:
1. There is a paragraph setting for hyphenation. Each paragraph may have it on or off.
2. This is also available through the paragraph style.
3. As a master override switch, there is a global setting "Hyphenate". When off, the paragraph or paragraph style setting is ignored.
This "global" setting is per-document.
if you create a new document, it inherits the global setting from the template file, but after that, the connection between document and template is cut.

So, after this explanation, if you wish that all of your future new documents have hyphenation off:
1.create a new blank document
2.right click the blank area
3. Paragraph style
4. Normal
5. Edit...
6. Text Flow
7. Hyphenation: None
8. Save the document as your default template: normal.tmvx

We'd like to have a better way, but unfortunately there are many constraints envolved. Maybe in the future.
Thanks for answering.

As I said earlier, I had read this script.

I can only say "unfortunately", too.

Post Reply

Return to “FreeOffice TextMaker 2018 for Linux”