Spell cheking not working

Post your questions, bug reports and suggestions here for FreeOffice TextMaker 2018 for Linux

Moderator: SoftMaker Team

Post Reply
jfe
Posts: 11
Joined: Tue May 22, 2018 8:45 am

Spell cheking not working

Post by jfe » Wed Jun 20, 2018 7:12 am

I use both English and Hebrew when writing. I cannot get spellcheck for either languages. When writing the text
sdfs sdfds sdfds

sdf
I see no red underline, clicking review > spell check brings up the popup "no misspelled words detected". File > options > Language has the "use background spell-checking" checked, includes only Hebrew (I assume that English is installed by default.

I am running Linux 4.16.8-1-ARCH

Jossi
SoftMaker Volunteers
SoftMaker Volunteers
Posts: 967
Joined: Fri Dec 05, 2003 10:47 pm
Location: Luebeck, Germany

Re: Spell cheking not working

Post by Jossi » Wed Jun 20, 2018 10:59 am

Select some English or Hebrew text, then go to Format > Character... Is the correct language indicated?

jfe
Posts: 11
Joined: Tue May 22, 2018 8:45 am

Re: Spell cheking not working

Post by jfe » Thu Jun 21, 2018 7:40 am

Where should I see that?
b.png
a.png
a.png (20.27 KiB) Viewed 1075 times

Jossi
SoftMaker Volunteers
SoftMaker Volunteers
Posts: 967
Joined: Fri Dec 05, 2003 10:47 pm
Location: Luebeck, Germany

Re: Spell cheking not working

Post by Jossi » Thu Jun 21, 2018 10:30 am

In the context menu shown in your screenshot, click "Character...".

jfe
Posts: 11
Joined: Tue May 22, 2018 8:45 am

Re: Spell cheking not working

Post by jfe » Thu Jun 21, 2018 1:16 pm

I think so. This is what I see
d.png
c.png

Jossi
SoftMaker Volunteers
SoftMaker Volunteers
Posts: 967
Joined: Fri Dec 05, 2003 10:47 pm
Location: Luebeck, Germany

Re: Spell cheking not working

Post by Jossi » Thu Jun 21, 2018 3:27 pm

In the upper right corner of the dialogue there is the field "Language". It shows which language the selected text has. So, if it is a text in English, "English (United States)" or "English (UK)" is fine. If it shows "Default", as with the Hebrew text in your first screenshot, it is the language which was defined as Default language in Tools > Options..., tab "Language". If Hebrew is not your default language, you must change the language of the text from "Default" to "Hebrew".

jfe
Posts: 11
Joined: Tue May 22, 2018 8:45 am

Re: Spell cheking not working

Post by jfe » Thu Jun 21, 2018 5:25 pm

Okay, so now I got Hebrew to work. I wonder if that is because I manually installed the Hebrew dictionary but not English.
a.png
According to http://www.freeoffice.com/en/support/ti ... ctionaries English is pre installed so maybe not...

jfe
Posts: 11
Joined: Tue May 22, 2018 8:45 am

Re: Spell cheking not working

Post by jfe » Sun Aug 12, 2018 9:20 pm

any ideas why English does not work?

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7999
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Spell cheking not working

Post by sven-l » Wed Aug 22, 2018 10:15 am

Please check the following steps in case that the spell checker (F7) does not work properly:

1. Select your text and invoke Format=>Character. Make sure that the language for the selected text is set to "English" for english text and "Hebrew" for Hebrew text.

2. Invoke Tools=>Options=>Language and set the default language to "English" or whatever your default language should be. Also make sure that there is a green tick next to every language entry you need. This indicates that the corresponding spell check dictionary is correctly installed. If the green tick is missing for your language, please start the Setup of SoftMaker Office again and perform a complete installation. This will install al dictionaries. You will not lose any settings with that new installation.

3. Make sure that the spell checker is enabled in Tools=>Options=>Language
Sven Leßmann
SoftMaker Software GmbH

jfe
Posts: 11
Joined: Tue May 22, 2018 8:45 am

Re: Spell cheking not working

Post by jfe » Thu Aug 30, 2018 10:38 pm

I was able to fix it. I downloaded the English dictionary from here: https://www.softmaker.com/en/downloads/dictionaries . I assumed that it came preinstalled with English, but I guess not.

Post Reply

Return to “FreeOffice TextMaker 2018 for Linux”