Unable to get a product key

General questions and answers about FreeOffice 2018 for Linux. Don't post application-specific questions here, but in the appropriate subforum.
Post Reply
Posts: 2
Joined: Thu Oct 04, 2018 8:51 am

Unable to get a product key

Post by Ceel » Fri Oct 05, 2018 2:56 pm


I've downloaded freeoffice 2018 (rev 934, 32bits) and installed it. All went well till I have to enter my product key:
  • I never receive the product key after I downloaded the .tgz file (and it is not in spams; I've already meat this issue with freeoffice 2016 but I gave up because my free office 2012 worked well; and same when I download FlexyPdf basic, no product key :( )
  • If I tryed to use my old key, I get the message "This product key is for an old version, please insert a product key for this version"...
  • When I clicked on "Product key lost or invalid?" I get the message "Cannot start the web browser."... but my web browser, Pale Moon, works like a charm (and I did a try with QtWeb too).
How can I receive a new product key?

Thanks in advance.

Btw, there is a little error @ https://www.freeoffice.com/en/tips-and-tricks-linux; in the Installation on other systems section:
If you use a 32-bit Linux system:
tar xvzf softmaker-freeoffice-2018-934-i386.tgz
The right name of the .tgz file is softmaker-freeoffice-934-i386.tgz; same error for 64bit system.

SoftMaker Team
SoftMaker Team
Posts: 6480
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg

Re: Unable to get a product key

Post by sven-l » Mon Oct 15, 2018 5:09 pm

I sent you another product key to the e-mail address you used to register your forum account.
Sven Leßmann
SoftMaker Software GmbH

Posts: 2
Joined: Thu Oct 04, 2018 8:51 am

Re: Unable to get a product key

Post by Ceel » Fri Oct 19, 2018 3:00 pm

Thanks a lot!

Posts: 1
Joined: Thu Jan 16, 2020 3:58 pm

Re: Unable to get a product key

Post by marlon85ca » Thu Jan 16, 2020 4:21 pm

I have a similar problem. I live in Cuba and I use this office suit in my work. Our internet acces is made throug a proxy, and your sotfware haven't a configuration (at less on the gui) to manage that. I think that the proxy is the cause wich i obtain the error of connection with the server. I'm on the end of the freeoffice trial period and i couldn't obtain the product key. If you include in the website an option to obtain the key, will be very nice. And offcoure... can enyone of the support staff send me a key of the freeoffice 2018 for linux (im using Ubuntu 18.04 64bits). Thanks

SoftMaker Team
SoftMaker Team
Posts: 907
Joined: Wed Jun 05, 2019 12:02 pm

Re: Unable to get a product key

Post by miguel-c » Thu Jan 16, 2020 7:38 pm

You should configure your Windows or Linux system to use the proxy systemwide, and then SoftMaker Office and FreeOffice will use it.
In Windows it's done in internet explorer. In windows 10 look for proxy in the start menu.

In Linux, it depends on you distro.
In ubuntu:
Open System Settings in Ubuntu.
Under Hardware, click on Network
On the left hand side plane, click on Network Proxy
In the Method drop down list, choose Manual
Fill up the http and https proxy. No need to set ftp and socks proxy.
Click on Apply system wide.

Post Reply

Return to “FreeOffice 2018 for Linux (General)”