Font not recognized

General questions and answers about FreeOffice 2018 for Linux. Don't post application-specific questions here, but in the appropriate subforum.
Post Reply
martinrinconbotero
Posts: 4
Joined: Sun Jul 05, 2020 5:25 pm

Font not recognized

Post by martinrinconbotero » Fri Jul 17, 2020 11:16 pm

Hello,

I installed a replacement for the Latin Modern font, by simply replacing the Latin Modern fonts in my system with a thicker version of them, on Ubuntu 18.04.. Whether before or after the font replacement was the Office recognizing the font in its various sizes (LMRoman 10, 12, etc.), but shows only 10. The version that it still uses is the old version, which I have no idea where it takes it from, since it doesn't exist in my system anymore. Does Softmaker Office has its own catalog/directory of fonts? How can I make it use only my system's fonts? Going to Options > Fonts, didn't help, since it only shows the same fonts I see. This is btw. not an issue in LibreOffice or other programs, where I can access the Latin Modern font in all its forms and sizes only in the version that I installed.

On a side note the font TEX Gyra Schola shows incorrect characters (maybe Polish?) when typing ñ, ê, and æ. The problem btw. doesn't happen in all other programs.

Regards,
Martín.

SuperTech
SoftMaker Team
SoftMaker Team
Posts: 692
Joined: Wed Mar 11, 2020 5:31 pm

Re: Font not recognized

Post by SuperTech » Tue Jul 21, 2020 2:06 pm

Thanks for reporting this problem. Please share the font file which you installed, the screenshot of your system vs FreeOffice conflict and your TextMaker file which is showing wrong characters.

Please make sure that you restarted your computer after the installation of new fonts on Linux.

Also, share your sminfo file which you can generate by clicking on '?' > About > Write system information.

martinrinconbotero
Posts: 4
Joined: Sun Jul 05, 2020 5:25 pm

Re: Font not recognized

Post by martinrinconbotero » Wed Jul 29, 2020 6:43 pm

Hello,

sorry for the delay in answering. The files I installed are all here https://github.com/jagd/fakebold/releas ... lm-otf.zip, taken from this article https://thedrwu.com/posts/thicker-lm/. These fonts simply replace the Latin Modern Roman fonts (in .otf format) that I had in my system for a thicker version of them. Since I already had the Latin Modern Roman font installed and Ubuntu recognizes the new fonts as if they were already installed, I just simply replaced the fonts in /usr/share/texmf/fonts/opentype/public/lm. That replacement works as expected in Libreoffice and LyX but not in Softmaker Office. The latter shows a font lmroman 10, which I don't know where it finds, since what happens is that I type using that font, and it corresponds visually to the old thinner LM font that I replaced with the new one!
LM font.png
For the second problem of the TeX Gyre Schola font, here is a screenshot (by accident I also discovered that the C059 doesn't have bold characters in Softmaker Office).
TeXGyreSchola.png
The TextMaker file is irrelevant. Both examples were made with a new file.

Best regards,
Martín.

martinrinconbotero
Posts: 4
Joined: Sun Jul 05, 2020 5:25 pm

Re: Font not recognized

Post by martinrinconbotero » Wed Jul 29, 2020 6:47 pm

Sorry for the shade of the app I used for taking the screenshots. I just discovered that I can simply use the "Print" key of my keyboard :roll:

SuperTech
SoftMaker Team
SoftMaker Team
Posts: 692
Joined: Wed Mar 11, 2020 5:31 pm

Re: Font not recognized

Post by SuperTech » Thu Jul 30, 2020 12:43 am

Please check the font list in ribbon File | Options | Fonts and share the screenshot also. I added LM Roman 10, 12 and 17 and they are showing correctly in TextMaker. As I can see in the screenshot you shared on TextMaker you selected LM Roman 10 and on another application, you selected LM Roman 12 which are different.

Thanks

Post Reply

Return to “FreeOffice 2018 for Linux (General)”