Input Lag

Post here those questions, bug reports and suggestions for SoftMaker FreeOffice 2018 for Windows that do not fit in any of the application-specific subforums.

Moderator: SoftMaker Team

Post Reply
muhlisgursoy
Posts: 1
Joined: Mon Aug 12, 2019 9:40 pm

Input Lag

Post by muhlisgursoy » Mon Aug 12, 2019 9:44 pm

Hi,

I'm using Softoffice (Free Edition). The problem is, when I'm writing on PlanMaker or TextMaker, it lags. It starts to lag a few minutes after using it. How can I prevent the input lag?

Thank you.

miguel-c
SoftMaker Team
SoftMaker Team
Posts: 441
Joined: Wed Jun 05, 2019 12:02 pm

Re: Input Lag

Post by miguel-c » Tue Aug 13, 2019 5:29 pm

Could you please tell us:
1. Your FreeOffice version (966?)
2. Your Windows version (Windows 10?)

You could try to disable:
File | Options | System | Smooth edges of pictures
File | Options | System | Enable OpenGL AutoShapes

Also, do you have many fonts installed on your system?

strangenoises
Posts: 6
Joined: Tue Aug 27, 2019 1:18 pm

Re: Input Lag

Post by strangenoises » Wed Aug 28, 2019 1:42 pm

I'll answer in lieu of the original poster. I'm seeing this as well, albeit I've only tried TextMaker Free so far. There's visible typing lagginess. I don't have to wait for it, it shows up right away, on a 2 thousand-ish words document using only one font family (Georgia) in the document (a few uses of italic and bold). There are no pictures or media of any kind in the document, and no other documents open. The system as a whole is quiet, verified in performance monitor. I'd be surprised if it's relevant but the document is being synced via NextCloud - but I haven't been trying to break it yet (instead making sure I save & quit before switching machines) so it ought really to be like using any folder on the local system. I'm using TextMaker's own file format, not docx.

I'm also test driving on macOS (Mojave) and Linux (Ubuntu 19.10 alpha in Gnome 3.33/Wayland fwiw), and in both there is no sign, no hint, of typing lag. One of the Linux systems I'm trying it on is the same actual machine as the Windows system (dual-booting) and is a Dell XPS 9370 with 4K display via Intel UHD graphics (it's a touchscreen though I don't use it that way, and haven't configured for that in the app), core-i7 cpu, 16GB RAM, NVMe internal SSD. I've never deliberately installed extra fonts on that system so the number has probably been about doubled by installing FreeOffice!

The Mac is a 2018 Macbook Air, its CPU is actually slower than the XPS 13, though otherwise it's a similar hardware spec, Intel UHD graphics etc. only 8GB RAM, but to reiterate, no hint of typing lag.

Windows 10 64-bit 1903, it and all apps and drivers are fully updated (with release, not pre-release versions with the exception of windows terminal; i only play with alphas on Linux!).

FreeOffice version 967 32-bit, the only one available for Windows. 64-bit on macOS and Linux. Only downloaded in the last couple of days. (Actually the Mac version says it's 967.0716. I might be assuming too much to say for sure the Windows one is too, as I don't have that machine with me right now to check. I did download all within the last 48 hours though, the Mac and Linux ones first. And that 0716 looks suspiciously like a date. ;) )

I was wondering if the fact of it being 32-bit incurred such a big performance penalty, I wouldn't have thought so, and then I saw this thread, so it looks like it isn't expected behaviour, and therefore probably wouldn't be fixed by paying for and getting the 64-bit build.

I remember looking for and not seeing any OpenGL related settings on the Windows version, but I'll have another look. There was an OpenGL setting on Linux, in the place you mention though I think differently worded, but as it's been behaving itself there I didn't see any reason to change from the default.

miguel-c
SoftMaker Team
SoftMaker Team
Posts: 441
Joined: Wed Jun 05, 2019 12:02 pm

Re: Input Lag

Post by miguel-c » Wed Sep 18, 2019 9:46 pm

Hi,
1. does the lag happen in all files or just in one?
2. Could you please go to "? | About | Write system information" and send us the file generated?
Thanks,

strangenoises
Posts: 6
Joined: Tue Aug 27, 2019 1:18 pm

Re: Input Lag

Post by strangenoises » Thu Sep 19, 2019 5:45 pm

sminfo.txt file attached.

Modified description:

It's not laggy as such in the sense that it doesn't get left behind by my typing. It took me a while to figure it out but it was revealed in the end by taking a slow-motion phone video of the text appearing on the screen while I was typing (not fast as doing it one-handed, so this isn't speed-critical, you don't need to type fast to see it).

On the Mac, and I think Linux (not done this test on Linux but in real-time the impression is it behaves like Mac), as you type each letter, the caret moves forwards and the new character appears behind it in one redraw, effectively instantaneously, and right on the keypress.

On Windows, the caret moves forward first, immediately on the keypress, and a perceptible time later, the new character actually appears. Slow-motion really clarifies that's what's happening; at real-time it just felt laggy even though it wasn't actually getting left behind. Or my alternative real-time impression was that the redraw was messy, as if without double-buffering.

The same thing happens when deleting characters. The caret moves back over the character being deleted, then that character disappears.

It also seems (revealed by slow-motion) that on Windows while typing the caret blinks off and back on again as the character appears, even though the caret itself isn't set to blinking when everything is at rest. This adds to the impression of flickeryness, messiness. Oddly the opposite happens on the mac, where the caret is blinking at rest, but solid as a rock while typing. (Not sure where the caret-blinking itself is configured; guessing in both cases it's taking it from the system?)

This happens for me on a new default document, from the standard default document template in TextMakerFree. I thought subjectively it might seem slightly worse on a longer (but still structurally simple) document, but slow-motion definitely reveals the two-step redraw that's producing the effect even on the simple, empty, default document.

(I have some short, slightly shaky, slow-motion movies, but not sure what it's useful to do with them. But it should be pretty easy to reproduce as described above.)
Attachments
sminfo.txt
(11.68 KiB) Downloaded 9 times

miguel-c
SoftMaker Team
SoftMaker Team
Posts: 441
Joined: Wed Jun 05, 2019 12:02 pm

Re: Input Lag

Post by miguel-c » Fri Sep 20, 2019 12:52 pm

#1: When it happens a few minutes after typing then the autosave could be the problem, for whatever reason. Disable it temporarily to check this.

#2: Does the task manager show any abnormal activity for TextMaker?

Post Reply

Return to “SoftMaker FreeOffice 2018 for Windows (General)”