Questions and answers about TextMaker 2018 for Mac
Post Reply
Posts: 6
Joined: Sun May 03, 2020 12:01 pm


Post by pikador » Tue May 05, 2020 8:35 am

I've browsed the forum and tried whatever is here. Nothing worked.
Here is the multilevel problem:
1. I use Polish so I downloaded Polish hunspell dictionary and intalled it via: Preferences->Language->Hunspell Dictionary->Add dictionary. It got in and worked.
2. I closed Textmaker, opened it again - the dictionary was gone! Reinstalled, worked, closed Textmaker, opened... and so on.
3. As I noticed, each time it creates a folder in Hunspell Folder. It's named pl_PL, then pl_PL2, pl_PL3....
4. I tried to leave only pl_PL and place the .sox file therein, nothing changed.
Question - how to make the hunspell dictionary stay forever.
Level 2
Whenever I try to add a new word to my custom dictionary, I get a message that the word cannot be saved. I looked for .ucd file within the SoftMaker folder in the Documents folder - nothing like that there. Nothing like that elsewhere on the Mac.
Question - how to create/find/use a custom dictionary

SoftMaker Team
SoftMaker Team
Posts: 1421
Joined: Wed Mar 11, 2020 5:31 pm

Re: Dictionary

Post by SuperTech » Fri May 29, 2020 10:24 am

Thanks for reporting these problems. I was unable to reproduce these issues because when I tried them in TextMaker 2018 For Mac S976.0313, everything worked fine.

I added the Polish dictionary which I downloaded from https://www.softmaker.com/en/dictionaries, added as you described, re-opened TextMaker and found it was still there. Please try this again and let us know if this works for you.

To add your word in the dictionary, With the Review | Spell check | Edit User dictionaries ribbon command you can add your words or when spell check report that there is some spelling mistake in your word you can simply click on Add button there. Please share the screenshot if you are getting any error in this.

Post Reply

Return to “TextMaker 2018 for Mac”