Dead key support

Questions and answers about TextMaker 2018 for Linux
Post Reply
User avatar
mgrinsven
Posts: 68
Joined: Mon Feb 10, 2020 9:40 pm

Dead key support

Post by mgrinsven » Fri Feb 21, 2020 9:57 am

What am i doing wrong in Textmaker? Somehow dead keys are not working. I run Textmaker in the Dutch language on Ubuntu 18.04. Everywhere else dead keys are working (i.e. ë by pressing " +e). But not in Textmaker..... Planmaker and presentation do not have problems. Seems a bit like the " key is ignored. Must be some setting somewhere i assume, but cannot figure it out.

What is going on here?

User avatar
Michael Uplawski
Posts: 177
Joined: Thu Dec 11, 2014 11:43 pm
Location: Canton Magny (previously Canton Carrouges), Orne, Normandy (previously Lower Normandy)

Re: Dead key support

Post by Michael Uplawski » Sat Feb 22, 2020 7:44 pm

mgrinsven wrote:
Fri Feb 21, 2020 9:57 am
What am i doing wrong in Textmaker? Somehow dead keys are not working. I run Textmaker in the Dutch language on Ubuntu 18.04. Everywhere else dead keys are working (i.e. ë by pressing " +e).
Good evening.
While I do not believe that you are doing anything wrong, the problem does however not concern everybody. I can compose arbitrary accented characters or add diaeresis to arbitrary characters, even in TextMaker.
sc_trema_accent_etc.png
Although I am using Debian and not Ubuntu, the divergence between TextMaker and the other components is surprising. Have you verified that you use the *same* font, when you compare TextMaker to PlanMaker and Presentations? But that is just a wild speculation, only SoftMaker can give you a real advice, here.
Hindsight is in the eye of the beholder.

miguel-c
SoftMaker Team
SoftMaker Team
Posts: 912
Joined: Wed Jun 05, 2019 12:02 pm

Re: Dead key support

Post by miguel-c » Sat Feb 22, 2020 7:52 pm

I can reproduce the issue @goodoldboy described in Ubunto 18.04.
Solution: Go to "File | Options | System" and then activate "Use XIM"
I'm going to report this issue to the developers. Thank you!
PS: I tested this under version 974.

User avatar
mgrinsven
Posts: 68
Joined: Mon Feb 10, 2020 9:40 pm

Re: Dead key support

Post by mgrinsven » Sun Feb 23, 2020 10:17 am

miguel-c wrote:
Sat Feb 22, 2020 7:52 pm
I can reproduce the issue @goodoldboy described in Ubunto 18.04.
Solution: Go to "File | Options | System" and then activate "Use XIM"
I'm going to report this issue to the developers. Thank you!
PS: I tested this under version 974.
Thanks, activating XIM solved my problem.

User avatar
Michael Uplawski
Posts: 177
Joined: Thu Dec 11, 2014 11:43 pm
Location: Canton Magny (previously Canton Carrouges), Orne, Normandy (previously Lower Normandy)

Re: Dead key support

Post by Michael Uplawski » Sun Feb 23, 2020 2:35 pm

@miguel-c

Could there be a list of cases that ask for the activation/deactivation of XIM?

I still do not know what it does, what it is, and why I am using it, sometimes and sometimes not. And sometimes, when things do not work as expected, it is because I have not activated XIM, sometimes this is not the question. I do not remember any case where I had to deactivate XIM and do not remember a discussion where it had been recommended... But, as we are free to use the setting or not, and as SoftMaker chose to not activate XIM anyway.., Nah. I really would appreciate a list.
Hindsight is in the eye of the beholder.

miguel-c
SoftMaker Team
SoftMaker Team
Posts: 912
Joined: Wed Jun 05, 2019 12:02 pm

Re: Dead key support

Post by miguel-c » Sun Feb 23, 2020 8:48 pm

According to the user manual:
Use XIM (Linux only): When this option is enabled, Presentations supports the composition
of accented characters (à, ô, é, etc.) using “XIM”.
For example, with a German keyboard, you can insert the character “ô” by first
pressing the (^) key and then pressing the (O) key.
If you disable this option, composing characters like this is no longer possible.
Note: On some systems, disabling this option improves the responsiveness of the
display when you are typing text fast.

joredor
Posts: 38
Joined: Thu May 25, 2017 1:50 am

Re: Dead key support

Post by joredor » Fri Mar 20, 2020 2:56 pm

Huh, this doesn't work for me. When I type ^ and then o, I simply get ^o. XIM is indeed enabled (Tools --> Options --> Use XIM).

Tried this on TM for Linux version 974 a few minutes ago, and then again on 976 after installing the new service pack. I'm on Kubuntu 18.04 LTS.

SuperTech
SoftMaker Team
SoftMaker Team
Posts: 716
Joined: Wed Mar 11, 2020 5:31 pm

Re: Dead key support

Post by SuperTech » Thu Apr 02, 2020 4:13 pm

Thanks for reporting this issue. I have updated our development team for this issue.

Post Reply

Return to “TextMaker 2018 for Linux”