Automatic hyphenation setting not persistent

Post your questions, bug reports and suggestions here for TextMaker 2018 for Linux.

Moderator: SoftMaker Team

Post Reply
astronos2007
Posts: 10
Joined: Wed Apr 04, 2018 1:51 pm

Automatic hyphenation setting not persistent

Post by astronos2007 » Wed Jul 25, 2018 5:07 pm

I noticed that the "Use automatic hyphenation" check from the Language settings of TextMaker is not persisting within restarts of the application.
Steps to reproduce:
- Open TextMaker Options, go to Language tab
- Uncheck "Use automatic hyphenation" (my setting is checked right now, I cannot undo it to test the other way)
- Click OK to save the settings
- Close TextMaker
- Open it again and see that the setting did not save itself.

sven-l
SoftMaker Team
SoftMaker Team
Posts: 8123
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Automatic hyphenation setting not persistent

Post by sven-l » Thu Jul 26, 2018 8:22 am

Hyphenation is not a global option (like all the other options in that dialogue). Hyphenation will be saved in the current document and you can have it either enabled or disabled in every document. I will ask the developers if they can add a hint to that option that it is only stored in the current document but not in the program.
Sven Leßmann
SoftMaker Software GmbH

astronos2007
Posts: 10
Joined: Wed Apr 04, 2018 1:51 pm

Re: Automatic hyphenation setting not persistent

Post by astronos2007 » Thu Jul 26, 2018 9:28 am

I understand, sven-l. Thank you for clarification!

Post Reply

Return to “TextMaker 2018 for Linux”