Chinese characters displayed as blocks

Post here those questions, bug reports and suggestions for SoftMaker Office 2018 for Linux that do not fit in any of the application-specific subforums.

Moderator: SoftMaker Team

Post Reply
Jackie
Posts: 1
Joined: Fri May 18, 2018 12:19 pm

Chinese characters displayed as blocks

Post by Jackie » Fri May 18, 2018 12:42 pm

I am from China and system lanauage is set to Chinese.

I've downloaded and install the x86_64 DEB package on my Debian sid 64 bit laptop. When I launched SoftMaker Office 2018, I noticed many Chinese characters in the menu options appeared to be blocks!

Image


I've tried Chinese input and all is fine.
My system info:
OS: Debian stable-updates sid
Kernel: x86_64 Linux 4.16.0-1-amd64
DE: XFCE
WM: Xfwm4
WM Theme: OSX Improved
GTK Theme: Paper [GTK2]
Icon Theme: Oranchelo
Font: 文泉驿正黑 Medium 10

The Chinese font's name is Wenquanyi. When I set default font to Noto Sans CJK SC Regular, the block disappeared and the charaters were just missing.

Below are the screenshot of the appearance when I used Wenquanyi and Noto Sans CJK as default font.
Attachments
20180518_18-16-35.png
Wenquanyi font appearance
20180518_18-31-34.png
Noto Sans CJK font appearance

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7893
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Chinese characters displayed as blocks

Post by sven-l » Thu May 24, 2018 11:58 am

I can confirm this issue with the Chinese user interface and will inform the developers.
Sven Leßmann
SoftMaker Software GmbH

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7893
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Chinese characters displayed as blocks

Post by sven-l » Wed Jun 06, 2018 2:31 pm

The issue has been fixed and should no longer occur with the next service pack.
Sven Leßmann
SoftMaker Software GmbH

Post Reply

Return to “SoftMaker Office 2018 for Linux (General)”