Problem with Brazilian Portuguese characters

Post here those questions, bug reports and suggestions for SoftMaker Office 2018 for Linux that do not fit in any of the application-specific subforums.

Moderator: SoftMaker Team

vtpoet
Posts: 122
Joined: Mon Dec 30, 2013 4:55 am

Re: Problem with Brazilian Portuguese characters

Post by vtpoet » Wed Jun 06, 2018 11:04 pm

This is great news. :)

Martin, maybe Softmaker should consider a "Known Issues" Document with Linux installations so this sort of issue doesn't get dragged out like this in the future? Just my 2 farthings. Prospective users would certainly appreciate it.

martin-k
SoftMaker Team
SoftMaker Team
Posts: 3034
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: Problem with Brazilian Portuguese characters

Post by martin-k » Thu Jun 07, 2018 11:32 am

vtpoet wrote:
Wed Jun 06, 2018 11:04 pm
This is great news. :)

Martin, maybe Softmaker should consider a "Known Issues" Document with Linux installations so this sort of issue doesn't get dragged out like this in the future? Just my 2 farthings. Prospective users would certainly appreciate it.
So did this change work for you as well?
Martin Kotulla
SoftMaker Software GmbH

vtpoet
Posts: 122
Joined: Mon Dec 30, 2013 4:55 am

Re: Problem with Brazilian Portuguese characters

Post by vtpoet » Thu Jun 07, 2018 4:41 pm

No it didn't. Alas. I upgraded and tested. The behavior is odd. In the latest version, I can still create the following characters, äàá for example. But I can't create an en-dash – or an em-dash — (among other symbols). I can't really say what's going on, but SO-931 (the latest version) obviously interferes with the compose key's functionality when certain key combinations are used.

For instance, I can't produce a degree sign ° in SO-931. Composekey + OO. I also can't create a Left guillemet for example « or the right ». The "section mark" also doesn't work after the upgrade: § Composekey + SO . One is almost tempted to think the font is somehow involved, but the default fault is the same before and after upgrading. As I say, this is 100% reproducible.

sven-l
SoftMaker Team
SoftMaker Team
Posts: 8032
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Problem with Brazilian Portuguese characters

Post by sven-l » Mon Jun 11, 2018 1:17 pm

vtpoet wrote:
Wed Jun 06, 2018 12:00 am
sven-l wrote:
Tue Jun 05, 2018 11:11 am
vtpoet wrote:
Mon Jun 04, 2018 5:20 pm
...but downgrading immediately fixed the problem. Somewhere and for some reason the newest versions of Softmaker for Linux (will test in windows) are interfering with the compose key.
Have you downgraded on the exact same system?
Yes. Downgraded on the exact same system:


1. Which distribution exactly is used (32bit or 64bit)?

System: Host: ThinkPad Kernel: 4.10.17-041017-generic x86_64 bits: 64 Desktop: KDE Plasma 5.12.5
Distro: Ubuntu 18.04 LTS
Machine: Device: laptop System: LENOVO product: 20HF0012US v: ThinkPad T470s serial: N/A
Mobo: LENOVO model: 20HF0012US v: SDK0J40697 WIN serial: N/A
UEFI: LENOVO v: N1WET31W (1.10 ) date: 04/17/2017

2. When you installed the Linux, which system language, which regional settings and (most important) which keyboard settings and drivers have you chosen in the setup?

System Language: English
Regional Setting: New York US
Keyboard Settings: English (intl. with AltGr dead keys) & German (de)

3. Have you installed any additional tools that affect or control the keyboard?

Set Compose Key to CapsLock

4. Which keys exactly did you type in TextMaker to write an accented character?

So, interestingly, the em-dash was the key affected by the upgrade. As I wrote, invoking the em-dash requires: CapsLock + ---

That gets you: —

Currently using:

apt policy softmaker*
softmaker-office-2018:
Installed: 2786
Candidate: 2786
Version table:
*** 2786 100
100 /var/lib/dpkg/status

If I upgrade, the compose key for the em-dash stops working. This is reproducible %100 of the time. When I press the first of the three dashes after Capslock, it doesn't appear, then the second two appear.
Em dashes will work again with the compose key with the next service pack.
Sven Leßmann
SoftMaker Software GmbH

sven-l
SoftMaker Team
SoftMaker Team
Posts: 8032
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Problem with Brazilian Portuguese characters

Post by sven-l » Mon Jun 11, 2018 1:22 pm

The problem with accented characters is solved now and should no longer occur in the next service pack.
Sven Leßmann
SoftMaker Software GmbH

kgha
Posts: 59
Joined: Sat Sep 01, 2012 6:52 pm

Re: Problem with Brazilian Portuguese characters

Post by kgha » Mon Jun 25, 2018 12:52 pm

I'm sorry having to report that after upgrading to latest buld 933, the problem still persist and I have to add the line
export LANG=sv_SE.utf8
to the start script in order to get accents to work properly. This also means that I can't save files where the filename contains the letters å, ä, ö (see the thread viewtopic.php?f=306&t=17856 )

miansancor
Posts: 3
Joined: Sun Jul 24, 2011 11:51 pm

Re: Problem with Brazilian Portuguese characters

Post by miansancor » Wed Sep 05, 2018 5:39 pm

PitagorasCWB wrote:
Sun May 20, 2018 3:07 pm
Hello, it seems there's a problem with input encoding.

I'm not able to insert characters like these: á, â, ã

They appear, instead: 'a, ~a, ^a

How to fix it?
To me is the very same problem with spanish, is does happens THE SAME I can not write any accented vowel, it writes the accent first and then the vowel: they appear, instead: 'a, ~a, ^a . Using opensuse, in all the other office applications it does not append.

Thanks for any help

kgha
Posts: 59
Joined: Sat Sep 01, 2012 6:52 pm

Re: Problem with Brazilian Portuguese characters

Post by kgha » Thu Sep 27, 2018 9:04 am

This problem persists after upgrading to version 936.

sven-l
SoftMaker Team
SoftMaker Team
Posts: 8032
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Problem with Brazilian Portuguese characters

Post by sven-l » Tue Oct 02, 2018 9:28 am

kgha wrote:
Thu Sep 27, 2018 9:04 am
This problem persists after upgrading to version 936.
Have you configured your system to use a Swedish UTF-8 locale? We pretty much expect that a Linux system these days is Unicode-enabled.

Notice for me: This issue was reported in ticket 38419.
Sven Leßmann
SoftMaker Software GmbH

kgha
Posts: 59
Joined: Sat Sep 01, 2012 6:52 pm

Re: Problem with Brazilian Portuguese characters

Post by kgha » Wed Oct 10, 2018 9:50 am

For various reasons I prefer to have en_US as system language and a Swedish keyboard. This doesn't affect the use of accents in any other program, only Softmaker. As previously mentioned, I have solved the accent issue by adding the line
export LANG=sv_SE.utf8
to the start script. This, however, leads to that I can't save files where the filename contains the letters å, ä, ö (see the thread viewtopic.php?f=306&t=17856 ). That's a minor issue and I can live with that.

Post Reply

Return to “SoftMaker Office 2018 for Linux (General)”