Using the "Average" function

Post your questions, bug reports and suggestions here for PlanMaker 2018 for Windows.

Moderator: SoftMaker Team

Post Reply
fargoone
Posts: 1
Joined: Fri Jun 29, 2018 4:52 pm

Using the "Average" function

Post by fargoone » Fri Jun 29, 2018 6:30 pm

I have a long column of figures in Planmaker 2018 that looks like this:

#DIV/0!
#DIV/0!
34.8%
61.5%
#DIV/0!
#DIV/0!
#DIV/0! Another view of the column is below.

I wish to average only the numerical ones. Not the #DIV/0!.

Is there some way to do this? This is the formula that I am using and it does not work.

=AVERAGE(K8:K323)

Thanks in advance for your help.

Chuck
Attachments
PROFIT.jpg
PROFIT.jpg (12.43 KiB) Viewed 339 times

User avatar
jimjutte
SoftMaker Volunteers
SoftMaker Volunteers
Posts: 931
Joined: Sun Oct 28, 2007 9:08 pm
Location: Chatham, Ontario, Canada
Contact:

Re: Using the "Average" function

Post by jimjutte » Wed Jul 04, 2018 7:03 am

Good question. I thought I might be able to solve this with an If Then statement, but it seems to keep sending back the error.

I'll see if there is another way, but for now, you may be stuck with click,shift-click. Sorry.
Cheers
Jim

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7924
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Using the "Average" function

Post by sven-l » Wed Jul 04, 2018 10:04 am

You have to make sure that only references to cells with valid (numerical) values are inside the formula. It does not work if there are #DIV/0! cells inside the calculation.
Sven Leßmann
SoftMaker Software GmbH

Jossi
SoftMaker Volunteers
SoftMaker Volunteers
Posts: 961
Joined: Fri Dec 05, 2003 10:47 pm
Location: Luebeck, Germany

Re: Using the "Average" function

Post by Jossi » Wed Jul 04, 2018 10:14 am

Divisions by zero (#DIV/0!) shouldn't occur at all. The correct way is to adjust your formulas to prevent this. Subsequent formulas will work then, too.

Post Reply

Return to “PlanMaker 2018 for Windows”