"Optimal cell height" not working

Questions and answers about PlanMaker 2018 for Windows
Post Reply
c26
Posts: 2
Joined: Thu Sep 26, 2019 1:16 pm

"Optimal cell height" not working

Post by c26 » Thu Sep 26, 2019 1:36 pm

Hello, I (try to) use the free version, and I would be willing to buy if PlanMaker was more robust re its user interface. One of the things which don't seem to work correctly:


Worksheet - Row - Optimum height does not do anything when I have selected the whole column (1), let alone when I select the whole table (2): The command does not do anything in both cases.

The expected behavior for (1) would be that PM would put each cell in the selected column to the height needed in order to display its whole content, possibly within the limits of some preset max. height (setting by the user, but there does not seem to be any such setting, or within some "factory-set" max height setting), these heights being dependent on the current column width ; in use case (2) it would do the same for the whole table, i.e. for each row, the program would set the height of all cells of that row, independently of the column, to the height needed for displaying all the text in that cell of that row which needs the most height (again, within some preset height limit, possibly).


None of this is done, even for (1), and even if I select the cells in a row as a block, i.e. not by selecting the caption (title line), but just the cells, by multiple "shift-down".

If this functionality is present in the paid version but not in the free version, please tell me; in this case, it would have been preferable to grey out the menu items which work in the paid version only, so as to know to expect from that version.

Thank you.

miguel-c
SoftMaker Team
SoftMaker Team
Posts: 907
Joined: Wed Jun 05, 2019 12:02 pm

Re: "Optimal cell height" not working

Post by miguel-c » Sat Sep 28, 2019 6:08 pm

Hi, I wasn't able to reproduce the issue you described in PlanMaker (FreeOffice)
For me it worked perfectly. These were the steps I performed:
1. File | New
2. Typed 123456 in Cell A1 and pressed ENTER
3. Dragged the line below it to a bigger (or smaller size)
4. Selected the cell, the column, the row, the entire table if you want
5. Clicked on Layout | Optimum height
6. PlanMaker changed the height back to the correct size.

c26
Posts: 2
Joined: Thu Sep 26, 2019 1:16 pm

Re: "Optimal cell height" not working

Post by c26 » Wed Feb 12, 2020 7:01 pm

Thank you very much, miguel-c.

(I had looked up my question 2 days later, without finding it, so I assumed it had been censored; as a first question from that user, it seems to have been delayed, then to have appeared here, together with your answer, just minutes after my unsuccessful look-up; I now tried to find a solution again and googled the same problem; my first "hit" now was my question of more than 4 months ago...)

PROBLEM SOLVED:

I hadn't been successful this time either, but then searched for "word wrap", and once I got to that setting, and had set it to "on" (for all cells or for the whole column(s) in question), "optimal cell height" has been working fine, too!

I have to admit I had wrongly assumed that "optimal cell height" would detect "overflow" text and then set the cell height accordingly - obviously since my base assumption had been that "optimal cell height" would only make sense in such "word wrap" cases.

I also see that in my question, I did not even mention "word wrap" or "text overflow" or the like, so it's obvious I didn't clarify my problem then: sorry for part-way misleading you, and thank you very much again!

Post Reply

Return to “PlanMaker 2018 for Windows”