Turning off hyphenation?

Post your questions, bug reports and suggestions here for TextMaker 2018 for Windows.

Moderator: SoftMaker Team

Post Reply
wbrells
Posts: 62
Joined: Fri Nov 18, 2016 4:09 pm

Turning off hyphenation?

Post by wbrells » Wed Oct 24, 2018 3:03 pm

I'd like to turn off the automatic hyphenation option. I've modified the normal.tmvx file to specify "Never" under Paragraph > Text flow > Hyphenation:, but every time I start a new document it seems that automatic hyphenation if turned ON! Is there some other way to change the default hyphenation mode? Thanks!

Jossi
SoftMaker Volunteers
SoftMaker Volunteers
Posts: 986
Joined: Fri Dec 05, 2003 10:47 pm
Location: Luebeck, Germany

Re: Turning off hyphenation?

Post by Jossi » Thu Oct 25, 2018 11:22 am

The simplest way is to go to Tools menu and uncheck „Automatic hyphenation".

wbrells
Posts: 62
Joined: Fri Nov 18, 2016 4:09 pm

Re: Turning off hyphenation?

Post by wbrells » Thu Oct 25, 2018 1:47 pm

Jossi - many thanks! I'm sorry that I didn't originally notice this option under File>Options>Language. (I was rather expecting to find this choice under File>Options>Edit). In any case, thanks again for your help.

RKanarek
Posts: 93
Joined: Tue Jan 13, 2004 6:59 am

Re: Turning off hyphenation?

Post by RKanarek » Fri Oct 26, 2018 12:14 am

Greetings,

If you are using a template that has a paragraph style set for no hyphenation, and TextMaker is hyphenating paragraphs in that style anyway, then there is something wrong with TextMaker. Perhaps, however, you are not actually using a paragraph style with no hyphenation? Earlier version of TextMaker would use the normal.tmv template file as the default, but TextMaker 2018 allows one to select and change the default template. Are you really certain that normal.tmvx is the template file being used, that it really does contain a paragraph style with hyphenation disabled, and that you are really using that paragraph style?

Just a thought.


Cordially,
Richard

wbrells
Posts: 62
Joined: Fri Nov 18, 2016 4:09 pm

Re: Turning off hyphenation?

Post by wbrells » Fri Nov 02, 2018 8:14 pm

Richard,

Thanks for the info! I resolved the problem by unchecking the "Use automatic hyphenation" option under File > Options > Language in the normal.tmvx template. My original error was in just turning off Hyphenation (in the template) under Home > Paragraph > Text flow.

In any case, all is now well!

Wayne

Post Reply

Return to “TextMaker 2018 for Windows”