Character alignment problem

Post your questions, bug reports and suggestions here for TextMaker 2016 for Linux.

Moderator: SoftMaker Team

Post Reply
joaodias
Posts: 4
Joined: Fri Oct 28, 2016 11:11 am

Character alignment problem

Post by joaodias » Fri Oct 28, 2016 4:00 pm

When I open one MS Office Professional Plus Word 2007 document in openSUSE Leap 42.1 with TextMaker Professional 2016 (rev 761 0922), the space between caracters changed.
The number of characters on the page is not the same and some "jump" to the next page.
I attached the document.
Attachments
Test_document.doc
(45 KiB) Downloaded 181 times

User avatar
Michael Uplawski
Posts: 139
Joined: Thu Dec 11, 2014 11:43 pm
Location: Canton Magny (previously Canton Carrouges), Orne, Normandy (previously Lower Normandy)

Re: Character alignment problem

Post by Michael Uplawski » Fri Oct 28, 2016 7:21 pm

Independently from any analysis done by the SoftMaker staff, I already see several possible reasons for your observations:
  • Do you have the font “Calibri” installed on the Linux-system that you try to work on?
  • How do you measure the distance between characters, i.e. can you give a difference in points from the settings in the font style?
  • Did the lateral and vertical margins change from those configured in the Windows® word-processor?
People should go where they are not supposed to go, say what they are not supposed to say and stay, when they are told to leave.
Image (Howard Zinn)

joaodias
Posts: 4
Joined: Fri Oct 28, 2016 11:11 am

Re: Character alignment problem

Post by joaodias » Sat Oct 29, 2016 12:02 pm

Yes, I have "Calibri" font installed on the Linux-system.
If we look at the two attached files, the first line on the "Test_msword.doc" and first line on "Test_linux.tmd" are not the same. There's an huge space between the "1." and "INFORMAÇÕES".
On the other hand, in the bottom, two lines of the text jumps to another page.
I think the lateral and vertical margins are unchanged because the rulers has the same values.
Attachments
Test_linux.tmd
(34.82 KiB) Downloaded 100 times
Test_msword.doc
(45 KiB) Downloaded 151 times

User avatar
Michael Uplawski
Posts: 139
Joined: Thu Dec 11, 2014 11:43 pm
Location: Canton Magny (previously Canton Carrouges), Orne, Normandy (previously Lower Normandy)

Re: Character alignment problem

Post by Michael Uplawski » Sat Oct 29, 2016 7:35 pm

As I do not have a Windows®-system at my disposition, nor any version of Word, both documents are opened in TextMaker and look identical to me. In the first line, you use justified text, which means that the content of the line will be distributed over the whole line. Both documents show the same behavior and left-align the number, while the word is glued to the right border. If this is correct or wrong, I cannot say.

Try imposing left-alignment to the line, if this is what bugs you.
People should go where they are not supposed to go, say what they are not supposed to say and stay, when they are told to leave.
Image (Howard Zinn)

Jossi
SoftMaker Volunteers
SoftMaker Volunteers
Posts: 971
Joined: Fri Dec 05, 2003 10:47 pm
Location: Luebeck, Germany

Re: Character alignment problem

Post by Jossi » Sat Oct 29, 2016 10:22 pm

I opened your original document (Test_document.doc) in Word 2013 and in TextMaker 2016 (under Windows 10, as I don't have Linux installed, but I don't think this makes much of a difference). You invalidated (made void) the rest of empty lines by typing dashes (hyphens); and in three cases you didn't insert a paragraph break at the end of line but typed simply on until the last dash was wrapped into the next line: after "educação;" (second occurence), after "saúde;" and in the last line.

Now TextMaker handles such rows of dashes differently from Word: In Word, if there are too many dashes to fit into a line, the superfluous dashes are wrapped to the next line; in TextMaker, a row of dashes without a blank in between is considered a word, and (with auto-hyphenation deactivated) the whole word, i. e. the complete row of dashes, goes into the next line. This was the reason why your document looked somewhat strange in TextMaker.

You may adjust your document in TextMaker simply by deleting the last dash in each of the three rows and (in the first two cases) inserting a paragraph break and adding a dash at the beginning of the next line.

But, generally spoken, it is a most inconvenient thing to fill empty lines by typing rows of dashes or underscores as you did here, because this will invariably lead to problems, like here, or if the page size, formatting or font of the document or the text itself is changed.

The correct way is:
1. Select the whole document.
2. Set a right-aligned tab at the right margin of the text: Click into the small square in the upper left corner of your working space until it looks like this:
Right-aligned tab.png
Right-aligned tab.png (3.26 KiB) Viewed 9266 times
Then click into the horizontal ruler above your text (if you don't see one, click View > Horizontal Ruler first) and move the small black hook to the right until it aligns with the right border of your text.
3. When the need arises to fill an empty line, go to Format > Tabs..., choose either "Solid" or "Dashed" in "Tab leaders" ("Solid" for underlining, "Dashed" for dashes), click "Set", then "OK" and press the tab key.
In this way, your document will always look exactly right (and by the way, you have only to press the tab key once instead of dozens of dashes or underscores).

To show you the difference, I have prepared a version of your document with tabs instead of dashes and underscores:
Attachments
Test_document with tabs.doc
(20.5 KiB) Downloaded 159 times

joaodias
Posts: 4
Joined: Fri Oct 28, 2016 11:11 am

Re: Character alignment problem

Post by joaodias » Sun Oct 30, 2016 12:45 am

Thank you Michael Uplawski for your help.
Thank you Jossi for your deep explanation, this is an service document and the invalidated lines with dashes is an procedure.
Was not wrote by me, but I must change it in TextMaker and sent by email to other colleagues with Windows O.S. (R). Although I have only shown a page, it consists of seven, but may contain up to twenty.
Thus, the need to fix the issue in every document I will receive weekly in the easy way.
"...Now TextMaker handles such rows of dashes differently from Word", it's there any way to enable the same beauvoir in TextMaker today?

sven-l
SoftMaker Team
SoftMaker Team
Posts: 8014
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Character alignment problem

Post by sven-l » Wed Nov 02, 2016 8:18 am

joaodias wrote:When I open one MS Office Professional Plus Word 2007 document in openSUSE Leap 42.1 with TextMaker Professional 2016 (rev 761 0922), the space between caracters changed.
The number of characters on the page is not the same and some "jump" to the next page.
I attached the document.
I will refer that issue to our developers and report here as son as I we have a solution. Thank you!
Sven Leßmann
SoftMaker Software GmbH

sven-l
SoftMaker Team
SoftMaker Team
Posts: 8014
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Character alignment problem

Post by sven-l » Tue Nov 08, 2016 10:54 am

That issue has been solved and should no longer occur with the next service pack.
Sven Leßmann
SoftMaker Software GmbH

joaodias
Posts: 4
Joined: Fri Oct 28, 2016 11:11 am

Re: Character alignment problem

Post by joaodias » Thu Nov 10, 2016 8:59 am

Thank you for the information.

Post Reply

Return to “TextMaker 2016 for Linux”