Quotation marks in wrong language and font

Post your questions, bug reports and suggestions here for TextMaker 2016 for Linux.

Moderator: SoftMaker Team

Post Reply
tkinami
Posts: 15
Joined: Tue Mar 08, 2016 11:28 pm

Quotation marks in wrong language and font

Post by tkinami » Wed Oct 12, 2016 9:38 am

The default language for TM is set to English. Letters in the Latin alphabet come out in the "Latin typeface" font that I set. But when I type quotation marks (' or "), they are always formatted in the "Asian typeface" set, even when the surrounding text is all in the "Latin" font. The only solution is to change the character font manually in each location. I think this is a bug. Quotation marks should be treated as Latin text, not Asian text.
My OS language is set to Chinese (Taiwan). Perhaps that is confusing the TM software?

Jossi
SoftMaker Volunteers
SoftMaker Volunteers
Posts: 961
Joined: Fri Dec 05, 2003 10:47 pm
Location: Luebeck, Germany

Re: Quotation marks in wrong language and font

Post by Jossi » Wed Oct 12, 2016 11:16 am

Are "Smart quotes" set (Tools > Options, tab "Language", lower right corner of dialogue box)? If yes, which option? Maybe it's an issue with the "Auto" setting.

tkinami
Posts: 15
Joined: Tue Mar 08, 2016 11:28 pm

Re: Quotation marks in wrong language and font

Post by tkinami » Sun Oct 16, 2016 4:02 am

"Smote Quotes" is set to "English", which is exactly what I want. The quotation marks do appear automatically in the right format, only the font is wrong.

Post Reply

Return to “TextMaker 2016 for Linux”