slow startup of softmaker office

Post here those questions, bug reports and suggestions for SoftMaker Office 2016 for Linux that do not fit in any of the application-specific subforums.

Moderator: SoftMaker Team

Post Reply
igpm
Posts: 1
Joined: Thu Mar 08, 2018 2:31 pm

slow startup of softmaker office

Post by igpm » Thu Mar 08, 2018 2:42 pm

Hello,

I have softmaker office 2016 installed on my linux computer (I guess, the problem still exists in the 2018 version)
and have the following problem:
When I install the complete texlive package with all fonts, planmaker16 (and the other apps) takes about 30 seconds until the window appears
on the screen.
When I remove all texlive Fonts from /usr/share/fonts, the startup only takes about 3 seconds.
This is, because I have installed all texlive fonts (about 23000 Fonts) and planmaker does a
stat64 call on each installed font.
Is there a environment Variable or a configuration parameter, so that I can exclude certain directories (all texlive- font directories)
from scanning, when starting up?
Or is there another workaround, that speeds up the starting process when the texlive Fonts are installed?

Best,

Frank

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7993
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: slow startup of softmaker office

Post by sven-l » Tue Mar 20, 2018 2:46 pm

Yes, our programs check the installed fonts on every start but it is not common to install 23.000! fonts on a system. Maybe it would be better to install fewer fonts. With 23.000 fonts, clarity is lost.
Sven Leßmann
SoftMaker Software GmbH

Post Reply

Return to “SoftMaker Office 2016 for Linux (General)”