Internet connection needed for every start up

Post here those questions, bug reports and suggestions for SoftMaker Office 2016 for Linux that do not fit in any of the application-specific subforums.

Moderator: SoftMaker Team

attilas
Posts: 34
Joined: Mon Dec 07, 2015 2:49 pm

Re: Internet connection needed for every start up

Post by attilas » Thu Mar 03, 2016 9:55 pm

sven-l wrote: We could now reproduce that issue here on a Lenovo X200 Notebook. I reported that issue to the developer and will inform you as soon as we have a fix for this.
Thank you :)

unhappy_customer
Posts: 4
Joined: Sun Mar 06, 2016 11:56 pm

Re: Internet connection needed for every start up

Post by unhappy_customer » Mon Mar 07, 2016 12:06 am

Hi guys,

Can we (your customers) expect this issue to be fixed soon ?

It is completely unacceptable for a Linux software to require internet connection and to "call home" on every start of the program !

I want to be able to work offline.

If I knew that your office package requires internet connection to verify the licence on every start - I would never have purchased it.

If this issue is not fixed soon, I will ask my credit card company for a refund and I am going to uninstall softmaker from all computers in our office.

C'mon gyus - 3 months passed already !

If you are going to fix this issue - just fix it, otherwise it is becoming ridiculous.

unhappy_customer
Posts: 4
Joined: Sun Mar 06, 2016 11:56 pm

Re: Internet connection needed for every start up

Post by unhappy_customer » Mon Mar 07, 2016 12:15 am

Tomorrow I will request a refund because ot this issue.

3 months and it is still not fixed !

I am seriously thinking of cracking SM office and I sincerely regred I bought it.

I feel betrayed !

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2986
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: Internet connection needed for every start up

Post by martin-k » Mon Mar 07, 2016 8:08 am

This issue has been fixed with the service pack released last week. Have you already installed it?

For clarification: The need for an internet connection on every start did not affect every customer. It just happened in specific configurations.
Martin Kotulla
SoftMaker Software GmbH

unhappy_customer
Posts: 4
Joined: Sun Mar 06, 2016 11:56 pm

Re: Internet connection needed for every start up

Post by unhappy_customer » Mon Mar 07, 2016 2:59 pm

The issue has NOT been fixed.
I updated to version 752.0229.
The issue is still here. Unable to work offline. Internet connection required. Textmaker presents the dialog asking for serial number on every attempt to start the application while offline.

Jim-J
SoftMaker Team
SoftMaker Team
Posts: 437
Joined: Fri Apr 04, 2014 8:29 am

Re: Internet connection needed for every start up

Post by Jim-J » Mon Mar 07, 2016 3:28 pm

unhappy_customer wrote:The issue has NOT been fixed.
I updated to version 752.0229.
The issue is still here. Unable to work offline. Internet connection required. Textmaker presents the dialog asking for serial number on every attempt to start the application while offline.
Hello,

I checked this issue with Ubuntu 15.10 and TextMaker 2016 rev752.0229. I disconnected Ubuntu from the network and started TextMaker 2016. I didn't receive an error message. It started as it should. See the attached screenshot.

Did you uninstall SoftMaker Office and reinstalled the new revision?

Which Linux distribution are you using?
Can you please send us the sminfo.txt (Invoke Help->About->Write System Information")?
Attachments
disconnect.png
Jim J.
SoftMaker Software GmbH

unhappy_customer
Posts: 4
Joined: Sun Mar 06, 2016 11:56 pm

Re: Internet connection needed for every start up

Post by unhappy_customer » Mon Mar 07, 2016 3:48 pm

I tried both ways - first installed new version over old one, then I uninstalled softmaker office, deleted .softmaker in home folder, rebooted, installed version 752.0229.

The issue is most probably not showing on your tests because you need to restart the laptop before trying to launch textmaker office offline.

If I launch textmaker office at least once while connected to the internet and then I disconnect from internet (without restarting the computer) - textmaker starts normally.

As soon as I shutdown the laptop, go to the place where there is no internet access, start the laptop there and try to use textmaker - the issue is showing up, i.e. textmaker is not starting.

So you need to reboot.

Another note: as i probably uninstalled and reinstalled softmaker office so many times, because of this issue, now I am afraid that textmaker will suddenly stop working with some message saying "too many activations" or something like that.

I should probably just crack my legally purchased version or stop using textmaker altogether :( :(

The issue is NOT fixed !

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2986
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: Internet connection needed for every start up

Post by martin-k » Mon Mar 07, 2016 5:41 pm

Can you please send us the sminfo.txt (Invoke Help->About->Write System Information")?
We need this to proceed further.
Martin Kotulla
SoftMaker Software GmbH

kgha
Posts: 55
Joined: Sat Sep 01, 2012 6:52 pm

Re: Internet connection needed for every start up

Post by kgha » Tue Mar 08, 2016 9:50 am

Problem persists for me, too. What's different from what unhappy_customer writes is that product key is requested even without reboot - it's enough to close Softmaker, disconnect from the internet and then try to restart Softmaker.
I first simply updated, using the tgz installer which I always have used previously.
I then tried after having first uninstalling SM completely.
I finally tried the RPM package (converting it with rpm2tgz since I'm running a slackware distro). That had at least one advantage - SM's gaudy icons weren't installed. But it's still impossible to start without an internet connection.
Content of my sminfo.txt file:

Code: Select all

SoftMaker TextMaker System Information
Revision: 752
---
Linux distribution detection results: [3] ; Slackware 14.1 ; 14.1
Linux kernel info: Linux darkstar 4.1.6-smp #2 SMP Fri Aug 21 02:06:44 CDT 2015 i686 Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz GenuineIntel GNU/Linux

List of found distribution file names and their content:
>>> Slackware Filenames (/etc/slackware-release ; /etc/slackware-version) <<<
*
Slackware 14.1
---
*** File info ***
[/home/kgha/.softmaker/tm16config.ini]

[SmoPrinterList]
GhostView [system]=2
Default printer queue [system]=4
[SMO Printer - GhostView [system]]
PrinterCmd=gv % ; rm %
PrinterOutput=1
Resolution=96
RotLandscape=1
[SMO Printer - Default printer queue [system]]
PrinterCmd=lpr -r %
PrinterOutput=1
Resolution=96
RotLandscape=1
[SmoDefaultPrinter]
SmoDefaultPrinter=GhostView [system]
[tm]
LinuxInfo=2016.LX.752
Handling=2
ShowSchoolLicense=0
ArabicSupport=0
AsianFonts=0
MSWordFormat=6
TimeFormat=
DateFormat=
SidebarPage=3370
WSColorRGBValue=11250603
TableGrid=0
FrameGrid=0
OleBounds=0
PageBorders=0
Guides=0
AutoTime=5
LanguageID=1053
HorizontalPages=1
BackupType=0
BackupFilesPath=/home/kgha/SoftMaker/Backup/
Revision=752
CharMapFont=Times New Roman
WinMax=1
WinSize=18,56,1110,670
DlgLID=1033
TemplatePath=/home/kgha/SoftMaker/Templates 2016/
Documents=/home/kgha/SoftMaker/
Databases=/home/kgha/SoftMaker/
Pictures=/home/kgha/SoftMaker/
Macros=/home/kgha/SoftMaker/
SidebarDocking=0
[UserHome]
Name=Hammarlund
FirstName=KG
Initials=kgha
[UserBusiness]
Name=Hammarlund
FirstName=KG
Initials=kgha
[Ignore]
OLE=0
[Intl]
iMeasure=0
[SymbolHistory]
Char1=8211
Font1=Times New Roman
Char2=61480
Char3=61481
Char4=61482
Char5=61483
Char6=61514
Char7=61515
Char8=61516
Char9=61679
Char10=61680
Char11=61681
Char12=61682
Char13=61521
Char14=61636
Char15=61638
Char16=61693
Char17=61694
Char18=61498
[tm MRUFontlist]
Fontname0=Basic Roman
Fontname1=Times New Roman

*** EOF ***
[/home/kgha/.softmaker/tm16config.ini]

---
Environment: 
LC_ALL: <null>
LC_LANG: <null>
LC_MESSAGES: <null>
LC_CTYPE: <null>
RC_LANG: <null>
LANG: en_US.UTF-8
GDM_LANG: <null>
---
Window Manager: IceWM 1.3.7.2 (Linux 4.1.6-smp/i686)
Screen resolution: 1366 ; 768
OS 64bit detection: [32] ; 0
OS 64bit internal values: 0 ; 0 --- 0 ; 0
Libraries [G ; F ; P ; C]: 0 ; 0 ; 0 ; 189158472
GnomeKdeUnityCustom init flags: 0 ; 0 ; 0 ; 0
GnomeKdeUnityCustom final flags: 0 ; 0 ; 0 ; 0
Colors inversion hack flags: 0xFFFFFFFF
Sdl config/status flags: 1 --- 1
---
*** Startup log ***
[00000ms]: LANG: Locale set to <en_US.UTF-8>
[00000ms]: Date 08.03.2016, 09:42
[00000ms]: TextMaker 2016, Revision 752 (Linux)
[00042ms]: OpenGL initialization successful. [183578720 ; 1 ; 6 --- 4 (3) ; 20]
[00042ms]: Main XWindow handle created: 39845891
[00044ms]: Detected number of monitors: 1
[00044ms]: Temporary subfolder initialized to: /tmp/tmIm7VkF/
[00051ms]: S64 - 64 bit os not-detected.
[00061ms]: mail not installed
[00071ms]: xdg-open installed
[00084ms]: xdg-mime installed
[00094ms]: thunderbird installed
[00105ms]: evolution not installed
[00115ms]: gv installed
[00126ms]: ggv not installed
[00136ms]: ghostview not installed
[00147ms]: kghostview not installed
[00157ms]: uname installed
[00168ms]: fontforge not installed
[00172ms]: ldconfig installed
[00185ms]: LibraryHandleCups: 189158472
[00185ms]: LibraryHandleCups - Full success!
[00187ms]: vInit
[00190ms]: InitVideo
[00190ms]: PersonalityInit
[00190ms]: GetMenuTextHeight
[00190ms]: RefreshIcons
[00190ms]: LoadSysBitMaps
[00198ms]: FontPathes: </usr/share/office2016/fonts:/usr/X11R6/lib/X11/fonts/Type1:/usr/share/fonts/misc/,/usr/share/fonts/TTF/,/usr/share/fonts/OTF/,/usr/share/fonts/Type1/,/usr/share/fonts/100dpi/:error-file = /var/log/xfs.log:/usr/share/fonts/OTF:/usr/share/fonts/TTF:/usr/share/fonts/Type1:/usr/share/fonts/Speedo:/usr/share/fonts/cyrillic:/usr/share/fonts/misc:/home/kgha/.fonts>
[00198ms]: Init Fontcache (364)
[00278ms]: LoadSysFonts
[00278ms]: LoadSysFonts End
[00278ms]: Tempfiles: /tmp/tmIm7VkF/out00000001.tmp
[00279ms]: comInit: CmdLine
[00279ms]: CmdLine < >
[00279ms]: comInit: Address
[00280ms]: comInit: InitCountry
[00280ms]: Countrycode set to <en_US.UTF-8>
[00298ms]: Main locale found: en_US.UTF-8
[00298ms]: Extra locale found: (Collate): C
[00298ms]: nl_langinfo(T_FMT)                       = |%%r|
[00298ms]: nl_langinfo(D_FMT)                       = |%%m/%%d/%%Y|
[00298ms]: nl_langinfo(D_T_FMT)                     = |%%a %%d %%b %%Y %%r %%Z|
[00298ms]: nl_langinfo(_NL_MEASUREMENT_MEASUREMENT) =  2
[00372ms]: Country Settings1: ID:1 CP:0 Curr:$ CF:0 NF:12 TS:, DS:.
[00372ms]: Country Settings2: MS:4 LS:, Lng:enu
[00372ms]: Country Settings Date: DF:56f9 DS:/ DW:  D1S:,   D2S: 
[00372ms]: Country Settings Time: TF:2 TS:: TA:AM TP:PM
[00372ms]: comInit: InitComPrefs
[00373ms]: comInit: Controls
[00373ms]: comInit: Res
[00377ms]: comInit: Install
[00377ms]: comInit: InitAppPrefs
[00380ms]: comInit: InitMenu
[00380ms]: comInit: CreateMain
[00380ms]: comInit: Menuhelp
[00380ms]: comInit: CtlStrips
[00382ms]: comInit: Colors
[00382ms]: comInit: WindowSize
[00567ms]: Debian maximization hacks probably insufficient! [10 ; 20]
(unless the restore size matches maximization size)
[00606ms]: comInit: Treeview
[00606ms]: comInit: Cursors
[00606ms]: comInit: AppBrushes
[00607ms]: comInit: AppFormat
[00607ms]: comInit: AppIcons
[00607ms]: comInit: AppBuffer
[00607ms]: comInit: BrushCache
[00607ms]: comInit: AppFonts
[00607ms]: comInit: AppWindows
[00648ms]: UUID failed
[00648ms]: MAC address failed
[00648ms]: GetHWDataFromSystemLx failed.
[14907ms]: UUID failed
[14907ms]: MAC address successful
[14907ms]: GetHWDataFromSystemLx was successful.
[15698ms]: UUID failed
[15698ms]: MAC address successful
[15698ms]: GetHWDataFromSystemLx was successful.
[15699ms]: comInit: Menus
[15699ms]: comInit: Accelerators
[15699ms]: comInit: History
[15699ms]: comInit: appData
[15699ms]: spInitCountryInfo(0): ID:1 Date:DMYhmsQ TS:, DS:.
[15699ms]: spInitCountryInfo(1): ID:1 Date:DMYhmsQ TS:, DS:.
[15699ms]: GetMRULanguages
[15701ms]: comInit: Printer
[15702ms]: comInit: QuickPath
[15702ms]: comInit: SetMenu
[15702ms]: comInit: Speller
[15702ms]: comInit: appCmdList Start
[15702ms]: comInit: appOpenCommandList
[15706ms]: LoadDocument </home/kgha/SoftMaker/Templates 2016/English/Normal.tmv>
[15741ms]: ReadDocument </home/kgha/SoftMaker/Templates 2016/English/Normal.tmv>
[15797ms]: ReadDocument End
[15834ms]: LoadDocument End
[15834ms]: comInit: appCmdList End
[15835ms]: comInit: ShowWindow
[15842ms]: comInit: Address
[15842ms]: comInit: Timer
[15842ms]: comInit: AutoLoad
[15843ms]: System information startup log finished.
*** End of startup log ***
---
*** End of output ***

Jim-J
SoftMaker Team
SoftMaker Team
Posts: 437
Joined: Fri Apr 04, 2014 8:29 am

Re: Internet connection needed for every start up

Post by Jim-J » Tue Mar 08, 2016 11:48 am

Hello,

Thank you for the content of your sminfo.txt. I have informed the developers about this problem.
Jim J.
SoftMaker Software GmbH

Jim-J
SoftMaker Team
SoftMaker Team
Posts: 437
Joined: Fri Apr 04, 2014 8:29 am

Re: Internet connection needed for every start up

Post by Jim-J » Tue Mar 08, 2016 2:23 pm

arobbo wrote:Thanks Jim - I received your link from the "Desktop Partners" address and have only recently implemented the hotfix. I am afraid it didn't work, but I tried a number of approaches all to no avail. I even copied the new files across to manually over-write the previous ones. With the wifi off, SoftMaker2016 refused to open or acknowledge it had a valid registration key. I will try a full reboot but I don't think I will be successful.
Cheers
I sent you an email.
unhappy_customer wrote:
The issue is NOT fixed !
I would be helpful if you could send us the sminfo.txt (Invoke "Help->About->Write System Information").
Jim J.
SoftMaker Software GmbH

arobbo
Posts: 33
Joined: Mon Nov 23, 2009 2:30 am

Re: Internet connection needed for every start up

Post by arobbo » Tue Mar 08, 2016 10:30 pm

Hi Jim,
I sent you copies of my sminfo post-update 752.0229, I hope they help - still unfortunately not corrected for Puppy Linux TahrPup 6.0.5... but EXTREMELY happy that direct cups-print *and* duplex functionality is now working :),
Nearly There,
arobbo

Jim-J
SoftMaker Team
SoftMaker Team
Posts: 437
Joined: Fri Apr 04, 2014 8:29 am

Re: Internet connection needed for every start up

Post by Jim-J » Wed Mar 09, 2016 9:59 am

arobbo wrote:Hi Jim,
I sent you copies of my sminfo post-update 752.0229, I hope they help - still unfortunately not corrected for Puppy Linux TahrPup 6.0.5... but EXTREMELY happy that direct cups-print *and* duplex functionality is now working :),
Nearly There,
arobbo
Thank you. I have forwarded the file to the development.
Jim J.
SoftMaker Software GmbH

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7886
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Internet connection needed for every start up

Post by sven-l » Wed Mar 23, 2016 12:50 pm

attilas wrote:Every message and dialog boxes are affected.

I’m using openSUSE Tumbleweed (20160208) (x86_64)

My hardware:
Dell Latitude E6520 notebook
CPU: i5-2540M CPU @ 2.60GH
RAM: 16GB DDR3-1333MHz
GPU: Intel(R) HD Graphics 3000 (2nd Generation Core Processor Family Integrated Graphics Controller)
The developers could solve that problem. It should not occur anymore with the next service pack.
Sven Leßmann
SoftMaker Software GmbH

attilas
Posts: 34
Joined: Mon Dec 07, 2015 2:49 pm

Re: Internet connection needed for every start up

Post by attilas » Wed Mar 23, 2016 1:07 pm

sven-l wrote:The developers could solve that problem. It should not occur anymore with the next service pack.
Thank you, the ofl16_hotfix fixed it 8)

Post Reply

Return to “SoftMaker Office 2016 for Linux (General)”