Edit the List Number Style

Post your questions, bug reports and suggestions here for TextMaker 2016 for Windows.

Moderator: SoftMaker Team

Post Reply
snowshed
Posts: 56
Joined: Fri Feb 23, 2018 11:10 pm

Edit the List Number Style

Post by snowshed » Fri Feb 23, 2018 11:24 pm

Windows 7 Ultimate

When I use the List Number Style, I get output that looks like this:

1.. Blah blah blah blah blah blah blah blah blah blah blah
2.. Blah blah blah blah blah blah blah blah blah blah blah
3.. Blah blah blah blah blah blah blah blah blah blah blah
4.. Blah blah blah blah blah blah blah blah blah blah blah

Please not the 2 periods after the number.

Is there a way to edit that style so there is only 1 period? I do not see a way to do that when I click Edit.

sven-l
SoftMaker Team
SoftMaker Team
Posts: 8123
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Edit the List Number Style

Post by sven-l » Fri Mar 02, 2018 4:07 pm

Could you please attach a sample file? That would help us to find out what's wrong here.
Sven Leßmann
SoftMaker Software GmbH

snowshed
Posts: 56
Joined: Fri Feb 23, 2018 11:10 pm

Re: Edit the List Number Style

Post by snowshed » Sat Mar 03, 2018 4:42 pm

sven-l wrote:
Fri Mar 02, 2018 4:07 pm
Could you please attach a sample file? That would help us to find out what's wrong here.
Attached. :)

I have been experimenting with modifying and creating my own styles, but the problem has shown up in 2 documents.

Thanks you.
Attachments
Windows 10 Basics.tmd
(57.43 KiB) Downloaded 70 times

Jossi
SoftMaker Volunteers
SoftMaker Volunteers
Posts: 1023
Joined: Fri Dec 05, 2003 10:47 pm
Location: Luebeck, Germany

Re: Edit the List Number Style

Post by Jossi » Sat Mar 03, 2018 7:43 pm

In editing the number list format, you added a full stop (period) in the field "Numbering text". This isn't necessary, as it is added automatically by the program. Delete it, and everything is o. k. (see attached screenshot).

Screenshot number list.jpg

snowshed
Posts: 56
Joined: Fri Feb 23, 2018 11:10 pm

Re: Edit the List Number Style

Post by snowshed » Sat Mar 03, 2018 9:24 pm

Jossi wrote:
Sat Mar 03, 2018 7:43 pm
In editing the number list format, you added a full stop (period) in the field "Numbering text". This isn't necessary, as it is added automatically by the program. Delete it, and everything is o. k.
Thanks, Jossi,

I don't remember ever being in that dialogue before, in fact I don't remember even using the list number style or even a numbered list in Textmaker until these last two documents.

I always try different programs for a purpose, then settle on the one I like the best.

As a result, I was using the Free Office version for a bit a long, long time ago. When I settled on Softmaker Office and purchased it, could that extra period have been somehow carried over from something I did a long time ago?

Jossi
SoftMaker Volunteers
SoftMaker Volunteers
Posts: 1023
Joined: Fri Dec 05, 2003 10:47 pm
Location: Luebeck, Germany

Re: Edit the List Number Style

Post by Jossi » Sun Mar 04, 2018 12:57 am

snowshed wrote:
Sat Mar 03, 2018 9:24 pm
As a result, I was using the Free Office version for a bit a long, long time ago. When I settled on Softmaker Office and purchased it, could that extra period have been somehow carried over from something I did a long time ago?
To check this, I unearthed and tried an old copy of FreeOffice from 2014, and it seems you are right: In the "Simple Numbering" list style in this program, no period is shown behind the number in the edit dialogue, but it is added in the text; in TextMaker 2016, the period is also visible in the dialogue box (see attached screenshots). So obviously there has been a change somewhere between. If you opened an old document created with FreeOffice in TextMaker 2016, maybe this caused the issue.

FreeOffice 2014.jpg
TextMaker 2016.jpg

snowshed
Posts: 56
Joined: Fri Feb 23, 2018 11:10 pm

Re: Edit the List Number Style

Post by snowshed » Sun Mar 04, 2018 5:16 am

No, I didn't open a doc created in Free Office 2014. If I even have one, I don't know where it would be, as it would have been just something to get the "feel" of the program.

It might be worth checking this out in 2018, to see if the problem exists there also.

Jossi
SoftMaker Volunteers
SoftMaker Volunteers
Posts: 1023
Joined: Fri Dec 05, 2003 10:47 pm
Location: Luebeck, Germany

Re: Edit the List Number Style

Post by Jossi » Sun Mar 04, 2018 11:38 am

Might be that an old preference option persisted, but I'm out of my depth here. SoftMaker should have a look at this issue.

snowshed
Posts: 56
Joined: Fri Feb 23, 2018 11:10 pm

Re: Edit the List Number Style

Post by snowshed » Sun Mar 04, 2018 4:45 pm

Jossi wrote:
Sun Mar 04, 2018 11:38 am
Might be that an old preference option persisted, but I'm out of my depth here. SoftMaker should have a look at this issue.
That could be. It shouldn't take too much time for SoftMaker to do a fresh install of 2018 on a virgin machine to see if the extra period is there. If it is, there's a minor bug. If not, then put an older version on a virgin machine, add that period, the install 2018 on top of the older version and see what happens.

sven-l
SoftMaker Team
SoftMaker Team
Posts: 8123
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Edit the List Number Style

Post by sven-l » Mon Mar 05, 2018 3:54 pm

I will check this here.
Sven Leßmann
SoftMaker Software GmbH

Post Reply

Return to “TextMaker 2016 for Windows”