SMO2016 refusing to start

Post here those questions, bug reports and suggestions for SoftMaker Office 2016 for Windows that do not fit in any of the application-specific subforums.

Moderator: SoftMaker Team

JohnWasilewski
Posts: 383
Joined: Sun Jan 13, 2008 1:06 am

SMO2016 refusing to start

Post by JohnWasilewski » Tue Dec 13, 2016 9:27 am

I have a Lenovo P50s laptop (core i7 vPro) with Windows 8.164 bit with 16GB memory and a SSD, connected to LAN and/or WiFI.
SM-Office worked when I first installed it, on or about 3rd/4th December 2016, but now it doesn't work any more.
Save for the problem I describe below, everything on the laptop works normally.

When I double-click the TM icon:

- sometimes, nothing at all seems to happen, but
Task Manager shows it as a background process
using 32% of CPU and 8MB of memory

- sometimes I get a grey window with the 'TextMaker'
title bar plus window-close and shrink gadgets, and
with a white menu bar with a single entry - 'Help' -
which I cannot click because the 'busy' wheel remains
permanently on. The Task Manager, then shows TM
as an 'App', which is 'not responding'.

PlanMaker and Presentations also won't start.

BasicMaker DOES start.

I have also tried UNinstalling and re-installing SMO2016.
It did not help.

I'm therefore stuck,
---
John
00971-50-642-2378

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2895
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: SMO2016 refusing to start

Post by martin-k » Tue Dec 13, 2016 9:28 am

Run TextMaker.exe with the -debug parameter:

TextMaker.exe -debug

This will create a log file "tmlog.txt" in My Documents. Please upload it here.
Martin Kotulla
SoftMaker Software GmbH

JohnWasilewski
Posts: 383
Joined: Sun Jan 13, 2008 1:06 am

Re: SMO2016 refusing to start

Post by JohnWasilewski » Tue Dec 13, 2016 5:05 pm

Thanks Martin. I'll do that tomorrow when I'm back in the office.
I'm sure it'll be something trivial causing it.
---
John

JohnWasilewski
Posts: 383
Joined: Sun Jan 13, 2008 1:06 am

Re: SMO2016 refusing to start

Post by JohnWasilewski » Wed Dec 14, 2016 9:40 am

Various files attached, which might help.
As you see, TM2012 runs OK. It's TM2016 and other SMO2016 executables that won't run.
---
John

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2895
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: SMO2016 refusing to start

Post by martin-k » Wed Dec 14, 2016 9:52 am

John, no file was attached. We just need the log file for TextMaker 2016.
Martin Kotulla
SoftMaker Software GmbH

JohnWasilewski
Posts: 383
Joined: Sun Jan 13, 2008 1:06 am

Re: SMO2016 refusing to start

Post by JohnWasilewski » Wed Dec 14, 2016 10:08 am

I keep trying to attach files. Not sure what I'm doing wrong.
I'll send them by email.
---
John

JohnWasilewski
Posts: 383
Joined: Sun Jan 13, 2008 1:06 am

Re: SMO2016 refusing to start

Post by JohnWasilewski » Wed Dec 14, 2016 10:26 am

Trying again to send files...
Attachments
tmlog for TM2016.txt
(65.12 KiB) Downloaded 126 times
tmlog for TM2012.txt
(71.03 KiB) Downloaded 110 times

JohnWasilewski
Posts: 383
Joined: Sun Jan 13, 2008 1:06 am

Re: SMO2016 refusing to start

Post by JohnWasilewski » Wed Dec 14, 2016 10:27 am

I'd tried to attach too many.
Attachments
tmw16config.ini
(3.17 KiB) Downloaded 105 times
tmw12config.ini
(523 Bytes) Downloaded 115 times

JohnWasilewski
Posts: 383
Joined: Sun Jan 13, 2008 1:06 am

Re: SMO2016 refusing to start

Post by JohnWasilewski » Wed Dec 14, 2016 10:28 am

I think you have the files now, that I was trying to send.
---
John

sven-l
SoftMaker Team
SoftMaker Team
Posts: 8123
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: SMO2016 refusing to start

Post by sven-l » Thu Dec 15, 2016 11:20 am

I will refer that issue to our developers and report here as soon as I have a solution.
Sven Leßmann
SoftMaker Software GmbH

sven-l
SoftMaker Team
SoftMaker Team
Posts: 8123
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: SMO2016 refusing to start

Post by sven-l » Fri Dec 16, 2016 11:31 am

Please try the following:

- Try to use a different default printer when starting.
- Temporarily rename the settings folder (in the SoftMaker folder) to see if some setting causes this.

Does it help?
Sven Leßmann
SoftMaker Software GmbH

JohnWasilewski
Posts: 383
Joined: Sun Jan 13, 2008 1:06 am

Re: SMO2016 refusing to start

Post by JohnWasilewski » Fri Dec 16, 2016 5:08 pm

I have tried changing the default printer and disabling the Settings folder.
I has not helped.

Here's another TMlog.txt file (attached).
---
John
Attachments
tmlog.txt
(64.04 KiB) Downloaded 133 times

JohnWasilewski
Posts: 383
Joined: Sun Jan 13, 2008 1:06 am

Re: SMO2016 refusing to start

Post by JohnWasilewski » Fri Dec 16, 2016 6:57 pm

I've tried using 'Process Explorer' to see if I can watch what TM2016 opens and see how far it gets.

When running TM2012, 'Process Explorer' reports that TM has run the MS printer driver host, splwow64.exe.
When I try running TM2016, however, 'Process Explorer' DOES NOT report that TM has run splwow64.exe.

This might be a helpful clue to how far TM2016 manages to reach in its startup process.

I am also finding, sometimes, TM2016 displays the attached incomplete screen, with the 'busy' icon spinning endlessly.
---
John
Attachments
Scrshot.jpg

sven-l
SoftMaker Team
SoftMaker Team
Posts: 8123
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: SMO2016 refusing to start

Post by sven-l » Mon Dec 19, 2016 7:52 am

Thank you! I informed the developers.
Sven Leßmann
SoftMaker Software GmbH

sven-l
SoftMaker Team
SoftMaker Team
Posts: 8123
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: SMO2016 refusing to start

Post by sven-l » Tue Dec 20, 2016 8:12 am

What would help us is using ProcMon (https://technet.microsoft.com/en-us/sys ... nitor.aspx), with a filter "Process Name" is "TextMaker.exe". Then start TextMaker. This will create a rather big log. Could you please send it to us? Thank you!
Sven Leßmann
SoftMaker Software GmbH

Post Reply

Return to “SoftMaker Office 2016 for Windows (General)”