Registration problem

Post here those questions, bug reports and suggestions for SoftMaker Office 2016 for Windows that do not fit in any of the application-specific subforums.

Moderator: SoftMaker Team

Post Reply
Scotty2016
Posts: 3
Joined: Wed Sep 21, 2016 10:19 am

Registration problem

Post by Scotty2016 » Wed Sep 21, 2016 10:37 am

I recently purchased, downloaded and installed SoftMaker Office Professional 2016 from your website, and received an email that included a 12-digit product key. However, when I start any of the applications and try to register the product all I get is an error message that says "The connection to the server failed. Please check your internet connection or try again later." This has happened for 3 days now, but I an not experiencing problems with my internet connection (70Mbit/s download, 5Mbit/s upload broadband) in any other application I run.
I an running Windows 10 Home (Version 1511, build 10586.589) and have Kaspersky IS 2016 installed. I have checked that Kaspersky is set to block any connection (and even turned it off completely for a short time), but to no effect.
Please can you tell me how to overcome this problem and register your product. Currently I haven't get a problem because I can use it in trial mode - but in another 27 days I'll be left with an unusable product unless I can resolve this problem. Please help. (I had no problems whatever in running your previos Professional 2012 version). Thank you.

martin-k
SoftMaker Team
SoftMaker Team
Posts: 3025
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: Registration problem

Post by martin-k » Wed Sep 21, 2016 9:08 pm

I checked your product key on the licensing server, and you never achieved a connection, successful or otherwise, to this server.

Do you have a direct internet connection, or do you go through a proxy? If you run Internet Explorer on your PC, can it open web sites? Our licensing code uses the same connection type as Internet Explorer.
Martin Kotulla
SoftMaker Software GmbH

Scotty2016
Posts: 3
Joined: Wed Sep 21, 2016 10:19 am

Re: Registration problem

Post by Scotty2016 » Wed Sep 21, 2016 11:47 pm

Martin-K,
No, I don't use any proxy server whatsoever. I use Firefox as my default browser, and I have no problems connecting to websites using this or the alternative Google Chrome or MS Edge (Yuk!) browsers on my system. (I also seem to have MS Internet Explorer v11 installed on my system - both 32-bit and 64-bit versions - although I never normally use them. I have just tried both versions and each one connects to webpages OK)
Glasswire logsTextMaker (or PlanMaker) attempting to connect to a server bonaire.softmaker.com at IP address 5.9.29.209 Is this what you would expect?
I am completely puzzled and extremely frustrated.
Regards,
Bob

martin-k
SoftMaker Team
SoftMaker Team
Posts: 3025
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: Registration problem

Post by martin-k » Thu Sep 22, 2016 2:35 pm

It is indeed the connection to bonaire.softmaker.com that's interesting (the software actually tries to connect to licensing.softmaker.com, but it's the same server).

Both Glasswire and Kaspersky contain firewalls that may prevent connections. Can you temporarily turn them off, or add exceptions for TextMaker, PlanMaker and Presentations?
Martin Kotulla
SoftMaker Software GmbH

Scotty2016
Posts: 3
Joined: Wed Sep 21, 2016 10:19 am

Re: Registration problem

Post by Scotty2016 » Sun Sep 25, 2016 9:54 am

Martin,

I have now finally managed to make this registration process work - but by a unusual route! I have 3 applications on my computer that could potentially block communications with your server: Kaspersky IS, Glasswire and MalwareBytes; but none of them had settings to interfere with communications to/from your servers. However, as you know, it still didn't work. I disabled them all as far as I could, but without success.

So what I did was to restart the Windows 10 system in Safe Mode with Networking. I logged in using an Administrator account and replaced my normal Wi-Fi connection to the broadband router (which uses an external adapter connected to the computer on USB) with a wired Ethernet cable directly to the router. I could then run TextMaker and manage to register successfully!

Will I have to repeat this process in the future when I need to install Service Packs?

I still don't understand what causes the problem with your registration system - I've never met it before on any other product.

Bob

JohnJonesSmith
Posts: 2
Joined: Fri Apr 21, 2017 6:28 pm

Re: Registration problem

Post by JohnJonesSmith » Fri Apr 21, 2017 6:41 pm

I'm having the same problem, but with a bit different genesis. I'd been using the applications for I'd say about 3 months, occasionally. Now it wants the license key, which I did save at installation time. It gives the same 'can't connect to the server" error as described above. Running windows 7, avast anti-virus and zonealarm. Have tried it with Zone shut off, but no luck. My internet connection is just fine. Can you send maybe a "super" key that doesn't need the internet connection? I highly dislike having to disable all my protections to register a piece of software. Thanks.

JohnJonesSmith
Posts: 2
Joined: Fri Apr 21, 2017 6:28 pm

Re: Registration problem

Post by JohnJonesSmith » Fri Apr 21, 2017 6:51 pm

Concerning my above reply, forgot to mention using free editions.

martin-k
SoftMaker Team
SoftMaker Team
Posts: 3025
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: Registration problem

Post by martin-k » Fri Apr 21, 2017 7:05 pm

The registration problems are already fixed in rev 766 of SoftMaker Office 2016. We are preparing a new FreeOffice which solves the problem there as well. But it still needs to connect to the internet to unlock the software, it just shouldn't do it again unless you change your hardware.
Martin Kotulla
SoftMaker Software GmbH

flapvaber
Posts: 1
Joined: Fri Jul 06, 2018 4:42 am

Re: Registration problem

Post by flapvaber » Fri Jul 06, 2018 4:45 am

I have the exact same problem again..
Last year I was able to solve it by connecting through cable as described.
however this year I'm on a different setup where this is no longer possible.

tried disabling my firewall and anti vir/mal.
no avail.

hope you can help and will solve this annoyance in future updates.
thanks.

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7993
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Registration problem

Post by sven-l » Tue Jul 10, 2018 11:59 am

No other customers are reporting problems with the online registration. Is there an error message?
Sven Leßmann
SoftMaker Software GmbH

Post Reply

Return to “SoftMaker Office 2016 for Windows (General)”