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Introduction
This manual is a guide to creating long publications such as books, newspapers, 
magazines, reports, and papers with Affinity Publisher. It does not describe all 
the features of Publisher so you will have to know how to use format text and 
create graphics.

Creating a book or other long document in Publisher for the first time can be 
daunting because there are so many ways to approach a project that you might 
not know where to start. This manual will help you master some of Publisher’s 
most complex features and get started more quickly.

This manual is laid out for print although it’s distributed electronically because it 
is intended to be a demonstration of what you can accomplish with Affinity 
Publisher. The tips and recommendations found in this guide will help you lay 
out similar publications.

Conventions used

The instructions provided here are for both Macintosh and Windows which 
share a similar user interface. The steps may be somewhat different for iPad and 
are not described in this guide.

Menu commands are abbreviated to make this guide more readable. For 
example, instead of writing choose Copy from the Edit menu this guide uses 
choose Edit > Copy. Keyboard modifiers are shown as:

Macintosh Windows

⌘ (Command) Ctrl

⌥ (Option) Alt

⇧ (Shift) Shift

⌃ (Ctrl)

 Return Enter

Many users of the Affinity suite prefer the dark UI Style, more commonly 
referred to as dark mode. This guide uses light mode screenshots with mono 
icons because they’re easier to read on screen and will save ink or toner for those 
who print this manual on their own printer. You’re welcome to print a copy for 
your own use.

Thank you

Thank you to Serif for providing us with an amazing suite of tools without a 
subscription and for patiently listening to our suggestions. And thank you to all 
the users on the Affinity forum who have put up with my rambling.

Good luck!

Mike
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Publisher makes it easy to create a new document but under-
standing layout options and master pages is important for creat-
ing a publication that is easy to update in the future.

Master pages can be used to insert headers and footers that are 
repeated throughout a publication with automatic page num-
bering and chapter titles.

Using a baseline grid can improve the design of a publication 
with multiple text frames and columns to align the baselines of 
text and objects.

In this chapter
Creating a new document .......................................................................... 2
Changing layout options ............................................................................. 5
Pages and master pages .............................................................................. 7
Headers, page numbers, and sections .................................................22
Baseline grid ...................................................................................................31

Document setup 1
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Creating a new document
Before you create a new document you should plan its size and margins and 
decide whether it will have facing pages. You can change anything about your 
document after creating it, but some changes may require additional effort so it’s 
best to decide on the layout in advance.

If you’re creating a book or magazine you should create the cover as a separate 
document—most book documents start with an interior title page.

1. Choose File > New…

2. Choose from one of the preset sizes on the left. By default, they are all portrait 
so to change the orientation click the Landscape  icon above the presets.

3. Click the Layout tab to change the page size, measurement units, resolution, 
image placement policy, and if a master page should be created.

• Enter the Width and Height and choose the Units if you want to custom-
ize a preset’s size.

• For projects with large images, choose Prefer Linked from Image place-
ment to avoid embedding them and increasing the file size.

Tip: There are two 
groups of paper size 
presets but the only 
differences are colour 
format (space), colour 
profile, and bleed; 
choose a Press Ready
preset if the document 
will be printed on a 
commercial press or a 
Print preset if you will 
print it on a desktop 
printer

Tip: Don’t select pixels 
for the units if the 
document will be 
printed
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• Select Default master so that all pages will be based on a master page 
unless you’re creating a short document such as a brochure or poster.

• DPI impacts only the default dimensions of placed images so it’s not that 
important; you will choose the resolution when printing or exporting.

4. Click the Pages tab to change whether a document is made up of single pages 
or facing pages and if you want to change how they’re arranged.

• Deselect Facing pages to create a single-pages document. All of the Print
and Press Ready presets default to facing pages which is commonly used 
for books and magazines.

• Choose Vertically from Arrange for a book bound at its top like a calen-
dar instead of on its side. Choose Left from Start on to start a document 
on the left side (top side for vertical books) but most books start on the 
right because the inside cover is typically blank.

• Use the Number of pages option only for short documents because Pub-
lisher doesn’t create text frames for the pages created with a document. 
New documents will be based on a default master page if Default master
is selected on the Layout tab, but they won’t have any text frames. If you 
create many pages when creating a document and later add text frames to 
their master page, the frames won’t be linked from page to page so it’s best 
to create just a single page.

5. Click the Colour tab to change the Colour format and Colour profile.

• The default Colour format (space) for the Press Ready presets is CMYK/8
and is RGB/8 for the Print presets. In general, select CMYK/8 when 
printing in colour on a commercial press or Grey/8 for a publication that 
will be printed in black and white. Select RGB/8 for a digital publication.

• The default Colour profile for CMYK documents is U.S. Web Coated 
(SWOP) v2. Always speak with your print partner before selecting a colour 
profile. Leave this option if you’re unsure because you can change it later 

Tip: Publisher doesn’t 
offer a feature similar 
to the Primary Text 
Frame option of 
InDesign® or Auto-
matic Text Box option 
of QuarkXPress™ so 
you must create text 
frames after creating a 
document

Tip: Publisher doesn’t 
offer a starting page 
number option in New 
Document but you 
can change it after 
creating the docu-
ment by choosing 
Window > Section 
Manager

Tip: Refer to Colour on 
page 241 for a descrip-
tion of colour formats 
(spaces) and profiles
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by choosing Document > Document Setup, but your colours may be 
adjusted for the new profile.

• If you don’t want an exported document to have a white background then 
choose Transparent background.

6. Click the Margins tab to customize the margins. Almost every document 
should have margins, even those with images that bleed off the page, but you 
can choose not to include them if you wish. The margins have no impact on 
the finished document but serve as guides for you to frame the body content 
of the page.

7. Click the Bleed tab and enter the dimensions if the document will have 
images that bleed off the page. This option applies only to documents that will 
be professionally printed and trimmed after printing.

8. To save this customized document setup as a preset to use in the future, click 
the Save Preset As  icon or click the Save and Overwrite Current Preset
icon to update an existing preset.

9. Click Create and the new document will be displayed in the window.

Tip: You can choose to 
show or hide margin 
guides later by choos-
ing View > Show 
Margins

Tip: Click the icon to 
the right of text fields 
to Link  the fields 
and set all the fields 
the same when you 
enter changes, or to 
Unlink  the fields to 
set them separately

Tip: Publisher doesn’t 
offer a separate slug 
option so create a 
larger bleed and place 
your slug information 
there and ensure View 
> View Mode > Clip to 
Canvas is not selected

The Trim Box is enclosed by the page edges 
and approximates where trimming will occur

Objects must extend to the edge of the Bleed 
Zone when Bleed is set in Document Setup

Tip: Select View > 
Show Bleed to show 
the bleed guides and 
the objects in the 
bleed zone

Definition: Bleed refers 
to the area beyond the 
edge of the page in 
which text and objects 
will still be printed

Tip: The two preset 
icons are difficult to 
see in Light Mode in 
Publisher 2.3; mouse 
over the area to the 
right of the preset 
name and a tooltip 
will appear when you 
are over them
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Changing layout options
A document doesn’t have an intrinsic page size, orientation, or margins—these 
are properties of the master pages in the document; however, the Document 
Setup window allows you to change the properties of all or selected master pages 
and spreads (pages) in the document.

To change the options for a document after creating it:

1. Choose File > Document Setup.

2. To change the entire document, leave the setting in the top left of the Docu-
ment Setup window as Whole Document. You can also change one or more 
master pages or spreads (pages) at once by choosing Selected Masters or 
Selected Spreads and then selecting masters or spreads from the list on the 
right.

3. Most of the options in this window are the same as for creating a new docu-
ment so refer to Creating a new document on page 2.

4. While you can turn facing pages on and off with the Model tab, it can have a 
serious impact to your document. Changing a facing-pages document to 
single pages will separate its facing-page master pages into two single-page 
master pages, as well as separating all of the document’s spreads. Changing a 
single-page document to facing-pages will convert the document’s pages to 
spreads but the masters will remain single pages.

Tip: A few of the 
options such as Facing 
Pages are under 
different tabs than in 
the New Document
window

Tip: The list of master 
pages and spreads is 
clickable only when 
Selected Masters or 
Selected Spreads is 
selected

Tip: If you change 
master pages or 
spreads with different 
page sizes or other 
options, the options 
shown will be for the 
first master or spread 
you selected; to 
change all selected 
masters or spreads to 
the option of the first 
one, select a different 
option and then 
change it back
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5. If you change the page size, you must choose whether to keep the objects and 
text the same size or to scale them to fit. Click the Scaling tab and choose 
Rescale for projects such as posters and brochures, and Anchor to Spread for 
projects such as books because rescaling changes the size of text and not just 
objects. When you anchor the objects, you can also choose the anchor posi-
tion by clicking one of the anchor handles. 

When you rescale the objects, you can select how images are resampled:

Nearest Neighbour Fast but lower quality; use for hard-edge images

Bilinear Use when scaling pages smaller

Bicubic Use when scaling pages larger

Lanczos 3 (separable) Very high quality but slower than the above options
 (recommended)

Lanczos 3 (non-separable) Marginally-higher quality than Lanczos 3 (separable)
but slightly slower

6. If you change the Colour format (space) or Colour profile, choose Assign to 
keep colours unchanged, including 100% Black, although the appearance may 
change. Choose Convert to modify colours to match the new format or 
profile while maintaining the appearance.

7. Click OK to change the layout options.

Tip: If you’re unsure 
which Resampling
option to use, select 
Lanczos 3 (separable) 
for best results
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Pages and master pages
A document in Publisher can include as many pages or spreads as you need. You 
can specify the number of pages to add when creating a new document but it is 
recommended to do that only for short documents. Refer to Creating a new 
document on page 2 for more information. Pages are referred to as document 
pages in this manual to distinguish them from the master pages on which they 
can be based.

Master pages
Document pages are usually based on master pages to create consistency between 
pages. Objects placed on a master page will be visible on all document pages 
based on that master and later changes made to the master will be replicated on 
all the pages.

Objects can’t be moved or modified on document pages unless you break the link 
between them and the master. However, the content of text and picture frames 
on a master page can be modified on a document page. Master pages are fre-
quently used to contain the text frames for a long publication.

When you create a new document with the Default master option selected, 
Publisher automatically creates a master page named Master A and applies it to 
the page(s) created for the document. You might not need to use a master page 
for a short document such as a brochure, but they should always be used for long 
publications such as books, magazines, and newspapers.

Spreads
A facing-pages document is made up of spreads, pairs of left (verso) and right 
(recto) pages of the same size and orientation joined together at the spine of the 
publication and displayed together. Spreads are used for books, magazines, and 
any document where the left and right page layouts are mirrored. 

Objects and text positioned on the left page of a spread also can extend onto the 
right page, an approach commonly used in magazines.

Publisher does not support spreads made up of more than two pages. If you need 
to use a multi-page spread, create a single page and divide it into sections using 
guides.

The document page 
(top) is based on the 
background master page 
(bottom)

Tip: You can add tens 
of thousands of pages 
to a Publisher docu-
ment but most 
computers can’t 
handle that many 
pages so if you run 
into performance 
issues you should 
divide your document 
into chapter docu-
ments; refer to Books
on page 129

Definition: Spread
refers to a pair of left 
and right pages in a 
facing-pages 
document

Tip: Use Edit 
Detached to modify a 
master page’s objects 
on a document page; 
refer to Overriding 
master page objects 
on document pages
on page 19

2 single pages Spread of left and right pages

Definition: A master 
page is a background 
or parent page that 
defines the layout and 
some of the text and 
objects of the regular 
document pages 
based on it; master 
pages are frequently 
referred to simply as 
masters
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Using the Pages panel
The Pages panel is an important panel to keep open when working on a multi-
page document because it allows you to add, move, modify, and delete pages, as 
well as select which page to view. A thumbnail for each page is displayed and 
spread thumbnails are shown for facing pages.

To display and customize the Pages panel:

1. Choose Window > Pages to display the Pages panel if it is not already open.

The page or spread that you’re currently viewing will be indicated with a grey 
rectangle.

Publisher will show both absolute and relative page numbers if you have 
restarted page numbering in the document. Refer to Page numbering on page 
23 for more information.

2. Change the width of the panel to set how many columns of thumbnails can be 
shown at once.

3. Collapse or expand the Master Pages or Pages areas by clicking the caret 
icons to the left of their titles.

4. Choose Small Icons, Medium Icons, or Large icons from the panel menu 
to change the size of the page thumbnails.

5. Choose Scroll with View from the panel menu  so that the page(s) visible 
in the document window are visible in the panel.

Master page area

Panel menu

Document page area

Add, Duplicate, and Delete 
master page

Section Manager, and Add, 
Duplicate, and Delete page

Current spread

Selected spread

Tip: The blue highlight 
colour can be custom-
ized on macOS with 
System Settings > 
Appearance

Definition: Absolute
page number refers to 
the number of the 
page within the 
document; the relative
page number is what 
is displayed on a page 
by restarting page 
numbering

Tip: You can’t move 
the Master Pages area 
to the bottom or set 
its thumbnail size 
independently, but 
you can collapse it to 
save space when you 
don’t need it
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To select pages to manipulate:

• Single-click a page, spread, or master page thumbnail to select it so you can 
perform actions to it. For a spread, click its left or right side to select just one 
side of it or click its centre or label to select the entire spread. The selected 
page, spread, or master is indicated by a blue rectangle.

• To select a range of pages or spreads, select one by single clicking it and then 
press Shift and click the last one in the range of pages or spreads. Alterna-
tively, you can drag select a range of pages just as you would drag select file 
icons on your computer.

• To select multiple pages that aren’t in a continuous range, press ⌘ (macOS) or 
Ctrl (Windows) and click each page thumbnail.
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Working with pages
To add multiple pages:

1. Select the page or spread in the Pages panel before or after which you want to 
add pages.

2. Click the Add Pages  icon in the panel or choose Document > Add 
Pages…

3. Enter the number of pages to add in the Add Pages window.

4. Choose whether to insert them before or after the page you specify.

5. Choose which master page, if any, on which to base them.

6. Click OK.

To add a single page or spread:

1. Drag a master page thumbnail before or after another page or spread thumb-
nail in the Pages area in the Pages panel, or choose Document > Add Page.

To view a page or master page:

1. Double-click a page or master page thumbnail in the Pages panel, or the page 
number below the thumbnail. For a spread, double-click its left or right side 
to centre that side in the document window or double-click its centre or label 
to centre the entire spread in the window. The page will always be zoomed to 
fit the window.

2. Or choose Document > First Page, Previous Page, Next Page, Last Page or 
the equivalent navigation icons at the bottom left of the document window.

3. Or choose Go to Page… or click in the Page number of the page navigation 
controls in the Status Bar at the bottom of the document window and enter a 
page number.

4. Or use the document window’s vertical scrollbar to scroll until the page you 
want is visible in the document window and then click anywhere on the page.

Tip: Adding a single 
page to a facing-pages 
document may lead to 
confusing results; refer 
to Working with 
spreads on page 13

First Page Page Number Previously Viewed PageLast Page

Next PagePrevious Page Toggle Master View

Tip: If you don’t like 
the view magnifica-
tion changing when 
switching pages, use 
one of the other 
methods for switching 
pages
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5. Or to view the master page for the current document page, choose Document 
> View Masters or click the Toggle Master View icon. Choose or click it 
again to view the document page again. If a page has more than one master 
page applied to it, this command and icon will display the top master page in 
the layer stack.

To reorder pages:

You must use the Pages panel to reorder pages in Publisher; there is no Move 
Pages command as in some other applications.

1. Select one or more page thumbnails in the Pages panel and drag them before 
or after another page thumbnail. A blue line will appear to indicate where the 
pages(s) will be moved. You can also drag a single master page thumbnail if 
you want to change their sort order.

To duplicate pages:

1. Select one or more page thumbnails in the Pages panel.

2. Right-click any of the selected thumbnails and choose Duplicate # Pages
from the context menu, where # is the number of pages selected. The dupli-
cate pages will be added after the last selected page.

To delete pages:

1. Select the page thumbnail(s) to delete in the Pages panel and click the Delete 
Selected Pages  icon. You can also right-click the thumbnail and choose 
Delete from the context menu.

• If the deleted page includes a text frame linked to or from another page, 
the text in the frame will not be deleted. The frame will be removed from 
the series of linked frames without any impact to the text in its story. The 
story may overflow the last text frame in the series.

To copy pages from one document to another:

You can’t drag page thumbnails from one document to another as you can in 
some other applications but you can add pages to another document.

1. Open the document you wish to add page(s) to.

2. Choose Document > Add Pages from File and then select the other docu-
ment from the Open window. You can also right-click the thumbnail of the 
page after which the page(s) should be added and choose Add Pages from 
File… from the context menu.

Tip: Adding, moving, 
or deleting a single 
page in a facing-pages 
document may lead to 
confusing results; refer 
to Working with 
spreads on page 13

Tip: If you recorder 
master pages with 
automatic names 
(Master A, Master B…), 
the masters will be 
reordered but their 
names will be updated 
to maintain the A, B, 
C… sequence
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3. Select the pages or spreads you want to copy.

4. Click OK. The pages or spreads will be imported and added to the current 
document.

5. Delete the page that you imported which will leave just the imported mas-
ter(s) ready for use.

To change the size of a page (without using a master page):

1. Right-click the page or spread thumbnail in the Pages panel and choose 
Spread Properties… from the context menu.

2. All of the other options in the Spread Properties window are the same as for 
creating a new document and changing its setup, so refer to Creating a new 
document on page 2 and Changing layout options on page 5.
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Working with spreads
Adding, moving, or deleting a single page in a facing-pages document can lead to 
confusing results. When you insert a single page before a facing-pages spread, 
the resulting spread will have a master page applied separately to each side of the 
spread, even if they’re both based on the same master. Objects directly on a 
document page will remain on the page in the same location as you would expect 
but objects on a master page layer will be doubled up. If you’ve modified those 
objects, for example, by adding text or a picture to a master layer frame, you will 
see overlapping content.

The best way to resolve this outcome is to re-apply the master page to the entire 
spread so that it’s not applied separately to each side. However, even if you do this 
the last page in the document may have the same issue.

It is best to avoid adding, moving, and deleting single pages in a facing-pages 
document if at all possible.

Creating master pages
You can create additional master pages if you want some pages to have a different 
layout than others; for example, mixing one- and two-column layouts in the 
same book.

Although a document has an inherent size, orientation, colour profile, margins, 
bleed, and more, you can change any of these options for each master page. This 
is useful if you want to mix page sizes in a document, or insert a landscape page 
for a large table in an otherwise portrait document.

To create a master page:

1. If the Pages panel is not already open, choose Window > Pages.

2. Click the Add Master  icon.

3. You can name the master page in the Add Master window for clarity but if 
you don’t enter a name then it will be given an automatic name such as 
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Master B. All of the other options in this window are the same as for creating 
a new document, so refer to Creating a new document on page 2.

4. Click OK to add the master page.

To delete a master page:

1. Select the master page thumbnail in the Pages panel and click the Delete 
Selected Master  icon. You can also right-click the thumbnail and choose 
Delete from the context menu. If the master page is applied to any pages then 
you will be prompted to confirm deleting the master’s content from those 
pages.

Changing master page layouts
To change the layout of a master page after creating it:

1. If the Master Pages section of the Pages panel is collapsed, click the > icon to 
the left of the Master Pages section title to expand it.

2. Right-click the master page thumbnail in the Pages panel and choose Spread 
Properties… from the context menu.

3. All of the other options in the Spread Properties window are the same as for 
creating a new document and changing its setup, so refer to Creating a new 
document on page 2 and Changing layout options on page 5.

Tip: Click a page 
thumbnail once to 
select it so you can 
perform actions to it; 
double-click it to 
display that page in 
the document window
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Applying master pages to document pages
You can apply a master page to document page(s) when creating a document or 
adding pages. After creating a document or adding pages, you can apply a differ-
ent master page or remove the master applied to the document pages.

If your document requires many similar master pages, you can base a page on 
two or more master pages to avoid duplicating objects on more than one master 
and having to update each of them separately if changes are later required.

There are two ways to use multiple master pages. You can apply multiple masters 
to a document page or you can base one master page on another and apply the 
combined master to a document page. The examples below illustrate combining 
two masters but you can apply many masters to the same page.

While a non-facing-pages document can include only single-page document 
pages and master pages, a facing-pages document can include single-page and 
facing-page document pages and master pages. If you apply a single-page master 
to a facing-pages spread then it will be applied to both sides of the spread. 
Adding a single-page master page to a facing-pages book or magazine might 
seem unusual but some publications have special pages that appear identically on 
the left or right side and it’s easier to use just a single-page master.

You can also apply different master pages to the left and right pages of a spread 
and apply masters of different sizes to the same page(s). If you apply different-
sized masters to a page you will be prompted whether to retain the existing page 
size or resize it to match the new master.

Base one master page on another: The 
document page (top) is based on a 
background master page (middle) which 
is based on the background master page 
(bottom)

Apply multiple masters: The document 
page (top) is based on the contents of 
both background master pages applied 
to it (middle and bottom)

Tip: A popular 
approach is to create a 
main master for the 
guides and header 
and footer text such as 
page numbers and 
running headers, and 
other masters based 
on that for the text 
and picture frames 
needed for the various 
page layouts

Tip: You can apply 
only one master page 
to a page at once so it 
is generally easier to 
base one master page 
on another
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To apply a master page to document page(s) or another master:

1. Right-click a page or master page thumbnail in the Pages panel and choose 
Apply Master… from the context menu.

2. Choose which master page to apply in the Apply Master window and which 
page(s) to apply it to.

3. Choose Replace Existing to remove the current master page(s) from the 
selected pages before applying the new master page or deselect it to layer the 
new master page over the existing one(s).

If you choose Replace Existing, choose Clear to delete the current master’s 
object(s) or Migrate to preserve content in master page text and picture 
frames. Using migrate will move content from the old master’s frames to the 
most similar frames on the new master. If there isn’t a matching object then 
the objects will be detached from the old master and promoted to regular 
objects on the document page.

4. If the new master page is a different size than the page(s) to which it is being 
applied, you will be prompted whether the page(s) should be resized. If you 
choose No then Publisher will scale the master page’s objects and text uni-
formly from the centre.

Tip: To migrate some 
text and images but 
not all, lock the 
objects on the new 
master page that you 
don’t want content 
migrated into with 
Layer > Lock

Tip: Objects other 
than frames will be 
removed regardless of 
whether Clear or 
Migrate is chosen

Tip: You can apply 
only one master page 
at once so to apply 
multiple masters, 
repeat these steps but 
ensure you deselect 
Replace Existing each 
time
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5. You can change how master page objects and text are scaled to fit a different 
page size with the Layers panel. If the panel is not already visible, choose 
Window > Layers. Right-click the master page layer (i.e., Master A or the 
name you have chosen for it) and choose Properties from the context menu.

6. The Master Properties window allows you to choose which sides of a spread 
the master is applied to (facing pages only) and how the content should be 
scaled. Note that text may not fit in its frame after scaling and may need to be 
adjusted.

• None: Applies the master without scaling, even though the content may be 
too small or too large for the page size.

• Stretch (not recommended): Stretches the master content in both direc-
tions to fill the page.

• Uniform to Fit (default, recommended): Scales the master content uni-
formly so that the content in the larger direction fits the page, ensuring 
that no content is cropped. This option will leave white space gaps for the 
smaller direction.

• Uniform to Fill: Scales the master content uniformly so that the smaller 
direction fits the page, cropping the content in the larger direction.

To apply a master page by dragging its thumbnail:

1. If the Master Pages section of the Pages panel is collapsed, click the caret 
icon to the left of the Master Pages section title to expand it.

2. Drag the master page thumbnail onto the thumbnail for a single page, a page 
spread, or one side of a spread. If multiple page thumbnails are selected. the 
master will be applied to all of them. The Apply Master window will not be 
displayed, the existing master page(s) will be replaced, edited objects will be 
migrated, and if the page sizes of the old and new masters do not match you 
will not be prompted whether to change the page size.

To convert a document page to a master page:

You can’t directly convert a document page to a master page but there is a way to 
accomplish this task.

Tip: Hold down ⌥
(macOS) or Alt (Win-
dows) while dragging 
the master page icon 
to apply the new 
master without 
replacing the existing 
one(s)
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1. Choose the Move  tool and then choose Edit > Select All.

2. Create a blank master page of the same size and layout. Refer to Creating a 
new document on page 2.

3. Choose Edit > Paste to duplicate the objects onto the new master page.

To unassign a master page from a document page:

1. Right-click a page thumbnail in the Pages panel and choose Clear Master
from the context menu. You can also choose Apply Master and then choose 
None from the list of master pages.

To import masters from one document into another:

You can’t directly import a master page from another document but there is a 
way to do this.

1. If you want to import multiple master pages from a document, open that 
document and using the Pages panel, add a new page or spread at the end of 
the document. Select the first master page you want to import when adding 
the page.

Right-click the thumbnail of the new page in the Pages panel and choose 
Apply Master… Select the name of the second master page you want to 
import and deselect Replace Existing. Repeat this step for each additional 
master page and then save the document under a temporary filename.

2. Open the document into which you want to import master page(s). Choose 
Document > Add Pages from File and then select the other document from 
the Open window.

3. Select the a page or spread based on the master page(s) you want to import.

4. Click OK. The page and its master(s) will be imported and added to the 
current document.

5. Delete the page that you imported which will leave the imported master(s) 
ready for use.
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Editing master page objects
You can add, transform, and delete master page objects by viewing the master 
page and making changes there. Changes made to a master page will be repli-
cated on all the pages. But you can also edit master page objects while viewing a 
document page so that you can see the impact of the changes in the context of a 
document page.

To edit master page objects while viewing a document page:

1. Choose Layer > Master Page > Edit Linked. A green bar will appear at the 
top of the document window to inform you that you’re editing the master 
page linked. Note: If there is more than one master page applied to the docu-
ment page then this will edit the top master in the layer stack. It is advisable 
to instead right-click the master page layer in the Layers panel and choose 
Edit Linked from the context menu.

2. Transform the master page’s objects as desired. Expand the master page layer 
by clicking its caret  icon in the Layers panel if you want to drag objects 
into and out of the master page layer.

3. Click Finish in the green bar or choose Layer > Master Page > Edit Frame 
Content. The master page will be updated along with all other document 
pages based on that master.

Overriding master page objects on document pages
The content of text and picture frames on a master page can be modified on a 
document page but the frames themselves can’t be transformed, nor can other 
objects such as shapes be changed on a document page.

When editing a document page, you can select a text or picture frame on a 
master page layer so that you can modify its content but you can’t select other 
master objects such as shapes because they don’t have content that can be 
changed on a document page.

Publisher displays master page frames on document pages with different handles 
to indicate that they can’t be transformed on the document page.

Tip: Art text and path 
text objects work like 
text frames when 
placed on a master 
page; their contents 
can be changed on a 
document page

Text and picture frames on 
a document page: Round 
size handles can be used to 
modify the frame

Text and picture frames on 
a master page: X handles 
indicate that the frame 
cannot be modified
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Sometimes you may want to change a master page’s objects for just one page 
without creating another master. While you can’t transform master objects on 
document pages, you can detach the master page to override it. This allows you 
to make changes to the master page’s objects for the current page.

Objects that are overridden by detaching the master page will still be updated if 
you change them later on the master page, as long as the updates are different 
from those you made while editing detached. For example, if you change a 
master page object’s colour from red to green on page 3 but later change it from 
red to blue on the master page, the object on page 3 will not change. But if you 
move the object on the master page, the object on page 3 will move.

To override a master page:

1. Choose Layer > Master Page > Edit Detached. A green bar will appear at the 
top of the document window to inform you that you’re editing the master 
page detached. Note: If there is more than one master page applied to the 
document page then this will edit the top master in the layer stack. It is 
advisable to instead right-click the master page layer in the Layers panel and 
choose Edit Detached from the context menu.

2. Transform the master page’s objects as desired and then click Finish in the 
green bar or choose Layer > Master Page > Edit Frame Content.

To prevent a master page object from being overridden:

1. Select the object on the master page.

2. Choose Window > Layers to open the Layers panel if it is not already open.

3. Right-click the object in the Layers panel and choose Lock from the context 
menu, or click the Toggle Lock  icon for the layer. You will be unable to 
unlock the object while using Edit Detached on a document page.

To hide master page objects on a document page:

1. Choose Window > Layers to open the Layers panel if it is not already open.

2. Click the Toggle Visibility  icon for the master page layer.

To remove master page overrides from a document page:

1. Re-apply the master page to the page.

Tip: Publisher’s Edit 
Detached feature is 
similar to the Override 
feature in Adobe®
InDesign® and 
shouldn’t be confused 
with its Detach feature 
that completely breaks 
the link to the master 
page; to fully detach a 
master object in 
Publisher, drag the 
object’s layer out of 
the master page layer 
while using Edit 
Detached
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Changing the stacking order of master page objects
Master page objects are on a master page layer which is positioned below docu-
ment page objects because a master page is the background of a document page. 
If you have multiple masters applied to the same document page you might want 
to change the order of the master page layers, and in rare cases you might want 
the master page layer to be above objects on the document page.

To change the stacking order of master page layers:

1. Choose Window > Layers to open the Layers panel if it is not already open.

2. All of the objects on each master page applied to the current page will be 
grouped together on a master page layer. Click that layer to select it and drag 
it to a different position in the layer stack.

Tip: You can reorder 
the master page layers 
relative to layers on 
the document page, 
but to reorder the 
layers within a master 
page layer you must 
use Edit Detached or 
Edit Linked

Tip: You can’t lock a 
master page layer to 
remain at the top of 
the layer stack—new 
objects draw on the 
document page will 
be created above of 
the master layer
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Headers, page numbers, and sections
Most books and magazines have headers or footers at the top or bottom of each 
page to convey information about the document, chapter, and page. Headers and 
footers should be created on master pages so that they will appear on each docu-
ment page without duplicating text frames.

If you want some pages to have a different version of the header or footer or none 
at all, create an additional master page for those pages.

Sections
Publisher uses sections to customize page numbering, to name or number chap-
ters, and to exclude a range of pages from being exported.

While it is a best practice to link text frames from page to page in a document, 
you should break the link at the end of each section because the start pages of 
sections are fixed and can’t float with the heading at the start of your next chapter 
as they do in word processors such as Microsoft® Word.

Most books created as a single document in Publisher will have at least two 
sections, one for front matter and one for body pages. This book has two sec-
tions. Using a section for every chapter is useful if you need to insert chapter 
names or numbers into a header or footer.

Master page layout: This is the master page for this page of this book. Note the mirrored text frames in 
the footer at the bottom for page numbers, and mirrored text frames which are linked from left to the 
right. The other lines are guides.

Definition: A section is 
a range of pages 
starting on a specific 
page and continuing 
until the start of the 
next section or the 
end of the document
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Page numbering
Publisher can number your document’s pages automatically. If you want to 
change the numbering format for different parts of your document, you can 
divide your document into sections and use a different numbering format for 
each section.

To create a header or footer:

1. Using the Pages panel, double-click a master page thumbnail or its name 
below the thumbnail. If the master is facing pages then you need to add text 
frames to both sides.

2. Using the Frame Text  tool, draw a text frame to include the header or 
footer information. While formatting a header or footer, it is best to type a 
placeholder page number or section name even if that information will be 
updated automatically. Once you have the formatting the way you want it, you 
can delete the placeholder information.

3. Apply the master page to document page(s). Refer to Applying master pages 
to document pages on page 15.

To add automatic page numbers:

1. View the master page and click in the header or footer where you want the 
page number to appear.

2. Choose Text > Insert > Fields > Page Number, or double-click the Docu-
ment Sections > Page Number field name in the Fields panel. The # sign will 
be shown for the page number on a master page.

3. Choose Text > Highlight Fields to add shading behind fields such as page 
numbers to make them easier to see while editing your document. This 
shading will not be printed.

Tip: To right align a 
page number as 
shown in this example, 
choose Text > Insert > 
Spaces and Tabs >> 
Right Indent tab or use 
a standard tab and 
create a right-aligned 
tab stop set to 0 from 
right

A footer with a page number field on a 
master page

A footer with a page number field on a 
document page

Tip: You can also use 
the Artistic Text
tool to create a header 
or footer but it is 
easier to draw a text 
frame aligned to the 
left and right margins 
and then to align the 
text within the frame, 
especially if you insert 
fields which have long 
names when viewed 
on a master
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To change the page number format:

Sections are used to customize the page numbering format.

1. Choose Window > Section Manager or click the Section Manager  icon in 
the Pages panel.

2. Choose the Number style for the default first section. You can also enter a 
Section Name if desired.

3. If you want to change the numbering style for the entire document, click 
Close. Many books use Roman numerals (i, ii, iii, iv…) for the front matter 
pages and Arabic Numbers (1, 2, 3, 4…) for the body pages. To do this, you 
will need at least two sections in your document. Change the first section’s 
Number style to i, ii, iii, iv…

4. Keep the Section Manager window open and in the document window, 
switch to the page on which the page numbering should change.

5. Using the Section Manager, create a second section for the body pages start-
ing on the current page by clicking the Add Section  icon. You can also 
right-click the page’s thumbnail in the Pages panel and choose Start New 
Section… from the context menu.

6. Enter a name for the new section (optional) and enter the absolute page 
number for its first page in Start on page. Set Restart page numbering at to 1, 
and change its Number style to 1, 2, 3, 4…

Definition: Absolute
page number refers to 
the number of the 
page within the 
document; the relative
page number is what 
is displayed on a page 
by restarting page 
numbering
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To number pages separately in each chapter (section):

Some books number pages in each chapter separately, such as 1.1, 1.2… and 2.1, 
2.2… Publisher can’t automatically add a section’s name as a prefix to the page 
number like some other applications but you can do this easily by combining two 
fields.

1. Choose Window > Section Manager or click the Section Manager  icon in 
the Pages panel.

2. Create a section for each chapter of your document by navigating to its first 
page and clicking the Add Section  icon. You can also right-click the page’s 
thumbnail in the Pages panel and choose Start New Section… from the 
context menu. Enter the chapter number as the Section name, and set Restart 
page numbering at to 1 for each section.

3. View the master page and click in the header or footer where you want the 
page number to appear.

4. Choose Text > Insert > Fields > Section Name, type a period, and then 
choose Text > Insert > Fields > Page Number. You can also double-click the 
Document Sections > Name field name in the Fields panel, type a period, 
and then double-click the Document Sections > Page Number field name. 

Tip: Be careful num-
bering your chapters; 
section 1 for most 
books will be for front 
matter so section 2 
will be for chapter 1 
and so on, as shown in 
this screenshot

Tip: Publisher does 
not offer automatic 
section numbering so 
you must enter a 
number for each 
chapter as its Section 
name

Pages panel showing absolute page 
numbers (left) and relative page numbers 
(in parentheses) for a facing-pages 
document



26 Document setup

This will be shown as <Section Name>.# on a master page but will appear as 
1.1 on the first page of chapter 1.

To change or delete a section after creating it:

1. Choose Window > Section Manager or click the Section Manager  icon in 
the Pages panel. You can also right-click the thumbnail of any page in the 
section and choose Edit Section… from the context menu.

2. Make the desired changes to the section or with the section selected in the list 
on the left, click the Remove Section  icon.

To add last and continued page numbers:

Some books need to display page numbers as # of # (for example, 17 or 98) or 
continued to/from page numbers (for example, continued on page 17). 

1. Using the Frame Text  tool, position the text cursor where you want the 
page numbers to be inserted.

2. Insert the desired fields by double-clicking their names in the Fields panel or 
by choosing it from Text > Insert > Fields:

• Page # of # for an entire document: Insert the Page Number field fol-
lowed by “ of ” and then insert the Total Pages field. The Page Number 
field will use the page numbering style defined for the section but the 
Total Pages field will always be displayed in Arabic numerals.

• Page # of # for a section: Insert the Page Number field followed by “ of ” 
and then insert the Last Page in Section field. Both numbers will use the 
page numbering style defined for the section. You can also choose the Last 
Page in Section Run field which refers to the last page before page num-
bering is restarted, whether that is in the next section or several sections 
later.

• Continued on page #: Enter text such as “continued on page ” (or from 
page) and then insert the Next or Previous Frame Page Number field into 
a text frame on a document page (not a master page) that is part of a series 
of linked frames. These fields display the page number of the previous or 
next frame.

Tip: All of these fields 
are shown as # on a 
master page but they 
will display correctly 
on a document page

A footer with section name 
and page number fields on a 
master page

A footer with section name 
and page number fields on a 
document page
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Using sections for chapters
Many books display the chapter name in the header or footer. If you use the 
Books feature and create each chapter as a separate document you can add the 
chapter name as static text in a master page’s header or footer but if the book is a 
single document then you would need a separate master page for each chapter. 
The Section Manager provides an easier way to add the chapter name to a header 
or footer.

To create sections for a book’s chapters:

1. Choose Window > Section Manager or click the Section Manager  icon in 
the Pages panel.

2. Create a section for each chapter of your document by navigating to its first 
page and clicking the Add Section  icon. You can also right-click the page’s 
thumbnail in the Pages panel and choose Start New Section… from the 
context menu. Enter the chapter name as the Section name.

To display the chapter (section) name in a header or footer:

1. Using the Pages panel, double-click a master page thumbnail or its name 
below the thumbnail.

2. Click in the header or footer where you want the chapter name to appear.

3. Choose Text > Insert > Fields > Section Name. You can also double-click the 
Document Sections > Page Number field name in the Fields panel. This will 
be shown as <Section Name> on a master page but the name of your chapter 
will appear on each page based on this master.

Tip: You can drag the 
Section Manager
window wider so you 
can see your full 
chapter names on the 
left side

Tip: You cannot use 
the Section Name
field for both the 
chapter name and as a 
chapter prefix to 
number pages sepa-
rately in each chapter, 
you must choose one 
or the other
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Running headers
Publisher can repeat heading text in the header or footer automatically. A run-
ning header helps the reader by describing what information will be found on 
the page. Many books display the current topic within a chapter in the header or 
footer while dictionaries and similar books might display the first and last head-
words on each page. If you format your topics or headwords consistently with a 
specific heading style then Publisher can display them automatically in a running 
header.

To create a running header:

1. View the master page and click in the header or footer where you want the 
page number to appear.

2. Choose Text > Insert > Fields > Running Header. You can also double-click 
the Document Sections > Running Header field name in the Fields panel. 
This will be shown as <Running Header> on a master page but the header text 
will appear on each page based on this master.

3. If you moved the text cursor since inserting the running header field, select it 
or position the cursor immediately after the field. Then click the Edit  icon 
to the right of the field in the Fields panel. You can also right-click the field in 
the text frame and choose Edit Field from the context menu.

4. Select which headings to display as a running header and how to format it.

Tip: If you click the 
icon when a field is 
not selected or the 
cursor is not beside it 
you can set the 
defaults for all running 
headers you subse-
quently create, but 
formatting a running 
header will also set the 
defaults so this is 
unnecessary

Tip: Publisher uses the 
term running header
even if it’s inserted 
into a footer

Definition: A run is the 
range of text until the 
next instance of the 
same level of heading
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• Style: Choose the text style you used for the headings you want to be 
displayed in the running header. For most publications you would choose 
Heading 1 (default), Heading 2, or Heading 3, but you can choose any 
paragraph or character text style.

• Use: Choose whether the first or last instance of the selected style should 
be displayed. The default First on page option is recommended for most 
publications—it will even use the header text from a previous page if there 
isn’t an instance of the text style on the current page. Use Last on Page only 
for the last headword on a page for dictionary-style formats because the 
running header will be blank if there isn’t an instance of the text style on 
the current page.

• Include paragraph numbering: Choose if the heading is a numbered list 
and you want the number displayed in the running header.

• Apply limits: Choose to control the running header’s length. Specify 
which character(s) to end on, whether to include the end character, the 
maximum number of words, and whether a truncated header should be 
displayed with an ellipsis.

• Case change: Choose whether the header should be displayed in its origi-
nal case or changed to upper, lower, title (default), or sentence case.

5. Choose Text > Highlight Fields to add shading behind fields such as page 
numbers to make them easier to see while editing your document. This 
shading will not be printed.
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Sample dictionary-format running header

This example uses three text frames on the master page for the running headers 
and page number. Both running headers are set to a character style used to bold 
the dictionary terms but one is set to First on Page and the other to Last on 
Page.

To format a Running Header:

1. Using the Frame Text  tool, right-click the running header field in the 
document text and choose Edit Field… from the context menu. You can also 
select the field or position the text cursor before or after it and then click the 
Format  icon to the right of the field in the Fields panel.

Tip: Do not format a 
running header on a 
master page layer 
while on a document 
page or you will 
override the field on 
the master page and 
impact only the 
current document 
page

Running header set to First on Page Page number Running header set to Last on Page

First instance of 
character style on page

Last instance of 
character style on page
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Baseline grid
A document’s baseline grid will align the baseline of each line of text to horizon-
tal guides spaced equally from the top to the bottom of the page, regardless of the 
paragraph’s leading and paragraph before/after spacing. The baseline grid is like 
writing on ruled paper and is separate from the drawing grid which is used to 
snap objects to uniform grid.

The baseline grid is used to align text vertically across text frames and columns 
on a page and is essential for professional page layout. It is a best practice to set 
the baseline grid’s spacing to the paragraph leading value defined for your body 
text and to define leading as an exact value rather than using the default auto-
matic setting. Headings are typically spaced by a multiple of the baseline grid and 
leading values.

For example, for 12 pt body text, you might set paragraph leading to exactly 14 pt 
and your baseline grid to 14 pt. Because headings would likely be larger than 14 
pt they would have leading of 28 pt, double the baseline grid. You would nor-
mally set space before and after the paragraph to 0 or an increment of the base-
line grid because they would be ignored if they were less than the baseline grid.

While you don’t have to align text frames to the baseline grid—their text base-
lines will be aligned regardless—it is a best practice to align everything on the 
page to a multiple of the baseline grid so position and size frames after setting up 
the baseline grid.

The baseline grid normally starts at the top of the page or spread but you can 

Tip: To snap text 
frames to the baseline 
grid when drawing, 
moving, or scaling 
them, ensure that 
Snap to Baseline Grid
is selected in View > 
Snapping…

Baseline grid on: The 
text in this 2-column text 
frame is aligned to the 
baseline grid; the text 
frame is also aligned to 
the top margin which 
itself is a multiple of the 
baseline grid

Tip: The baselines of 
text in art text and 
path text objects are 
not aligned to the 
baseline grid

Baseline grid off: The 
text in this 2-column text 
frame is not aligned to 
the baseline grid so the 
baselines of the text in 
the two columns are not 
aligned

Definition: The 
baseline is the invisi-
ble line on which the 
bases of characters 
without descenders 
are aligned
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customize the starting position or align the grid to the top margin; however, 
most designers start the baseline grid at the top of the page spread and set the top 
margin to a multiple of the baseline grid.

A document has only one baseline grid but you might choose to ignore or over-
ride the grid for specific text frames used for captions, quotations, or margin 
notes, or for data tables. Refer to Baseline grid on page 53 for more information 
on customizing the baseline grid for text frames. You can even ignore the base-
line grid for specific paragraphs within a text frame.

To set and show the baseline grid:

1. Choose View > Baseline Grid…

2. Select Use Baseline Grid and set the Grid Spacing to match the body text’s 
paragraph leading value. You can also set:

• Start Position: Enter a value to offset the baseline grid, the default of 0 is 
recommended for most documents.

• Relative to: For most documents, Top of Spread (default) and Top of Page
are identical; the latter is relevant only for facing-page documents 
arranged vertically which will restart the grid at the top of the spread’s 
bottom page.

• Colour: Click the colour sample to set the colour of the baseline grid’s 
lines and drag the slider to change their opacity.

3. Select Show Baseline Grid. You can also change the Display Threshold value 
below which the baseline grid will be hidden.

4. Click Close.

5. Click the Show Baseline Grid Manager  icon in the Toolbar or choose 
View > Show Baseline Grid to see the grid’s lines when you zoom in to above 
the chosen display threshold.

32 Document setup
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Entering and editing text in Publisher is similar to most applica-
tions but unlike a word processor, Publisher allows you to create 
and link your own text frames. You can also create text without 
using text frames.

Formatting text is somewhat more complex than in most appli-
cations due to the range of formatting options available. Text 
styles, which are explained in the next chapter, can be used to 
combine formatting options to ensure consistent formatting 
throughout a long document.

This chapter also details text frame properties which will allow 
you to style a text frame and control how text is displayed in it.

In this chapter
Text objects ....................................................................................................34
Text frames .....................................................................................................36
Shape text frames ........................................................................................38
Art text .............................................................................................................39
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Setting text frame properties ..................................................................49
Word processing ...........................................................................................54
Importing (placing) text ............................................................................68
Formatting characters ................................................................................70
Formatting paragraphs ..............................................................................82
Setting default text formatting .............................................................104
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Pinning (anchoring) objects ...................................................................108
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Text objects
All text entered in Publisher is contained within a text object. Publisher offers 
five types of text objects for different purposes:

• Text frame: Use text frames for the main text of your documents. Text frames 
can be linked together so that text flows from one frame to the next. Text 
frames can be divided into multiple columns so there is no need to draw 
separate frames for each column. Scaling a text frame scales the frame with-
out scaling the text size unless you use the content scaling handle. Refer to 
Text frames on page 36 for more information on text frames.

• Shape text frames: Use shape text frames for special effects. Shape text objects 
are text frames that you have converted from a shape or closed path to a text 
frame. They function identically to text frames and can be divided into multi-
ple columns and linked to another text frame. Refer to Shape text frames on 
page 38 for more information on shape text frames.

• Art text: Use art text for short lines or blocks of text such as display type and 
labels. Art text objects are rectangular like standard text frames but they don’t 
have a constraining frame with a right edge to wrap lines of text so they are 
frameless and scaling them will scale the text size. Typing into an art text 
object will not wrap and will continue until you press Return to start a new 
paragraph or insert a line break. Art text objects can’t be linked together 
because they have no bottom edge. Refer to Art text on page 39 for more 
information on art text objects.

• Path text: Use path text to align the baseline of text to a curved or angled path 
for design effects. Typing into a path text object will continue until the end of 
the path is reached or until you press Return and then will continue on the 
other side of the path. Pressing Return multiple times will enter spaces. Scal-
ing path text will scale the path without scaling the text size. Path text objects 
can’t be linked together, but because the length of the path is finite, it is possi-
ble to overflow path text in the same manner as a text frame. Refer to Path 
text on page 41 for more information on path text objects.

• Tables: Use tables to organize information in rows and columns. Typing into 
a table cell will wrap at the cell’s right edge just as in a text frame. Press Tab to 
move the text cursor to the next cell. Tables are not described in this manual.

Tip: Art text is short for 
artistic text and is 
referred to as point 
text or frameless text in 
other applications; 
you can use them for 
any purpose, they 
don’t have to be 
artistic
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Text tools
Publisher provides three text tools to create text objects but once a text object is 
created you can edit text with any of the text tools.

Publisher works somewhat differently than other applications when it comes to 
creating point text or frameless text. Instead of clicking with an application’s 
single text tool to create point text, Publisher has separate tools for creating text 
frames and art text objects.

• Frame Text  tool: Select to create text frames and to edit the text in any type 
of text object.

• Artistic Text  tool: Select to create art text objects and to edit the text in any 
type of text object.

• Table  tool: Select to create tables and to edit the text in any type of text 
object.

Publisher doesn’t provide specific tools to create shape text frames and path text 
objects because those are created by converting shapes and paths to contain text 
using the commands in the Layer menu.

Stories
The text in a text object is referred to as a story so when you create a text object 
you are also creating a story, even though the text object will be blank until you 
enter text into it. The text in a series of linked text frames is a single story. Refer 
to Single vs. multiple stories on page 132 and Flowing text on page 43 for more 
information on stories.

All of the text in a table is a single story with tabs separating the text in each cell.

The Esc key
When text is selected, press Esc to deselect the selected text. The text cursor will 
appear at the end of the selected text range.

When text is not selected but the text cursor is in text, press Esc to remove the 
text cursor from the text. The text frame or object will be selected so that you can 
modify it instead of the text or press V to switch to the Move  tool.

When a text frame or object is selected and the text cursor is not in its text, press 
Esc to deselect the object.

Definition: The term 
story refers to all the 
text in a text object or 
in a series of linked 
text frames

Tip: To switch to the 
Move tool without 
having to consider 
whether or not text is 
selected, press Esc
twice before 
pressing V;
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Text frames
Text frames are used to contain the main text of a document but can be used for 
any purpose. Unlike word processors such as Microsoft® Word that have a fixed 
text frame on each page linked to the next page, Publisher allows you to create as 
many frames on each page as you like and link them in any direction. This flexi-
bility is what allows the laying out of newspapers, magazines, and newsletters 
that have articles continued elsewhere in the same publication.

When you create a new document with Publisher, its page(s) will be based on a 
default master page if Default master is selected on the Layout tab, but they 
won’t have any text frames. Text frames can be created on master pages or docu-
ment pages. You can edit the text in a master page’s text frame on a document 
page but not otherwise transform the frame, such as by moving or scaling it.

For a short document, you would likely create the text frames directly on the 
document page. For a long publication, it is best to create the document with a 
single page and to create the text frames on master pages to ensure layout consis-
tency and simplify later changes to the layout.

To create a text frame:

1. From Tools, choose the Frame Text  tool. The mouse pointer will change to 
a crosshair with the tool icon appended to it: 

2. Drag diagonally on a blank area of the page. While dragging:

• Hold ⌘ (macOS) or Ctrl (Windows) to draw outward from the centre.

• Hold Shift to constrain drawing to a square.

• Hold Spacebar to move the frame instead of continuing to change its size.

Release the mouse button to finish creating the text frame. Publisher will 
display the frame with handles to indicate it is selected and can be modified. 
If you have drawn a text frame on a master page, the frame’s handles will be 
non-editable when viewed on a document page that is based on the master to 
indicate that it can’t be transformed on the document page.

3. If you want more than one column on the same page you can adjust the 
number of columns and the gutter (space) between them with the Context 

A text frame on a document 
page: Round size handles can 
be used to modify the frame

Text frame on a master page: 
X handles indicate that the 
frame cannot be transformed

Content scaling handle

Tip: Do not drag the 
content scaling handle 
below and to the right 
of the bottom-right 
size handle because it 
scales the text in the 
frame and is difficult 
to undo

Tip: You can override a 
master page on a 
document page to 
transform a text frame; 
refer to Overriding 
master page objects 
on document pages
on page 19

Definition: A text 
frame is a rectangular 
text container and can 
be linked to other text 
frames to flow text 
between and pages
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Toolbar at the top of the screen. This feature will divide the frame into multi-
ple columns that are permanently linked together and is simpler than draw-
ing multiple frames and then linking them together.

For asymmetrical column layouts, choose Document > Text Frame to display 
the Text Frame panel and expand the Columns section.

4. If you are creating a facing-pages publication then you should create text 
frames on both the left and right sides. You must link the two frames together 
on the master page so that document pages based on this master will have 
linked frames; otherwise, you’ll have to link them together on each page 
spread. Refer to To link a text frame on page 44 below for more information.

5. Optional: If the text frame is on a master page you can fill it with placeholder 
text to aid in visualizing your layout. Choose Text > Insert Filler Text.

If you added linked frames to a facing-pages master page and were to add more 
pages based on that master to the document now, the text frame on page 1 would 
not be linked to the text frame on page 2 although the frames on all of the newly-
created pages will would be linked. It is best to AutoFlow text or you’ll have to 
manually link the frame from page 1. Refer to AutoFlow text on page 47 for more 
information.

To move or scale text frames:

1. To move the text frame, position the mouse pointer over its outline and drag.

2. To scale the text frame, drag the size handles at its corners and midpoints. 
The corner handles will scale the frame symmetrically and the midpoint 
handles will scale it asymmetrically unless you hold Shift while scaling. The 
font size will not change unless you drag the content scaling handle at the 
bottom-right corner.

To scale the text object from its centre rather than the corner handle, hold ⌘
(macOS) or Ctrl (Windows) while dragging.

3. To rotate the text frame, drag the rotation handle above the frame. You can 
also press ⌘ (macOS) or Ctrl (Windows) while dragging to rotate the frame 
around the opposite corner handle at the same time.

4. For more precise changes, enter new values for position, width, height, rota-
tion, and shear with the Transform panel.

To convert a text frame to art text:

1. Select the text frame with the Move  tool or any text tool.

2. Choose Layer > Convert to Art Text.

Tip: If the frame is 
linked to another 
frame you must unlink 
it first
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Shape text frames
In addition to creating standard text frames, Publisher allows you to convert any 
shape such as an ellipse, triangle, or closed path to a text frame. You can link 
these shape text frames just as you would any standard text frame.

You can manipulate both the text frame and shape properties for a shape text 
frame. The Context Toolbar will show a combination of options for text and the 
original shape when you select a text frame converted from a shape using the 
Move  tool.

All other features of shape text frames are the same as standard text frames.

To convert a shape to a text frame:

Once converted to a text frame, there is no way to convert shape text back to a 
standard shape. It’s not important because you can format the shape text frame 
just as you would a standard shape but the Context Toolbar will show several 
text attributes instead of all the object attributes.

1. Draw a shape using the appropriate shape tool.

2. Convert the shape to a text frame by doing one of:

• Select the shape and using the Frame Text  tool, click inside the shape to 
position the text cursor. When over the shape, the mouse pointer will 
change to a crosshair with a T inside of a shape: 

• Or with the shape selected, choose Layer > Convert to Text Frame.

• Or right-click the frame and choose Convert to Text Frame.

Tip: The Context 
Toolbar shows differ-
ent options for 
selected text frames 
and shapes and there 
isn’t room to show 
both sets of options at 
the same time so you 
may need to use other 
panels to access 
options that you 
would normally find in 
the toolbar

Definition: A shape 
text frame, commonly 
referred to as shape 
text, is a text container 
that functions identi-
cally to standard text 
frames but retains the 
properties of its 
original shape
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Art text
Art text objects are used for short lines or blocks of text such as display type and 
labels. Art text objects are rectangular like standard text frames but they don’t 
have a constraining frame with a right edge to wrap lines of text so they are 
frameless. Scaling art text will scale the text size.

Art text is frequently used in short, design-intensive documents such as 
brochures and posters. It’s sometimes better to use a text frame even for short 
blocks of text such as a caption because a frame provides a right edge to which 
text can be aligned. For example, all of the captions in this manual are text 
frames and not art text.

Typing into an art text object will not wrap and will continue until you press 
Return to start a new paragraph or insert a line break. Most art text objects are a 
single line but you can type an almost unlimited number of lines and paragraphs 
of text.

Art text objects can’t be linked together because they have no bottom edge that 
would cause text to overflow.

To create art text:

1. From Tools, choose the Art Text  tool. The mouse pointer will change to a 
crosshair with the tool icon appended to it: 

2. Click on a blank area of the page to create a new art text object with the 
current font size.

Or drag diagonally on a blank area of the page to define a custom text size.

Publisher will display an empty text object with handles to indicate it is 
selected and can be modified. If you have created an art text object on a 
master page, the frame’s handles will be non-editable when viewed on a 
document page that is based on the master to indicate that it can’t be trans-
formed on the document page.

Art text object when first created: 
Round size handles can be used to 
modify the font size; the bounding box is 
wide enough to enclose the End of Story 

 symbol even if Text > Show Special 
Characters is not selected

Art text object after 
typing text: The bounding 
box changes to match the 
size of the characters 
typed

Art text object on a 
master page: X handles 
indicate that the object 
cannot be transformed

Definition: Art text is 
a frameless text object 
commonly used for 
display type and is 
known as point text or 
frameless text in other 
applications
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To move or scale art text:

1. To move the text object, position the mouse pointer over its outline and drag.

2. To scale the text object, drag the size handles at its corners and midpoints. 
The corner handles will scale the text symmetrically and the midpoint han-
dles will scale it asymmetrically unless you hold Shift while scaling.

To scale the text object from its centre rather than the corner handle, hold ⌘
(macOS) or Ctrl (Windows) while dragging.

3. To rotate the text object, drag the rotation handle above the text object. You 
can also press ⌘ (macOS) or Ctrl (Windows) while dragging to rotate the 
object around the opposite corner handle at the same time.

4. For more precise changes, enter new values for position, width, height, rota-
tion, and shear with the Transform panel.

To convert art text to frame text:

1. Select the art text object with the Move  tool or any text tool.

2. Choose Layer > Convert to Text Frame. You can also right-click the text 
object and choose Convert to Text Frame from the context menu but only 
with the Move tool selected.
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Path text
Path text objects are used to achieve special design effects by aligning the base-
line of their text to a curved or angled path.

Typing into a path text object will continue until the end of the path is reached or 
until you press Return and then will continue on the other side of the path. 
Pressing Return multiple times will enter spaces.

Any path can be converted to a path text object, including closed paths. Path text 
objects can’t be linked together, but because the length of the path is finite, it is 
possible to overflow path text in the same manner as a text frame.

Overflow control meaning

 The selected path text has hidden overflowing text: click the Eye to view it

 The selected path text has visible overflowing text: click the Eye to hide it

To create path text:

1. Draw a path using the Pen  tool.

Or draw a shape and convert it to a path by selecting it and choosing Layer > 
Convert to Curves.

2. Using the Context Toolbar, set the path’s stroke to solid to make it easier to 
work with, even if it will eventually be turned off.

3. Convert the path to a text path by doing one of:

• Select the path using the Move  tool, and then using the Art Text  tool, 
click on the path. When over the path, the mouse pointer will change to a 
crosshair with a T on a path: 

• Or with the shape selected, choose Layer > Convert to Text Path.

4. Select the path text object with a text tool and type onto the path. Green and 
orange triangles will indicate the start and end of the path. Optional: Drag the 
triangles to limit the amount of the path used for text.

5. Set the paragraph alignment to centred if appropriate or scale the text to fill 
the path.

Definition: Path text, 
sometimes referred to 
as a text path, is a text 
object that curves the 
baseline to align to the 
path

Ellipse converted to a path and 
text centred on its first side

After pressing Return and 
typing text for the second side

After adjusting the baseline 
offset for the second side

Tip: After conversion 
to a path, you can set 
the path’s stroke and 
fill with the Text 
Frame panel



42 Basic text

6. Press Return to start a new paragraph on the other side of the path. Dark 
green and red triangles will indicate the start and end of the second side. 
Drag these triangles to limit the amount of the second side used for text. 
Publisher can snap the triangles to the 25%, 50%, and 75% points along the 
path to help you align the triangles with logical points. This is especially 
useful with ellipses and other regular shapes.

If you type more text than will fit on the first side, the text will flow to the 
second side automatically without pressing Return.

7. Set the paragraph alignment and baseline offset to position the text on the 
path and adjust tracking to avoid character collisions. Fonts are designed so 
that characters are positioned on a straight baseline so you may need to adjust 
tracking to avoid characters colliding if the path includes sharp turns.

To convert a path text object back to a path:

There isn’t a direct way to convert a path text object back to a path and delete its 
text but it’s easy to do.

1. Select the path text object with any tool and choose Layer > Convert to 
Curves.

2. Using the Layers panel, click the caret  icon to the left of the group to 
expand it. Drag the original path (curve) layer out of the group; it will be the 
bottom object in the group.

3. Delete the group. If there was text in the path text object, the characters 
would have been converted to individual curve layers which can be deleted 
with the group.

To move or scale a path text object:

1. To move the path text object, position the mouse pointer over its outline and 
drag.

2. To scale the path but not the text, drag the size handles at its corners and 
midpoints. The corner handles will scale the text symmetrically and the 
midpoint handles will scale it asymmetrically unless you hold Shift while 
scaling.

To scale the path and text together, drag the content scaling handle at the 
bottom-right corner. Hold Shift to scale it asymmetrically.

To scale from its centre rather than the corner handle, hold ⌘ (macOS) or Ctrl
(Windows) while dragging.

3. To rotate the path text object, drag the rotation handle above the text object. 
You can also press ⌘ (macOS) or Ctrl (Windows) while dragging to rotate the 
object around the opposite corner handle at the same time.

4. For more precise changes, enter new values for position, width, height, rota-
tion, and shear with the Transform panel.
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Flowing text
You can link and unlink text frames at any time to flow text from one frame to 
the next. When you link two frames together their stories are joined into a single 
story. If the text frames were empty this won’t make any difference but if they 
both contained text then the first character of the second frame’s story will 
immediately follow the last character of the first frame. Ensure that there is a 
paragraph return at the end of the first story before linking two filled text frames.

When you unlink two frames, all of the text from the story will be in the frame 
before the broken link while the frame(s) after the broken link will be empty—
they will have a new blank story.

The end of a story is marked by the End of Story  symbol, a special character 
you can see by selecting Text > Show Special Characters. The symbol will be 
shown at the end of the story text, or if the frames are empty, at the top-left of the 
story’s first text frame.

Every text frame has two controls that define the flow of text in and out of the 
frame. The Text Flow In control near the top-left corner is used to link to a 
previous frame while the Text Flow Out control near the bottom-right corner is 
used to link to the next frame. These controls will have a hollow icon if the frame 
is not linked in that direction or a solid icon if it is linked.

The Text Flow In and Out controls will change from blue to red if the story text 
for the text frame or frames is overflowing.

Text Flow control meaning

 The selected frame is not linked in this direction

 The selected frame is linked in this direction

 The selected frame has overflowing text or is linked to an overflowing frame

 The selected frame is linked to a frame with overflowing text

 The selected frame has hidden overflowing text: click the Eye to view it

 The selected frame has visible overflowing text: click the Eye to hide it

 The selected frame has hidden overflowing whitespace; ignore this

 The selected frame has visible overflowing whitespace; ignore this

 The deselected frame has overflowing text or is linked to an overflowing frame*

Text Flow In

End of story

Text Flow Out

Definition: The Text 
Flow In and Out
controls will be hidden 
if you zoom out too far 
due to lack of space

* Shown only when 
View > Show Text 
Flow is enabled
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To link a text frame to an existing unlinked frame:

1. Choose View > Show Text Flow if it is not already selected so that you can see 
the outlines of text frames and their connecting lines.

2. From Tools, choose the Frame Text  tool or the Move  tool.

3. Click the first text frame’s triangular Text Flow Out control  near its bot-
tom-right corner; the mouse pointer will change to a link arrow  when you 
are within range to click it. The frame will turn blue after you click it.

4. Move the mouse pointer over the second text frame. It will turn blue when 
you are within range to click it.

5. Click anywhere on the second text frame. A non-printing text flow line will 
be shown between the frames.

If the text in the frame you linked to is scaled larger or smaller than it should 
be compared to the first frame, you likely scaled that frame’s contents with the 
content scaling handle below and to the right of the bottom-right size handle 
which scales the text in the frame and is difficult to undo. To fix it, you should 
select the frame with the Move  tool and choose Edit > Defaults > Revert. 
If your defaults don’t match what you wanted for the frame then delete the 
frame and create a new one.

To create a new frame linked to an existing one:

1. Choose View > Show Text Flow if it is not already selected so that you can see 
the outlines of text frames and their connecting lines.

2. From Tools, choose the Frame Text  tool or the Move  tool.

3. Instead of creating the second text frame before linking the first to it, click the 
first frame’s triangular Text Flow Out control  near its bottom-right corner. 
The mouse pointer will change to a link arrow  when you are within range 
to click it and the frame will turn blue after you click the control.

4. Now draw a second text frame on the desired page. Publisher will link the 
first frame to the second one automatically.

Content scaling handle

Tip: If you find the 
Text Flow In and Out
controls are too small, 
you can increase their 
size; open Settings
…(Preferences), select 
Tools in the left pane, 
and select a different 
Tool Handle Size
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To remove a text frame from the middle of a series of linked frames:

1. From Tools, choose the Move  tool.

2. Select the text frame to remove.

3. Choose Edit > Delete or press Backspace—the frame will be deleted and the 
previous text frame will be linked to the next frame in the series.

To unlink text frames:

1. Choose View > Show Text Flow if it is not already selected so that you can see 
the outlines of text frames and their connecting lines.

2. From Tools, choose the Frame Text  tool or the Move  tool.

3. Select the text frame that you want to unlink. To unlink it from the next 
frame, click its triangular Text Flow Out control  near its bottom-right 
corner or to unlink it from the previous frame click the matching Text Flow 
In control near the top-left corner. The mouse pointer will change to a link 
arrow  when you are within range to click it. The frame will turn blue after 
you click it.

4. Mouse anywhere over the text frame. The mouse pointer will change to a link 
arrow .

5. Click anywhere on the text frame to unlink it. The story for the linked frames 
will now be entirely in the frame(s) before the one you unlinked from and any 
text that does not fit will be overset (overflowing). The frame after the point at 
which you unlinked will have a new blank story.

To split a story when unlinking frames:

Publisher doesn’t provide an automatic way to split a story between frames but 
it’s not hard to copy and paste the text. Follow the instructions above to unlink 
text frames and then follow these steps.

1. Ensure you have a keyboard shortcut for Select Story End. Unless you have 
changed it, the shortcut will be Shift + ⌘ + End (macOS) or Shift + Ctrl + End
(Windows). 

If you use a keyboard without an End key you will need to modify the default 
shortcut first because you’ll be unable to type it. Go to Settings… (Prefer-
ences), select Shortcuts in the left pane, and choose Text Input from the list 
under the persona list set to Publisher. Scroll down the list of shortcuts until 
you find the one for Select Story End and change it to something that works 
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for your keyboard. The arrow pointing down to the right in this macOS 
screenshot is for a Mac’s End key.

2. From Tools, choose the Frame Text  tool.

3. Position the text cursor at the end of the text in the last frame before you 
unlinked.

4. Press the keyboard shortcut for Select Story End to select all of the text from 
the text cursor to the end of the story. All of the text that is overset (overflow-
ing) from the text frame will now be selected even though you can’t see it.

5. Choose Edit > Cut to cut the text to the clipboard.

6. Click in the empty text frame where you want the text to appear and then 
choose Edit > Paste to paste the text into the frame.

If you split a story that has anchors generated by the Table of Contents feature, 
the links between the table of contents and the anchors will be broken and Pub-
lisher will insert duplicate anchors when you next update the table. If you don’t 
want the duplicate anchors, delete them before updating the table of contents.

If you split a story that includes the targets for cross-references the cross-refer-
ences will be broken because their target will be missing. To fix these, double-
click each cross-reference that has a Target Missing  icon in the Cross-Refer-
ences panel and reselect the target.

Tip: If the missing 
targets were to 
anchors generated by 
the Table of Contents 
feature, fix the table of 
contents first
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AutoFlow text
Publisher doesn’t create additional pages automatically if there’s too much text to 
fit in a text frame or in the last text frame of a series of linked frames. The excess 
text, known as overset text, will be hidden by default.

When there is overflowed text Publisher will change the Text Flow controls from 
blue to red and the last text frame will have an eye icon to indicate if the over-
flowing text is hidden  or visible  below the frame. Refer to the list of text 
flow control shapes and colours in Flowing text on page 43 for more information.

You could create additional text frames to contain the overflowed text but Pub-
lisher can do this for you. AutoFlow will create as many additional pages of text 
frames as required to contain all the text in a story, all linked together automati-
cally.

To AutoFlow text to as many new text frames as required:

1. From Tools, choose the Frame Text  tool or the Move  tool.

2. Press Shift and click the red Text Flow Out control  near the overflowing 
text frame’s bottom-right corner; the mouse pointer will change to a link 
arrow  when you are within range to click it. Publisher will create as many 
pages of text frames as required.

To AutoFlow text to a single new text frame:

1. From Tools, choose the Frame Text  tool or the Move  tool.

2. Press ⌥ (macOS) or Alt (Windows) and click the red Text Flow Out control 
 near the overflowing text frame’s bottom-right corner; the mouse pointer 

will change to a link arrow  when you are within range to click it. If the new 
frame is not large enough to contain all the overflowing text, it will also have 
a red Text Flow Out control.

Overflowing
text
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Interrupting text flow
You can interrupt the text flow of story text to force it to start at the top of a new 
column, frame, or page by inserting a break. Using breaks is preferable to adding 
blank lines because if you add or remove text earlier in the story you can be 
assured that the text after the break will remain at the top of the column, frame, 
or page.

To insert a break:

1. Position the text cursor before the text you want to shift to the new column, 
frame, or page.

2. Choose Text > Insert > Breaks and select one of the following:

Break type Description Symbol

Column break Forces text to the next column, regardless of
  whether that column is in the same frame or in the  
  next linked frame

Frame break Forces text to the next text frame

Page break Forces text to the next page, even if there are other
  linked frames before it  

Odd page break Forces text to the next odd page, even if there are 
  other linked frames before it  

Even page break Forces text to the next even page, even if there are 
  other linked frames before it  

Tip: Choose Text > 
Show Special Charac-
ters when working 
with breaks to see 
their invisible symbols 
and avoid accidentally 
deleting them
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Setting text frame properties
Text frames and other text objects have properties to control their appearance 
and change how text within them is displayed. New text objects will be created 
with the properties you last used. Some properties can be changed directly from 
the Context Toolbar but most require use of the Text Frame panel.

Using the Text Frame panel
To display the Text Frame panel:

1. Click the Show Text Frame panel  icon in the Context Toolbar or choose 
Window > Text > Text Frame to display the Text Frame panel.

Panel menu

Expand/collapse section

Indent text from the frame

Show/hide overflowing 
text below frame

Balance columns without 
inserting a column break

Add a rule between 
columns

Use a different baseline 
grid than the document

Set frame stroke and colour

Ignore objects with text wrap
Ignore document’s baseline grid

Set frame background colour

Align text vertically

Add/remove columns

Customize column widths and 
gutters

Tip: The Text Frame
panel is misleadingly 
named because it is 
used to change the 
properties of all text 
objects, including art 
text and path text; 
controls that don’t 
apply to art text or 
path text will be 
disabled
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2. Collapse and expand the panel’s sections by clicking the caret  icons to the 
left of their titles.

General

The General section of the panel allows you to change the text object’s fill and 
stroke and the inset of the text from a frame’s edges.

• Fill: Click the colour sample to set the colour of the text object’s fill.

• Stroke: Click the colour sample to set the colour of the text object’s stroke 
(outline) and click the stroke control on its right to set its thickness, dash 
pattern, and other properties.

• Insets: Enter values for how much text should be inset from a text frame’s 
borders. Click the Link icon to their right so that they all change together.

• Hide Overflow: Select to hide overflowing text for a text frame or path text or 
deselect to show the overflowing text below the frame or after the end of the 
path. You can also click the Text Flow Out  control to toggle this setting 
on and off.

• Ignore Text Wraps: Select so that text in the frame will not wrap around 
objects with text wrap set.

• Ignore Baseline Grid: Select so that text in the frame will not be aligned to 
the document’s baseline grid. Selecting this option will disable Independent 
Baseline Grid at the bottom of the panel.

Tip: Disable Hide 
Overflow if you want 
to edit the overflow-
ing text to make it fit 
in the frame

Tip: Specify Insets
when you assign a fill 
or stroke to a text 
frame to avoid having 
the text immediately 
adjacent to the frame’s 
borders

Tip: Although art text 
and path text are 
frameless text objects, 
the Text Frame panel
allows you to set their 
fill colour and stroke
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Columns

The Columns section of the panel allows you to set the number of columns, the 
gutter (space) between them, and whether text should be balanced across the 
columns.

• Columns: Enter the number of columns to create within the text frame. You 
can also choose this from the Context Toolbar.

• Width: Specify the width of each column. Select Preserve Width to maintain 
the width of the frame when changing a column’s width or deselect it to 
preserve the width of the adjacent column.

• Gutter: Specify the space between columns. By default, the gutters are linked 
so changing one value will change them all. Click the Link icon to the right of 
the Gutter label to change the gutter values separately. You can also specify 
gutter from the Context Toolbar but not separately for each pair of columns.

• Balance text in columns: Select to distribute text evenly across the columns 
in a text frame. This will have no effect if the story is longer than the text 
frame.

Balanced columns off Balanced columns on
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Column rules

The Column Rules section of the panel allows you to specify if a rule should be 
drawn between multiple columns and how the rule should appear.

• Stroke: Click the colour sample to set the colour of the vertical rule (line) 
between columns and click the stroke control on its right to set its thickness, 
dash pattern, and other properties.

• Gap: Enter how much the rule should be inset from the top or bottom of the 
frame—you cannot enter negative values to extend the rule outside of the 
frame.

Vertical position

The Vertical Position section of the panel allows you to set how the text should 
be vertically aligned within the frame and the baseline of the first line of text.

• Alignment: Choose whether to align text to the top, centre, or bottom of the 
text frame, or whether it should be vertically justified (distributed). You can 
also choose this from the Context Toolbar.

• Maximum Paragraph Space: When text is vertically justified, enter the 
maximum space between the baseline of the last line in one paragraph and 
the first baseline of the next.

• Initial Advance: Choose how the baseline of the first line of text in the frame 
is positioned relative to the top inset of the frame:

• Default: For a standalone text frame, this is the same as Cap Height, it 
uses the largest cap height of all the characters on the first line as the 
baseline value. For a text frame pinned in another frame or for a footnote 
or sidenote, it defaults to the Initial Advance value of the parent frame.

• Leading: Uses the first paragraph’s leading as the baseline value.

• Pointsize: Uses the largest point size of all the characters on the first line as 
the baseline value.

• Ascent: Uses the largest ascent of all the characters on the first line as the 
baseline value to ensure that the top of a lowercase “d” fits inside the top 
inset of the frame; for most fonts there will be space between the top of the 
frame and the top of the “d”.

Tip: Set the maximum 
to the height of the 
text frame to add 
space only between 
paragraphs and not 
lines
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• Cap Height: Uses the largest cap height of any character on the first line as 
the baseline value to align the flat tops of uppercase letters with the top 
inset of the frame; rounded or pointed tops may appear above.

• X Height: Uses the largest x height of any character on the first line as the 
baseline value.

• Fixed: Specify the baseline value in Minimum; a value of 0 will set the 
baseline to the top inset of the frame.

• Minimum: Enter a minimum value for the baseline; will have no effect unless 
you enter a value greater than it would otherwise be

Baseline grid

The Baseline Grid section of the panel allows you to override the document’s 
baseline grid for a text frame. These options are disabled if you select Ignore 
Baseline Grid near the top of the panel.

• Use Independent Baseline Grid: Select to override the document’s baseline 
grid; refer to Baseline grid on page 31 for more information.

• Start Position and Relative to: Enter an offset from the top of the page, top 
margin, top of the frame, or its top inset. You can also set the start position 
relative to the artboard but that feature is less relevant in Publisher.

• Colour: Click the colour sample to set the colour of this baseline grid to 
differentiate it from the document’s baseline grid.

Independent baseline grid off Independent baseline grid on

Tip: To see the base-
line grid, choose View 
> Baseline Grid and 
select Show Baseline 
Grids; note that the 
grid will not be shown 
if you zoom out below 
the threshold set in 
that window
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Word processing

Positioning the text cursor
To position the text cursor with the mouse

1. Choose the Frame Text , Artistic Text , or Table  tool.

2. Position the mouse pointer  between the characters where you want to make 
changes and click the mouse. You can click anywhere on an empty text frame.

A blinking vertical bar will appear to represent the text cursor position, also 
known as the insertion point.

To change the position of the text cursor with the keyboard:

1. Press one of the following keyboard shortcuts. You can press all of the keys at 
the same time, or the modifier keys first (⌘, Shift, Ctrl) followed by the action 
key (such as an arrow key).

macOS Windows Action

� or � � or � Move one character left or right

↑ or ↓ ↑ or ↓ Move one line up or down

⌘ + � or � Ctrl + � or � Move to the start or end of the current
  word and then to subsequent words

⌘ + ↑ or ↓ Ctrl + ↑ or ↓ Move to the start or end of the current
  paragraph and then to subsequent
  paragraphs

fn + � or � Home / End Move to the start or end of the current
  line

fn + ⌘ + � or � Ctrl + Home / End Move to the start or end of the story

Text cursor

Tip: If you’ve changed 
your shortcuts by 
choosing Apple 
Defaults (macOS only) 
or creating custom 
shortcuts, your actual 
modifiers may vary
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Typing text
To type basic characters:

1. Position the text cursor in a text frame or other text object.

2. Enter text as you would in any text editor or word processor. Publisher will 
automatically wrap text to a new line when it reaches the right edge of the text 
frame or table cell. For an art text object, you must press Return to start a new 
paragraph.

3. Press Return to start a new paragraph or Shift + Return to start a new line 
within a paragraph.

4. Press Delete (macOS) or Backspace (Widows) to erase characters, including 
erasing a paragraph or line break.

To type special characters:

1. Position the text cursor in a text frame, art text object, or table.

2. Type the character’s Unicode value and choose Text > Toggle Unicode, or 
choose Text > Insert and select from the list.

3. Choose Text > View Special Characters to show the invisible symbols for 
special characters.

To choose characters from a list of those available in the selected font:

Publisher allows you to select characters to insert from a visual browser.

1. Position the text cursor in a text frame or other text object.

2. Choose Window > Text > Glyph Browser to display the Glyph Browser
panel.

3. Publisher will select the Font Family and Font Style automatically based on 
the text cursor position but you can change these options. Publisher will 
display a list of all of the characters (glyphs) for the selected font. If the glyphs 
are too small, choose Large Size or Largest Size from the panel menu . 

Panel menu

Lock Font Family and Font Style (Traits)

Subset (Unicode block)

Search

Font Family and
Font Style (traits)

Recently used

Tip: A list of the most 
common special 
characters is provided 
in Appendix A on page 
259
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4. Select the Subset (Unicode block) to reduce the number of characters shown 
and find one more easily. You can search for glyphs by name; for example, 
type “a” into Search to filter the list to glyphs that include “a” in their Unicode 
names, including all of the variations with accents, or type “acute” to see 
glyphs that include an acute accent.

5. Double-click a glyph symbol to insert it at the text cursor position. The glyph, 
including the font family and font style (traits) selected will be added to 
Recently used in case you need to insert it again this session. Choose Clear 
Recently Used from the panel menu  to clear the list of recently-used 
characters.

6. Select the Lock Font Family and Font Style (Traits)  icon to prevent the 
font family and style from changing automatically when you position the text 
cursor in text with different formatting. 

macOS users can also use the system-wide Emoji & Symbols feature but while 
it’s the best choice for inserting the wide range of emojis, it’s not as useful for 
inserting standard characters and typographic symbols because it’s harder to 
know what characters are available in certain fonts.

To insert filler text, also known as placeholder text or lorem ipsum:

1. Position the text cursor in a text frame; filler text cannot be inserted in other 
types of text objects.

2. Choose Text > Insert Filler Text. Publisher will fill the text frame (and any 
linked frames) with enough filler text to fill all of the frames. There will never 
be overflowing text even if you reduce the size of a frame because Publisher 
will add and remove filler text automatically.

The filler text is actually a text field so it will not be directly editable unless 
you right-click it and choose Expand Field from the context menu.

3. To modify the Insert Filler Text command to always insert filler text as 
regular, editable text, choose Affinity Publisher 2 > Settings…, click General
in the left pane, and then select Text > Insert filler text as text.

4. To modify the filler text that is inserted, choose Affinity Publisher 2 > Set-
tings…, click Filler Text in the left pane, select the language you wish to 
customize, enter the new filler text, and click Save as Default. Refer to Filler 
text on page 253 for more information.

Tip: Many Unicode 
character names are 
descriptive so typing 
“a” will display unex-
pected results

Tip: You can change 
the sort order from 
Unicode ID to Glyph ID
but this is not recom-
mended as the same 
Glyph ID may be used 
for a different charac-
ter in another font
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Selecting text
Before you can modify text and applying formatting, you need to select the text 
using the Frame Text , Artistic Text , or Table  tool.

• Select any range of text: Click the mouse pointer  at the start or end of the 
text you want to select and then drag to the other end. Publisher will indicate 
the selected text by highlighting it. If you drag past an edge of the document 
window then Publisher will scroll the page in the window automatically.

Or click the mouse pointer at the start or end of the text and Shift + click at 
the other end.

• Extend or shorten the selected text range: Hold Shift and click again to select 
the text from the start of the text selection range to where you clicked.

• Select an additional range of text without deselecting the selected text: Hold 
⌘ (macOS) or Ctrl (Windows) and click. This modifier key enables you to 
select multiple disconnected ranges of text in the same story.

• Select a word, line, or paragraph: Double-click to select a word, triple-click 
to select a line of text, or quadruple-click to select an entire paragraph.

To select an entire story, quintuple-click, choose Edit > Select All, or press 
⌘ + A (macOS) or Ctrl + A (Windows).

• Select a word, line, or paragraph without deselecting the selected text: Hold 
⌘ (macOS) or Ctrl (Windows) while double-, triple-, or quadruple-clicking to 
add disconnected words, lines, and paragraphs to the selected text.

To select text with the keyboard:

1. Position the text cursor at the start or end of the text to select.

2. Press one of the following keyboard shortcuts. You can press all of the keys at 
the same time, or the modifier keys first (⌘, Shift, Ctrl) followed by the action 
key (such as an arrow key).

macOS Windows Action

Shift + � or � Shift + � or �  Extend selection one character left or right

Shift + ↑ or ↓ Shift + ↑ or ↓  Extend selection one line up or down

Shift + ⌘ + � or � Shift + Ctrl + � or �  Extend selection to the start or end of the current
  word and then to subsequent words

Shift + ⌘ + ↑ or ↓ Shift + Ctrl + ↑ or ↓  Extend selection to the start or end of the current
  paragraph and then to subsequent paragraphs

Shift + fn + � or � Shift + Home or End Extend selection to the start or end of the current line

Shift + fn + ⌘ + � or � Shift + Ctrl + Home or End Extend selection to the start or end of the story

Tip: If you’ve changed 
your shortcuts by 
choosing Apple 
Defaults (macOS only) 
or creating custom 
shortcuts, your actual 
modifiers may vary

Tip: You don’t have to 
use the Frame Text
tool to edit text in a 
text frame, the Frame 
Text, Art Text, and 
Table are interchange-
able when editing text 
in a text frame, art text 
object, path text 
object, or table
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To deselect text:

1. Press Esc to deselect text without moving the text cursor.

2. Or press any of the arrow keys or click the mouse to reposition the text cursor 
which will deselect the text.

Copying and deleting text
You can move and duplicate text from one location to another with copy and 
paste or by dragging selected text. Both methods will move or duplicate pinned 
objects, note and index mark, and anchors.

Publisher uses the shared macOS and Windows pasteboard (clipboard) so copy-
ing text or objects in Publisher or any other application will overwrite whatever 
was previously copied.

To move or duplicate text with menu commands:

You can also use the equivalent keyboard shortcuts or right-click to access the 
same commands in the context menu.

1. Select the text to move or duplicate.

2. Choose Edit > Cut to move it or Edit > Copy to duplicate ti.

3. Position the text cursor at the location where the text should appear, or select 
a range of text to replace with the pasted text.

4. Choose Edit > Paste.

To move or duplicate text with the mouse:

1. Select the text to move or duplicate.

2. Drag the selected text to move it or press Option (macOS) or Ctrl (Windows) 
and drag it to duplicate it.

To paste text without formatting:

You can paste the contents of the pasteboard (clipboard) without its formatting 
so that you’re pasting just plain text. This is known on macOS as Paste and Match 
Style and on Windows as Paste Plain Text or Keep Text Only. This feature is 
especially useful when pasting text from another document or application to 
avoid importing its text styles.

1. Cut or copy the text.

2. Position the text cursor at the location where the text should appear, or select 
a range of text to replace with the pasted text.

3. Choose Edit > Paste Without Format.

To delete selected text:

1. Press Delete or Choose Edit > Delete. Pressing any character key will also 
delete selected text while typing that character.

Tip: Paste Without 
Format will not 
remove anchors, note 
and index marks, or 
pinned objects; to 
remove them, paste 
the text into a text 
editor and then copy it 
from there back to 
Publisher

Tip: Text can be 
dragged within the 
same document or 
from another applica-
tions into a Publisher 
document, but not 
between documents 
or from Publisher to 
another application
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To delete unselected text:

1. Position the text cursor at the start or end of the text to select.

2. Press one of the following keyboard shortcuts. You can press all of the keys at 
the same time, or the modifier keys first (⌘, Shift, Ctrl) followed by the action 
key (such as an arrow key).

macOS Windows Action

Delete Backspace  Delete the previous character

fn + Delete Delete  Delete the next character
or ⌦ Delete

Option + Delete Ctrl + Backspace  Delete to the start of the current word and then to
  subsequent words

Option + fn + Delete Ctrl + Delete  Delete to the end of the current word and then to
or Option + ⌦ Delete  subsequent words

fn + ⌘ + Delete n/a Delete to start of line

Tip: If you’ve changed 
your shortcuts by 
choosing Apple 
Defaults (macOS only) 
or creating custom 
shortcuts, your actual 
modifiers may vary
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Copying text formatting
Publisher allows you to copy and paste text character and paragraph styles and 
attributes between blocks of text. You can also copy stroke and fill attributes from 
objects to apply to text.

To copy text formatting to unselected text:

1. Ensure that the text cursor is not positioned in text or Publisher will treat the 
word containing it as selected. To remove the text cursor from a text frame, 
click once on a blank area of the page—pressing Esc is not sufficient to cause 
Publisher to forget the cursor’s last position.

2. Choose the Style Picker  tool. The mouse pointer should change to an 
unfilled  pointer to indicate that formatting has not been loaded. If it 
changes to a filled  pointer, press Esc or click the Unload button in the 
Context Toolbar to unload the formatting.

3. Click on the text with the formatting you want to copy or on an object whose 
line or fill attributes you want to copy. The mouse pointer will change direc-
tion to a filled  pointer to indicate that formatting has been loaded.

4. Do one of:

• Click a word to apply the loaded character formatting to a single word.

• Drag select a range of text to apply the loaded character formatting to it.

• Drag select past the last character of a paragraph to apply the loaded 
character and paragraph formatting to the paragraph. For an art text 
object, press ⌘ (macOS) or Ctrl (Windows) and click on the object to 
easily apply the loaded formatting to the entire object

5. Continue applying the loaded formatting to additional text if desired. To load 
formatting from different text, press Option (macOS) or Alt (Windows) and 
click on that text. The mouse pointer will change to an unfilled  pointer 
while you hold down the key to indicate that formatting can be loaded. If you 
release the key without clicking then the loaded formatting will not be 
changed.

6. When you are done, press Esc or click Unload in the Context toolbar before 
changing tools to unload the formatting to avoid a future mistake.

Tip: The filled pointer 
will include a T next to 
the eyedropper when 
it is positioned over 
text to indicate that 
clicking will now apply 
formatting to text

A paragraph, including the paragraph 
break marker at the end, is selected 
with the filled  pointer to apply 
character and paragraph formatting

Tip: You cannot copy 
and paste formatting 
between documents 
with the Style Picker
tool

Tip: Unlike Microsoft® 
Word’s Format Painter
tool which loads (picks 
up) formatting when 
the tool is chosen, 
Publisher’s Style 
Picker tool does not 
load formatting until 
you first click with it

Tip: To apply loaded 
paragraph formatting 
to the last paragraph 
in a text frame, you 
must press Return
after it to create a 
blank paragraph

Tip: The Style Picker
tool does not unload 
formatting automati-
cally when you change 
tools

Tip: It is difficult to 
know where to stop 
dragging so it is 
recommended that 
you apply copied 
paragraph formatting 
with Text > Show 
Special Characters
enabled which will 
reveal the hidden 
paragraph break 
marker 
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To copy text formatting to selected text:

1. Using the Frame Text , Artistic Text , or Table  tool, select the text to 
which you want to copy formatting. If you want to apply formatting 
attributes, ensure you select the paragraph break marker at the end of the 
paragraph as shown above.

2. Choose the Style Picker  tool. The mouse pointer should change to an 
unfilled  pointer to indicate that formatting has not been loaded. If it 
changes to a filled  pointer, press Esc or click the Unload button in the 
Context Toolbar to unload the formatting.

3. Click on the text with the formatting you want to copy or on an object whose 
line or fill attributes you want to copy. The loaded formatting will be applied 
to the selected text and the mouse pointer will change direction to a filled
pointer to indicate that formatting has been loaded.

4. Continue applying the loaded formatting to additional text if desired. To load 
formatting from different text, press Option (macOS) or Alt (Windows) and 
click on that text. The mouse pointer will change to an unfilled  pointer 
while you hold down the key to indicate that formatting can be loaded. If you 
release the key without clicking then the loaded formatting will not be 
changed.

5. When you are done, press Esc or click Unload in the Context toolbar before 
changing tools to unload the formatting to avoid a future mistake.

To change which text formatting is loaded:

When you choose the Style Picker  tool, the Context Toolbar will change to 
show options to control its behaviour when applying formatting, not when 
loading formatting. It is recommended not to change these options when copy-
ing and pasting formatting for text but you must select both Character Settings
and Paragraph Settings to properly copy paragraph styles.

1. Choose a combination of options from the Context Toolbar before applying 
loaded formatting to text. Click the All button to select all of the checkboxes 
or None to deselect all of them. Layer Opacity, Layer Effects, and Object 
Settings are not applicable to text and can be ignored.

• Stroke: Apply the loaded stroke attributes to the text’s stroke.

• Fill: Apply the loaded fill attributes to the text’s stroke.

• Character Settings: Apply the loaded character attributes, including 
character style and stroke and fill.

• Paragraph Settings: Apply the loaded paragraph attributes, including 
paragraph style but not the character attributes of the paragraph style.

Tip: The Style Picker
tool does not unload 
formatting automati-
cally when you change 
tools

Tip: The filled pointer 
will include a T next to 
the eyedropper when 
it is positioned over 
text to indicate that 
clicking will now apply 
formatting to text
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Finding and replacing text
You can use the Find and Replace panel to search for and replace plain text, 
formatted text, and text formatting in the current document.

While find and replace text is a basic feature, you can also search for text format-
ted with a text style and change its text style. Publisher also allows you to search 
for text with specific formatting attributes and replace those attributes with a text 
style, or to search for fields and change their formatting or replace them with 
other fields.

To find or replace text and/or text formatting:

1. Choose Text > Find… to display the Find and Replace panel. You can also 
choose Window > Find and Replace if the panel isn’t visible but the first 
option also makes the Find field active so you can immediately type the text 
to find, so it’s always better to use the Find… command.

2. Enter the text to find in the Find field and if you want to replace it with 
different text, enter the replacement text in the Replace with field. Leave these 
fields blank if you want to search for or replace text formatting only.

To enter special characters, click the magnifying glass  icon on the left side 
of the Find or Replace with fields and select one from the Special Characters
list. For other special characters, copy and paste them from the main docu-
ment text.

To enter a field, click the magnifying glass  icon on the left side of the Find
or Replace with fields and select one from the Fields list. Replacing with a 
field creates a new one with the current formatting defaults for that field.

3. To find text formatting on its own or in combination with the text you 
entered into the Find or Replace with fields, click the Formatting  icon to 
the right of Find or Replace with. From the popup menu, choose:

• Format: Select individual text formatting; this window is identical to the 
options for creating and editing text styles and is described in Creating 
text styles on page 121.

Panel menu

Find formatting

Replace formatting

Clear FindFind what

Clear Replace withReplace with

Replace and Replace AllFind (search)

Search results

Scope

Tip: Click the Clear
icon to quickly delete 
entered text

Tip: Finding a straight 
apostrophe (') will not 
find a typographic (‘) 
apostrophe or vice 
versa so finding 
contractions such as 
isn’t requires typing 
the apostrophe 
exactly as it appears in 
the document

Tip: You can search 
only the current 
document and not all 
open documents
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• Character Style: Select a character style from the list.

• Paragraph Style: Select a paragraph style from the list.

• Reset Format: Select to clear the above three formatting options.

The selected formatting will be shown below the Find or Replace with fields.

4. To limit the search results by case and whole words, click the Formatting
icon to the right of Find. From the popup menu, choose:

• Match Case: select to find only text that exactly matches the case of the 
text in the Find field; for example, Analog won’t find analog.

• Match Whole Word Only: select to find only text that isn’t part of a longer 
word; for example, log won’t find analog.

5. Select from the Scope popup menu to set the search scope to the current 
Document, Section, Spread, Page, Story (all the text in the text object or a 
series of linked text frames), or Selection. The latter refers to either selected 
text or to the story in a selected text object. If you select multiple text objects 
with different stories, all of their stories will be searched.

6. Click Find to search and display the page containing the first result forward 
in the document from the current position. Click Find again or choose Text > 
Find Next to move to the next search result or choose Text > Find Previous
to move the previous search result. Click a search result in the list to jump to 
that result.

7. If you are replacing text or formatting, click Replace to replace the selected 
search result and move to the next result.

8. Click Replace All to replace all remaining search results.

To reuse previous search strings:

Publisher automatically keeps remembers the last 20 search and replacement 
strings so you can reuse them to save time. It does not save the formatting or 
options that you used with that search.

1. To select a recently-used search or replacement string, click the magnifying 
glass  icon on the left side of the Find field or the caret  icon on the left of 
the Replace with field, and select from the list.

2. Select Clear Recent Finds or Clear Recent Replaces to clear the list.

Tip: With Scope set to 
Selection and a text 
frame in a linked series 
of frames selected, 
Publisher will search 
the entire story and 
not just the text in the 
selected frame

Tip: Match Case and 
Match Whole Word 
Only are sticky options 
that will persist for the 
rest of the session, 
including when you 
switch documents

Tip: Choose Reset 
Format from the 
Formatting icon’s 
popup menu to clear 
the selected 
formatting

Tip: Although Pub-
lisher stores recent 
searches, you cannot 
save search strings for 
future use
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Using regular expressions (GREP)
You can use regular expressions to find and replace text patterns. For example, 
you could search for all of the numbers in your document and change their 
numeric formatting.

Learning how to use regular expressions is beyond the scope of this manual but 
some examples are provided further below.

Regular expressions normally use the ANSI C or POSIX locale and ignore the 
text’s language setting so they are limited to the 7-bit ASCII character set. For 
example, entering [a-z] will match any lower- or uppercase letter but not 
accented characters such as åéîøü. With Locale Aware Regular Expression
selected, entering [a-z] will also match the accented characters because they will 
use the full Unicode character set.

To find and replace using regular expressions:

1. Choose Text > Find… to display the Find and Replace panel. 

2. Click the Formatting  icon to the right of Find. From the popup menu, 
choose Regular Expression or Locale Aware Regular Expression.

3. Enter the regular expression to search for in the Find field and if applicable, 
its replacement in the Replace with field.

4. Click Find, Replace, and Replace All to find and replace as you normally 
would.

Examples

Find Replace with Description

\s+$ blank Removes a space at the end of a paragraph

\b(\w+)\b \1 $1 Removes duplicate words

([\.\!\?])\s\s+ $1  and a space Replaces two spaces after periods, exclamation points, and
  question marks with a single space

^\d+\. ?(.) $1 and a style Changes paragraphs starting with “1. “, “2. “, etc. to a numbered
  list if you also set a replacement paragraph style that is
  numbered, such as the default Numbered 1 style

\b(one|two|three) any text Replaces any of a list of words separated by a vertical bar | (the
  words in this example are one, two, three) with any text

(?<=\d)[., ](?=\d\d\d) a space Replaces the comma separator in numbers with a space

(?<!\d)\d{4}(?!\d) Bold Makes 4-digit numbers such as years that aren’t part of longer
  numbers bold, if you set replacement formatting to Bold

Tip: Regular Expres-
sion is sticky and will 
persist for the rest of 
the session, including 
when you switch 
documents; ensure 
you switch back to 
Normal when you are 
done or it will appear 
that Find and Replace 
doesn’t work
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Find  Description

colou?r  Finds color and colour

[\x7f-\xff]  Finds non-ASCII characters

[[=e=]]  Finds any e character, including uppercase and accented

(?<=\d)(st|nd|rd|th)  Finds ordinals (1st, 2nd, 3rd, 4th…), regardless of superscripting

\d+/\d+  Finds fractions, but will also find dates written as 10/21/2023

[-\u\l\d._]+@[-\u\l\d_]+\.[\u\l]{2,4} Finds most email addresses

\b(\w+)\s+\1\b  Finds repeated words

Spell checking
Publisher can check spelling as you type or on demand. Spell checking requires 
that you specify the language for text. Refer to Language on page 80 for more 
information and to ensure you have the appropriate dictionaries installed.

Words you add to your custom dictionary will be available to all applications 
(macOS) or to all three Affinity applications (Windows). Affinity does not use 
the macOS Automatic by Language spelling option which mixes learned words 
of all languages together in one dictionary, so words you learn in other applica-
tions may not be available to Affinity and vice versa.

To enable or disable spelling as you type:

1. Choose Text > Spelling > Check Spelling While Typing. Misspelled words 
will be underlined in red.

To spell check manually:

1. Choose Text > Spelling > Check Spelling to highlight the next misspelled 
word and then right-click the misspelled word to see a list of spelling 
suggestions.

• Spelling suggestion: Select a suggestion to correct the word.

• Ignore Spelling: Select to ignore all instances of the word in this docu-
ment only. You can also choose Text > Spelling > Ignore Misspelled 
Word.

• Learn Spelling: Select to add this word to your custom spelling dictionary. 
To later remove the word from the dictionary, right-click the word again 
and choose Unlearn Spelling.

2. For a longer document, choose Text > Spelling > Spelling Options… to 
display the Spelling Options window.

Tip: The Check 
Spelling command 
(more commonly 
known as Check 
Document Now on 
macOS) is most useful 
with a keyboard 
shortcut to it and to 
Ignore Misspelled 
Word to make it easy 
to navigate between 
misspelled words
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• Change: Click to change the word highlighted in the document to the first 
word in the list below, or to the one you have selected in the list.

• Find next: Click to skip this word and move to the next misspelled word.

• Ignore: Click to ignore all instances of the word in this document only.

• Learn: Click to add this word to your custom spelling dictionary. To later 
remove the word from the dictionary, right-click the word and choose 
Unlearn Spelling.

• Define: Click to see definitions for the selected word. (macOS only)

• Guess: Shows a list of suggestions for the word highlighted in the 
document.

AutoCorrect
Publisher can convert straight quotation marks to typographic ones, convert 
paragraphs to lists, change capitalization, set superscripts, and correct common 
errors as you type. For example, you can replace teh with the. AutoCorrect can 
also automatically capitalize the first word of a sentence and you can define 
exceptions to automatic capitalization to avoid capitalizing the word after an 
abbreviation, such as the word following vs.

Publisher uses its own lists for each type of text replacement for every language it 
supports and doesn’t rely on the similar text replacement features built into 
macOS and Windows. This is important because while you might want the same 
corrections for basic text some of the corrections you use in Publisher may be 
more typographic and not suitable for your other applications. macOS also lacks 
separate text replacement lists for each language so Affinity’s custom feature is 
important for those who work in multiple languages.

You can customize how AutoCorrect works by setting its options, defining the 
text to correct, and defining the abbreviation exceptions. Refer to AutoCorrect, 
Abbreviations, and Title exceptions on page 249 for information.
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Word count
Publisher can display the count of the words, characters, lines, and paragraphs 
for the selected text, current story, or entire document. The current count is 
displayed in the Status Bar at the bottom of the document window to the right of 
the Preflight status indicator but can be hidden if you find it distracting. The 
count is updated when you pause during typing.

You can customize the count feature to display the count of words, characters, 
characters including spaces, lines, or paragraphs and you can view the other 
counts by clicking the count number.

If there is overset (overflowing) text, the 

To show the count:

1. Choose View > Show Word Count to display the count if it’s not currently 
displayed.

2. Choose what you want to count:

• To display the count for the entire document: deselect all text and text 
objects.

• To display the count for a single story: select a text object or position the 
text cursor in a text object.

• To display the count for a range of text: select the text range.

3. Click the count number to display a popup menu with the other statistics. 
Select a different statistic to change the default count to be displayed. Or press 
Esc or click outside of the popup to close it without selecting a statistic.

Word count Overset text
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Importing (placing) text
Publisher can place (import) text from word processors and text editors into text 
frames and other text objects. It supports the most common file formats but not 
the .odf (OpenDocument) format used by Google Docs™ and LibreOffice or the 
.pages format used by Apple® Pages®. It is recommended that you export from 
those applications to the .docx format used by Microsoft® Word for best results.

Format Description Notes

.docx Microsoft® Word Supported by most word processors

.rtf Rich Text Format Supported by most word processors and some text
  editors

.txt Plain text format Supported by most word processors and text editors

Imported text retain all of its text styles, formatting attributes, footnotes, and 
endnotes. Embedded images and tables will be imported although shapes are 
limited to rectangles and ellipses. 

When you import text, it will be placed into a text frame or other text object in 
an existing document; you are not opening a document or adding its pages to the 
Publisher document. The layout of the placed text and images will differ from the 
original document, especially if the size of the text frame does not match the 
original document’s main text area.

You can also copy and paste text from a word processor or text editor, but unless 
you’re pasting a small block of text, you will lose so much formatting that it’s 
better to place text.

Copy from Results when pasting

Microsoft® Word Will lose images and shapes; tables will be converted to text

Apple® Pages® Will lose text styles, notes, images, and shapes; tables will be
 converted to text

LibreOffice  Will lose text styles, images, and shapes; tables will be converted to
 text

Google Docs™ Will import as plain text; everything else will be lost

To place text into an empty text frame or text object, or at the cursor 
position in a range of text:

1. Using the Frame Text , Artistic Text , or Table  tool, position the text 
cursor where the imported text should be placed.

2. Choose File > Place…

3. Select a file from the window and click Open.

Tip: Refer to Importing 
notes from Microsoft® 
Word on page 196 for 
more information on 
importing documents 
that include footnotes 
or endnotes



Expert Guide to Affinity Publisher 69

To append text to the end of the text in a text frame or text object:

1. Deselect any selected object(s) by clicking on a blank area of the page.

2. Choose File > Place…

3. Select a file from the window and click Open. The mouse pointer will change 
to a place cursor .

4. Click the text frame or text object in which to append the text. As you move 
the mouse pointer over the frame or object, the text will appear to show you a 
preview of how it will be placed.

To replace all the text (the story) in a text frame or text object:

1. Using the Move  tool, select the text frame or text object. Do not double-
click it or Publisher will position the text cursor in it.

2. Choose File > Place…

3. Select a file from the window and click Open.
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Formatting characters
Character attributes are those that can be applied to one or more characters and 
include font family, size, kerning, tracking, and spelling language. While you can 
apply these attributes to an entire paragraph, they are applied to a range of text 
and not to the paragraph. For formatting attributes that can be applied only to 
entire paragraphs, refer to Formatting paragraphs on page 82.

If you regularly use the same combination of character attributes, consider 
creating a character text style to ensure consistency and save time. Refer to 
Creating text styles on page 121 for more information. Character attributes are 
applied over the attributes defined in paragraph and character styles and are 
sometimes referred to as character overrides.

To apply character attributes:

All character attributes can be selected from the Character panel. Some of the 
most common ones are also available from the Context Toolbar and those you 
might want to use with a keyboard shortcut are also available in the Text menu.

1. Using the Frame Text , Artistic Text , or Table  tool, select the text to 
which you want to apply formatting or place the cursor in a word to apply the 
formatting to that word.

2. Select the character attributes. These are described in the following sections.

To display the Character panel:

1. Click the Character panel  button in the Context Toolbar or choose 
Window > Text > Character.

Panel menu

Decorations: Underline, strikethrough, outline 
stroke, and outline colour

Positioning and Transform: Kerning, tracking, 
baseline offset, leading override, no break…

Typography: Ligatures, alternates, variants, 
figures, and capitals…

Language: Spelling and hyphenation…
Optical Alignment: positioned relative to frame 
edges

Font: Font family, size, style, colour, and 
background colour, plus character style

Expand/collapse section

Tip: Refer to Setting 
default text formatting
on page 104 for 
information on 
changing Publisher’s 
default character 
attributes

Tip: If you select an 
entire text object 
instead of selecting 
text or placing the text 
cursor, the attributes 
will be applied to all 
the text in the object
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Font
The top section of the Character panel allows you to set the font and character 
style. To specify the font, you must select the font family (typeface), font size, and 
font style (traits). These three elements make up a digital font. For example, 
12-pt Myriad Pro Semibold Italic is a font.

• Font Collection: Select a collection to narrow the number of font families 
listed. macOS: You can create and modify the font collections using the 
FontBook application included with macOS. There are three other collections 
in the list:

• Recents: Lists the 10 most recently-used font families.

• Missing: Lists the fonts used in the document that are not installed on this 
computer.

• Favourites: Lists the font families you have marked as a favourite.

• Font Family: Select a font family (typeface) from the popup menu of those 
installed on your computer, for example, Myriad Pro. Expand a font family to 
see the available font styles and select one without having to select font style 
separately.

Tip: You cannot 
customize the sample 
text in the font list but 
if you select text first it 
will change as you 
scroll through the list, 
allowing you to 
preview fonts

Panel menu

Font collection
Font size and Font style

Font family
Font colour and Background colour

Character style

Tip: You can also select 
Font Family from the 
Context Toolbar

Tip: Click the 
Favourite  icon to 
add the font family to 
your Favourites 
collection

Number of font styles

Favourited

Not favourited

Sample text

Expand/collapse font 
family

Selected font style

Tip: Publisher sup-
ports fonts in the 
OpenType, TrueType, 
and Affinity Font 
formats but cannot 
use variable fonts or 
colour fonts
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• Font Size: Select a preset font size or enter a custom size. By default, Publisher 
measures text in points (abbreviated as pt). Points are a traditional measure-
ment system for type but there wasn’t a universal standard for its size until the 
advent of desktop publishing. A point is defined now as 1⁄72 of an inch. You 
can use the document’s measurement system instead of points by choosing 
Affinity Publisher 2 > Settings…, clicking User Interface in the left pane, and 
then deselecting Show Text in points.

Instead of specifying a size you can also choose to make the text larger or 
smaller by a set increment. Choose Text > Size > Bigger, Smaller, Precise 
Bigger, or Precise Smaller or their keyboard shortcuts:

Command Shortcut Increment

Bigger ⌘ + > (Ctrl + >) 1 pt, 0.01 in, 0.1 mm

Smaller ⌘ + < (Ctrl+ >) 1 pt, 0.01 in, 0.1 mm

Precise Bigger ⌘ + ⌥ + > (Ctrl + Alt + >) 0.1 pt, 0.001 in, 0.01 mm

Precise Smaller ⌘ + ⌥ + < (Ctrl + Alt + <) 0.1 pt, 0.001 in, 0.01 mm

• Font Style (traits): Select a font style for the selected font family, for example, 
Semibold Italic. Font style is a combination of traits, including weight (thin, 
medium, bold, black…), width (condensed, regular, expanded…) and slope 
(roman, also referred to as regular or plain, and italics). The name of a font 
style may not include all of its traits, for example, a font style named Italic
implies that it is for the roman (regular or plain) weight and is not condensed.

Many users simply refer to font style as the font weight. Font style should not 
be confused with Character Style which is a combination of character 
attributes you create to format text.

Faux bold and italic

Some display fonts used for large headings, titles, and other non-body text 
purposes are available in just one or two font styles. For example, macOS and 
Windows include just the Regular style of the font Impact because it is already 
bold and there is no italic version. The Bold and Italic buttons in the Context 
Toolbar and the equivalent commands in the Text > Character Traits menu 
will be disabled when a bold or italic font style is not available. Some applica-
tions, including Microsoft® Word, will allow you to make it bold and italic 
even if there isn’t a bold or italic font style, a technique known as faux bold
and faux italic. These applications smear the font to make it appear bold and 
slant the characters to make them appear italic. Publisher does not support 
faux bold and italic it they shouldn’t be used in professional typesetting. 

Tip: If you don’t need 
these shortcuts, 
remove them to avoid 
accidentally changing 
font size; refer to 
Keyboard shortcuts on 
page 246

Tip: You can also 
choose the faux Bold
and Italic traits from 
the Text > Character 
Traits menu or click 
from the equivalent 
buttons in the Context 
Toolbar

Tip: You can create 
your own faux italic by 
setting Shear to 
approximately 14°

Tip: You can also select 
Font Style from the 
Context Toolbar

Tip: You can also select 
Font Size from the 
Context Toolbar
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Tip: Be careful when using the Bold button or menu command. If you’re using a profes-
sional body font with several weights, such as Light, Regular, Medium, Bold, and Black, 
the Bold button will not make the text the next bolder weight but make it Bold. If it’s 
already Bold or Black, the Bold button will make it Regular.

• Font Colour and Background Colour: Click the colour samples to set the 
text fill colour and background or highlight colours.

• Character Style: Select the character text style. Any other attributes you select 
in the Character panel will override the character style. Refer to Creating text 
styles on page 121 for more information.

Decorations
The Decorations section of the Character panel allows you to specify underline, 
strikethrough, and the text outline, modifications (decorations) to the character 
appearance.

Underline thickness and positioning are defined in the font and are scaled auto-
matically based on font size. If you format text of varying sizes with underline, 
Publisher will use the thickness and positioning of the larger text for a seamless 
underline.

• Underline and Colour: Select Single Underline  or Double Underline
to enable one of these or No Underline  to disable underline. Click the 
colour sample to set the underline colour. Setting to None will use the Font 
Colour and will not make it invisible.

• Strikethrough and Colour: Select Single Strikethrough  or Double 
Strikethrough  to enable one of these or No Strikethrough  to disable 
strikethrough. Click the colour sample to set the strikethrough colour. Setting 
to None will use the Font Colour and will not make it invisible.

• Outline Stroke and Colour: Click the stroke control to set the text outline’s 
thickness, dash pattern, and other properties. Click the colour sample to set 
the text outline colour. Setting to None will cause the text will appear un-
stroked (default).

Tip: Use the Outline 
Colour control in the 
Decorations section 
to set the text outline 
colour

Tip: You can also select 
the character style 
from the Text Styles 
panel and Context 
Toolbar

Tip: You can also set 
Outline Stroke with 
the Stroke panel and 
Outline Colour with 
the Colour panel

Tip: You can also select 
Font Colour, but not 
Background Colour, 
from the Context 
ToolbarColour

Background colour
Font colour

Tip: You cannot adjust 
Underline and 
Strikethrough thick-
ness or positioning in 
Publisher

Continuous underline is based on 
largest font size in the selected range

Interrupted underline is based on 
individual font sizes

Tip: Use the Font 
Colour control in the 
top section of the 
panel to set the text fill 
colour

Underline off, single, 
double, and colour

Strikethrough off, single, double, and colour

Outline stroke and colour
Tip: You can also 
choose single Under-
line and Strike-
through from the Text 
> Character Traits
menu or click the 
equivalent buttons in 
the Context Toolbar
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Positioning and Transform
The Positioning and Transform section of the Character panel allows you to 
change how the characters are positioned relative to neighbouring characters and 
lines of text and how they are scaled.

• Kerning: Kerning adds and removes space between specific pairs of charac-
ters to correct visual gaps caused by adjacent characters with overhanging 
shapes. Most quality fonts have kerning values defined for character pairs that 
would produce a gap but at large display sizes you may wish to override the 
value set by the font designer.

• Auto: Select to use the font’s defined kerning pair values. This field will 
show Auto only when a range of text set to Auto is selected and it will 
show the font’s kerning value in parentheses when the text cursor is 
between two characters. If there is not a kerning pair value defined for the 
two characters then (0‰) will be shown.

• 0‰: Select to turn off kerning for a pair of character or range of text. The 
field will show 0‰ if you have set it to zero or (0‰) if you have set it to 
Auto.

• Preset or custom value: When the text cursor is between two characters, 
select a preset value or enter a custom value in permilles (thousandths of 
an em space). Positive values will loosen spacing and negative values will 
tighten spacing.

Instead of specifying a kerning value you can also tighten or loosen kerning 
by a set increment. Choose Text > Spacing > Tighten, Loosen, Tighten More, 
or Loosen More or their keyboard shortcuts:

Command Shortcut Increment

Loosen ⌥ + � (Ctrl+ �) 10‰

Tighten ⌥ + � (Ctrl+ �) 10‰

Loosen More ⌘ + ⌥ + � (Shift + Alt + �) 50‰

Tighten More ⌘ + ⌥ + � (Shift + Alt + �) 50‰

Tip: Choose Text > 
Spacing > Use None
to set both kerning 
and tracking to 0‰

Tip: If you don’t need 
these shortcuts, 
remove them to avoid 
accidentally changing 
kerning or tracking; 
refer to Keyboard 
shortcuts on page 246

Tip: Choose Text > 
Spacing > Use Default
to set kerning and 
tracking back to Auto, 
the font’s default

To Av We To Av We
Auto 0‰

Tip: Publisher does 
not offer an Optical 
Kerning feature to 
automatically kern 
characters based on 
their shapes

Tip: You can’t change 
kerning when a range 
of text is selected, 
except to Auto or 0‰

Kerning
Tracking

Baseline Offset
Leading Override

No Break

Shear
Horizontal Scale
Vertical Scale
Super/Subscript

Tip: Tighten and 
Loosen change 
kerning when the text 
cursor is between two 
characters, or tracking 
when text is selected
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• Tracking: While kerning is used to add and remove space between specific 
character pairs, tracking adds and removes space between all characters. 
Tracking can be used in conjunction with kerning. For example, you could 
increase tracking to loosen the overall spacing but keep Auto kerning enabled 
to avoid unsightly gaps with overhanging character shapes. Select a preset 
value or enter a custom value in permilles (thousandths of an em space). 
Positive values will loosen spacing and negative values will tighten spacing.

In general, display type should be tracked tightly with a negative value while 
you may not need to adjust tracking at all for body text. White text on a solid 
background may need to be loosened to avoid having the characters seem 
closer than they are.

Instead of specifying a tracking value you can also tighten or loosen tracking 
by a set increment. Choose Text > Spacing > Tighten, Loosen, Tighten More, 
or Loosen More or their keyboard shortcuts:

Command Shortcut Increment

Loosen ⌥ + � (Ctrl+ �) 10‰

Tighten ⌥ + � (Ctrl+ �) 10‰

Loosen More ⌘ + ⌥ + � (Shift + Alt + �) 50‰

Tighten More ⌘ + ⌥ + � (Shift + Alt + �) 50‰

• Baseline Offset: Select a preset baseline offset or enter a custom value. Posi-
tive values will raise the character above the baseline and negative values will 
lower the character below the baseline.

Instead of specifying an offset you can also choose to raise and lower the 
baseline by a set increment. Choose Text > Size > Raise Baseline, Lower 
Baseline, Precise Raise Baseline, or Precise Lower Baseline or their keyboard 
shortcuts. You can also choose Use Default to reset the baseline to normal.

Command Shortcut Increment

Raise Baseline Shift + ⌥ + ↑ (Shift + Alt + ↑) 1 pt, 0.01 in, 0.1 mm

Lower Baseline Shift + ⌥ + ↓ (Shift + Alt + ↓) 1 pt, 0.01 in, 0.1 mm

Precise Raise ⌘ + Shift + ⌥ + ↑ (Ctrl + Shift + Alt + ↑) 0.1 pt, 0.001 in, 0.01 mm

Precise Lower ⌘ + Shift + ⌥ + ↓ (Ctrl + Shift + Alt + ↓) 0.1 pt, 0.001 in, 0.01 mm

Tip: Use Baseline 
Offset to adjust the 
vertical position of an 
inline image to align it 
with neighbouring 
characters

Tip: Tighten and 
Loosen change 
kerning when the text 
cursor is between two 
characters or tracking 
when text is selected

Tip: Choose Text > 
Spacing > Use None
to set both kerning 
and tracking to 0‰

Tip: If you don’t need 
these shortcuts, you 
can remove them to 
avoid accidentally 
changing kerning or 
tracking; refer to 
Keyboard shortcuts on 
page 246

Tip: If you don’t need 
these shortcuts, 
remove them to avoid 
accidentally changing 
the baseline; refer to 
Keyboard shortcuts on 
page 246

Tip: Choose Text > 
Spacing > Use Default
to set kerning and 
tracking back to Auto, 
the font’s default

Tightened Normal Loosened
-50‰ 0‰ 50‰ loose

Definition: The 
baseline is the invisi-
ble line on which the 
bases of characters 
without descenders 
are aligned
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• Leading Override: Leading (line spacing) is normally set for an entire para-
graph but you can override it for specific characters. The paragraph leading 
value will be shown in parentheses if you have not overridden it.

• Shear: Enter a value to slant the characters to create the appearance of an 
italicized font. Positive values will slant the characters to the right and nega-
tive values to the left. A faux italic can be created with a shear of approxi-
mately 14% and while it is not a replacement for a true italic font style, it can 
be useful for display type.

• Horizontal Scale: Enter a value to horizontally scale the characters and the 
space between them. Positive values will stretch the text and negative values 
will condense it. Scaling is not a replacement for a true condensed or 
expanded font style, but it can be useful for display type.

• Vertical Scale: Enter a value to scale the characters vertically. Positive values 
will increase the height while negative values will decrease it.

• Super/Subscript: Select Superscript or Subscript to automatically decrease the 
font size and increase or decrease the baseline offset. You cannot adjust the 
changes applied and the changed values are not shown in the Font Size and 
Baseline Offset fields. It is better to use a font’s true superscript or subscript 
characters than this automatic option because it results in thinner strokes 
than normal characters, but some fonts don’t include true super- and sub-
script characters. Refer to Super/Subscript: on page 78 for more information.

• No Break: Select to disable automatic word wrapping inside of a text frame. 
This feature is useful to prevent automatic hyphenation of proper nouns (for 
example, Southampton), breaking at manual hyphens (for example, 
90-degree), or to keep certain words together (for example, 4K TV).

Tip: Refer to Typogra-
phy on page 77 for 
more information on 
true superscript and 
subscript

Tip: Setting Leading 
Override to less than 
the paragraph leading 
value will have no 
effect

Tip: There is no visual 
indication of text that 
is formatted with No 
Break but you can 
search for it with the 
Find and Replace 
panel

Tip: Scaling art text 
with the Move  tool 
will adjust its horizon-
tal scale

Super¹ Sub₂ Super1 Sub2
Automatic super- and subscriptTrue super- and subscript

Tip: No Break has no 
impact on art text or 
path text because 
there is no right frame 
edge to wrap the text

Shear Shear Shear
-14° 0‰ 14°
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Typography
The Typography section of the Character panel allows you to access the 
extended characters of some fonts including ligatures, ordinals, super- and 
subscripts, and small caps. The options available will vary with the font selected 
and in some cases are impacted by the Typography script and Typography 
language you have set as described in the section on Language on page 80.

Fonts often have more options than can fit in the Character panel. You can 
access the full set of options and view samples with the Typography window that 
can be opened by clicking the More  icon, by choosing Show Typography
from the panel menu , or by clicking the Show Typography  icon in the 
Context Toolbar.

• Standard Ligatures:  Select to use ligatures in place of the standard charac-
ter glyphs for the most common ligatures. This option is on by default 
because it is almost always a good idea to use these ligatures. Discretionary 
ligatures, ones that you might not want to use in all cases, are available for 
some fonts in the Typography window.

Definition: A ligature 
is a single character 
glyph that replaces 
two or more single 
glyphs to improve 
readability and 
aesthetics

fi ff fl ffi ffl fi ff fl ffi ffl
Standard ligatures offStandard ligatures on

Tip: The Typography
options in the Charac-
ter panel are listed as 
radio buttons and 
checkboxes in the 
Typography window; 
the options available 
depend on the 
selected font

ct st sp  ct st sp
Discretionary ligatures offDiscretionary ligatures on

Tip: The typography 
options change the 
appearance of charac-
ters but do not change 
the characters you 
have entered; for 
example, lowercase 
letters will still be 
lowercase when 
applying All Caps

Two views of the 
Typography window
for different fonts

Tip: The Typography
window is a floating 
window and not a 
panel

Option buttons

Option menus More
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• Contextual Alternates:  Select to use the alternate or variant form of a 
character glyph depending on the context. They are commonly used to 
improve the joining of specific characters but in this example, the alternate 
form of the colon is raised above its normal position when used with digits to 
express a time. The Contextual Alternates option is on by default if supported 
by a font. Refer to the font’s documentation for a list of the supported 
alternates.

• Ordinals:  Select to format ordinal numbers such as 1st as superscripted 
with characters scaled relative to adjoining characters of the same size. While 
it may be more convenient to use the Superscript ordinals as they are typed
feature in Settings…, it is better to disable it and use ordinals as intended by 
the font designer if they are available. This option is off by default because it 
should be applied only to the ordinal number or else you will inadvertently 
superscripting body text.

• Fractions and Figure Position:  Select to use formatted fractions for 
numbers separated by a forward slash with digits scaled relative to adjoining 
characters of the same size. This option is off by default because it should be 
applied only to the fraction itself. Some fonts support only basic fractions 
such as ½ while others allow you to compose your own complex fractions 
such as 1¼76. For the latter, format the numerator and denominator with the 
options of the same names in the Figure Position section of the Typography 
window. Format the forward slash with Fraction.

• Super/Subscript:  Select to raise or lower characters from the baseline 
and scale them relative to adjoining characters of the same size. While it may 
be more convenient to use the similar Supers/Subscript feature in the Posi-
tioning and Transform section, it is better to use superscripts as intended by 
the font designer if they are available. Some fonts may also offer Superior and 
Inferior options for scientific notation which can be found in the Figure 
Position section of the Typography window.

Tip: Always precede a 
fraction with a space 
or it will not be 
properly formatted

Super¹ Sub₂ Super1 Sub2
Automatic super- and subscriptTrue super- and subscript

½ ⅜ 1¼76
Basic fractions Composed fraction

9:15 Time: 9:15 Time:
Contextual Alternates offContextual Alternates on

1st 2o 3re 1st 2o 3re

Ordinals off and superscript onOrdinals on



Expert Guide to Affinity Publisher 79

• All/Small Caps and Case-Sensitive Forms:  Select All Caps or Small 
Caps to use a font’s style for real all or small capital letters. You can also use 
the Text > Capitalization > All Caps and Small Caps commands to access 
this feature. If the font supports it, selecting All Caps will also select the Case-
Sensitive Forms and Capital Spacing options which can be accessed sepa-
rately in the Capitals section of the Typography window. Case-Sensitive 
Forms shifts characters such as parentheses up to align better with all capital 
characters and lining figures while Capital Spacing improves the spacing for 
all capital characters.

• Character Variants:  Click to select from a menu of the variants available 
for the font. Applying these options to characters other than those in the 
menu will have no effect so if you want to use certain variants throughout a 
document you can enable them in a text style. Each of the characters in the 
example below is a variant form of the standard character. Slash zero is a 
common one used to distinguish between a zero and capital O.

• Stylistic Sets:  Click to select from a menu of the stylistic sets available for 
the font. A stylistic set is a group of character variants or alternates that can 
be applied together. For example, the font used in the example above allows 
selecting the straight-sided six and nine separately as variants to combined as a 
set. Not all of the characters in a set are available separately as character 
variants so refer to the font’s documentation for a list, especially since sets are 
not always clearly named.

• Swash:  Click to select from a menu of the swash style sets available for 
the font in place of the standard characters. Swash characters are often used at 
the start or end of a word for a flourish. Be careful when using them in the 
middle of a word because the swash may collide with another character.

Kick  Kick
Standard charactersSwash characters

(CAPS 12) (Caps 12)
Standard charactersAll Caps + Case-Sensitive Forms + Capital Spacing

Galf  Galf
Stylistic set off (standard characters)Stylistic set on

ɑll 4069 all 4069
Standard charactersCharacter variants
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• Figure Style: Select Old Style from the Figure Style section of the Typogra-
phy Window for non-lining figures, also known as lowercase or hanging 
figures, which have varying heights and baseline positions.

• Figure Width: Select Tabular from the Figure Width section of the Typogra-
phy Window when numbers in columns should align.

Language
The Language section of the Character panel allows you to specify the language 
for spelling and hyphenation, as well as the typography script and language.

You can add words to the included spelling dictionaries or the ones you install 
(refer to Installing additional dictionaries on page 255) by right-clicking a mis-
spelled word and choosing Learn from the context menu, but you cannot add 
words to the hyphenation exception dictionary.

• Spelling language: Select the language for the text. Select None to turn off 
automatic spell checking.

• Hyphenation language: Select Auto to allow Publisher to select the most 
appropriate hyphenation dictionary. For most languages, this will exactly 
match the spelling language but some languages such as English (Canada)
don’t have their own hyphenation dictionary so choosing Auto would use 
English (US).

• Typography script and language: The typography script and language deter-
mine how OpenType rules are applied and thus which alternate characters are 
available. You can ignore these controls and leave them set to Auto if you 
don’t need to access certain alternate characters. Typography script specifies 
the way text is written, for example, Arabic, while Typography language
specifies the actual language, for example, Persian. Select Auto to allow Pub-
lisher to select the most appropriate option or Default to use the font’s default 
option. The typography scripts and languages available will depend on the 
selected font.

Tip: The user interface 
language set in 
Settings has no 
impact on the lan-
guage of your text; 
refer to Setting default 
text formatting on 
page 104 for informa-
tion changing 
Publisher’s default 
attributes

Tip: You cannot 
automatically disable 
hyphenation for 
capitalized words

Tip: Use Tabular
figures in conjunction 
with Lining (non-Old 
Style) figures for 
columns of numbers

1234567890 1234567890
Lining figuresOld Style figures

Tip: You cannot 
automatically disable 
spell checking for 
capitalized words

Spelling language

Hyphenation language

Typography script

Typography language

12345  12345
67890  67890

ProportionalTabular

Tip: There is no reason 
to use the None option 
for Hyphenation; 
insert a soft hyphen 
before a word to 
disable automatic 
hyphenation for a 
word; you can also 
format it with No 
Break
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Optical Alignment
The Optical Alignment section of the Character panel allows you to specify how 
punctuation and certain characters are positioned relative to the left and right 
edges of the text frame. Optical alignment is off by default but is commonly used 
in magazines, brochures, and books to ensure that a page of text is visually 
aligned. It is generally used for body text and not for headings or tables.

Optical alignment makes the left and right edges of a column of text look more 
uniform to the eye by slightly shifting certain characters and by hanging punctua-
tion (positioning it) outside of the text frame. With a bit of manual adjustment to 
find the right value, you can even hang entire words outside of the text frame.

• Type: Select Font to enable optical alignment and use the font’s values or 
Manual to use custom values. Select None to disable optical alignment. Few 
fonts offer optical alignment values so selecting Font will almost always use 
Publisher’s default values.

• Add: Click to add an optical alignment rule to the table below. Click the 
Remove Rule  icon to delete a rule from the table.

• Left/Right: Set how far the character should extend outside of the text frame’s 
left or right edge. This value is specified as a percentage of the character 
width.

• Characters: List the characters (without separators) to which the rule applies. 
For example, CGOQ() characters extend 10% of their width out of the text 
frame because they have curved sides.

Type (on/off)

Set Rule values

Add Rule

Remove Rule

Product 1
New! Product 2

Product 3

“Hanging
Normal
Optical

Punctuation hung 
outside of column Word hung

outside of columnCurved side of character 
outside of column

Tip: Optical Alignment 
is not recommended 
for use with art text or 
path text because they 
lack a frame
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Formatting paragraphs
Paragraph attributes are those that can be applied only to entire paragraphs and 
include justification, indents, paragraph leading, tab stops, hyphenation, and 
much more. For formatting attributes that can be applied only to any range of 
characters, refer to Formatting characters on page 70.

If you regularly use the same combination of character attributes, consider 
creating a character text style to ensure consistency and save time. Refer to 
Creating text styles on page 121 for more information. Character attributes are 
applied over the attributes defined in paragraph and character styles and are 
sometimes referred to as character overrides.

To apply paragraph attributes:

All paragraph attributes can be selected from the Paragraph panel. Some of the 
most common ones are also available from the Context Toolbar and those you 
might want to use with a keyboard shortcut are also available in the Text menu.

1. Using the Frame Text , Artistic Text , or Table  tool, position the text 
cursor in the paragraph to which you want to apply the formatting, or select a 
range of paragraphs.

2. Select the paragraph attributes. These are described in the following sections.

To display the Paragraph panel:

1. Click the Paragraph panel  button in the Context Toolbar or choose 
Window > Text > Paragraph.

Panel menu

Spacing: Leading, left/right indents, first line 
indent, space before/after, 

Justification: minimum, desired, and 
maximum word and letter spacing

Bullets and Numbering: list options

Hyphenation: auto hyphenation rules

Initial Words: format the first words in a 
paragraph

Justification plus paragraph style

Expand/collapse section

Tab Stops

Baseline Grid: override

Drop Caps

Decorations: borders and 
fill

Flow: Start, keep, 
widow, and orphan

Tip: If you select a 
range of paragraphs it 
is not important to 
select all of the 
paragraphs’ characters 
because Publisher will 
apply the formatting 
to the entire 
paragraphs

Tip: Refer to Setting 
default text formatting
on page 104 for 
information on 
changing Publisher’s 
default paragraph 
attributes
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Alignment (justification)
The top section of the Paragraph panel allows you to set the alignment of the 
paragraph to the left or right edges of the text frame or text object and the para-
graph style.

•  Left Align (default): Select to left align all lines of text; also known as rag 
right.

• Centre Align: Select to centre align all lines of text.

• Right Align: Select to right align all lines of text; also known as rag left.

•  Justified Left: Select to align text to both the left and right edges and to 
left align the last line of the paragraph (recommended for justified text).

•  Justified Centre: Select to align text to both the left and right edges and to 
centre align the last line of the paragraph.

•  Justified Right: Select to align text to both the left and right edges and to 
right align the last line of the paragraph (not recommended for languages 
written left-to-right).

•  Justified All: Select to align text to both the left and right edges and to 
force justify the last line of the paragraph, even if it’s a single word (not 
recommended).

•  Align Towards Spine: Select to left align text on right pages and right 
align text on left pages.

•  Align Away from Spine: Select to right align text on right pages and left 
align text on left pages.

• Paragraph Style: Select the paragraph text style. Any other attributes you 
select in the Paragraph panel will override the paragraph style. Refer to 
Creating text styles on page 121 for more information.

Tip: You can also 
choose all of these 
options from the Text 
> Alignment menu or 
click from the equiva-
lent buttons in the 
Context Toolbar

Panel menu

Justification (from left): Left, Centre, and Right 
Align; Justified Left, Centre, Right, and All; Align 
towards spine, Align away from spineParagraph style

Tip: Publisher does 
not offer a Flush 
Space (variable space) 
character which is 
sometimes used with 
Justified All text

Tip: You can also select 
the paragraph style 
from the Text Styles 
panel and Context 
Toolbar
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Spacing
The Spacing section of the Paragraph panel allows you to set the space between 
paragraphs and lines of text as well as how much text is indented from the left or 
right edges.

• Leading: Leading controls the space between lines of text and is measured 
from the baseline of a line of text to the line above it. Word processors usually 
refer to leading as line spacing. To override leading for a range of characters 
in a paragraph, refer to Leading Override on page 76.

• Default (not recommended): Select to use the font’s defined leading. The 
calculated leading value for the font size will be shown as [value] in square 
brackets when you have selected Default. For example, if the font’s default 
leading is 120% and the font size is 12 pt, then Publisher will show 
[14.4 pt].
Tip: The Default leading option works very differently than the Auto leading option 
in Adobe® InDesign® which uses leading of 120% (a value you can customize) while 
Publisher uses the value the font designer intended. Unfortunately, many fonts, 
including those from major type foundries, lack a default leading value or have a 
poorly defined one which results in very tight leading in Publisher. Unless you’re 
using a font that has properly-defined default leading such as fonts from Adobe, it is 
recommended to avoid the Default option and to instead use Exactly or % Height.

• Exactly (recommended): Select to specify an exact leading value and then 
enter the value into the field. You can also choose from a list of preset 
leading values. If the font size is greater than the leading then characters in 
the lines of text may overlap.

Left and Right indent

First Line indent and 
Last Line outdent

Sum space before and 
after

Leading

Space before

Space after

Space between same styles

Use space before

Definition: The 
baseline is the invisi-
ble line on which the 
bases of characters 
without descenders 
are aligned

Tip: You can also select 
Leading options from 
the Context Toolbar

A font with default leading of 
120%

A font without default leading which 
results in text that is too tight

Using a larger font size for 
some text on a line will 
increase its leading when 
using Default or % Height

Leading is measured 
between baselines

Tip: Leading is pro-
nounced ledding
because it refers to the 
metal lead which was 
previously used to set 
type
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• % Height (recommended): Select to specify a percentage of the font size. 
The calculated leading value will be shown as (value) in parentheses when 
you have selected % Height. For example, if you enter 120% for a font size 
of 12 pt then Publisher will show (14.4 pt). If you click in the Leading field 
again, the percentage you entered will be shown.

• At Least: Select to specify the minimum leading for the font size. This 
option is similar to Exactly and will generally result in a fixed leading 
amount but if you increase the font size then leading may increase. The 
value you enter will be shown as (value) in parentheses when you have 
selected At Least to differentiate it from an exact value. For example, if you 
enter 14 pt then Publisher will show (14 pt).

• Multiple (not recommended): Select to specify leading as a multiple of the 
font’s default leading. Selecting Multiple will initially set leading to 1.5 
times the font’s default leading. If you click in the Leading field, the multi-
ple will be shown but otherwise the field will show the calculated leading 
value for the font size will be shown as [value] in square brackets. For 
example, if the font’s default leading is 120%, the font size is 12 pt, and the 
multiple is set to 1.5, then Publisher will show [21.6 pt].

Instead of specifying a leading value you can also increase or decrease leading 
by a set increment. Choose Text > Paragraph Leading > Increase, Decrease, 
Precise Increase, or Precise Decrease or their keyboard shortcuts:

Command Shortcut Increment

Increase ⌥ + ↓ (Alt + ↓) 2 pt, 0.02 in, 0.2 mm, 21%, 0.21x

Decrease ⌥ + ↑ (Alt + ↑) 2 pt, 0.02 in, 0.2 mm, 21%, 0.21x

Precise Increase ⌘ + ⌥ + ↓ (Ctrl + Alt + ↓) 0.2 pt, 0.001 in, 0.01 mm, 3.6%, 0.03x

Precise Decrease ⌘ + ⌥ + ↑ (Ctrl + Alt + ↑) 0.2 pt, 0.001 in, 0.01 mm, 3.6%, 0.03x

• Left/Right Indent: Enter the amount that the paragraph should be 
indented from the left and right edges of the text frame or object. Entering a 
value for Left Indent will automatically change First Line Indent by the same 
amount, and entering a value for Right Indent will change Last Line Outdent
by the same amount.

• First Line Indent: Enter the amount that the first line should be indented 
from the left edge of the text frame or object. A typical value for a book is one 
or two times the font size. To creating a hanging indent, enter the indent 
value into Left Indent and then set First Line Indent to zero.

Publisher uses the macOS approach to first line indent and doesn’t work the 
same way as Adobe® and Microsoft® applications. To create an indented first 
line, set Left Indent to 0 and First Line Indent to a positive value. To create a 
hanging indent, set Left Indent to a positive value and set First Line Indent
to 0.

Tip: You can set Left, 
Right, and First Line 
Indent visually with 
the Text Ruler; refer to 
Tab Stops in the 
following section for 
an example

Tip: If you don’t need 
these shortcuts, 
remove them to avoid 
accidentally changing 
leading; refer to 
Keyboard shortcuts on 
page 246

Tip: Instead of using 
Left and Right Indent, 
You can inset all text in 
a text frame with the 
Insets fields in the 
Text Frame panel



86 Basic text

• Last Line Outdent: Enter the amount that the last line should be indented 
from the right edge of the text frame or object. This feature works best with 
full justification and is not frequently used.

•  Space Before/After: Enter the amount of space that should be added 
between paragraphs. You can add space before or after the paragraph, or add 
both. The behaviour of these controls is modified by Space Between Same 
Styles, Sum Space Before and After, and Use Space Before which are 
described below.

• Space Between Same Styles: Select to override the defined Space Before and 
Space After values and enter the amount of space to add between two para-
graphs of the same paragraph style.

• Sum Space Before and After: Select to add both Space Before and Space 
After. When deselected, Publisher will use only the larger value.

• Use Space Before: Select Only Between Paragraphs to avoid adding Space 
Before the first line of text in a column or text frame or select Always to allow 
space to be added at the top of a column or frame. You can also select Only at 
Column Top but there is no reason to use that option.

Tip: Use Space 
Between Same Styles
to reduce the space 
between items in a 
bulleted or numbered 
list while continuing 
to add more space 
before and after the 
first and last list 
paragraphs

Tip: Always use Space 
Before or Space After
to add space between 
paragraphs instead of 
pressing Return a 
second time so that 
you can control the 
amount of space
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Tab Stops
The Tab Stops section of the Paragraph panel allows you to indent text with tab 
characters to specific positions relative to the left edge of a text frame or object. 
You can also specify that the tab’s space be filled with a visible character to form a 
dot leader or other type of leader.

Click the More  icon for a tab stop or click a tab stop in the Text Ruler to 
display a popup window and edit additional tab stop settings:

When working with tab stops you may wish to choose View > Show Text Ruler
so that you can visually set and modify tab stops. The Text Ruler will appear 
above the active text frame or object. You can move the ruler closer to the text 
you are formatting by dragging the handle on the left side of the ruler.

Drag an indent or tab stop marker in the Text Ruler to change its position. Click 
a tab stop marker to edit its values in the same popup window above that is 
opened from the Tab Stops section of the Paragraph panel.

• Default tab stops: Set the default spacing for tab stops. Adding tab stops will 
override the default spacing until the last added tab stop at which point the 
default spacing will resume.

• Add tab stop: Click  to create a new tab stop. Its default position will be the 
sum of the last tab stop and the default tab stop spacing. You can also add a 
tab stop by clicking on the Text Ruler.

• Tab stop position: Set the position for the tab stop. You can also change a tab 
stop’s position by dragging its marker in the Text Ruler. Click the More
icon and select From Right to measure the position from the right edge of the 
ruler; this option is commonly used in conjunction with a leader.

Drag to move

First Line Indent Right IndentLeft Indent
Tab Stop

Tip: For text frames or 
objects with curved or 
irregular left edges, 
tab stops are relative 
to the leftmost point; 
for Path Text, the tab 
stops are positioned 
along the path and 
not necessarily in a 
straight line

Decimal Character

Delete Tab Stop

Alignment

Leader CharacterLeader Type

Measure from right edgeTab Stop Position

Tip: The Text Ruler is 
not available for path 
text objects

Tab stop leader MoreTab stop alignment

Panel menu

Delete tab stop

Add tab stop

Tab stop value

Tab stop list

Default tab stops
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• Tab stop alignment: Select the alignment for the tab stop. You can also 
change a tab stop’s alignment by clicking its marker in the Text Ruler and 
selecting an alignment from the popup window.

• Left: Select to left align text to the tab stop.

• Centre: Select to centre align text to the tab stop.

• Right: Select to right align text to the tab stop.

• Decimal: Select to align the next decimal in the text to the tab stop. The 
default decimal character is a period but you can change it by clicking the 
More  icon and entering a different character into the Decimal field.

• Leader type (dot leader): Click the More  icon for a tab stop or click a tab 
stop in the Text Ruler and select a dot leader type:

• None: Select to use a normal blank tab.

• Character: Select to fill the tab space with a leader. The default period 
character will create a dot leader but you can enter a custom leader 
Character.

• Underline: Select to fill the tab space with underline characters which 
is useful for creating printed forms.

• Strikethrough: Select to fill the tab space with strikethrough 
characters.

• Delete tab stop: Click the Delete  icon to delete the corresponding tab stop. 
You can also delete a tab stop by dragging it off of the Text Ruler and then 
releasing the mouse button.

Tip: You can also 
double-click a tab stop 
in the Text Ruler to 
cycle through the 
types of tabs until you 
reach the one you 
want
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Justification Options
Justifying text, aligning it to both the left and right edges of the text frame or 
object, requires adding and removing space between words and letters to balance 
lines of text. The Justification section of the Paragraph panel allows you to set 
the minimum, desired, and maximum word- and letter-spacing options for the 
justification options in the top section of the panel.

The minimum and maximum options will have no impact on left-, centre-, or 
right-aligned text. For both the word and letter spacing options, enter values 
from 0 to 250% but minimum must be less than desired which must be less than 
maximum.

Publisher will do its best to honour the values you set and will never use less than 
the minimum spacing, but if it is impossible to fit or break a word, Publisher will 
exceed the maximum as required.

• Minimum, Desired, and Maximum word spacing: Set the desired 
space between words and sentences. Change the desired word spacing to 
reduce or increase the width of the space character. Change the minimum 
and maximum word spacing to avoid unsightly rivers of white space in justi-
fied text; minimum and maximum will have no effect on non-justified text. 
The default values of 80, 100, and 133% will work well for most text.

• Minimum, Desired, and Maximum letter spacing: Set the desired 
space between characters, before the application of kerning and tracking. 
These values will be set to zero by default so that space will be added and 
removed only between words. You would not normally set desired spacing to 
more than zero but if your text has unsightly rivers of white space, you might 
consider increasing the maximum; minimum and maximum will have no 
effect on non-justified text. Changing the desired spacing is similar to chang-
ing tracking at the paragraph level.

Tip: Publisher does 
not also offer Glyph 
Scaling (horizontal 
scaling) for automatic 
justification

Tip: Using two spaces 
between sentences 
will interfere with the 
word spacing settings

Minimum, Desired, and Maximum letter spacing
Minimum, Desired, and 

Maximum word spacing

Tip: If you don’t want 
to change the Justifi-
cation options, review 
your text for incorrect 
hyphenation and 
insert soft hyphens 
where possible
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Flow
The Flow section of the Paragraph panel allows you to direct Publisher to avoid 
creating widows and orphans and to set where a paragraph should start.

Incorrect use of these options can lead to unusual text flow with entire para-
graphs moved to the next page.

A widow occurs when the last line of a paragraph can’t fit at the bottom of the 
previous text frame or column and is positioned on its own at the top of a 
column. An orphan occurs when the first line of a paragraph is all that can fit at 
the bottom of a text frame or column. A runt occurs when the last line of a 
paragraph has only a single word.

• Start anywhere: Set where the paragraph will start. This option is often used 
to start certain levels of headings at the top of the next page, text frame, or 
column as an alternative to manually inserting a page, column, or frame 
break.

• Anywhere: Select to allow the paragraph to start anywhere after the previ-
ous paragraph.

• In Next Column: Select to force the paragraph to start in the next column.

• In Next Frame: Select to force the paragraph to start in the next text 
frame.

• On Next Page, Next Odd Page, Next Even Page: Select to force the para-
graph to start on the next page or next odd or even numbered page. Next 
page refers not to the next sequential page but to the next text frame in the 
linked series that is not on the current page.

• Keep with previous paragraph: Select to keep at least the first line of the 
paragraph with the last line of the previous paragraph. Setting this option for 
a paragraph following a heading will avoid the heading being positioned at 
the bottom of a text frame or column without text beneath it.

Widow

Orphan

Runt

Widow

Keep with previous
Prevent orphans

Keep together
Prevent widows

Start paragraph

Keep with next

Tip: Publisher does 
not offer an option to 
avoid runts; one way 
to fix a runt is to select 
the runt and the 
preceding word and 
set No Break so that 
the last two words will 
be on a new line
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• Prevent orphaned first lines: Select to keep the first two lines of a paragraph 
together to avoid an orphan at the bottom of a text frame or column.

• Keep paragraph together: Select to keep the entire paragraph together. If the 
next text frame or column isn’t large enough to fit the entire paragraph then 
Publisher will be forced to break it.

• Prevent widowed last lines: Select to keep the last two lines of a paragraph 
together to avoid a widow at the top of a text frame or column.

• Keep with next: Enter the number of lines of the next paragraph that the last 
line of a paragraph should be kept with. Always use this option together with 
Prevent widowed last lines to avoid creating widows.



92 Basic text

Bullets and Numbering
The Bullets and Numbering section of the Paragraph panel allows you to create 
and set the formatting of bulleted and numbered lists. Publisher allows you to 
create multi-level (hierarchical) lists as well as those spanning an entire 
document.

Each item in a list must be a separate paragraph; entering a line break will not 
create a new item in the list.

To create a bulleted or numbered list:

1. Position the text cursor in a paragraph or select a range of paragraphs.

2. Select the Bulleted List  or Numbered List  icons in the Context Tool-
bar or choose Text > List > Bullet or Number.

3. Set the list formatting options as described below.

4. To add another item to the list, position the text cursor at the end of a list 
paragraph and press Return.

5. To end the list, press Return to start a new paragraph and set List Type to No 
List.

To change a bulleted or numbered list to regular paragraphs:

1. To remove the bullets or numbers entirely, select the paragraph(s) and dese-
lect the Bulleted List  or Numbered List  icon in the Context Toolbar.

You can also deselect the Text > List > Bullet or Number command or set 
Type to No List in the Bullets and Numbering section of the Paragraph
panel.

2. To convert the bullets or numbers from a list to editable text, select the para-
graph(s) and choose Text > Expand > Expand List. The visual appearance of 
the paragraphs will be unchanged but you will now be able to format or delete 
the bullets and numbers.

To create a multi-level (hierarchical) list:

1. Create a bulleted or numbered list.

2. Position the text cursor at the start of a list paragraph that should be a child of 
the item before it, or select a range of paragraphs.

3. Press Tab to increase the list level or press Shift + Tab to decrease the list level. 
This will change the List Level and Left Indent values without entering a tab 
character.

4. To include the parent’s number in the list number (for example, 1.1, 1.2…), 
insert the parent’s level number  into the Text field by clicking the caret
icon at its left and selecting from the popup menu. For example, the Text field 
should contain the following for these number formats:

Tip: It is recom-
mended to use 
paragraph styles to 
format bulleted and 
numbered lists to 
ensure consistent 
formatting

Tip: Bullets and 
Numbers are not plain 
text so their characters 
cannot be found with 
Find and Replace and 
are not counted by 
Word Count
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Format Text value Notes

7.1, 7.2, 7.3…  .   refers to the parent level

7.2.1, 7.2.2, 7.2.3… . .   refers to the first parent level and 
   refers to the second parent level

7a, 7b, 7c…  This is the same as the first level but with a
   different number format and without the
   decimal

To format list markers (bullets and numbers):

If you apply character formatting to the first character in a bulleted or numbered 
paragraph, the formatting will also be applied to the list marker, the bullet or 
number.

1. Create a character style for the list marker that specifically defines the 
attribute you do not want changed by the following paragraph text’s format-
ting. For example, if you apply Bold to the following text, define this style as 
Regular.

2. Select the list paragraphs and select the character style from the Character 
Style option in the Bullets and Numbering section of the Paragraph panel.

To create a named list for global numbering:

In addition to creating a list of consecutively numbered paragraphs, you can 
name a list and add new items to it anywhere in your document or Book. Named 
lists are especially useful for naming figures and illustrations.

If you add paragraphs to the same list in multiple text frames on the same page, 
they could be numbered incorrectly depending on the position of the text frames 
in the layer stack. The text frame that should be numbered before another should 
be lower in the layer stack than the other frame.

1. Select a numbering style from the Type field.

2. Enter the text to define the list marker in the Text field. You can include 
Figure or a similar word as a prefix.

Format Text value

Figure 1: some text…  Figure : 

3. Set Tab Stop to 0 if the list marker (Text) includes or will be followed by a 
space and set Marker Alignment to Left.

4. Set Start numbering at to 1.

5. Select Restart numbering to Manual Only.

6. Enter a unique list Name and select Global.

7. Optional: Select a character style to apply to the list marker (Text).

Tip: An alternative to 
using a character style 
to avoid the format-
ting of the first charac-
ter changing the list 
marker is to insert a 
Zero-Width Space 
between the marker 
and first character



94 Basic text

8. Optional: To right-align the numbers, set Marker Alignment to Right. Using 
the Spacing section of the panel, set First Line Indent to greater than zero.

9. Create a paragraph style for this list. For all subsequent items in this noncon-
secutive list, you must set every item in the Bullets and Numbering panel 
exactly for the list to continue and be formatted consistently so it is easier to 
do this using a paragraph style. Refer to Creating text styles on page 121 for 
more information.

Using the Bullets and Numbering panel:

• List type: Select Bullet for a bulleted list or select one of the number formats 
for a numbered list to change a regular paragraph to a list. Select No List to 
change a list paragraph back to a regular paragraph.

It is recommended to use this setting only when editing paragraph styles and 
formatting lists and to instead select the Bulleted List  or Numbered List

 icons in the Context Toolbar or choose Text > List > Bullet or Number. 
These options don’t provide the means to select the bullet character or 
number format but they will automatically indent the list paragraph, saving 
you from having to manually format a standard list.

• List level: Set the list level to a value between 1 and 9 for a multi-level (hierar-
chical) list or choose Text > List > Increase Level or Decrease Level or their 
keyboard shortcuts:

Command Shortcut

Increase Level Ctrl + Shift + ] (Alt + Shift + ])

Decrease Level Ctrl + Shift + [ (Alt + Shift + [)

Changing this number will not automatically change the list paragraph’s left 
indent. It is recommended to use this setting only when editing paragraph 

Tip: If you don’t need 
these shortcuts, 
remove them to avoid 
accidentally changing 
leading; refer to 
Keyboard shortcuts on 
page 246

Tip: If a paragraph was 
previously formatted 
as a list, using the 
menu commands or 
Context Toolbar icons 
will restore its prior 
format

Tip: Test with the 
largest number to 
determine the appro-
priate First Line 
Indent value

List type

List marker

Marker tab stop

Start numbering at

List name

List character style

List level

Bullet glyph browser

Marker alignment

Restart numbering where

Restart numbering now (override)

Global list
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styles and to instead position the text cursor at the start of a paragraph or 
select the paragraphs and press Tab or Shift + Tab to change the Left Indent
value at the same as the list level is changed.

• Text (list marker): Enter the text to define the list marker:

Bulleted list: Enter a bullet character followed by a tab . Click the caret 
icon at the left of the field to select from a list of common bullet characters or 
click the more  icon to select a bullet from the Glyph Browser. A bulleted 
list will normally have the same bullet character(s) for each list paragraph but 
it is possible to use a different bullet for each item.

Numbered list: Click the caret  icon at the left of the field to select from a 
list of options including list number levels. The default value of the current 
number level  followed by a tab  is suitable for basic lists. To format a 
number such as 1.2.3, use the parent number levels for the first two levels 
separated by periods, for example, . .

• Tab stop: Enter the amount of space from the list marker (text) to the start of 
the paragraph text because lists don’t use the default or set tab stops but have 
their own tab stop value. Choose a value that is wide enough to fit the largest 
number and the white space before the paragraph text.

• Marker alignment: Select the alignment of the bullet or number Text
(marker). This is normally used only with numbered lists so that the numbers 
can be right aligned, but it can also be used with bulleted lists that have 
glyphs of varying widths.

• Start numbering at: To start numbering at a value other than 1, enter a 
different starting number.

• Restart numbering: Set when numbered should be restarted.

• Any Non List (default): Select to restart numbering after any paragraph 
that isn’t numbered and at the next paragraph with a higher List Level.

• Manual Only: Select to allow numbering to continue throughout a story 
even if there are intervening paragraphs that aren’t numbered.

Example of a multi-level numbered list with Marker 
Alignment set to Left

• for level 1, Tab Stop and Left Indent are set to 2p (24 
pt) and First Line Indent is set to 0

• For level 2, Tab Stop is set to 4p (48 pt) and Left 
Indent and First Line Indent are set to 2p (24 pt)

Tip: Test with the 
largest number to 
determine the appro-
priate First Line 
Indent value

Tip: Refer to Glyph 
Browser on page 55

Tip: First Line Indent
must be set to greater 
than zero with centre- 
and right-aligned 
markers

To right align the numbers, 
set Marker Alignment to 
Right and First Line Indent to 
a value that is greater than 
zero, less than Left Indent
and Tab Stop, but wide 
enough to fit the numbers

Tip: When using Tab
to indent selected 
paragraphs, you must 
start the selected text 
range at the begin-
ning of a paragraph or 
a tab character will be 
entered, deleting the 
selected text
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• Below Current Level: Select to allow numbering to continue throughout a 
story as with Manual Only but to restart numbering at the next paragraph 
with a higher List Level.

• Below Level #: Same as above but below a specified level number. This 
option is available only when there is already at least a second level.

• Restart numbering now: Select to restart numbering at 1 with the current list 
paragraph and override the Restart numbering setting.

• Name and Global: Enter a name for a list to be continued throughout multi-
ple stories in a document or in a Book’s chapters. For each list in each story, 
set Restart numbering to Manual Only, enter a list name, and select Global. 
The names you enter must exactly match for list numbering to be continued.

• Style: Select a character style to apply to the list marker (Text). Use this option 
if you want the bullets to be a different colour than the text or the numbers to 
be bold.

Baseline Grid
The Baseline Grid section of the Paragraph panel allows you to override the 
baseline grid for a paragraph. Refer to Baseline grid on page 31 for information 
on using a baseline grid.

• Align to Baseline Grid: Select to ignore the baseline grid(s) of the document 
or text frame, allowing the paragraph to be positioned according to the text 
formatting.

Align to Baseline Grid 
(override)
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Hyphenation
The Hyphenation section of the Paragraph panel allows you to enable automatic 
hyphenation and configure how it functions.

Using hyphenation with the default settings, especially in narrow columns, can 
lead to hyphenation issues.

Customizing the default settings will correct most issues but the ideal settings 
depend on the font, column width, language, and content type. Words containing 
a soft hyphen (discretionary hyphen) will never be hyphenated at any other 
position. You can prevent a word such as a name from being hyphenated by 
inserting a soft hyphen before the word; it will never be visible.

• Use auto-hyphenation: Select to enable hyphenation or deselect to disable it. 
It is recommended that hyphenation be disabled for heading styles.

• Minimum score (not recommended): Enter a whole number between 0 
(default) and 10 to control how aggressively text is hyphenated. Publisher will 
hyphenate at any point with a score of 0 but only at the most preferable points 
with a score of 10. In practice, scores higher than 5 will lead to no hyphen-
ation. Scores of 0 or 1 are recommended for strong hyphenation or 2 or 3 for 
less hyphenation.

Tip: Choose Text > 
Insert > Dashes and 
Hyphens > Soft 
Hyphen to insert a 
soft hyphen

Enable hyphenation

Minimum score (0 to 10, whole numbers)
Minimum word length (shortest word to hyphenate)
Minimum prefix (characters before hyphen)
Minimum suffix (characters after hyphen)
Maximum consecutive hyphens
Hyphenation zone
Capital zone
Paragraph end zone
Column end zone

2-character prefix

4 consecutive hyphens

Example of hyphenation 
issues using default settings

Setting Max Consecutive Hyphens, Minimum 
Prefix, and Maximum Prefix to 3 corrects the issues 
except for the hyphenated name which can be 
fixed by inserting a soft hyphen before the name

Hyphenated name Hyphenated name
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• Minimum word length: Enter the minimum number of characters a word 
must have for it to be hyphenated. The default value of 5 is recommended for 
English text.

• Minimum prefix and suffix: Enter the minimum number of characters before 
the first hyphen in a word and after its last hyphen. For example, changing 
these options from their default of 2 to 3 would cause automatic to be 
hyphenated only as auto-matic instead of as au-tomatic in addition to 
auto-matic. It is recommended changing these options to 3 for English text.

• Max consecutive hyphens: Enter the maximum number of consecutive 
hyphens that should be allowed. The default of 0 will allow unlimited consec-
utive hyphens. Values of 2 or 3 are recommended.

• Hyphenation zone: Enter the amount of space from the right edge allowed at 
the end of a line before hyphenating the next word. The default of 0 will allow 
any hyphenation while increasing the value will result in less hyphenation. 
Commonly-used values are 2–3p, 24–36 pt, 0.3–0.5 in, or 8–12 mm.

• Capital zone: Enter the hyphenation zone for words in all uppercase. Set a 
value larger than the width of most uppercase words to prevent them from 
being hyphenated.

• Paragraph end zone: Enter the hyphenation zone for the end of the para-
graph. It is a best practice to avoid hyphenating the last word so set this value 
larger than Hyphenation Zone. A commonly-used approach is to set this 
value to 150% of Hyphenation Zone.

• Column end zone: Enter the hyphenation zone for the end of a column. It is 
recommended to avoid hyphenating the last word in a column so set this 
value larger than Hyphenation Zone and to at least the value of Paragraph 
End Zone. Set this value to a very large value to prevent the last word in a 
column from ever being hyphenated.

Tip: Publisher does 
not offer an option to 
prevent capitalized 
words, including 
proper names, from 
being hyphenated; it is 
recommended that 
you review your text 
and address issues by 
inserting a soft 
hyphen before a 
hyphenated name to 
disable automatic 
hyphenation; you can 
also format it with No 
Break
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Drop Caps
The Drop Caps section of the Paragraph panel allows you to scale and position 
the first character or characters of a paragraph so they occupy the space of multi-
ple lines of text. Drop caps are commonly used in books at the start of a chapter.

To create a basic drop cap:

1. Position the text cursor in a paragraph or select a paragraph.

2. Select Enabled in the Drop Caps section of the Paragraph panel.

3. Increase the Distance to text value to add white space to the right of the drop 
cap character to avoid a drop cap with a vertical right stroke encroaching on 
the neighbouring characters.

4. Select Align left edge so that the enlarged drop cap character is better aligned 
with the text below it.

5. To create a drop cap of more than one character, deselect Auto and enter the 
number of characters.

• Enabled: Select to create a drop cap at the start of the paragraph or deselect to 
remove the drop cap.

• Height in lines: Enter the height of the drop cap in lines of text. You may 
enter values of 1 to 20 and the default is 3. A value of 1 will appear as normal 
text.

• Characters: When Auto is deselected, enter the number of characters that 
should be formatted as a drop cap. You can enter any number of characters 
but this is normally limited to the first word.

• Auto: Select to convert the first alphanumeric character and any preceding 
punctuation to a drop cap. Deselect to specify the number of characters to 
include in the drop cap.

Enable drop caps

Gap between

Drop cap character style

Drop cap height
Number of characters to format as a drop cap

Align drop cap to frame
Scale if descender present

Example of a 3-line drop cap Example of a 5-character wide drop cap
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The Auto setting is better than specifying one character manually because if 
the first letter is preceded by a quotation mark, they will be converted 
together into a drop cap together. To hang the quotation mark outside the left 
edge of the text frame, select the quotation mark and set Type to Font in the 
Optical Alignment section of the Character panel.

• Distance to text: Enter a value to add white space to the right of the drop cap 
character to avoid a drop cap with a vertical right stroke encroaching on the 
neighbouring characters.

• Align left edge: Select so that the enlarged drop cap character is better 
aligned with the text below it.

• Scale for descenders: Select if you are converting a lowercase letter with a 
descender to a drop cap to avoid the descender overlapping the text below. 
Publisher will automatically scale the drop cap so that the entire glyph is 
inside the specified number of lines.

• Style: Select a character style to apply to the drop cap. Use this option to 
change the font or colour for the drop cap rather than directly applying 
formatting attributes.

Example of a drop cap using Auto Example of a drop cap using Auto with 
Optical Alignment enabled
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Initial Words
The Initial Words section of the Paragraph panel allows you to apply different 
formatting to the first few words of a paragraph. This option is used with some 
books that apply formatting such as uppercase letters to the first few words but it 
can also be used to apply formatting such as bold to the text in a bulleted list 
until a punctuation character is encountered.

• Enabled: Select to format the first words with different formatting at the start 
of a paragraph or deselect to remove the Initial Words. There is no default 
formatting for initial words so this setting will have no apparent impact until 
you select a Style.

• Max word count: Enter the number of words to format as Initial Words.

• End characters: To end the Initial Words formatting before the Max Word 
Count limit is reached, enter one or more characters at which to automati-
cally end the formatting. The most common end characters are included in 
the field by default but you can enter any character. Click the caret  icon at 
the left of the field to select from a list of common special characters.

• Style: Select a character style to apply to the initial words.

Example of initial words using 
default settings with a bold 
character style

Example of initial words using 
default settings with a bold 
character style and Optical 
Alignment enabled

Enable initial words

Number of words to format as Initial Words

End characters for early termination

Initial words character style
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Decorations (background and borders)
The Decorations section of the Paragraph panel allows you to set the stroke and 
background fill for paragraphs. Strokes on all four sides can be combined to 
create a box around a paragraph while strokes on the top and bottom can be used 
for rules above or below a paragraph.

The background fill for a paragraph extends to its left and right edges and fills the 
space between lines of text while the similar Background Colour option in the 
Character panel only fills behind the individual characters.

A decoration is made up of one or more stroked sides and the background fill. 
You can create multiple decorations for a paragraph which will be automatically 
named Decoration 1, 2, 3… Strokes will be applied in numerical order so if you 
set Decoration 1 to have a 10 pt black stroke and Decoration 2 to have a blue fill, 
the blue fill of Decoration 2 will obscure the inner half of Decoration 1’s stroke.

• Selected decoration: When using more than one decoration, select the deco-
ration to edit or delete.

• Add/Delete decoration: Click Add  to create an additional decoration or 
Delete  to delete the selected decoration. New decorations will be created 
with the same settings as the selected decoration.

• Stroke side and fill: Select the left , top , right , or bottom  side(s) to 
which to add a stroke (border or rule) or fill .

• Indent from: Enter a positive value to indent the stroke and fill or a negative 
value to outdent the stroke and fill.

Tip: There is no limit 
on the number of 
decorations you can 
add

Use paragraph decorations 
to create callouts

Example using a background 
fill and left stroke

Tip: Publisher does 
not offer separate Rule 
Above/Below and 
Border features but 
instead offers the 
more flexible Decora-
tions feature that 
allows you to create 
any combination of 
rules and borders

This text has a 
character 
background

This text has a 
paragraph 
background

Example of character 
background colour

Example of paragraph 
background colour

Tip: To add a fill 
behind the entire text 
frame instead of just 
the paragraph or 
characters, use the 
Text Frame panel

Selected decoration

Stroke side and Fill

Indent from

Add/Delete decoration

Indent relative to

Stroke colour Stroke

Fill colour Transparency
Combine identical decorations
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• Indent relative to: Select how the stroke and fill are aligned. The left and right 
sides can be aligned to:

• Column: Select to align to the left or right edge of the column.

• Indents: Select to align to the Left Indent and Right Indent values speci-
fied in the Spacing section of the panel.

• Text (default): Select to align to the left or right edge of the longest line of 
text in the paragraph. For text that is left-aligned, setting the left side to 
Text will have the same result as selecting Column while setting the right 
side to Text will usually result in a stroke and fill that are inset from the 
column’s edge.

The top and bottom sides can be aligned to:

• Ascent: Select to align to the highest ascent of all the characters on the first 
(top) or last (bottom) line of text. This option is not recommended for 
bottom because the stroke and fill would be above the line of text.

• Baseline: Select to align to the baseline of the first (top) or last (bottom) 
line of text. This option is not recommended for Top because the stroke 
and fill would be below the line of text, overlapping only the descenders.

• Cap Height (default for Top): Select to align to the highest cap height of 
any character on the first (top) or last (bottom) line of text. This option is 
not recommended for bottom because the stroke and fill would be above 
the line of text.

• Descent (default for Bottom): Select to align to the lowest descent of all 
the characters on the first (top) or last (bottom) line of text. This option is 
not recommended for top because the stroke and fill would be below the 
line of text.

• X Height (not recommended): Select to align to the largest x height of any 
character on the first (top) or last (bottom) line of text.

• Stroke: Click the colour sample to set the colour of the border stroke and 
click the stroke control on its right to set its thickness, dash pattern, and other 
properties.

• Fill colour: Click the colour sample to set the colour of the fill.

• Transparency: Click to set the transparency of the stroke and fill.

• Combine identical decorations: Click to combine overlapping decorations 
from multiple paragraphs. The horizontal strokes will be removed and the fill 
extended to include the space between the paragraph.

Two paragraphs
of text

Two paragraphs
of text

Two paragraphs
of text

Two paragraphs
of text

Combine identical off Combine identical on
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Setting default text formatting
Publisher has default values for all character and paragraph formatting. You can 
customize the defaults by setting all of the formatting settings to the state you 
would like them to be and then saving that group of settings as the new defaults. 
You can also revert to Publisher’s original defaults at any time.

In addition to the default formatting used for new documents, Publisher also has 
session defaults, the formatting that is currently in use. For example, Publisher’s 
factory default formatting is Arial 12 pt and if you choose Garamond 14 pt that 
will be the current session default. Setting the default formatting saves the cur-
rent session defaults.

Setting the default formatting will save character, paragraph, and the default text 
styles but it will not save the text style definitions. If you set the defaults while a 
paragraph or character style is in use, the text style name will be saved in your 
defaults, but for that to be effective you would also need to save that text style as a 
default style for new documents. Refer to Importing and setting default text 
styles on page 126.

To set the default formatting based on formatted text:

1. Using the Frame Text , Artistic Text , or Table  tool, position the text 
cursor in the text whose formatting you want to set as the default formatting.

2. Choose Edit > Defaults > Synchronize from Selection to set Publisher’s 
session defaults to match the text’s formatting.

3. Choose Edit > Defaults > Save to save the session defaults as Publisher’s new 
defaults.

To change only specific attribute(s) in the current default formatting:

1. Create a temporary new document; its settings are unimportant because it 
will be deleted when you’re done.

2. Choose the Frame Text , Artistic Text , or Table  tool.

3. Set the attributes you wish to change.

4. Choose Edit > Defaults > Save.

To revert to the factory default formatting:

1. Choose Edit > Defaults > Factory Reset.

2. Choose Edit > Defaults > Save.
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Default font
If you enter text in Chinese, Japanese, or Korean you should change the default 
font from Arial to avoid missing characters. You can use any font you want but 
the default fonts included with macOS and Windows are listed below. Follow the 
instructions above for changing the default text formatting.

Language macOS font Windows font

Simplified Chinese PingFang SC Microsoft YaHei UI

Traditional Chinese (Taiwan) PingFang TC Microsoft JhengHei UI

Traditional Chinese (Hong Kong and Macau) PingFang HK Microsoft JhengHei UI

Japanese Hiragino Sans (sans serif) Yu Gothic UI
 Hiragino Mincho (serif)

Korean Apple SD Gothic Neo Malgun Gothic
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Text wrap
Publisher will flow text in text frames without regard to an overlapping object 
unless you specify that text should be wrapped around it. The text wrap feature 
creates an editable and invisible outline around which the text will wrap.

To wrap text around an object:

1. Select one or more objects to modify.

2. Click the Show Text Wrap Settings icon  in the Toolbar or choose Text > 
Text Wrap > Show Text Wrap Settings to open the Text Wrap window.

3. Select a Wrap Style:

Wrap Style Description

None (default) Text will not wrap around the object

Jump Text will flow above and below the object

Square Text will flow on all four sides of the object’s bounding box

Tight Text will flow around the object’s invisible wrap outline; the
 outline will match the object’s shape unless you change it

Inside Text will flow inside the object’s invisible wrap outline, as well as
 above and below the object

Edge Text will flow on both sides of the object’s invisible wrap outline,
 as well as above and below the object

Tip: Unlike most 
applications, text wrap 
in Publisher also 
applies to text frames 
above the wrapped 
object; you must set 
Ignore Text Wraps for 
a text frame above a 
wrapped object to 
avoid the object 
impacting the frame

Tip: Text in art text and 
path text objects is not 
affected by text wrap

Tip: To ensure a 
wrapped object 
moves with the 
relevant text, pin the 
object and choose 
Float With Text
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4. For Square and Tight, select where to Wrap To:

Wrap To Description

Both Sides (default) Text will wrap on both the left and right sides

Largest Side Text will wrap only on the wider side; if the object is
 positioned in the centre of the text frame, text will wrap on
 the left side

5. Set the Distance from Text offsets to adjust the space between the object and 
text.

To customize the wrap outline to wrap text around the subject of an image:

When you select the Tight, Inside, or Edge wrap styles, Publisher flows text 
around the object’s invisible wrap outline rather than its bounding box. For a 
non-rectangular shape, the wrap outline will match the shape’s path until you 
change it. Paths and shapes converted to paths

1. Select the object to modify.

2. Click the Edit Wrap Outline icon  in the Toolbar or choose Text > Text 
Wrap > Edit Wrap Outline. Publisher will display node handles along the 
object’s path which you can drag and modify like any other path to change 
the shape of the wrap outline.

3. Deselect the object to end editing of the wrap outline.

To reset the wrap outline to the object’s shape or path:

1. Select the object to modify.

2. Click the Reset Wrap Outline icon  in the Toolbar or choose Text > Text 
Wrap > Reset Wrap Outline. Publisher will restore the original wrap outline.

To ignore text wrap for a text frame:

1. Select a text frame or position the text cursor in a frame.

2. Choose Text > Text Wraps > Ignore Text Wraps or select Ignore Text Wraps
in the General section of the Text Frame panel. Objects with text wrap 
applied will no longer impact text in the selected text frame.

Text wrap set to Tight Editing the wrap outline

Tip: Ignore Text Wraps
applies to the text 
frame and not to a 
selected range of text

Tip: Publisher does 
not offer options to 
wrap toward or away 
from the document’s 
spine

Tip: To ensure a 
wrapped object 
moves with the 
relevant text, pin the 
object and choose 
Float With Text

Tip: Publisher does 
not include a feature 
to set the wrap outline 
to match the subject 
of a photograph—you 
must manually trace 
the subject by editing 
the wrap outline
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Pinning (anchoring) objects
You can pin an object to a position in text to enable the object to move with the 
text to which it is pinned as you continue to edit the text.

Publisher allows you to pin objects to text so they float relative to a position in 
the text or to position objects inline so that they are treated similar to a character. 
The examples below are a group a images and text frames grouped together and 
pinned inline.

Pinned objects can be scaled, rotated, and deleted like any other object but 
moving them may be limited by the options you select in the Pinning panel.

To pin an object or change its pinning type:

1. Select the object. If there are multiple text objects on the page, move it near to 
where it should be pinned.

2. Do one of the following:

• Click the Float With Text  icon or the Inline In Text  icon in the 
Toolbar

• Click the Float With Text or Inline In Text buttons in the Pinning panel.

• Choose Layer > Float With Text or Inline In Text.

3. The object will be pinned to text in the nearest text object. A blue pin  icon 
will indicate where the object is pinned.

Tip: Pinning is referred 
to as anchoring in 
some applications

Tip: All of the images 
in this manual are 
pinned inline, includ-
ing both the icons 
placed between words 
and the larger illustra-
tions between 
paragraphs

Float With Text: Example of a columnar 
object with Text Wrap set to Tight

Float With Text: Example of an extra-
columnar object

Inline In Text: Example of a columnar 
object in a paragraph by itself; the 
multiple objects were first grouped 
together

Inline In Text: Example of a columnar 
object positioned between two 
characters; the tool icons in this manual 
are created in this manner

Definition: Extra-
columnar object refers 
to objects outside of 
the column
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4. Drag the pin icon to the position in the text where you want to anchor the 
object. The object will remain in the same position but the horizontal and 
vertical offset values in the Pinning panel will change.

5. If necessary, set the pinning options with the Pinning panel. If the panel is 
not visible, choose Window > Text > Pinning.

To import an image and pin it inline:

1. Position the text cursor in text.

2. Choose File > Place… and select an image to import. Publisher will position 
it inline.

3. If necessary, set the pinning options with the Pinning panel. If the panel is 
not visible, choose Window > Text > Pinning.

To unpin a pinned object:

1. Select the object and do one of the following:

• Deselect the Float With Text  icon or the Inline In Text  icon in the 
Toolbar

• Click the Unpin button in the Pinning panel.

• Choose Layer > Float With Text or Inline In Text to deselect it.

To view pin icons:

Blue pin  icons will indicate where objects are pinned. The pins are always 
visible when a pinned object is selected but hidden when special characters are 
not shown.

1. Choose Text > Show Special Characters to display pins for all pinned objects.
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Using the Pinning panel
To display the Pinning panel:

1. Choose Window > Text > Pinning to display the Pinning panel.

2. Set the pinning options:

• Float With Text: Click to pin the object relative to a position in the text. 
This option is used for extra-columnar objects often placed outside of the 
text frame. It can also be used for objects inside the text frame if text wrap 
is enabled.

• Inline in Text: Click to position objects inline so that they are treated 
similar to a character.

• Unpin: Click to disconnect the object from the text.

• Horizontal align, Of, and Offset: Select how the object should be posi-
tioned horizontally. To float an object in a consistent horizontal position 
outside of a text frame, set Of relative to the Column, Frame, Page Margin, 
or Page Edge.

• Horizontal Align: Outside Left, Inside Left (default), Inside Centre, 
Inside Right, or Outside Right. If Mirror Facing Pages is selected, this 
option will alternate between left and right as the pin is moved 
between facing pages.

• Of (what): Character (default, not recommended), Text (Indented), 
Column, Frame (recommended), Page Margin, or Page Edge.

Tip: Changing the 
Horizontal Align and 
Of options will change 
the Offset to maintain 
the object’s current 
horizontal position

Tip: This tip could 
have been created as a 
floated object but was 
actually created using 
the Sidenotes feature 
for better automatic 
positioning

Float With Text Inline In Text

Unpin
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• Offset: Enter the amount the object should be offset horizontally from 
the selected page element.

• Keep within bounds: Select to prevent the floated object from being 
shifted to the left or right of the text column.

• Vertical align, Of, and Offset: Select how the object should be positioned 
horizontally. To float an object outside of a text frame without it appearing 
above or below the column, select Keep within bounds.

• Vertical Align: Outside Above, Inside Top (default), Inside Centre, Inside 
Bottom, or Outside Below.

• Of (what): Line (default, recommended), Frame, Page Margin, or Page 
Edge.

• Offset: Enter the amount the object should be offset vertically from the 
selected page element.

• Keep within bounds: Select to prevent the floated object from being 
shifted above or below the text column.

• Mirror Facing Pages: Select to automatically alternate Horizontal Align 
between left and right as the pin is moved between facing pages.

• Preserve Manual Position: Select to allow the object to be moved manu-
ally within the limits imposed by the other options. Deselect to prevent 
the object from being moved manually.

• On Overlap: Select what to do if two or more floated objects would over-
lap at their optimal positions. This option must be set for all of the floated 
objects to be of any use.

• Do Nothing (default): Select to allow objects to overlap.

• Pack Horizontally: Select to adjust the object’s horizontal position so 
that more than one object can be positioned at the same vertical posi-
tion. This option is not recommended for large objects because they 
may overlap the adjacent text even if positioned in the page margin.

• Stack Vertically: Select to adjust the object’s vertical position so that 
the objects are spaced vertically, even if they’re not directly aligned to 
the pin position.

• Horizontal/Vertical Gap: Enter the gap between objects when On Over-
lap is set to Pack Horizontally or Stack Vertically.

• Scale to: Select to scale the inline object to match the adjacent text. Select 
No Scale (default) to set the size manually, Point Size to match the font 
size, or Ascent, Cap Height, or X-Height to match these font measurements.

Tip: Changing the 
Vertical Align and Of
options will change 
the Offset to maintain 
the object’s current 
vertical position
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• Scale: When Scale To is set to an option other than No Scale, set how 
much the image should be scaled relative to the selected option. For 
example, if Point Size is selected for 24 pt text then setting Scale to 50% 
would cause the inline object to be scaled to 12 pt tall.

• Base position: Select to align the bottom of the object with the text’s 
Baseline (default) or Descender.

• Offset: Enter the offset of the object from the Base Position.

• Preserve manual scale: Select to allow the object to be scaled manually. 
Scaling an object manually will adjust the Scale value.

• Borders: Enter the gap between the object and adjacent text. Enter nega-
tive values to allow adjacent text to overlap the object.

112 Basic text
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Text styles, also known as character and paragraph styles or style 
sheets, are essential for creating a consistently-formatted docu-
ment. You can use text styles in documents of any length but 
they are critical for long publications such as books, magazines, 
and newspapers.

In this chapter
Using text styles ..........................................................................................114
Applying text styles ...................................................................................118
Creating text styles ....................................................................................121
Changing text styles ..................................................................................125
Importing and setting default text styles ..........................................126

Text styles 3
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Using text styles
A text style is a collection of paragraph and character attributes that you can 
apply to text without having to apply the attributes individually to save time and 
ensure consistent formatting.

Publisher offers paragraph and character text styles which are applied to para-
graphs and characters. A paragraph style is a collection of any paragraph and 
character attributes while a character style is limited to character attributes. 
Applying a paragraph style to one or more characters will apply it to the entire 
paragraph while applying a character style will apply it only to the selected 
characters.

You can apply only a single paragraph style to a paragraph and a single character 
style to a range of text. For example, you can’t apply both Heading 1 and Bullet 1
to the same paragraph—if you want Heading 1 to have a bullet you would need to 
edit the style or create a version of it with that formatting. Likewise, you can’t 
apply both the Emphasis and Highlight character styles to the same text.

You can override a paragraph or character style with individual formatting 
attributes. This capability should be used sparingly because if you were to over-
ride the Body style with Bold and then later decided that Semibold was more 
appropriate, you’d have to change all instances of Bold manually. With a character 
style, you could change the style’s definition to update all instances automatically. 
Individual attributes are best reserved for text that already has a character style 
applied or for rare exceptions.

Most users define a paragraph style for each type of paragraph, such as Heading
1, Heading 2, and Body, and apply a style to every paragraph in the main text. 
Most text will not have a character style applied because they are used to modify 
the formatting of selected words and phrases in a paragraph, such as Emphasis to 
make text stand out or Hyperlink to indicate that the text is a clickable link.

Text style and formatting precedence:
If you apply conflicting formatting to the same text, Publisher uses a hierarchy to 
determine which formatting to display. For example, if you defined a paragraph 
style as Helvetica, a character style as Garamond, and then formatted the text as 
Caslon, Publisher would display the text as Caslon regardless of the order you 
applied the paragraph style, character style, and font family.

Formatting precedence (from top to bottom)

Character attributes (style overrides)

Character style

Paragraph attributes (style overrides)

Paragraph style

Application defaults

Tip: Don’t confuse text 
styles with object styles, 
which Publisher refers 
to simply as styles

Tip: Publisher allows 
you to apply para-
graph styles to charac-
ters with the Show in 
both panels option 
but this is not recom-
mended for beginners

Tip: Publisher allows 
you to apply only a 
single character style 
to a range of text

Tip: Publisher does 
not offer GREP styles 
or nested styles
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Text style example

How text styles affect formatting
Text formatting is a combination of the default text attributes, the paragraph 
style, the character style, and any paragraph or character attributes applied to 
override the styles.

Text styles can be based on another text style and attributes defined in the parent 
style will be inherited by the child style. For example, it is common to base 
Heading 2 on Heading 1. Publisher also offers style groups which aren’t applied 
directly to text but which can be used as the base for other styles and to group 
styles in the Text Styles panel. For example, all of Publisher’s default paragraph 
styles are based on the Base style group.

If you do not define an attribute such as font family or size for a text style that is 
based on another style or style group, it will inherit the parent’s attribute. If you 
do not define an attribute for a text style that is not based on another style or 
style group, applying the text style will not change those attributes. For example:

 Based on Font family Weight Size/Leading Colour

Default attributes n/a Arial – 12/Default Black

“Base” style group [No Style] Garamond – 10/12 –

“Heading 1” Base Myriad Pro Bold 24/28 –

“Heading 2” Heading 1 – – 12/14 –

If you applied Heading 2 to text formatted as Arial 12/Default Green, it would 
become Myriad Pro Bold 12/14 Blue—the Myriad Pro Bold and Blue attributes 
would be inherited from Heading 1 while 12/14 were defined in Heading 2.

If it had not been defined as Blue, applying Heading 2 to the green text would not 
change the colour was not defined in Base, Heading 1, or Heading 2 and you had 
already overridden the default text attributes with Green. However, if Base had 
been defined as Black and Heading 1 did not define the colour, applying Heading 
2 would have made the green text black because Heading 1 and Heading 2 would 
have inherited it from Base.

Lorem ipsum
Dolor sit amet, consectetur adipiscing elit, sed 
do eiusmod tempor.

Incididunt ut labore et ½ aliqua.

Body paragraph style

Body paragraph style +
Strong Emphasis character style + 
a character attribute (Fractions)

Body paragraph style +
Strong Emphasis character style

Heading 1 paragraph style

Tip: 12/Default means 
12 pt type on Default 
leading while 10/12
means 10 pt type on 
12 pt leading
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Using the Text Styles panel
The formatting applied to text is expressed as paragraph style + character style + 
individual attributes. For example, Body + Strong Emphasis + Font size: 24 pt. The 
Text Styles panel shows 

To display the Text Styles panel:

1. Choose Window > Text > Text Styles to display the Text Styles panel.

2. Click the caret  icon to the left of the Current Formatting field to view 
overflowing information. This field lists the formatting in use at the text 
cursor position or for the first character in a selected range of text. The pre-
sentation format is Paragraph Style + Character Style + individual formatting 
attributes.

3. Choose Show Hierarchical from the panel menu  to toggle between listing 
text styles as children of the styles or groups on which they are based (default) 
and showing styles as a flat list (recommended). Hierarchical makes it easy to 
see at a glance how your styles are structured while a flat list makes it easier to 
find styles by name.

Create
Paragraph Style

Create
Character Style

Update
Paragraph Style

Create Style Group
Update
Character Style

Style group

Current Formatting

Paragraph style

[No Style]

Character style

Panel menu

Reapply Text Styles

Style options menu

Delete Style
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4. Choose Show Samples from the panel menu  to toggle between listing text 
styles with their formatting (default) and as plain text (recommended). 
Samples makes it easy to find certain styles such as Drop Caps at a glance but 
it gives too much weight to lesser-used such as Initial Words compared to 
Body and Heading 1.

5. Choose Sort by Type from the panel menu  to toggle between listing style 
groups first followed by paragraph and then character styles (default, recom-
mended), and listing all styles and groups in alphabetical order regardless of 
type. Styles are listed alphabetically within the three types when sorted by 
type.

6. Click the Style options menu for a text style to see options specific to that 
style. You can also right-click a style name to see the same options.
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Applying text styles
There is more than one way to apply character styles but the most common way 
is to select a range of text or position the text cursor in text and then select a 
paragraph or character style. This option will clear existing formatting. If you 
want to preserve or control the existing formatting when applying text styles, 
refer to the next section.

To apply a text style:

1. Position the text cursor in text or select a range of text.

2. Select a style by doing one of:

• Click the character or paragraph style name in the Text Styles panel.

• Select the style from the Character Style or Paragraph Style popup menus 
in the Context Toolbar.

• Select the style from the Character Style popup menu in the Character 
panel or Paragraph Style popup menu in the Paragraph panel.

• Choose Apply “Style Name” to Paragraphs from the style options menu 
 to the right of the text style’s name in the panel, but there’s no reason to 

use this more cumbersome method. This option is available only for 
paragraph styles.

• Choose Apply “Style Name” to Characters from the style options menu 
to the right of the text style’s name in the panel. Paragraph styles can be 
applied to selected characters with this option—doing so applies only their 
character attributes.

To apply a text style to and preserve or control existing formatting:

1. Position the text cursor in text or select a range of text.

2. Apply a paragraph style by doing one of:

• Choose Apply “Style Name” to Paragraphs and Clear Character Styles
from the style options menu  to the right of the text style’s name in the 
panel to clear existing character styles from a paragraph but not individual 
character attributes. For example, if you applied Body to a paragraph with 
some text formatted with the Emphasis character style and, this option 
would remove Emphasis from the text.

• Choose Apply “Style Name” to Paragraphs and Preserve Character 
Formatting from the style options menu  to the right of the text style’s 
name in the panel to retain the existing character attributes as overrides. 
For example, if you applied Body to a paragraph formatted as Garamond 
14, those attributes would override the Arial 12 defined for Body.

Tip: Although text 
styles are normally 
applied with a text 
tool, you can apply 
text styles to entire 
text frames selected 
with the Move  tool; 
this can lead to 
unexpected results for 
text in linked frames 
because the styles will 
be applied only to the 
text that was in the 
frame when the style 
was applied, and the 
frame may end up 
containing more or 
less text depending on 
the style’s formatting

Tip: You don’t need to 
select an entire 
paragraph to apply a 
paragraph style; the 
style will be applied 
even to partially 
selected paragraphs
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• Choose Apply “Style Name” to Paragraphs and Preserve Local Format-
ting from the style options menu  to the right of the text style’s name in 
the panel to retain all character and paragraph attributes and character 
styles as overrides. For example, if you applied Body to a paragraph for-
matted as Garamond 14 and with some text formatted with the Emphasis
character style, those attributes and the Emphasis style would override 
Body.

3. Or apply a paragraph or character style by choosing Apply “Style Name” to 
Characters and Preserve Local Formatting from the style options menu  to 
the right of the text style’s name in the panel to retain all character attributes 
and character styles as overrides. For example, if you applied Emphasis to text 
formatted as Garamond 14, those attributes would override Emphasis.

To remove a text style from text:

1. Position the text cursor in text formatted with the style.

2. To remove the style and its formatting, click [No Style] in the Text Styles 
panel. There are two [No Style] options in the panel so be sure to click the one 
with the pilcrow (paragraph)  icon to remove the paragraph style or the 
lowercase a  icon to remove the character style.

3. Or to remove the style and retain its formatting, choose Detach Paragraphs 
from “Style Name” or Detach Characters from “Style Name” from the style 
options menu  to the right of the text style’s name in the panel.

To override a style:

A style override is any attribute you’ve applied to text formatted with a text style. 
If there are overrides applied to the selected text or text cursor position, a plus 
sign will be shown beside the style name in the Current Formatting field in the 
Text Styles panel as well as in the Context Toolbar, Paragraph panel, or Charac-
ter panel.

1. Position the text cursor in text or select a range of text.

2. Apply any character or paragraph formatting attributes.

To clear text style overrides:

1. Position the text cursor in text or select a range of text.

2. Reapply the style by doing one of:

• Click the style name in the Text Styles panel.

• Click the Reapply Text Styles  icon to the right of the Current Format-
ting field at the top of the Text Styles panel or choose Text > Reapply Text 
Styles. These options will reapply the paragraph and character style and 
remove all paragraph and character overrides.

Tip: The plus sign will 
not be shown next to 
the style name in the 
Text Styles panel list
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• Choose Text > Reapply Base Styles. This option will reapply the paragraph 
style but remove character styles in addition to paragraph and character 
overrides.

• Choose Apply “Style Name” to Paragraphs or Apply “Style Name” to 
Characters from the style options menu  to the right of the text style’s 
name in the panel, but there’s no reason to use this more cumbersome 
method.
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Creating text styles
To manually create a new text style:

1. Optional: Position the text cursor in a text frame or other text object. The new 
style will be based on the text style and formatting in use. For example, if you 
place the cursor in text formatted as Body with 14 pt overriding the style, the 
new style will be based on Body and have 14 pt already defined.

2. Choose the type of style to create. You can change the type of style after 
starting but choosing the right type now will pick up the current text style and 
formatting in use.

• Click the Create Paragraph Style  icon or choose Text > Text Styles > 
Create Paragraph Style to create a paragraph style.

• Click the Create Character Style  icon or choose Text > Text Styles > 
Create Character Style to create a paragraph style.

• Click the Create Style Group  icon. There is not a matching menu 
command.

• Or if you want to create a text style based on another style, choose Create 
Style based on “Style Name” from the style options menu  to the right 
of the text style’s name in the panel.
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3.  Style name: Enter a unique name for the text style.

4.  Based on: Select another text style or style group on which to base this style. 
The new style will inherit all of the base style’s attributes. This is especially 
useful if there are only minimal differences between styles, such as a heading 
that is smaller than the heading on which it is based. Select [No Style] if you 
don’t want to base this style on another.

5.  Next style: Select another text style for the paragraph following one formatted 
with this text style. For example, setting Next style to Body for Heading 1
would automatically set Body for the next paragraph when pressing Return in 
a Heading 1 paragraph. Select [Same Style] if you don’t want the text style to 
change when you press Return; you would use this option for body, num-
bered, and bulleted styles

6.  Next level: Select another style for the next lower text style in a hierarchy of 
styles. For example, you would set Next level to Heading 2 for Heading 1, and 
to Heading 3 for Heading 2. This feature allows you to press Tab or Shift + Tab
at the start of a paragraph to switch to the next lower or higher level of the 
style hierarchy. For example, pressing Tab at the start of a Heading 1 paragraph 
would switch automatically to Heading 2 instead of entering a tab character.

7.  Keyboard shortcut: Assign a custom keyboard shortcut for commonly-used 
text styles by clicking in the text field and pressing the shortcut combination 
you want to use. If that shortcut is already in use a warning  icon will 
appear. Mouse over that triangle to find out which shortcut is in conflict.

If you assign a keyboard shortcut to a character style and want to be able to 
turn it off (set it back to [No Style]) turn it off with a shortcut, too, you must 
assign a shortcut to [No Style] because shortcuts can’t be used as toggles.

The keyboard shortcut will be shown in the Text Styles panel as a reminder.

8.  Type: Choose between Paragraph, Character, and Group style types. Regard-
less of which type of style you started to create, you can change this setting to 
create a different type of style. The title of the window will not update to 
reflect the change in the type of text style.

A style group has all of the same options as a paragraph style.

9.  Show in both panels: Select this option if you want to be able to apply the 
character attributes of a paragraph style as a character override to text set in a 
different paragraph style, or to apply a character style as a paragraph style. For 
example, you might choose this option if you wanted to be able to apply the 
font family, weight, and size attributes of Heading 2 to text set as Body.

In the above example both Body and Heading 2 would be listed in the Text 
Styles panel as the selected paragraph style, but Body would be applied to the 
paragraph and Heading 2 to just a range of characters. Look at the Context 
Toolbar or Character and Paragraph panels for clarity.

Shortcut is set to Shift + ⌘ + B

Tip: The both panels
name refers to apply-
ing text styles via the 
Character panel and 
Paragraph panel and 
via the Context 
Toolbar, not via the 
Text Styles panel

Tip: You can’t edit [No 
Style] with the Text 
Styles panel but you 
can assign a keyboard 
shortcut by choosing 
Affinity Publisher 2 > 
Settings… (macOS) or 
Edit > Settings…
(Windows), clicking 
Shortcuts in the left 
pane, choosing Text
from the menu list, 
and then selecting 
Text Styles > Set No 
Character Style

Tip: Consider how the 
text style will be 
sorted alphabetically 
when choosing a 
name; for example, 
numbering heading 
styles as 1, 2, 3 makes 
them easier to find 
than naming them 
Title, Heading, and 
Sub-heading

Tip: Consider how the 
text style will be 
sorted alphabetically 
when choosing a 
name; for example, 
numbering heading 
styles as 1, 2, 3 makes 
them easier to find 
than naming them 
Title, Heading, and 
Sub-heading
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10.  Reset formatting: Click to remove all attributes defined for the text style.

11.  Style settings: This field displays a summary of the text style definition.

12.  Apply style to selection: Select to apply the new text style to the selected text 
or text cursor position when you click OK; deselect it to create the style 
without applying it to the text. This option is not applicable to style groups.

13.  Category: Click each category of character or paragraph attributes in the left 
pane and define the values you wish to include in the text style. The options 
are the same as those in the Character and Paragraph panels.

Character

Font Set the font family, traits (font style) weight, width, and size

Colour & Decorations Set the fill and highlight colours, underline, etc.

Position & Transform Set the kerning, tracking, baseline offset, leading override,
 superscript, etc.

Language Set the spelling and hyphenation language

Optical Alignment Set how punctuation and certain characters are positioned
 relative to the frame edges

Typography Specify ligatures, alternates, variants, figures, and capitals

Paragraph

Spacing Set the alignment, indents, leading, space before, and after

Tab Stops Set tab stops and leaders

Justification Set minimum, desired, and maximum word and letter
 spacing

Bullets & Numbering Set bulleted and numbered list options

Flow Set start, keep together, widow, and orphan options

Baseline Grid Set to override a baseline grid

Hyphenation Set hyphenation rules

Drop Caps Set to create automatic drop caps

Initial Words Set formatting for the first words in a paragraph

Decorations Set paragraph borders and fill

If you don’t want the style to change the existing formatting for an attribute, 
leave the option set to[No change]. If you edit a value and want to restore it to 
[No change], the way you do that depends on the type of control:

• Popup menu: Select [No change] from the list.

Tip: Weight and Width 
will be disabled if you 
select a font style 
because it combines 
the weight, width, and 
slope (italic) traits

Tip: Reset formatting
does not change the 
options in the Style
category (Style name, 
Based on, Next style, 
Next level, Keyboard 
shortcut, Type, and 
Show in both panels)



124 Text styles

• Text field: Delete the value to clear the field and then press Tab.

• Checkbox: Click the checkbox until the mixed-state value appears (a 
horizontal line instead of the usual checked or unchecked appearance).

• Radio button: Click the No Change radio button option.

• Colour sample: Deselect the neighbouring checkbox; the colour will be 
ignored if the checkbox is deselected.

14. Click OK to create the style.

To duplicate a text style to create a new text style:

1. Choose Duplicate “Style Name” from the style options menu  to the right 
of the text style’s name in the panel.

2. The Edit Text Style window will be displayed with the same options as creat-
ing or editing a text style. Name the new style and change its formatting 
attributes as required. Publisher will show the effect of the changes live as you 
modify the attributes in the window.

3. Click OK to create the style.

To delete text style(s):

1. To delete a single text style, choose Delete “Style Name” from the style 
options menu  to the right of the text style’s name in the panel.

Or select the text style name in the panel list and then click the Delete Style
 icon or choose Text > Text Styles > Delete Paragraph Style or Delete 

Character Style. Note that selecting a style will apply it to the selected text or 
text cursor position so this method is often less convenient.

2. To delete all text styles, choose Detach and Delete All Styles from the panel 
menu  or choose Text > Text Styles > Detach and Delete All Styles. No 
formatting will be lost as the formatting attributes will be detached from the 
text styles and applied directly to any styled text. There is no confirmation for 
this command but you can undo it.

3. To delete only the text styles that are not in use, choose Delete Unused Styles
from the panel menu  or choose Text > Text Styles > Delete Unused Styles. 
There is no confirmation for this command but you can undo it.

4. To delete a style group or a text style, as well as all the styles based on it, 
choose Delete “Style Name” Group from the panel menu . There is no 
confirmation for this command but you can undo it.

Tip: A white colour 
sample with a red line 
through it means no 
colour
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Changing text styles
You can change text styles at any time using the same options as when you cre-
ated the style.

One of the first things you might do after creating a new document with the 
default text styles is edit the Base style group. With the default text styles, Body, 
Heading 1, Bullet 1, and Numbered 1 are all based on the Base style group so 
instead of changing the font family for each from Arial to your preferred font you 
could edit Base and the styles would be updated automatically.

You can even change a paragraph style to a character style or vice versa. You can 
even change a paragraph or character style to a style group but these types of 
changes can have confusing consequences so it’s best to avoid changing a style’s 
type. For example, if you changed the Body style to a style group then all text 
formatted as that style would appear to be formatted with a style group. You 
would also no longer be able to apply the style directly via the Text Styles panel
without using the group’s style options menu.

To update a text style to match the current formatting:

1. Format text with the text style and then adjust its formatting attributes as 
desired using the Paragraph and Character panels. Position the text cursor 
anywhere in the formatted text. If you leave a range of text selected, Publisher 
will use the formatting at the start of the text range.

2. Update the paragraph or character style by doing one of:

• Click the Update Paragraph Style  icon or the Update Character Style
 icon at the bottom of the Text Styles panel or in the Context Toolbar.

• Choose Update “Style Name” from the style options menu  to the right 
of the text style’s name in the panel.

• Choose Text > Text Styles > Update Paragraph Style or Update Character 
Style.

To manually change a text style’s definition:

1. Choose Edit “Style Name” from the style options menu  to the right of the 
text style’s name in the panel.

Or double-click the style name in the Text Styles panel. Note that double-
clicking a style will apply it to the selected text or text cursor position so this 
method is not recommended unless the cursor is in text of the text style you 
want to edit.

2. The Edit Text Style window will be displayed with the same options as creat-
ing or editing a text style. Name the new style and change its formatting 
attributes as required. Publisher will show the effect of the changes live as you 
modify the attributes in the window.

3. Click OK to create the style.
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Importing and setting default text styles
Newly-created documents include Publisher’s default text styles. You can save 
your current collection of text styles for use in future documents or import text 
styles from one document into another.

To save the current text styles as the default:

1. Choose Save Styles as Default from the panel menu  or choose Text > Text 
Styles > Save Styles as Default.

To revert to the factory default text styles:

1. Choose Affinity Publisher 2 > Settings… (macOS) or Edit > Settings…
(Windows) and then click Miscellaneous in the left pane.

2. Click Reset Text Styles.

3. Click Close.

To import text styles from another document:

1. Choose Import Styles… from the panel menu  and then select the other 
document from the Open window.

2. Select which text styles to import by selecting or deselecting the checkboxes 
to the left of their names. Publisher will display the formatting attributes of 
the selected text style and for a style in the document of the same name at the 
bottom of the window.
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Choose Check All from the popup menu below to select or deselect all text 
styles, or choose Check Paragraphs or Check Characters to select or deselect 
all paragraph or character styles.

3. Publisher will indicate which text styles will replace and overwrite an existing 
style. To import a style but not replace an existing one with the same name, 
enter a new name for the style in the text field to the right of the style name.

4. Click OK to import the selected text styles into the document.

To export text styles to share them with another user:

Publisher doesn’t provide a way to export text styles because you can import 
styles from another document, but if it’s easy to share text styles without sharing 
the contents of your document.

1. Create a new document.

2. Choose Detach and Delete All Styles from the panel menu  or choose Text 
> Text Styles > Detach and Delete All Styles to delete all text styles from the 
document.

3. Choose Import Styles… from the panel menu  and then from the Open
window select a document that contains the text styles you want to share.

4. Click OK in the Imported Text Styles window. The blank document now 
contains just the text styles you want to share.

5. Save the document and send it to the other user.
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There are many different ways to create a book with Affinity 
Publisher, including creating it as individual chapter documents 
combined together as a Book file. The best approach to use for 
your book project will depend on the type of book you plan to 
publish, its design, and your preferred workflow.

In this chapter
Parts of a book .............................................................................................130
Static layouts vs. automatic text flow ..................................................130
Sections and stories in books ................................................................132
Books: splitting a book into chapter documents ............................134

Books 4
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Parts of a book
Books are typically divided into front matter, body pages, and end matter, also 
known as back matter. Below is a list of the most common parts of a book but 
not all books will have every part or have them in the same order:

Front Matter Body End Matter

Accolades Prologue or Introduction Appendices
Half title Chapters Endnotes
Frontispiece Epilogue Bibliography
Title page Afterword/Conclusion Glossary
Copyright/Colophon Postscript Index
Also by the author  Acknowledgements
Dedication  Author bio
Table of contents  Accolades
Epigraph  Colophon
List of figures
Preface
Foreword

Static layouts vs. automatic text flow
Many books have text that flows automatically from page to page like a word 
processor. The text and images pinned into it will flow as you add and edit text as 
long as the text frames are linked together. To change the order of pages you 
would cut and paste the text from one page to another, just as you would with a 
word processor.

Other books use a static layout with text that does not flow automatically from 
page to page. To move a page to another position in the document you would 
change the order of the pages. These books are sometimes designed around 
complex illustrations with text edited to fit the available space.

Tip: Adding, moving, 
or deleting a single 
page in a facing-pages 
document can lead to 
confusing results; refer 
to Working with 
spreads on page 13

Static layout: text frames 
are not linked, each 
frame contains its own 
story

Automatic Text Flow: 
text frames are linked 
from page to page into 
one story

Definition: The term 
story refers to all the 
text in a text object or 
in a series of linked 
text frames
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A novel or textbook will almost always use automatic text flow while a photo 
book or children’s story book will almost always use a static layout. This manual 
uses automatic text flow with inline images that are pinned to the text, as well as 
page breaks to interrupt the flow where required.

Some books can be laid out either way and the choice is a personal preference. 
For example, a cookbook could be created as a static layout if you want to posi-
tion each page element manually and be able to change the order of recipes 
easily. But you could also use automatic text flow and pin each recipe’s sidebars 
and photos.

Using static layouts with automatic text flow
If a chapter’s body text skips a page or spread due to the use of a full-page or full-
spread photo or illustration, you can insert a page break before the photo or 
illustration and pin the full-page image followed by another break. Be careful 
using this approach with full-spread images because if you add or remove text 
before the image it could shift to the right side and not fit onto the page. You 
could avoid this by inserting an even page break before the image but that could 
lead to a preceding blank page.

Alternatively, you can also place the images on static pages and link the previous 
and following text frames to skip over them. If you add or remove a substantial 
amount of text before the static page or spread you may need to rearrange the 
pages because the static page or spread may become distant from the text that 
describes it.

Automatic text flow with a static 
spread: the story is linked from the 
frame before the static spread to the 
frame after it, jumping over the image

Automatic text flow with a pinned 
image: a page break is inserted before 
the pinned full-page image, followed by 
another page break

Tip: Refer to Interrupt-
ing text flow on page 
48 for information on 
page breaks

Automatic text flow with a pinned 
spread: a page break is inserted before 
the pinned full-spread image, followed 
by two page breaks

Automatic text flow with a static page: 
the story is linked from the frame before 
the static page to the frame after it, 
jumping over the image

Tip: You can pin 
images with the 
Pinning panel so they 
move with the associ-
ated text; refer to 

Definition: A spread is 
a pair of left and right 
pages in a facing-
pages document
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Sections and stories in books
Publisher uses the term section to refer to a range of pages but sections don’t 
have to correspond to your book’s chapters. You might use sections even if your 
book doesn’t have chapters because most books have front matter, pages before 
the first body page. Using a section for your front matter and one or more sec-
tions for the body of the book will allow you to restart page numbering at the 
first body page and to change the page numbering style.

A book with a static layout might not use linked frames so each frame would 
contain a separate story, or it might have frames on the left and right side of each 
spread that are linked together as pairs, but not linked to frames on other 
spreads.

For a book with automatic text flow there would be many pages of linked frames 
containing one story. You must choose whether to use a single story for all of the 
text in the body of your book or whether to use a separate story for each chapter. 
And you must also choose whether to create a section for each chapter.

Single vs. multiple stories
Use a single story for simplicity. With a single story, all of the text in the body of 
the book in a single series of linked frames. You can start a new chapter by 
inserting a page break. You can move a chapter by cutting and pasting all of its 
text as you would in a word processor. You may need to add or remove pages at 
the end of the book as you add and remove text.

Use multiple stories in a single document, one for each chapter, to simplify 
reordering chapters, add endnotes at the end of each chapter, and improve per-
formance. You can move a chapter by dragging all of its pages to a new position 
with the Pages panel. You may need to add or remove pages at the end of each 
chapter as you add and remove text.

Using multiple stories reduces the load on your computer because Publisher only 
has to reflow a single chapter instead of the entire book when you add or delete a 
line of text. Although modern computer hardware makes this less of a concern, 
performance can still be an important factor in a document with many inline 
images.

Regardless of which approach you select, adding pages and linking their text 
frames is easy with AutoFlow. Refer to AutoFlow text on page 47 for more 
information.

654
B

321
A Single story: the last text frame of chapter A 

on page 3 is linked to the first text frame of 
chapter B on page 4 so there is only a single 
story

Tip: Use the Section 
Manager to create 
sections; refer to 
Sections on page 22 
for more information

654
B

321
A Multiple stories: the text frames in chapter A 

are linked from pages 1–3 and the frames in 
chapter B are linked from 4–6 but there is no 
link between the chapters

Definition: Front 
Matter refers to the 
pages before the body 
of a book, including 
the title page, copy-
right page, table of 
contents, and preface
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Single vs. multiple sections
Use a separate section for each chapter if you want chapter-specific page number-
ing or to easily change the chapter name shown in the header or footer. But if 
your chapters require master page objects unique to each chapter, such as tabs 
that bleed off the right edge of pages, sections will be of little value because 
master pages must be applied manually to pages. You could apply a master page 
manually to all of the pages in a section but if you do that you might as well place 
the chapter name on the master page.

If you use separate sections for each chapter then you should use a separate story 
for each chapter, too. Unlike word processors such as Microsoft® Word which 
allow you to insert a section break at any point in your text, sections in Publisher 
are a grouping of pages. If you had a section starting on page 50 but the chapter 
heading on that page re-flowed to page 51 when you added more text, your 
chapter headings would be off by one page. If you used separate stories, the story 
for the previous chapter would be overset (overflowing) when you added more 
text. Publisher will warn of this you through Preflight so that you could add 
another page with AutoFlow.

Tip: Use the Fields 
panel to insert a 
Section Name into a 
header or footer
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Books: splitting a book into chapter docu-
ments
You can create a book as a single file or as separate files for each chapter joined 
together into a book. Many people used to create separate files for chapters due 
to limited computer hardware but today’s computers are more than sufficient to 
create a long, complex document with hundreds of images without needing to 
use separate files. But if you do need or prefer to work this way, the Books panel
allows you to create a Publisher Book comprised of multiple chapter documents. 
A chapter document is just a regular Publisher document that has been added to 
a Publisher Book. Working on a single chapter at once lowers the demands on 
your system’s memory and it’s much easier to reorder chapters with the Books 
panel.

The disadvantage of using the Books feature is increased complexity and the 
inability to package a Book for publication—at this time the Save As Package
command works only with individual documents. Publisher simplifies most of 
the complexity for you by synchronizing text styles, page numbers, and more 
across the Book but you may need to add or remove pages to the end of chapters 
to achieve the layout you desire.

Undo and Books
When you undo an action in Publisher it is added to the undo history which you 
can view with the History panel. Each document has its own undo history so the 
list of actions in the History panel will change when you switch documents.

A Book does not have its own undo history so the actions you perform on a book 
cannot be undone.

Tip: Books is capital-
ized in this manual 
when referring to the 
Books feature of 
Affinity Publisher, and 
uncapitalized when 
referring to the book 
you are creating

Tip: Do not add a 
chapter document to 
more than one Book 
because it will impact 
synchronization

A Publisher Book is stored as a .afbook file which combines the pages of separate document .afpub files 
together when you export or print the Book

Tip: You can use the 
Books feature even if 
your project doesn’t 
have chapters because 
you can divide your 
Book into whatever 
groups of pages you 
want

Tip: Do not duplicate a 
Book and its chapters, 
other than for archiv-
ing, because Books 
use absolute links to 
their chapters so 
opening the duplicate 
Book will modify the 
original chapters
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Using the Books panel
To display the Books panel:

1. Choose Window > Books to display the Books panel.

The first icon to the right of each chapter’s name and page number indicates its 
chapter file status:

Chapter file
Status Description

 The chapter is open for editing

 The chapter is closed and there are no issues

 The chapter is closed and was edited while the Book was closed—open it
 to update the Book

 The chapter could not be found and you opted not to locate it when
 opening the Book—close and reopen the Book to resolve this
 the Book

 The chapter is locked because it’s in use by another user or application

The second icon to the right of each chapter’s name and page number indicates 
its Preflight status:

Preflight
Status Description

 Preflight not completed because Check is set to Never

 All Preflight tests passed

 One or more Preflight warnings

 One or more Preflight errors and possibly one or more warnings

Add chapter

Remove chapters

Synchronize chapters

Panel menu

Switch between open books

Selected chapter is highlighted

Chapter file status

Preflight status

Update Numbers now

Style source chapter
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Managing stray pages
Most books use facing pages to mirror headers and footers on the left and right 
side or to allow for different inner and outer margins, so pages are paired into 
spreads. The term stray page refers to a single page at the start or end of a chap-
ter document that isn’t part of a spread in that chapter. Stray pages from adjoin-
ing chapter documents need to be joined together into a spread and sometimes a 
blank page needs to be added to maintain the proper order of pages.

Publisher’s Books feature does not support books with chapters that can start on 
the left side of a spread. Novels, biographies, and some other text-focused books 
often start chapters on either side to avoid blank pages. If you were to use the 
Books feature for this type of book and chapter 1 ended on a right page but you 
created the chapter 2 document with its first page on the right, as a new docu-
ment is normally created, Publisher would have to change the side for every page 
in chapter 2. This would result in unsatisfactory results so it’s best to avoid this 
issue.

If your chapters always start on the right side of a spread then you can use the 
Books feature but you will have to add and remove blank pages manually if you 
don’t want two successive blank pages.

The Books panel’s menu offers two Stray Pages commands:

• Merge Where Possible: If a chapter ends on a left page and the following 
chapter starts on a right page this command will merge those two stray pages 
into a single spread when printing or exporting the Book.

• Pad: If a chapter ends on a right page and the following chapter starts on a 
right page this command will add a blank page to maintain the facing pages.

By default, Merge Where Possible is enabled and Pad is disabled but this is not 
an optimal combination. Leaving Pad off will result in a single-page spread when 
a chapter document ends with a right page which must be avoided.

Definition: Spread
refers to a pair of left 
and right pages in a 
facing-pages 
document
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When Pad is used, as is shown in the middle and right scenarios above, a com-
pletely blank page will be added; you cannot choose a master page to be applied 
to it. If you want your blank pages to display a chapter name or page number 
then you must add your own blank pages.

The right scenario above shows how a chapter document ending with a blank 
right page can result in two successive blank pages. The blank page at the end of 
the first chapter document would not be completely blank–it would typically be 
based on a master that displays the page number and perhaps the chapter name, 
but from a book design perspective it’s effectively blank. Because you would have 
Pad enabled to avoid single-page spreads, Publisher will add a blank page before 
page 7. Merge Where Possible merges only stray pages as shown in the left sce-
nario and Pad will have created two spreads, albeit ones with two blank pages.

If you want to avoid two successive blank pages you must first delete the blank 
right pages from the end of your chapter documents. If you later need another 
page in that chapter, you must manually add a new page—do not use AutoFlow 
because it always inserts an even number of pages, and in this case that would 
leave you with a blank left page.

If you don’t want to deal with the complexity of adding and removing pages in 
your chapter documents then you may wish to refrain from using the Books 
feature.

Chapter ends on a blank right page: 
The Pad command will insert a blank 
page before page 7 but Merge Where 
Possible won’t merge the two blank 
pages

Chapter ends on right: The 
Pad command can insert a 
blank page before page 7 to 
maintain facing pages

Chapter ends on left: The 
Merge Where Possible 
command can merge pages 4 
and 5 into a single spread
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Creating a Book
Create at least one of the chapter documents before you create a Publisher Book. 
Although you can update the design and formatting of chapters later, it’s a best 
practice to finalize the document size, margins, colour profile, master pages, 
notes formatting, and other basics before creating additional chapter documents. 
Some information can be synced across chapters, but other options such as 
endnote placement would have to be changed manually in each chapter.

To create a Book:

1. Choose File > New Book. The Books panel will be displayed if it is not 
already shown. You can also open the Books panel with Window > Books
and then click its Create new book button or choose New Book from the 
panel menu .

2. Choose Stray Pages > Pad from the panel menu  to avoid single-page 
spreads.

3. Choose Save Book from the panel menu  and give your project a name.

Tip: You can only save 
a Book from the panel 
menu ; it doesn’t 
allow for the use of 
keyboard shortcuts 
like the File menu
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To add chapters to a Book:

1. Click the Add Chapter icon  or choose Add Chapter… from the panel 
menu .

2. Select one or more Affinity Publisher document files to add.

3. If your chapters aren’t in the right order, you can drag them to the correct 
order in the panel.

To remove chapters from a Book:

1. Select the chapter name(s) in the Books panel; press Shift and click to select a 
range of chapters, or press ⌘ (macOS) or Ctrl (Windows) and click to select 
multiple discontinuous chapters.

2. Click the Remove Chapter  icon or choose Remove Chapter from the panel 
menu .

3. Choose Replace Chapter from the panel menu  to remove one selected 
chapter document and replace it with another of your choosing in a single 
step.

To open a Book:

You can open more than one book simultaneously. Only one Book is active at 
once, similar to how only one document is active at once.

1. You can open a Book with the same File > Open… command used to open a 
document. The Books panel will be displayed if it is not already shown. 
When no Book is open, the Books panel will display an Open book… button 
and you can also open a Book by choosing Open Book… from the panel 
menu .

2. To change which Book is active, click the current Book’s name at the top of 
the Books panel to choose from the list of open Books.

Tip: Recently-used 
books can be opened 
by choosing them 
from the File > Open 
Recent menu or the 
Recent pane of the 
New Document
window

Tip: It is a best practice 
to add separate 
chapters for Front 
Matter and End Matter
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To save a Book:

1. Choose Save Open Chapters from the Books panel menu  to save any 
modified (un-saved) chapters you have open, or choose File > Save for each 
of them.

2. Choose Save Book or Save Book As… from the Books panel menu . These 
commands are not in the File menu and a keyboard shortcut cannot be 
assigned; however, if you quit Publisher with a modified Book open then 
Publisher will prompt you to save it.

To close a Book:

1. To close the active Book, choose Close from the Books panel menu . You 
can close only one Book at a time but if you quit Publisher with open Book(s) 
they will be closed automatically and you will be prompted to save modified 
Book(s).

To duplicate a Book:

1. Using macOS Finder or Windows File Explorer, duplicate the folder contain-
ing the Book and its chapter documents; for example, name this folder 
Project-Copy.

2. Temporarily rename the original folder; for example, rename it to Project-
Temp.

3. Open the duplicate Book’s .afbook file in Publisher.

4. Publisher won’t be able to locate its chapter documents because a Book uses 
absolute paths to its chapters and you renamed the original folder. Click Yes
and in the file window that appears select the chapter document in the 
Project-Copy folder. Ensure you don’t select the same chapter in the original 
folder.

5. Publisher will relink all the remaining chapter documents if they’re in the 
same folder. Save the Book now by choosing Save Book from the Books panel 
menu .

6. Using macOS Finder or Windows File Explorer, rename the original folder 
back to its original name.

Tip: Saving a Book will 
not save its chapter 
documents
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Syncing styles, formats, and masters in a Book
Each chapter document has its own master pages, text styles, table formats, and 
swatches but Publisher can sync this information across the Book. By default, the 
first chapter you add is designated the Book’s Style Source Chapter, the master 
copy for this information.

You can synchronize formatting to other chapters even while those chapters are 
closed. Publisher will open the chapter documents in the background, update 
them, save changes, and close them. Note that chapters that are currently open 
will be updated but changes will not be saved; you should save those chapters 
when you’re done with your other edits.

Syncing text styles and table formats

If a text style or format one with the same name doesn’t exist in the target chap-
ter, it will be copied from the Style Source Chapter. You can add a new text style 
or table format in the Style Source Chapter and sync it to all other chapters.

If a text style or format with the same name exists in the target chapter, it will be 
updated to have the same attributes. You can update a text style or table format in 
the Style Source Chapter and sync the change to all other chapters.

If you rename a text style or table format in the Style Source Chapter, syncing 
will create a new one in the target chapters because the names won’t match. Text 
formatted with that text style won’t be formatted with the renamed style. For 
example, consider the case of renaming the Body style in the Style Source Chap-
ter to Body Text and then syncing to another chapter. The text formatted as Body
in the target chapter will still be formatted as Body and a new Body Text style will 
be created. You would need to use Find and Replace to search for all instances of 
Body to replace format them as Body Text.

Syncing swatches

Syncing swatches is identical to syncing text styles and table formats with the 
addition of synching document palette categories.

Syncing master pages

Syncing master pages is more complex. If a master page with the same name 
doesn’t exist in the target chapter, it will be copied from the Style Source Chapter.

If a master page with the same name exists in the target chapter but anything 
about that master is different, it will not be updated and instead a new master 
page will be created and copied from the Style Source Chapter. Making any 
change to a master page in the Style Source Chapter can result in duplicate 
master pages in the target chapters.

If you rename a master page in the Style Source Chapter, syncing will create a 
new master page in the target chapters because the names don’t match.

If you must adjust your master pages—for example, adjusting page size, margins, 

Tip: Note that custom 
variables are not 
synced across chap-
ters and are available 
only in the chapter 
document in which 
they were created

Tip: It is important to 
finalize your text style 
names before creating 
additional chapters or 
your chapters will end 
up with multiple 
copies of your styles 
with different names

Tip: It is important to 
finalize your master 
pages before creating 
additional chapters or 
your chapters will 
have multiple copies 
of your master pages
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or bleed, or adding an object—it is best to make the changes manually to each 
chapter and disable the synchronization of master pages in Synchronize Settings.

To synchronize chapter documents:

1. If necessary, select a chapter in the Books panel and choose Set Style Source 
Chapter from the panel menu . Or click in the blank well area to the left of 
the chapter name in the Books panel—a tooltip will be displayed when the 
pointer is over the well. This action cannot be undone.

2. Select the chapters you want synchronized. To synchronize only specific 
chapters, select just those chapters in the panel list. To synchronize all chap-
ters, deselect any selected chapters by clicking in a blank area of the chapter 
list or by holding ⌘ (macOS) or Ctrl (Windows) while clicking the selected 
chapter.

3. If desired, you can customize which information is synced by choosing 
Synchronize Settings from the panel menu . The settings you select will be 
saved with the Book.

4. Choose Synchronize from the panel menu , Synchronize Now from this 
window, or click the Synchronize Chapters  icon to sync the information 
from the Style Source Chapter to the selected chapters.

Tip: Be careful when 
clicking near the Style 
Source Chapter well
because there is no 
visual cue that clicking 
in the well will do 
anything, nor is there a 
confirmation alert to 
avoid accidental 
changes

Tip: As with other 
Book actions, synchro-
nizing chapters cannot 
be undone
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Number pages, notes, and lists in a Book
Publisher can number pages, notes, and global list items automatically across 
chapters even while chapters are closed. Publisher will open the chapter docu-
ments in the background, update them, save changes, and close them. Note that 
documents that are currently open will be updated but changes to them will not 
be saved.

Page numbers are updated automatically and there is no need to manually 
update them unless you turn off automatic numbering. Note and list item num-
bers are updated only when you choose to update them. All numbers can be 
updated automatically when you print or export a Book.

Notes will be numbered across chapters only if Restart Every > Book is chosen 
from the Notes panel for all of the chapter documents.

List items will be numbered across chapters only if the lists at the start and end 
of each chapter are the same level and if the following options are chosen from 
the Bullet and Numbering section of the Paragraph panel:

• Restart numbering > Manual Only

• Restart Numbering Now set to Off

• Global set to On.

To update page numbers automatically across chapters:

If you turn off automatic page numbering Publisher will change the Start page 
number at setting in the Section Manager for the first section of each chapter 
document to a fixed number.

1. Choose Update Numbers > Update Page Numbers Automatically from the 
Books panel menu  to enable or disable automatic page numbering. This is 
on by default.

To modify the page numbering for a chapter:

Many books have front matter with pages numbered in Roman numerals (i, ii, iii, 
iv…) followed by body pages numbered in Arabic numerals (1, 2, 3, 4…) To 
create this common numbering approach in a Publisher Book:

1. Ensure Update Numbers > Update Page Numbers Automatically is selected 
from the Books panel menu .

2. Open the front matter chapter and choose Window > Section Manager or 
click the Section Manager  icon in the Pages panel.

3. Set the Number style to i, ii, iii, iv…

4. If there are no other sections in this chapter, open the next chapter. Other-
wise, select the next section in this chapter.

Tip: With a Book you 
cannot select Con-
tinue page number-
ing for the first section 
of a chapter document 
in the Section Man-
ager because this 
feature is controlled at 
the Book level
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5. Set the Number style to 1, 2, 3, 4… in the Section Manager. The remaining 
chapters will continue this numbering style automatically unless you wish to 
change it again.

6. To restart page numbering at the start of a chapter, select that chapter in the 
Books pane and choose Page Number Options from the panel menu .

To number notes across chapters:

1. Choose Numbering > Restart Every > Book from the Notes panel.

2. Create or edit an endnote and then choose Update Document Settings from 
Selected Endnotes from the panel menu . If you’ve already created multiple 
chapter documents you will need to repeat these steps for each chapter.

To update page, note, and list numbers before printing or exporting:

1. Choose Update Numbers > Update Numbers Before Output from the panel 
menu . This is on by default. Note that this affects only the Export… and 
Print… commands in the panel menu . Choosing the same commands 
from the File menu will not update numbers because those export only the 
current chapter and not the whole Book.

To manually update page, note, and list numbers:

1. Select the chapter(s) to update in the Books panel.

2. To update just one type of number, select Update Numbers > Page Numbers, 
List Numbers, or Note Numbers from the panel menu .

3. To update all numbers at the same time, choose Update Numbers > All 
Numbers or click the Update Numbers button at the bottom of the panel.

Tip: Although this 
command is named 
Update Numbers it 
will also update the 
text of endnotes so 
there is no need to use 
the similarly-named 
command for 
endnotes
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Positioning endnotes at the end of a Book
Many books include endnotes at the end of chapters which Publisher does by 
default. If you want to consolidate all of your endnotes at the end of a Book, 
Publisher can do this automatically but you should learn how it works to avoid 
confusion.

To position endnotes at the end of a Book:

1. Choose Positioning > Note position > End of Book from the Notes panel.

2. Create or edit an endnote and then choose Update Document Settings from 
Selected Endnotes from the panel menu . If you’ve already created multiple 
chapter documents you will need to repeat these steps for each chapter.

3. When the End of Book option is chosen, Publisher will create a non-printing 
section named #Booknotes at the end of each chapter to make it convenient 
to edit its endnotes without having to keep switching between the current 
chapter and the endnotes at the end of the Book.

4. Create an End Matter document for your endnotes and index to avoid adding 
a printing section for them after the non-printing #Booknotes section in your 
last actual chapter.

5. Add the End Matter document to the Book as a chapter.

6. Place the cursor in a text frame in the End Matter chapter and choose End-
notes > Insert Endnotes from the Books panel menu . All of the Book’s 
endnotes will be added to that text frame. These endnotes are not editable so 
they are similar to an inserted index or table of contents.

Definition: End Matter
is also known as Back 
Matter and includes 
the appendices, 
endnotes, glossary, 
index, and bibliogra-
phy



146 Books

Adding references to a Book
Publisher can create the table of contents and index for an entire Book and cross-
reference text across its chapters but the features function slightly differently in a 
Book.

To add a table of contents to a Book:

Refer to Creating a table of contents on page 158 for general information on 
tables of contents.

1. Place the cursor in a text frame in your Front Matter chapter and click the 
Insert  icon in the Table of Contents panel.

2. No entries will be shown for the inserted table of contents unless your Front 
Matter chapter has applicable headings. Click Scope > Book in the panel to 
include all chapters in this table of contents.

3. Click the Update  icon in the Table of Contents panel to reflect the table’s 
right-click scope.

4. To update tables of contents automatically before printing or exporting, 
choose Update Numbers > Update Tables of Contents Before Output.

To add an index to a Book:

Refer to Creating an index on page 172 for general information on indices.

1. Place the cursor in a text frame in your End Matter chapter and click the 
Insert Index  icon in the Index panel. Unlike the table of contents feature, 
the scope for a Book’s index is always the entire Book so there is nothing else 
you need to do. Publisher will automatically sync index topics across chapters, 
even if you rename them.

2. To update the index automatically before printing or exporting, choose 
Update Numbers > Update Index Before Output.

To add cross-references to a Book:

Refer to Creating cross-references on page 150 for general information on cross-
references. The Book and the chapters to target (add a cross-reference to) must 
be open when you add or remove a cross-reference. You can edit a cross-refer-
ence without the Book and target chapter being open as long as you don’t need to 
change the target paragraph, anchor, or index mark.

1. Open the Book and the chapter(s) you want to target.

2. Follow the steps for creating a cross-reference. A Target Chapter option will 
appear in the Insert Cross-Reference window to select a chapter for the target 
paragraph, anchor, or index mark. The remainder of the options are the same 
as for standard documents.

3. To update all cross-references in a Book, choose Cross-References > Update 
Cross-References from the Book panel menu .
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4. To update cross-references automatically before printing or exporting, choose 
Cross-References > Update Cross-References Before Output.

Printing and exporting a Book
The Print and Export commands in the File menu will print and export the 
current document, not an entire Book. To print and export a Book you must use 
the Book panel. Likewise, the Preflight panel will check for errors in the current 
document, not an entire Book. To preflight a Book you must use the command 
in the panel menu .

To preflight a Book:

1. Select one or more open chapter documents in the Books panel to preflight 
the selected chapter(s), or deselect all chapter documents to preflight all open 
chapters.

2. Choose Preflight from the panel menu . The Preflight panel will not be 
displayed and no window will open; instead, the Preflight status icons for the 
chapter(s) will update to reflect the results of the Preflight check:

Status Description

 Preflight not completed because Check is set to Never

 All Preflight tests passed

 One or more Preflight warnings

 One or more Preflight errors and possibly one or more warnings

3. Click the Preflight status icon to open a chapter and display the Preflight 
panel to see the list of warnings or errors.

To print or export a Book:

1. To export specific chapters, select the chapters in the Books panel.

2. Choose Print… or Export… from the panel menu . The Print and Export 
windows will include a Range option (for Print) and an Area option (for 
Export) to let you choose whether to export the entire Book or the chapters 
selected in the panel.

Tip: You can only 
preflight chapters that 
are currently open

Tip: Refer to Preflight-
ing documents on 
page 214 for more 
information on 
Preflight

Tip: Refer to Printing 
on a commercial press
on page 228 for more 
information on 
printing
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The features described in this chapter are critical to creating 
books, newspapers, magazines, academic papers, reports, and 
other long documents.

Cross-references are used to refer readers to another place in the 
same publication and can be updated automatically as the docu-
ment changes. A table of contents is used to list the topics for 
the publication or one of its chapters in page number order. The 
index is used to list topics and keywords in alphabetical order, 
typically at the end of a publication.

Notes, including footnotes, sidenotes, and endnotes, are used to 
cite other works or to provide comments on the main text.

Anchors and hyperlinks are used to link to other places in the 
publication or to another document or website URL.

Fields are used to insert information about the document, such 
as the page number or section name, and can be updated auto-
matically as the document changes.

Together these features simplify the effort required to create a 
long and complex publication. Mastering these features will save 
you time as you prepare a document for publication and help 
ensure a more consistent publication with fewer errors.

In this chapter
Creating cross-references ........................................................................150
Creating a table of contents ...................................................................158
Creating an index .......................................................................................172
Creating notes .............................................................................................185
Using fields ...................................................................................................197
Using anchors ..............................................................................................205
Using hyperlinks .........................................................................................209

References 5
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Creating cross-references
A cross-reference refers the reader to another place in the same publication, 
whether through a page or chapter reference or a hyperlink in a PDF or eBook.

A cross-reference in Publisher is a field that refers to the position of an anchor 
elsewhere in your publication. The cross-reference field will update automatically 
when its target changes pages and you can choose to update cross-references 
when the paragraph text changes.

Publisher can generate many complex types of cross-references by combining 
subfields including the paragraph text following the anchor position. You can 
save combinations of subfields and text as presets to make it easy to add cross-
references.

You can format cross-references automatically with a character style but the style 
can be applied only to the entire cross-reference. If you want to format only part 
of a cross-reference or format two parts of it separately, you would need to com-
bine it with plain text or a second cross-reference to the same target.

Cross-reference targets

You can choose to target a cross-reference to an anchor, paragraph, or index 
mark, but targeting a paragraph or index mark will generate a new anchor auto-
matically. Anchors generated automatically by cross-references will not be 
exported as PDF bookmarks unless you modify them.

The choice of which to target depends on your work style:

• If you cross-reference a heading and target the paragraph, Publisher will 
insert an anchor at its start. If you later insert a table of contents, Publisher 
will insert a second anchor because the table of contents feature also relies on 
anchors.

• If you insert the table of contents first and update it as you edit your docu-
ment, Publisher can reuse the table of content’s anchor when adding a cross-
reference.

• If you cross-reference an index mark, Publisher will create an anchor using 
the index mark’s name rather than the paragraph text.

refer to “Aperture” on page 192

refer to “Depth of field” above

see Understanding Exposure on page 87 of chapter 2

See Depth of Field

See Depth of field for more information

See Depth of field on page 73 for more information

See Depth of field on page 73 for more information

The boxed text in these 
examples can be inserted 
automatically as a cross-
reference
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Using the Cross-References panel
To display the Cross-References panel:

1. Choose Window > References > Cross-References to display the Cross-Ref-
erences panel.

2. Choose Edit Strings… from the panel menu  to change the Above/Below
text used for certain cross-references.

3. Drag the column dividers to see more of a particular column.

Go to target

Update AllUpdate

EditInsert

Filter list by page or spread

Go to cross-reference

Selected cross-reference

Panel menu

Text inserted on the page

Column dividers—drag to resize

Status icon

Delete

Page number of
a cross-reference
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Adding a cross-reference
To insert a cross-reference:

1. Using the Frame Text  tool, position the text cursor where you want the 
cross-reference to be inserted.

2. Click the Insert Cross-Reference  icon in the Cross-References panel or 
choose Text > Cross-References > Insert Cross-Reference, and select the 
target.

• Link to: Select Paragraph (default), Anchor, or Index Mark. You must have 
previously defined anchors or index marks to use the latter options.

• Filter style (Optional): Select a text style name to filter the list by style.

• Search (Optional): Enter a search phrase to filter the list by text. Publisher 
will search anywhere in the paragraph, anchor name, or index mark name. 
To search only from the start, click the caret  icon and select Search from 
Start.

• List: Select one of the listed paragraphs, anchors, or index marks.

3. Format the cross-reference:

• Preset: Choose one of the default cross-reference presets. You can create a 
custom format with the Text option below and create your own presets.

Tip: Presets are 
language specific
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• Language: If the cross-reference’s language doesn’t match the language of 
the surrounding text, click the menu icon  beside the Preset list, choose 
Language from the popup menu, and then select the language to use.

• Text: Create a custom format for the cross-reference. Enter plain text and 
click the caret  icon on its left side to easily enter relevant special charac-
ters and select from a list of cross-reference components or building 
blocks.

Component Text Result

Page Number on page PageNumber on page 192

Section Name in chapter SectionName in chapter 3

Chapter Name in the ChapterName chapter in the Exposure chapter

Object Description see figure ObjectDescription see figure 46

Anchor Name see AnchorName see Depth of field

Above/Below continued AboveBelow continued below

Numbered Paragraph see NumberedParagraph see 3. Aperture

Paragraph Body see ParagraphBody see Aperture

List Number see ListNumber see 3

Note Number in footnote NoteNumber in footnote 17

• Combine components together to create complex cross-references:

Text  Result

refer to “ParagraphName” on page PageNumber refer to “Aperture” on page 192

refer to “ParagraphName” AboveBelow refer to “Depth of field” above

see AnchorName on page PageNumber of chapter SectionNumber see Understanding exposure on page
   87 of chapter 2

on page SectionName.PageNumber on page 12.10

• For Above/Below, you can change the text that will be inserted by choos-
ing Edit Strings… from the panel menu .

Tip: Object Descrip-
tion inserts the layer’s 
name which you can 
use as a way to insert 
text that doesn’t 
appear in the 
document

Tip: You could type 
text such as “refer to” 
and “on page” directly 
in the text frame but 
including this text in 
the cross-reference 
format helps ensure 
consistency through-
out a long publication

Tip: Note Number 
inserts the number of 
a footnote, endnote, 
or sidenote, use 
Paragraph Body to 
insert its text

Tip: Do not use a 
component with a 
paragraph that doesn’t 
make sense, such as 
List Number for a 
paragraph that isn’t 
numbered because 
the cross-reference 
will be shown as out-
of-date until you 
remove the 
component
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4. Optional: To create a preset for your custom cross-reference format, click the 
menu icon  beside the Preset list and choose Create Preset… from the 
popup menu. Enter a preset name and then click OK. If you later modify the 
preset, choose Save Preset from the menu icon to update it. Choose Rename 
Preset… or Delete Preset… to rename or delete the selected preset.

5. Optional: To apply a character style to the cross-reference, choose one from 
Style override. Choose what the style is applied to with For.

• Everything: Select to apply the character style to the entire cross-reference

• All Fields: Select to apply the style to just the fields and not the plain text 
you enter. For example, for a cross-reference of “ParagraphBody on page 
PageNumber”, the style would be applied to ParagraphBody and 
PageNumber but not to the words in between.

• Text Fields: Select to apply the style just to text fields such as 
ParagraphBody.

• Number Fields: Select to apply the style to just the number fields such as 
PageNumber.

6. Optional: Deselect Generate hyperlinks if you don’t want cross-references to 
be clickable in an exported PDF file. It is recommended to leave this on 
because you can control whether hyperlinks are included when exporting. 
Hyperlinks added for cross-references will not appear in the Hyperlinks 
panel because they are not editable. Ensure Include Hyperlinks is selected 
when exporting to PDF if you want them included.

7. Optional: If you cross-reference short paragraphs such as headings, you’ll 
likely want to include the full heading name in the cross-reference but if you 
cross-reference a full paragraph or a long section name then you may wish to 
truncate the inserted text. Select Limit subfields to choose from two options 
to shorten the text:

• Enter the Max word count to limit the text by number of words. Select 
Add ellipsis to add an ellipsis to truncated text. For example, setting Max 
word count to 3 and adding an ellipsis to “Introduction to digital photog-
raphy” would result in “Introduction to digital…” being inserted.

• Enter one or more characters into End characters to choose which charac-
ters mark the end of the text to include—if an end character is not 
encountered the full paragraph will be inserted. Select Include end char-
acter if you want it included in the inserted cross-reference. For example, 
setting End characters to a colon would insert “Chapter 6” for a paragraph 
with the text “Chapter 6: Exposure”.

8. Click OK to insert the cross-reference.

9. Optional: If you created a cross-reference to a Paragraph or Index Mark you 
can rename the generated anchor with the Anchors panel. Refer to Using the 
Anchors panel on page 205.

Generate hyperlinks
does not apply 
formatting automati-
cally; it’s up to you to 
apply an appropriate 
character style with 
Style override
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To edit a cross-reference:

1. To edit one cross-reference, position the text cursor before or after its field in 
the document text and choose Text > Cross-References > Edit Cross-Refer-
ence… You can also double-click its name in the Cross-References panel or 
select the cross-reference in the panel and click the Edit Cross-References
icon.

2. To edit the format of multiple cross-references at once, press Shift and click to 
select a range of cross-references, or press ⌘ (macOS) or Ctrl (Windows) and 
click to select multiple discontinuous cross-references, before clicking the 
Edit Cross-References  icon. You can’t set the target for multiple cross-ref-
erences and the formatting options of the first one will be shown in the Edit 
Cross-Reference Format window

3. All of the options for editing a cross-reference are the same as for creating a 
new one. When editing a single cross-reference, you can change its target to a 
different paragraph, anchor, or index mark.

To find a cross-reference in the document:

1. Select a cross-reference in the Cross-References panel and click the Go to 
Cross-Reference  icon.

To view the target of a cross-reference:

1. Select a cross-reference in the Cross-References panel and click the Go to 
Target  icon.

To delete cross-references:

1. Select one or more cross-references in the Cross-References panel and click 
the Remove Cross-References  icon. The cross-reference field in the docu-
ment text will be expanded to become regular text which you can then edit. 
You can also simply delete the cross-reference field directly in the document’s 
text.
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To convert a cross-reference to regular text:

1. Right-click a cross-reference field and choose Expand Field from the context 
menu. The cross-reference field will be expanded to become regular text 
which you can then edit and the cross-reference will be removed from the 
panel. Deleting a cross-reference with the panel will also convert a cross-ref-
erence to regular text.

2. If the text in a cross-reference was hyphenated by automatic hyphenation, the 
hyphen will be included in the expanded field. Fields are expanded automati-
cally when copying text from Publisher to a word processor such as 
Microsoft® Word so it is a good practice to scan expanded fields for misplaced 
hyphens. Spell checking text copied to Word will usually find these hyphens.

To share a cross-reference preset with another computer or user:

Presets are not saved in your user settings but there is a way to share them with 
another computer or Publisher user.

1. Click the Insert Cross-Reference  icon in the Cross-References panel.

2. Choose the preset you want to copy.

3. Click in the Text field and press ⌘ + A (macOS) or Ctrl + A (Windows) to 
copy the cross-reference format to the clipboard. Click Cancel. To close the 
Insert Cross-Reference window.

4. Create a new document and draw a text frame.

5. Paste the clipboard into the text frame. It will appear empty because you have 
pasted invisible control codes that don’t have associated special character 
symbols.

6. Save this document and transfer it to the other computer.

7. Open the document on the other computer.

8. Click in the text frame and press ⌘ + A (macOS) or Ctrl + A (Windows) to 
copy the cross-reference control codes to the clipboard.

9. Click the Insert Cross-Reference  icon in the Cross-References panel.

10. Paste the clipboard into the Text field.

11. Click the menu icon  beside the Preset list and choose Create Preset…
from the popup menu. Enter a preset name and then click OK. 
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Updating cross-references
Cross-references aren’t updated automatically when you edit your document and 
the target of a cross-reference changes. It’s up to you to update the cross-refer-
ences before printing or exporting.

The Cross-References panel shows a status icon for each cross-reference:

Status Description

 OK – there are no issues with the cross-reference

 The cross-reference target is missing because the paragraph, anchor, or index
 mark was deleted; copying and pasting text that includes a target anchor will
 result in a missing target

 The cross-reference is out-of-date, the anchor or index mark is no longer on
 the same page; click the Update  or Update All  icon

To update cross-references:

1. Click the Update All Cross-References  icon in the Cross-References panel
to update all in the document. This is the right of the two Update icons and is 
always available, regardless of what part of the document you are viewing or 
which tool you have selected.

2. To update one or more specific cross-references, select the cross-references in 
the Cross-References panel. Click the Update Cross-Reference  icon to 
update the selected items.

Publisher can also warn you of an outdated cross-reference through the Preflight 
panel which offers a convenient Fix button to update it, but each outdated cross-
reference will have its own Fix button so it’s usually faster to update cross-refer-
ences with the Cross-References panel.
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Creating a table of contents
Publisher can generate one or more table of contents for your publication based 
on the selected paragraph styles. While most publications will have just one table 
of contents near the front of the document, some may have a second table of 
contents to list figures, illustrations, or photo credits. Some textbooks also have a 
table of contents at the start of each chapter to list its topics.

A table of contents is a block of special text that you can modify but when you 
update the table of contents any edits you made to it will be lost. You should 
avoid making any edits until the last stage before publishing. The table of con-
tents can be updated at any time and can be generated from a single document or 
from all of the chapter documents in a Publisher Book.

Sort order

A table of contents is sorted in the order the headings are used in your publica-
tion, from the first to last page and from the bottom to top of the layer stack on 
each page.

The layer stack order is important only if you use more than one text frame for 
your headings. Most long documents have just one main text frame per page for 
all of the page’s text, with separate frames only for the header and footer. If your 
document uses a separate text frame for each heading then your table of contents 
entries could be in the wrong order unless you pay attention to the layer stack 
order. Ensure the heading at the top of the page is on the bottom of the layer 
stack with additional headings on top.

Parts of a table of contents
A table of contents is a list of entries that are made up of a heading and a page 
number. You can select how many levels of headings to include and you can 
modify the formatting, including the separator between the heading and page 
number and whether the page number is shown before or after the heading. You 
can even hide the page number entirely.

Sample table of contents

Tip: If you number 
chapter pages using a 
combination of 
section name and 
page number (for 
example, 1.1, 1.2, 
1.3…), the section 
prefixes will not be 
included in the table 
of contents because 
they are not part of 
the page number

Tip: Master page text 
frames will be on the 
bottom of the layer 
stack unless you have 
edited the master 
layer detached

Exposure .................................................................5
Aperture ......................................................... 12
Shutter speed ............................................... 15
ISO ..................................................................... 17
Light meter .................................................... 21

Focusing modes .................................................27
Manual focus ................................................. 28
Auto focus ...................................................... 39
Continuous focus ........................................ 42

White balance .....................................................44
Types of lenses ...................................................58

a TOC 1: Heading 1 Number¶ TOC 1: Heading 1

a TOC 1: Heading 2 Number¶ TOC 1: Heading 2

Tip: You cannot sort a 
table of contents 
alphabetically
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Using the Table of Contents panel
To display the Table of Contents panel:

1. Choose Window > References > Table of Contents to display the Table of 
Contents panel.

Set indent level and page number 
visibility

Update All DeleteUpdate

Limit scope to current section (chapter)

Include in TOC

Panel menu

Rename TOC

Ignore unlinked text frames

Include front matter before the TOC

Share styles among TOCs

Table of contents name

Insert

Limit scope automatically

Generate PDF bookmarks
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Generating a table of contents
You must use paragraph styles for the text to include in a table of contents. You 
can use any styles that you want but for the main table of contents there are some 
advantages to using the standard Heading 1, 2, 3… naming convention, or 
Publisher’s equivalent for the user interface language in use.

It’s difficult to see the start and end of a table of contents because Publisher 
doesn’t display it with any shading as in other applications. Until you’re experi-
enced with working near the table of contents text block, it is recommended that 
you insert the table of contents into a separate text frame without any other text 
to avoid losing text when the table of contents is updated.

The table of contents inserted by Publisher does not include the title Table of 
Contents and you might consider placing even the title in a separate frame so that 
updating the table of contents can replace all the text in the frame(s).

It doesn’t matter whether you create text frames for the table of contents on a 
master page or whether you create them directly on a document page.

To insert a table of contents:

1. Using the Frame Text  tool, create a text frame for the table of contents and 
position the text cursor in it.

2. Click the Insert Table of Contents  icon in the Table of Contents panel or 
choose Text > Table of Contents > Insert Table of Contents. Publisher will 
insert the table into the frame.

3. Review the list of paragraph styles in the panel. Select any additional styles 
you want to include in the table and deselect any selected ones that you want 
to exclude.

4. If the table of contents’ text frame has an overflowing Text Flow Out
control near the frame’s bottom-right corner, press Shift and click the control. 
The AutoFlow feature will create as many pages of text frames as required to 
contain the table of contents.

5. Refer to Formatting a table of contents on page 162 for information on the 
formatting options and instructions for editing the table of contents text 
styles.

To delete a table of contents:

1. To delete a table of contents, select the table name from TOC popup menu 
and click the Delete  icon.

To update a table of contents:

The table of contents isn’t updated automatically when you add, edit, and delete 
headings. It’s up to you to update the table of contents before printing or 
exporting.

Tip: Each time you edit a heading used in the table of contents and update the table, 
Publisher will insert a new anchor before the heading. Editing your headings and 

Tip: For information 
on generating an table 
of contents for a Book 
made up of separate 
chapter documents, 
refer to Adding 
references to a Book
on page 146

Tip: When a TOC is first 
created, an anchor is 
added for each style 
that matches the 
standard Heading 1, 2, 
3 naming convention, 
so if you don’t want 
anchors generated for 
one of them rename it 
temporarily, insert the 
table of contents, and 
then rename it back

Tip: You cannot 
choose the text styles 
to include in the table 
of contents before 
generating it
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generating the index multiple times can lead to duplicate anchors that will make a mess 
of a PDF file’s bookmarks. To avoid this, delete the anchor when editing a heading 
before updating the table of contents.

1. Click the Update All Tables of Contents  icon in the Table of Contents 
panel to update all the tables in the document. This is the right of the two 
Update icons and is always available, regardless of what part of the document 
you are viewing or which tool you have selected.

2. To update a specific table of contents, position the text cursor in the table of 
contents frame or choose the table name from the TOC popup menu in the 
Table of Contents panel. Click the Update Table of Contents  icon to 
update the selected table. Publisher can also warn you that a table of contents 
is outdated through the Preflight panel which also offers a convenient Fix
button to update it.

To set the scope for a table of contents:

If your publication has only one table of contents, Publisher will automatically 
add all headings that are after the table of contents. You can also choose to 
include headings in the publication before the table of contents.

If you wish to limit the table’s scope or are working with multiple tables of con-
tents, you can choose from these options.

1. To include front matter headings on pages before the table of contents, select 
Include entries before TOC in the Table of Contents panel.

2. To limit the scope until the next table of contents is found, select Stop at next 
TOC in the Table of Contents panel.

3. Or to limit the scope to the current section, change Scope from Document to 
Section in the Table of Contents panel.

Tip: For tips on 
formatting and setting 
the scope of multiple 
tables of contents, 
refer to Pinning 
(anchoring) objects on 
page 108
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Formatting a table of contents
Publisher provides several formatting options in the Table of Contents panel to 
modify the table text that will be inserted.

Because a document can have more than one table of contents, the formatting 
options are saved as a TOC style. A TOC style is not a text style but a group of 
text styles used to format a table of contents. You can use the same TOC style for 
multiple tables of contents or a different style for each table, but you’ll need to 
use separate styles if you want modify formatting or the included heading levels.

To set the table of contents options:

1. To choose a different TOC style, select from the TOC Style popup menu in 
the Table of Contents panel.

2.  TOC Style formatting options: Use these options to customize the text 
inserted into the table of contents.

Item Purpose

Numbers before headings Position page numbers to the left of headings

Remove line breaks Replace manual line breaks in headings with spaces

Include inline pins Include images pinned in headings

Separator Inserted between the heading and page number;
 click the caret  icon on its left side to easily enter
 relevant special characters

Style Name Select which paragraph styles to include in the
 table of contents; click the menu icon  to the
 right of a selected style to Include Page Number
 (default) or change the Indent Level

Include page number Deselect to not display page numbers for this level
 of the table of contents; this is useful when you want
 to summarize the contents of a major topic

Indent level Set the hierarchy level for TOC anchors so book-
 marks are organized correctly in exported PDF files;
 Publisher will do this automatically if you use the
 standard Heading 1, 2, 3… text styles or Publisher’s
 equivalent for the user interface language in use;
 indent levels are numbered from 1

3. To rename a TOC style, click the menu  icon to the right of the TOC Style
popup menu and choose Rename… from the context menu.

Tip: Table of contents 
text styles are based 
on the document’s 
Base text style but you 
cannot change 
Publisher’s default 
formatting for a table 
of contents so refer to 
To import TOC styles 
from another docu-
ment on page 168 for 
more information

Tip: Indent level does 
not indent the text; 
edit the associated 
TOC text style to 
change the left indent 
value

Tip: Changes you 
make to a TOC style’s 
text styles or to the 
options in the Table of 
Contents panel are 
made immediately to 
the TOC style–there is 
not a command to 
save changes to the 
TOC style
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4. To delete a TOC style, click the menu  icon to the right of the TOC Style
popup menu and choose Delete from the context menu.

5. You can also create a new TOC style with the Create New… command but it’s 
unnecessary unless you deleted the automatic style created for an additional 
table of contents.

Using numbered headings in a table of contents:

If you create a table of contents for numbered headings the numbers cannot be 
removed automatically when the table is created; editing the TOC heading style 
will have no effect because the numbers are included as text.

When you insert the table of contents, the numbered headings will be poorly 
formatted because the number and heading are separated by a tab but the table of 
contents text styles have only one tab stop for between the heading text and page 
number. To fix this:

1. Position the text cursor in the table of contents heading you want to correct.

2. Using the Text Styles panel, click the menu  icon to the right of the heading 
text style and choose Edit “TOC #: Heading #”, where TOC # is the name of 
the table and Heading # is the name of the heading style.

3. Click Tab Stops in the left pane.

4. Click the Add New Tab Stop  icon and adjust the value for the new tab stop.

5. Click OK.
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To reformat the table of contents by editing its text styles:

When you insert a table of contents in a document for the first time, Publisher 
will create a number of additional text styles to control the table formatting. You 
can modify the attributes of these styles as required for your publication. These 
text styles are grouped into a table of contents style, referred to as a TOC style.

Each TOC style has its own set of text styles numbered in the order you create 
them so you can format each one separately. Because this can result in many text 
styles, table of contents styles are displayed in the Text Styles panel only when 
the text cursor is placed in a table of contents.

The styles are:

Style Purpose

¶ TOC 1: Entry Base style, not applied directly to the TOC; the TOC
  style for the first TOC you insert is named TOC 1 and
  additional ones are numbered sequentially

¶ TOC 1: Heading 1 For all TOC entries, numbered by level; if you use
  custom heading style names, they will be prefixed with
  the TOC name

a TOC 1: Number Base style, not applied directly to the TOC

a TOC 1: Heading 1 Number For the page number

To add a dot leader:

The default formatting for tables of contents doesn’t include a dot leader but you 
can add one.

1. Ensure Separator in the Table of Contents panel is set to  (tab), the 
default value.

2. Using the Frame Text  tool, position the text cursor in the table of contents.

3. Double-click the TOC 1: Entry style in the Text Styles panel to edit it, where 
TOC 1 is the name of the TOC style.

4. Select Tab Stops from the left pane. There will already be a right-aligned tab 
stop set to 0 from right.

5. Select (.) Tab stop leader character or one of the other leader characters from 
the list. You can also click the More  icon to chose a custom character.

Tip: TOC 1: Entry will 
be based on whatever 
style your level 1 
heading is based on; it 
is not advisable to 
change this

Tip: Publisher creates 
the table of contents 
text styles for you; 
while you can redefine 
the character and 
paragraph attributes 
of these styles, do not 
rename them because 
the modified name 
will not be shown
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6. Click OK.

To create clickable bookmarks for an exported PDF:

1. Select Include as PDF bookmarks in the Table of Contents panel. This 
option is specific to each table of contents so if you have more than one you 
can choose whether to select it for each table.

2. When exporting to PDF, you must also select Include bookmarks in the 
Export window.
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To exclude specific headings from a table of contents:

Sometimes you might want to exclude a specific heading from a table of contents 
yet wish to use the same heading style for that paragraph. There is more than one 
way to do this but the best option is:

1. Using the Frame Text  tool, position the text cursor in the heading to 
exclude.

2. Click the menu icon  beside the heading style name in the Text Styles panel
and choose Duplicate from the popup menu.

3. Name the new style Heading # Copy, where # is the number of the original 
heading.

4. Click OK. Paragraphs formatted with this new style won’t be included in the 
table of contents. Changes you make to the original heading style will be 
made to the duplicate style, too.

To include headings that do not appear in a publication:

Sometimes you might want to include headings that do not appear in a publica-
tion, such as list of advertisers, or perhaps the actual headings are images but you 
need plain text equivalents to appear in the table of contents.

In this manual, the chapter headings are written as “References 3” but as 
“3. References” in the table of contents. This was achieved by formatting the 
actual chapter headings with a paragraph style not used by the table of contents 
and then following the steps below to add a hidden layer for the heading used by 
the table of contents.

1. Using the Frame Text  tool, create a separate text frame for a heading that 
should be invisible. The frame does not need to be in the exact position 
because it will not be printed or exported to PDF.

2. Type the heading text and apply the heading style to it.

3. If the heading should move with the text on page, select the heading’s text 
frame and click the Float with Text  icon in the Toolbar at the top of the 
screen to pin the heading’s frame into the main text frame.

4. Choose Layer > Hide to make the heading’s frame invisible. The heading will 
still be included in the table of contents but it will not be printed on the page. 
You can also click the Toggle Visibility  icon next to the heading’s text 
frame’s layer in the Layers panel to show and hide the frame but you might 
have to expand the master page layer and the main text frame’s layer to find it.
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To include a chapter number prefix in the table of contents:

If you number chapter pages using a combination of section name and page 
number (for example, 1.1, 1.2, 1.3…), the section prefixes will not be included in 
the table of contents because they are not part of the page number. You must use 
a workaround to include the chapter’s section name prefix.

1. After each heading that will be included in the table of contents, type a tab 
character, insert a SectionName field, and type a period. An entry will look 
like this for a chapter with a section name of “7”:

White balance  7.

2. Select the tab and field and using either the Context Toolbar or Character 
Panel, set their text fill colour to none  to make them invisible. Repeat this 
for each heading.

3. Generate the table of contents but remove the tab from the Separator field in 
the Table of Contents panel because you already inserted a tab manually into 
each heading. The resulting entry will look like this:

White balance ................................................. 7.44

To switch between print and digital table of contents formatting:

If you want to be able to export your document with hyperlink style formatting 
for digital but plain text for print, you can do this with two TOC styles.

1. After generating the table of contents and adjusting the TOC text styles for 
print (or digital), click the menu  icon to the right of the TOC Style popup 
menu and choose Rename… from the context menu. Name it Print (or 
Digital, as appropriate) or another name of your choosing.

2. Click the menu icon again and choose Create New… from the context menu. 
Name this style Digital (or Print, as appropriate) or another name of your 
choosing.

3. Adjust this TOC style’s text styles for digital (or print).

4. To switch between the two styles, select the Print or Digital style name from 
the TOC Style popup menu and your table of contents will be reformatted 
automatically.



168 References

To import TOC styles from another document:

TOC styles cannot be exported independently but you can import a TOC style 
by adding a page from another document.

1. In the document from which you want to import a TOC style, rename the 
desired TOC style to something unique by clicking the menu  icon to the 
right of the TOC Style popup menu and choosing Rename… from the con-
text menu. For example, My TOC Style

2. Save that document and switch to the document in which you want to import 
the TOC style.

3. Using the Pages panel, note the absolute page number of the last page.

4. Choose Document > Add Pages from File… and select the first document.

• Page Numbers: There is no need to import all of the document’s pages 
since you just want the TOC style so enter the number of a single page to 
import.

• Pages: Enter the absolute page number of the last page you noted above. 
This will ensure the imported page is placed at the end of the document so 
it won’t disrupt an existing page spread.

Click OK.

5. Publisher will display a window listing the source (incoming) document’s text 
styles and noting any conflicts. Assuming you named the TOC style with a 
unique name, those styles will not have any conflicts.

Tip: The Pages panel 
will only show abso-
lute page numbers 
unless you use a 
section to restart page 
numbering, and then 
it will show the 
absolute page number 
followed by the 
relative number in 
parentheses, for 
example, Pages 60,61 
(54,55)
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• Deselect all text styles except for those that are part of the TOC style 
group that you named to avoid replacing an existing text style such as 
Body or Heading 1.

Click OK.

6. The page you chose will be added to the document. Select that page in the 
Pages panel and click its Delete  icon to remove it.

7. Using the Table of Contents panel, select the table of contents you want to 
style from the TOC popup menu near the top of the panel. If there is only one 
table of contents and you haven’t renamed it, it will be named TOC 1.

8. Choose the name of the TOC style you imported from the TOC Style popup 
menu in the panel. The table of contents will be reformatted using the 
imported TOC style.
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Working with multiple tables of contents
Most books have a single table of contents. If a book has more than one table of 
contents they can share a single TOC style as long as they have identical format-
ting, but if their formatting or settings differ you will need at least a second TOC 
style.

For demonstration purposes, this book also has chapter-specific tables of con-
tents at the start of each chapter, listing only the topics in that chapter. While 
Publisher provides the tools to do this, it takes some effort to format the tables 
consistently. The steps below instruct you to match the approach used for this 
book.

1. Follow the instructions in Using sections for chapters on page 27 to create a 
section for each chapter in the book.

2. Follow the instructions in Generating a table of contents on page 160 to insert 
the main table of contents. This first table will be named TOC 1 in the TOC
popup menu near the top of the Table of Contents panel. To rename this 
table of contents for your own convenience, click the Rename  icon, but this 
will not change its appearance.

3. Follow the instructions in Formatting a table of contents on page 162 to 
format this first table of contents. The first table will have a TOC style named 
TOC 1. To rename this TOC style for your own convenience, click the menu 

 icon to the right of the TOC Style popup menu and choose Rename…
from the context menu, but this will not change its appearance.

4. Sometimes you might need to customize a heading. For example, if your 
chapter headings are numbered and you use the same heading style for 
Introduction, it would be left aligned with the “1” for the following chapter 
name as shown in this example. One solution is to insert a tab before the 
word Introduction in that heading but to make it invisible. To do this, a tab 
stop can be created at 0.0001 pt for that heading. This invisible tab would 
become visible in the table of contents because its tab stop was set to match 
the other chapter headings.

5. Insert the second table of contents at the start of the first chapter. The second 
table and its TOC style will be named TOC 2.

6. Deselect Heading 1 from the Style Name popup menu because the chapter 
headings are formatted as Heading 1 and are not included in the chapter-spe-
cific tables.

7. Deselect Include as PDF bookmarks because you only want bookmarks 
generated from the main table of contents. While Publisher will not create 

Tip: Publisher doesn’t 
allow tab stops at 0 pt 
so 0.0001 pt was used 
as an approximation 
of 0 pt without adding 
so many decimal 
places that Publisher 
rounded it to zero
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duplicate bookmarks for the same heading, leaving this on will break the 
hierarchy of the PDF bookmarks because you deselected Heading 1 for this 
table.

8. By default, the scope for these chapter tables will be the same as for the main 
table. Include entries before TOC is not selected so the second table will start 
with subsequent headings. You could choose Stop at next TOC to prevent 
this table from including entries in the next chapter’s table but in this book 
the Appendices chapter heading needed to be excluded from the last chapter’s 
table. It’s possible to do that with a table of contents in a hidden layer just 
before the Appendices page but the better approach is to create sections, as 
you did in step 1, and to limit the scope of this table of contents to the current 
section by changing Scope from Document to Section.

9. Repeat steps 5 to 8 for each of the chapter-specific table of contents. 

10. The panel’s controls act on the table selected in TOC list. To switch between 
tables of contents, select the table name from TOC popup menu or click in 
the table of contents’ text frame. All of the chapter-specific tables of contents 
share the same formatting but as each table was inserted, Publisher created 
TOC styles for each chapter. Only two TOC styles are needed, TOC 1 for the 
main table and TOC 2 for the chapters, so the excess TOC styles were deleted 
to avoid later confusion. To delete a TOC style, select the table name from 
TOC list, click the menu  icon to the right of the TOC Style list, and choose 
Delete from the context menu. Ensure you choose TOC 2 from TOC Style for 
each of the chapter tables.

11. The left indent for the new chapter-specific tables is different than the main 
table because Heading 1 is not included. Unfortunately, it’s not possible to 
base one TOC style on another nor is it possible to make a copy of a TOC 
style and customize it. The TOC 2 style created by Publisher has none of the 
formatting that was set for the main table so all of the formatting would 
normally have to be repeated but there is a workaround. To do this, go to a 
chapter-specific table of contents and:

• Change TOC 2: Entry to be based on TOC 1: Entry instead of Base

• Change TOC 2: Heading 2 to be based on TOC 1: Heading 2 instead of 
TOC 2: Entry

• Change TOC 2: Heading 3 to be based on TOC 1: Heading 3 instead of 
TOC 2: Entry

The TOC 2: Heading 1 style was skipped because Heading 1 is not included in 
this table. There is no need to change the number styles.

12. Adjust the left indent for the TOC 2: Heading 2 and 3 text styles to complete 
the formatting of the chapter-specific tables of contents.
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Creating an index
Publisher can generate an index for your publication based on index marks that 
you add into your text. The index is normally placed at the end of the document 
and there can be only one index per document so you can’t create multiple 
specialized indices unless you use a workaround such as the one described in 
Creating multiple indices on page 183.

Publisher sorts index entries alphabetically with punctuation and symbols first, 
followed by numbers, A–Z, and then non-Roman language characters. You 
cannot customize the order of these categories but you can manually change the 
sort order of individual index entries.

An index is a block of special text that you can modify but when you update the 
index any changes you made to it will be lost. You should avoid making any edits 
to the generated text until the last stage before publishing. The index can be 
updated at any time and can be generated from a single document or from all of 
the chapter documents in a Publisher Book.

Publisher offers two approaches for creating an index. You can create its topics 
and then find the topics in the document to reference them or you can add index 
marks to create topics and references at the same time. Both approaches will 
create the same results but which approach is best for you depends on the publi-
cation and your working style. You can also use a combination of both 
approaches,

Parts of an index
The key parts of an index are the index topics, the words you have indexed, and 
the references which can be either the page numbers or cross-references to other 
index topics. A topic and reference are together referred to as an index entry. 
Some topics may not have a reference because they may list only subtopics.

Sample index

A
Aperture, 17, 192, 223
Aspect ratio, 33
Auto focus, 24

B
Bokeh, 67. See also Focus

D
Depth of field, 69
Dynamic range, 82

E
Exposure, 31–34, 79

F
Film speed, 54, 86
Focal length, 16, 81
Focus
 Auto focus, 29
 Manual focus, 25–27

H
Hot shoe, 29

I
Image stabilization, 18, 30
ISO. See Film speed

Index entry (index topic and index reference)

Index entry with a sub-topic

Style override for a primary reference

Cross-reference

Grouped page range

Index topic without a reference

Section heading

Tip: If you number 
chapter pages using a 
combination of 
section name and 
page number (for 
example, 1.1, 1.2, 
1.3…), the section 
prefixes will not be 
included in the index 
because they are not 
part of the page 
number
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Using the Index panel
To display the Index panel:

1. Choose Window > References > Index to display the Index panel.

2. Choose Show Topics from the panel menu  to view topics without refer-
ences. This view saves space and allows you to focus on the topics. Choose 
Show Topics and References to restore the default view.

Delete Insert Index UpdateInsert Mark

Panel menu

Add Topic Show/Hide Index Marks toggle

Filter the topic list

Expand/collapse a topic

Index formatting options
(click to collapse)

Index subtopic
Index topic

Index reference

Index cross-reference
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Adding index topics
You don’t have to create index topics manually because Publisher will create them 
automatically when you insert an index mark. These instructions are for those 
who prefer to create topics on their own before they add index references.

To create a topic list (optional):

If you want to create topics before reviewing where they are mentioned, you can 
add a list of topics to have available during indexing.

Creating topics in advance is optional because you can create a topic at the same 
time as you insert an index mark. Topics without any references added to them 
will not be listed in the index.

Publisher does not provide an option to import a topic list. The best way to create 
a list quickly is to enter the topic names into a temporary text frame and to copy 
the topic names to the clipboard one by one as you add them. Once you’ve added 
all of the topics, use the Find in document feature to quickly index all of the 
added topics.

To add an index topic:

1. Click the Add Topic  icon. This feature does not have a matching menu 
command so you can’t assign a keyboard shortcut to it.

2. Enter the Topic Name, for example, Auto focus. Ensure the capitalization is 
correct because there isn’t a global setting to adjust the capitalization of index 
topics.

3. Optional: To create a subtopic, select a Parent Topic from the list of existing 
topics. For example, select Focus to add Auto focus as a subtopic of Focus.

4. Optional: To override the automatic sorting of the topic, enter text for a 
custom sort order. For example, to sort van der Linden as Linden you would 
enter Linden for Sort By.

5. Optional: To create a cross-reference to another index topic, select the other 
topic from the list of existing topics under See. For example, select Focus to 
append See also Focus to the Bokeh topic. Refer to adding cross-references 
below for more information on See vs. See Also.

6. Click OK. The index topic will appear in the Index panel list.

Tip: You can create 
sub-subtopics to as 
many levels as 
required by selecting a 
subtopic as the Parent 
Topic

Tip: The Find in 
Document feature 
only searches the 
current document, not 
a Book comprised of 
multiple chapter 
documents
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To add a subtopic:

1. Right-click an index topic title in the Index panel and choose Edit topic…
from the context menu.

2. The features of the Add Index Topic window are the same for adding topics 
and subtopics.

To rename or edit an index topic:

1. To rename it, select an index topic title in the Index panel and then click it a 
second time—do not double-click. Enter a new name and press Return.

2. Or right-click an index topic title in the Index panel and choose Edit topic…
from the context menu. The features of the Edit Index Topic window are the 
same for adding topics.

To change the index topic for an index reference:

1. Using the Index panel, drag the index reference below another index topic.

To change the index parent topic for an index topic:

1. Using the Index panel, drag the index topic below another index topic.

To delete an index topic:

1. Select an index topic in the Index panel and then click the Delete  icon. The 
topic and all of its references will be deleted.

To import index topics from another document:

Publisher doesn’t provide a way to import or export index topics but it’s relatively 
easy to copy index topics, but only for those that have at least one reference 
(index mark).

1. Open the document containing the index topics to be copied.

2. Using the Frame Text  tool, select and copy the text containing the index 
references. If the references are in more than one story you will need to repeat 
this for each story.

3. Open the document to which the topics should be copied.

4. Using the Frame Text  tool, create a temporary text frame.

5. Paste the copied text into the frame using Edit > Paste or Paste Without 
Format. The latter will paste the text and index marks without importing any 
text styles.

6. Delete the pasted text. The text and its index references will be deleted but the 
index topics will remain.
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Adding index entries
An index entry is made up of an index topic and a reference which is either a 
page number or a cross-reference to another topic. When you insert an index 
mark in your text, you can create a new topic or choose an existing topic to 
associate it with.

When you insert an index mark a special character is inserted at the text cursor 
position or at the start of the selected word.

Publisher does not allow you to enter multiple references simultaneously so if 
you want to insert marks for multiple topics you will need to repeat the steps 
below.

To add a new reference to an index topic:

1. Using the Frame Text  tool, position the text cursor before, in, or after a 
word, or select a word.

2. Double-click the desired index topic or subtopic in the Index panel. Publisher 
will insert an index mark for the topic before the text cursor or selected text.

To add an index entry:

1. Using the Frame Text  tool, position the text cursor before, in, or after a 
word, or select a word. To index a phrase, select the range of text to index.

2. Click the Insert Mark  icon in the Index panel or choose Text > Index > 
Insert Index Mark.

3. The Topic field will be pre-filled with the word you clicked in or the words 
you selected. If the pre-filled text matches any topics in the list they will be 
suggested. If you select a subtopic from the list, it will also pre-fill the Parent 
Topic field. Alternatively, you can delete the pre-filled text and select from the 
full Topic list.

4. Optional: To make the topic a subtopic of another topic, select the Parent 
Topic or enter a new one. For example, to index Auto Focus as a subtopic of 
Focus, you would enter Auto Focus as the Topic and Focus as the Parent Topic. 
If the text pre-filled for Topic should be the Parent Topic, click the Move to 
Parent  icon to the right of the two fields.

Tip: Click the Show/
Hide Index Marks 
toggle  icon in the 
Index panel or Choose 
Text > Index > Show 
Index Marks to see the 
invisible index markers 
and avoid accidentally 
deleting them
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5. Optional: To indicate the primary reference for a topic, choose a character 
style from Style Override. This is typically used to bolden or italicize the page 
number of the most important page for an index topic.

6. Click OK. Publisher will insert an index mark before the text cursor or 
selected text. If the Topic or Parent Topic fields contains a topic that is not 
already in the list, Publisher will create it when inserting the index mark.

To quickly index many occurrences of a topic:

1. Right-click an index topic in the Index panel and choose Find in docu-
ment… from the context menu. The panel will list all occurrences of the topic 
title in the document with a checkbox beside them. The checkboxes for the 
existing reference(s) will be selected.

2. Click a list item to view it in context in the document window. Select its 
checkbox if you want to add an index mark for that occurrence.

3. Click the Done button after you have selected the desired occurrences of the 
topic.

To view an index mark in the document:

1. Double-click an index reference in the Index panel. Publisher will change the 
page displayed in the document window so that the index mark is visible.

2. Click the Show/Hide Index Marks toggle  icon in the Index panel or 
Choose Text > Index > Show Index Marks to see the invisible markers.

An index mark between two characters
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Adding index cross-references (See or See Also)
A cross-reference is an index reference that points to a related index topic rather 
than a page number in the document. For a topic that has a page number refer-
ence, a cross-reference will insert See also in the index entry. In the Sample index
on page 172, Bokeh has another page number reference so the cross-reference to 
Focus creates an index entry of:

Bokeh, 67. See also Focus

For a topic that has no page number references of its own, a cross-reference will 
insert See in the index entry. In the sample index, ISO doesn’t have a page 
number reference so the cross-reference to Film speed creates an index entry of:

ISO. See Film speed

To add a cross-reference to another index topic:

1. Right-click an index topic in the Index panel and choose Add cross-refer-
ence… from the context menu.

2. Select a topic from the See topic list.

3. Click OK. Publisher will add the cross-reference.

4. To customize the See and See also text that Publisher adds to the index, refer 
to Formatting an index on page 180.

To delete an index entry:

1. To delete the entire index entry, include the topic and its references, select an 
index topic in the Index panel and then click the Delete  icon.

2. To delete only the reference to a page number or a cross-reference, select the 
reference in the Index panel and click the Delete  icon.

Tip: Index cross-refer-
ences are unrelated to 
the general Creating 
cross-references
feature described on 
page 150
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Generating an index
It’s difficult to see the start and end of an index because Publisher doesn’t display 
it with any shading as in other applications. Until you’re experienced with work-
ing near the index text block, it is recommended that you insert the index into a 
separate text frame without any other text to avoid losing text when the index is 
updated.

The index inserted by Publisher does not include the title Index and you might 
consider placing even the title in a separate frame so that updating the index can 
replace all the text in the frame(s).

It doesn’t matter whether you create text frames for the index on a master page or 
whether you create them directly on a document page.

To insert the index:

1. Using the Frame Text  tool, create a text frame for the index and position 
the text cursor in it.

2. Click the Insert Index  icon in the Index panel or choose Text > Index > 
Insert Index. Publisher will insert the index into the frame.

3. If the index’s text frame has an overflowing Text Flow Out  control near 
the frame’s bottom-right corner, press Shift and click the control. Publisher 
will create as many pages of text frames as required to contain the index.

To update the index:

The index isn’t updated automatically when you add and delete index marks. It’s 
up to you to update the index before printing or exporting.

1. Click the Update Index  icon in the Index panel. The Preflight panel can 
also warn you when the index needs to be updated and offers a convenient 
Fix button that to update it.

To delete the index:

1. There isn’t a command or button to delete the index, so using the Frame Text
 tool, select all the text in the index text block and press Backspace or Delete.

Tip: For information 
on generating an 
index for a Book made 
up of separate chapter 
documents, refer to 
Adding references to a 
Book on page 146
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Formatting an index
Publisher provides several layout options in the Index panel to modify the index 
text that will be inserted. The options you select and the text you enter in this 
panel will be saved in your user defaults for future documents.

1.  Language: Use this to specify the language of the index for spell checking and 
hyphenation.

2.  Include section headings: Use this to add heading characters before all of the 
indexed words starting with A, B, C, etc. Publisher will add a letter for each 
character, including non-Roman alphabets, but not for the punctuation and 
numbers section. For example, 6-pack starts with a number so it would be 
sorted into the punctuation and numbers section but would not have a sec-
tion heading.

3.  Group page ranges: Use this to group references on sequential pages rather 
than listing each of them separately. For example, 7–9 instead of 7, 8, 9

4.  Expand cross-references: Use this to replace the See cross-reference for a 
topic that has no page number references of its own with the page number(s) 
of the cross-referenced topic. With this setting off, the Sample index on page 
172 inserted these entries in their respective sections:

Film speed, 54, 86
ISO. See Film speed

But with this setting on, it would insert:

Film speed, 54, 86
ISO, 54, 86

5.  Labels and separators: Use these options to customize the text inserted into 
the various parts of the index. Click the caret  icon on their left side to 
easily enter relevant special characters.

Item Purpose

After Topic Inserted after the topic name, default is comma + en space

Between Items Inserted between references, default is comma + space

Between Ranges Inserted between grouped page ranges, default is en dash

Before References Inserted before cross-references, not page numbers, default is
 period + space

See Inserted as part of a cross-reference, default is See

See Also Inserted as part of a cross-reference, default is See Also

After See (Also) Inserted after the See or See Also text, default is space

After References Inserted after the last cross-reference, default is space

Tip: To insert empty 
space between letters 
instead of section 
headings, edit the 
Index Section Heading 
style and change the 
text fill colour to white



Expert Guide to Affinity Publisher 181

To reformat the index by editing its text styles:

When you insert an index in a document for the first time, Publisher will add a 
number of additional text styles to your document to control the index format-
ting. You can modify the attributes of these styles as required for your publica-
tion. The styles are:

Style Purpose

¶ Index Base style, not applied directly to the index

¶ Index Entry Base style, not applied directly to the index

¶ Index Entry 1 For topics

¶ Index Entry 2 For subtopics, if they exist

¶ Index Section Heading For section headings (there is no option to
  insert a section heading for a character that
  lacks matching entries)

a Index Cross-reference Base style, not applied directly to the index

a Index Cross-reference Label For the words See and See Also

a Index Cross-reference Topic For the cross-reference topic name

a Index Entry Number Separator For the characters between multiple index entry
  page numbers; for example, 7–9, or 14, 22, 36

a Index Entry Page Number For the page numbers

To right align index page numbers or add a dot leader:

Publisher left aligns index page numbers but you can change this with text styles.

Aperture, 17, 192, 223
Aspect ratio, 33

 Auto focus, 24

Follow the steps below to format an index with this formatting:

Aperture ................................... 17, 192, 223
 Aspect ratio ................................................ 33
 Auto focus ................................................... 24

1. Delete all of the characters from the After Topic field of the Index panel.

2. Choose Tab from the field’s menu (click the caret  icon on its left side).

3. Double-click the Index Entry style in the Text Styles panel to edit it.

4. Select Tab Stops from the left pane and click the Add New Tab Stop  icon.

Tip: Publisher creates 
the index text styles 
for you; while you can 
redefine the character 
and paragraph 
attributes of these 
styles, do not rename 
them or Publisher will 
generate a new 
version when you 
update the index



182 References

5. Click the More  icon to display the popup settings window. Choose right 
alignment, select (.) (the tab stop leader), select From Right, and set Position
to 0.

6. Click OK.

Tip: If you can’t type 0 
into the Position field, 
use the down arrow to 
its right to reduce it to 
0
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Creating multiple indices
While you can create only one index with Publisher, there is a workaround but it 
involves manual work that must be repeated each time you update the index.

Index topics for a secondary index can be created as subtopics for a dummy
parent topic that you will later delete. After updating the index, you would simply 
cut the secondary index from the main index, paste it elsewhere, and reformat it 
to correct the indentation level.

The dummy topic can be named anything but it’s easiest to choose a name that 
will be sorted to the top of the index. If you chose one that sorted to the end of 
the index, the secondary index text might be overflowed from the main index’s 
text frame, making it difficult to select.

Publisher sorts punctuation before numbers and letters so it’s recommended to 
prefix the dummy topic name with an underscore. In the example below, the 
dummy topic is named _Film brands. When the index is generated, all of the 
subtopics of the dummy topic are sorted below it before the first entry of the 
main index.

Sample multiple indices

To add an index entry for a secondary index:

1. Index the term as you normally would but enter the dummy topic name into 
the Parent Topic field.

_Film brands
 Austria
  Lomography, 322
 Belgium
  Dan-Di, 306
 Germany
  ADOX, 324
  AGFA, 338
  Rollei, 306
 Hungary
  Forte

 Italy
  Ferrania, 314
 Japan
  Fujifilm, 307
  Konica, 316
…truncated example

A
Aperture, 17, 192, 223
Aspect ratio, 33
Auto focus, 24

B

First section heading

Punctuation and 
numbers section
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To generate and format a secondary index:

1. Using the Frame Text  tool, create a text frame for the secondary index just 
as you did for the main index.

2. Insert or update the main index as you normally would.

3. Select all the text from the start of the dummy topic name up to and including 
the paragraph break  at the end of the last secondary index entry.

4. Choose Edit > Cut.

5. Position the text cursor in the secondary index’s text frame and choose Edit > 
Paste.

6. Select the dummy topic name, including its paragraph break , and press 
Delete.

7. The secondary index entries are indented one level more than they should be 
since they were created as children of the dummy parent topic. If they are all 
the same indent level, you can simply choose Edit > Select All and then use 
the Paragraph panel, change the Left Indent and First Line Indent to match 
the main index’s first level index entry. If the secondary index has subtopics of 
its own, you must adjust the indent values for each entry manually because 
Publisher can’t change varying indent values by a relative amount.

To update a secondary index:

1. Each time you update the main index, the secondary index’s entries will be 
added to it. Repeat the steps for generating and formatting a secondary index 
each time you update the main index.



Expert Guide to Affinity Publisher 185

Creating notes
A note is text positioned at the bottom or side of a page or at the end of the 
chapter or publication and is used to cite other works or to provide comments on 
the main text. A note is made up of two parts: the note reference marker in the 
text and the note body.

Publisher offers three types of notes which you can use together in the same 
document. For each you can control the formatting of the note reference and the 
note body as well how the body is positioned. You can choose whether long notes 
can be split and continued in the next column or frame. Publisher will keep 
footnote and sidenote references and bodies on the same page, where possible.

• Footnotes are positioned at the bottom of the column or frame and can be 
positioned inside or below the frame. If a frame has more than one column 
you can choose whether they should span columns. They can be separated 
from the main text by a horizontal rule.

• Sidenotes are positioned to the left and/or right side of frames and are verti-
cally aligned with the marker, although multiple or long sidenotes may cause 
the vertical position to change.

• Endnotes are positioned at the end of the story, chapter, or document and 
don’t affect the layout of the main text but readers must navigate to the end of 
the text to find the corresponding endnote. Publisher can also insert a title for 
the endnotes.

Tip: Note references 
are not plain text so 
their characters 
cannot be found with 
Find and Replace and 
are not counted by 
Word Count

Tip: Choose Text > 
Notes > Show Note 
Markers when work-
ing with notes to see 
their markers more 
easily, and never edit 
endnotes without this 
selected
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Using the Notes panel
To display the Notes panel:

1. Choose Window > References > Notes to display the Notes panel.

Go to note reference

Panel menu

Insert note

Type of note

Go to note body

Scope of settings

Expand/collapse section

For footnotes only
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Adding notes
To insert a note into text:

1. Using the Frame Text  tool, position the text cursor where you want the 
note reference to be inserted.

2. Choose one of Text > Notes > Insert Footnote, Insert Sidenote, or Insert 
Endnote. Notes inserted via the menu will always use Document-wide
settings.

Or to insert a note using the Notes panel, choose Footnotes, Sidenotes, or 
Endnotes and choose Document-wide or Custom. Click the Insert Note
icon.

Publisher will insert the note reference and for a footnote or sidenote will 
adjust the text flow to accommodate the note body. The text cursor will move 
automatically to the note body to allow you to type the note.

3. When you have finished typing the note body, click the Go to Reference
icon to return to the main text.

To view the note body for a note reference:

1. Click the Go to Body  icon to move the text cursor from the note reference 
to the note body.

To view the note reference for a note body:

1. Click the Go to Reference  icon to move the text cursor from the note body 
to the note reference.

To edit a note:

1. Edit a note body as you would any other text. Choose Select All to select all 
the text in the note without selecting text outside of the note.

2. For endnotes, you must first select Text > Notes > Show Note Markers to see 
their enclosing brackets. Be very careful when placing the text cursor at the 
start or end of an endnote. If you start typing and notice that the text is 
outside of the endnote brackets you must undo what you have typed and 
move the cursor inside of the brackets.

3. If you copy and paste a range of story text that includes a note marker, the 
note will be pasted along with the text.

To delete a note:

1. You must delete the note reference to delete a note body. You can delete the 
note reference as you would any other character with Backspace or Delete. A 
field is treated as a single character so you need only press the key once.

The text cursor may look like it 
is to the left of this end bracket 
but it is actually to its right

Tip: For information 
on using notes in a 
Book made up of 
separate chapter 
documents, refer to 
Adding references to a 
Book on page 146

Tip: You cannot 
navigate from one 
note to the next so 
position the text 
cursor in a different 
note using the mouse

Tip: You can include 
inline and floating 
images in the note 
body; text wrap for 
floating images will 
apply only to the note 
body and not to the 
story text
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Converting one type of note to another
You can convert footnotes, sidenotes, and endnotes to either of the other types. 
You can convert all the notes in your document at once or just those in a 
selection.

To convert notes from one type to another:

1. Choose Convert Notes… from the Notes panel menu .

2. Choose the types of note you want to convert from and to.

3. Set Scope to Entire Document to convert all notes or to Current Selection to 
modify only the notes in the selected text.

To convert notes in selected text only:

1. Choose Convert Selection to Footnotes/Sidenotes/Endnotes, as applicable, 
from the Notes panel menu . This has the same effect as choosing Convert 
Notes… and setting the scope to Current Selection.
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Note settings
Note settings includes all of the numbering, formatting, and positioning options 
in the Notes panel. When you create a new note you can choose whether to 
create it with the document-wide settings or with custom settings for a specific 
note. The document-wide settings for a new document will be based on Pub-
lisher’s default settings which you can change to match those of the current 
document.

It is important to understand that the settings used to create a note depend on 
the Document-wide / Custom toggle. Once the note is created the toggle will 
have no further effect on the note and there is no user interface feedback as to 
which settings were used to create the note. Clicking in a note will not change the 
toggle to reflect whether it uses document-wide or custom settings.

You can revert the document-wide settings for a document back to Publisher’s 
default settings, and revert the default settings back to the original factory 
defaults. Changes are saved and reverted to all three types of notes at once.

Changing the document-wide settings will update the settings for all notes 
created using those settings but will have no impact on custom notes which each 
have their own individual settings. To change custom notes to the document 
settings you must use Revert Selected/All Notes to Document Settings.

You can’t create custom presets nor can you copy custom settings from one note 
to another, but you can copy a note reference (marker), paste it at the desired 
location, and then change its note body text.

To set the document-wide note settings:

1. If the text cursor is positioned in text, click on a blank area of the page or 
change to the Move  tool.

2. Choose one of Footnotes, Sidenotes, or Endnotes in the Notes panel.

3. Choose Document-wide.

4. Set any note options to update the document-wide settings.

To convert custom-formatted notes to the document-wide settings:

1. Using the Frame Text  tool, position the text cursor in a note with custom 
settings or select a range of text containing one or more note reference 
markers.

2. Choose Revert Selected Footnotes/Sidenotes/Endnotes to Document Set-
tings, as applicable, from the Notes panel menu . The command you 
choose will have no impact on the other two types of notes. Or choose Revert 
All Footnotes/Sidenotes/Endnotes to Document Settings to change all 
custom notes of the chosen type at once.

Tip: After using 
Custom to format a 
specific note, change 
the toggle back to 
Document-wide or 
the next note you 
insert with the panel 
will use custom 
settings

Tip: You can set 
document-wide 
settings only when the 
text cursor is not 
placed in a text frame 
or when the cursor is 
placed in a note of the 
same type that was 
created with docu-
ment-wide settings

Tip: The only way to 
know if a note uses 
document-wide or 
custom settings is to 
look in the panel 
menu;  if the Revert 
Selected Notes to 
Document Settings
command is disabled 
then the note uses 
document-wide 
settings and if it is 
enabled then it uses 
custom settings
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To convert notes using document-wide settings to custom settings:

1. Using the Frame Text  tool, position the text cursor in a note with docu-
ment-wide settings or select a range of text containing one or more note 
reference markers with document-wide settings.

2. Choose Custom from the Notes panel and define the settings for the selected 
notes.

To save the current document’s document-wide note settings as Publisher’s 
defaults:

1. Choose Save Document Settings as New Defaults from the Notes panel
menu .

To revert the current document’s note settings to Publisher’s defaults:

1. Choose Reset Document Settings to Factory defaults from the Notes panel
menu .

2. This will change only the current document’s settings, not Publisher’s current 
defaults. To change the defaults to the factory defaults, now choose Save 
Document Settings as New Defaults.

To change the current document’s note settings to match those of the 
current custom-formatted note:

1. Using the Frame Text  tool, position the text cursor in a note with custom 
settings.

2. Choose Update Document Settings from Selected Footnotes/Sidenotes/
Endnotes, as applicable, from the Notes panel menu . The command you 
choose will have no impact on the other two types of notes.
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Numbering notes
Notes are numbered automatically within a document, from the first to last page 
and from the bottom to top of the layer stack on each page, but you can restart 
numbering for each frame, page, story, or section. In the case of a Book you can 
also restart numbering every chapter.

There is one significant exception to the numbering of endnotes. Note references 
that are in text frames or tables pinned in another text frame will be numbered 
after the end of the story. If the story spans dozens of pages and you pin a text 
frame containing a note reference on the first page, it will be numbered after the 
last note on the last page of the story. If you must use notes in a pinned text 
frame then you should consider using footnotes in that frame and numbering 
them separately.

You can choose whether to restart note numbering every frame, page, story, 
section, document, or Book. 

To change note numbering:

1. Choose one of Footnotes, Sidenotes, or Endnotes in the Notes panel. Each 
type of note can be numbered separately.

2. Choose Document-wide to change the document’s settings or Custom to 
change the selected note(s) or the next one you insert. It is generally best to 
maintain a consistent numbering system within a document but you are able 
to use 1, 2, 3… for the document and A, B, C… for a custom note. However, 
if you restart numbering in a custom note it will impact subsequent docu-
ment-wide notes.

3. In the Numbering section, choose a Number format from the list. In addi-
tion to the standard number and letter options, you can choose symbols 
which numbers notes as *†‡§¶#, duplicating each symbol when the pattern 
repeats.

4. Choose the Start number and when to Restart numbering. By default, Pub-
lisher will restart numbering footnotes for each frame which you may want to 
change to story, section, or document. Numbering for sidenotes and endnotes 
restarts by default for each story which you may want to change to section or 
document.

5. For Custom-formatted notes you can also choose to Restart numbering now.

Tip: When using 
symbols for number-
ing, restart numbering 
every frame for best 
results due to the 
limited range of 
symbols

Tip: You cannot 
change Document-
wide settings while a 
Custom-formatted 
note is selected
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Formatting notes
Before changing note formatting:

1. Choose one of Footnotes, Sidenotes, or Endnotes in the Notes panel. Each 
type of note can be formatted separately.

2. Choose Document-wide to change the document’s settings or Custom to 
change the selected note(s) or the next one you insert. Refer to Note settings
on page 189 for more information.

To format the note reference marker:

In the Format section of the Notes panel, use the settings under In main text:

1. By default, the Number text will appear as a pound sign or hashtag  which 
inserts an automatic note number. You can enter additional character(s) such 
as enclosing brackets [ ]or click the caret  icon on its left side to easily 
enter relevant special characters.

2. Choose a character style from Number style to format the note reference 
marker. Ignore this if you are satisfied with the default reference marker’s 
appearance.

3. The reference marker is superscripted by default but you can deselect Super-
script for formats such as [#].

To format the note body text:

In the Format section of the Notes panel, use the settings under In note body:

1. The Number text, Number style, and Superscript options apply to the note 
number in the note body and are identical to those for the reference in the 
main text so refer to the above description. Number text in the note body 
defaults to  plus a space to provide a separator before the note text.

2. Choose a paragraph style from Note body style to format the text of the note’s 
text. The default is the Body style but you may want to create a unique style.

3. You can apply character styles and attributes directly to the note body text. If 
you apply formatting to the first character of the note body, the note body’s 
number will be formatted, too. To avoid this, position the text cursor before 
the first character, choose Text > Insert > Spaces and Tabs > Zero-Width 
Space. Then while pressing Shift, use � (Right Arrow) to select the text you 
want to format. As long as you don’t select the Zero-Width Space and apply 
formatting to it, the note number will be unaffected.

To link note references to note bodies:

1. Choose Generate hyperlinks if you want the note references to be linked to 
and from the note bodies in an exported PDF file. This is useful mainly for 
endnotes that are separated from the note references. Hyperlinks added for 
notes will not appear in the Hyperlinks panel as they are not editable.

2. Ensure Include Hyperlinks is selected when exporting to PDF.

Tip: The Superscript
option scales the font 
size so the character 
strokes will be thinner 
than normal text; 
disable this feature 
and apply a character 
style with Typography 
> Superscript enabled 
to take advantage of a 
font’s true superscript 
characters, if available

Tip: You can also avoid 
this by selecting a 
character style from In 
Note Body > Number 
Style but it must have 
the same type of 
character attributes 
defined; for example, if 
the first word of the 
note body is italicized 
and you don’t want 
the Number Text to be 
italicized, select a 
character style that 
has Italics set to off

Tip: You cannot 
change Document-
wide settings while a 
Custom-formatted 
note is selected
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Positioning notes
These controls determine how notes are positioned.

Before changing note positioning:

1. Choose one of Footnotes, Sidenotes, or Endnotes in the Notes panel. Each 
type of note can be formatted separately.

2. Choose Document-wide to change the document’s settings or Custom to 
change the selected note(s) or the next one you insert. Refer to Note settings
on page 189 for more information.

To position footnotes:

1. In the Positioning section of the Notes panel, choose a Note position option 
from the list.

• Below Text: Notes appear below the last line of story text in the text frame 
or column.

• Bottom of Column (default): Notes appear inside the bottom of the frame, 
spanning only one column if there are multiple columns. This is the most 
common setting for books.

• Bottom of Frame: Notes appear inside the bottom of the frame and span 
the width of the frame if there are multiple columns.

• Below Frame (not recommended): Notes appear below the text frame in 
an adjacent note frame. You can specify their maximum height to ensure 
they don’t flow off the bottom of the page.

2. Set Min gap before to define the desired whitespace between the story text 
and the start of the first footnote and set Gap between to define the vertical 
space between each footnote. You can also set Initial advance and Min 
advance to define the position of the footnote’s first baseline; refer to Initial 
Advance on page 52.

3. Set Allow split notes to allow footnotes to be continued in the next column or 
frame to reduce undesired whitespace.

4. Set Pack short notes to start footnotes on the same line as the previous foot-
note’s body, and Short note gap to define the horizontal distance between 
them.

Tip: Choose Text > 
Insert > Breaks > 
Column Break to split 
a footnote earlier than 
Allow split notes will 
do

Tip: You cannot 
change Document-
wide settings while a 
Custom-formatted 
note is selected

Tip: Unlike in Adobe®
InDesign®, the Keep 
Together paragraph 
flow setting does not 
override Allow split 
notes
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5. In the Rules section, select First Note from Rule before to define the rule 
above a footnote, or Continued Note to define the rule above a note split 
from the previous column or text frame with Allow split notes.

6. Select Draw rule if you want a rule (line) to separate the first or continued 
footnote and then select the Stroke style including colour, width, and other 
options. Set Left indent and Length to define the width of the rule and Verti-
cal offset to define the rule’s position relative to the start of the first note.

To position sidenotes:

1. In the Positioning section of the Notes panel, choose a Note position option 
from the list.

• Left of Frame: Notes appear to the left of the text frame, even if the note 
reference is not in the leftmost column of the frame.

• Right of Frame: Notes appear to the right of the text frame, even if the 
note reference is not in the rightmost column of the frame.

• Away From Spine (recommended): In a facing-pages document, in the 
outer margin. In a non-facing-pages document, this is the same as Left of 
Frame.

• Towards Spine: In a facing-pages document, in the inner margin. In a 
non-facing-pages document, this is the same as Right of Frame.

• Alternate Sides: The first note in the frame will be on the outer (or left) 
side, the next on the inner (or right) side, etc.

• Closest Side (default): Notes appear on the side that is closest to the note 
reference. Adding and removing text will cause the notes to change sides.

2. Set Width and Distance from frame to define the size and position of the 
sidenote.

3. Set Min gap between to define the vertical space between each sidenote. You 
can also set Initial advance and Min advance to define the position of the 
sidenote’s first baseline; refer to Initial Advance on page 52.

4. Set Allow split notes to allow sidenotes to be continued on the side of the 
next text frame for the main story. Split sidenotes are less common than split 
footnotes.

Tip: To change the 
space before the rule, 
use Min gap before in 
the Positioning 
section
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To position endnotes:

1. In the Positioning section of the Notes panel, choose a Note position option 
from the list.

• End of Story: Notes appear below the last line of text in the story in the 
same text frame.

• Separate Frame: Notes appear in a new text frame after the story’s last text 
frame to create separate endnotes for each story.

• Shared Section Frame: Notes appear in a new text frame after the section’s 
last page to create separate endnotes for each section.

• Shared Document Frame (default): Notes appear in a new text frame after 
the document’s last page to create endnotes for the entire document. This 
is the most common setting for books.

• End of Book: Refer to Adding references to a Book on page 146.

2. Set Min gap before to define the desired whitespace between the story text 
and the start of the first endnote and set Gap between to define the vertical 
space between each footnote. You can also set Initial advance and Min 
advance to define the position of the footnote’s first baseline; refer to Initial 
Advance on page 52.

3. In the Title section of the Notes panel, enter the Title text and select a para-
graph style from Title style to create an automatic heading for endnotes 
displayed in a separate frame than the story text. To create your own heading, 
leave the Title text field blank.

How notes work:

Footnotes and sidenotes, as well as endnotes positioned at the end of a story, are 
stored in individual text frames associated with a note reference marker. These 
frames are similar to a pinned text frame so if you expand the main text frame’s 
layer in the Layers panel you’ll see that the note frames are child layers.

Publisher will display X handles at the corners and midpoints of a selected note 
to indicate that you cannot move or scale the layer. The width of the text frame 
for footnotes and endnotes is determined by the column or frame they are asso-
ciated with while the width of the frame for sidenotes is set in the Notes panel. 
The height is always determined by the note’s content.
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Importing notes from Microsoft® Word
Footnotes imported from a Microsoft® Word .docx file will all use custom set-
tings because they won’t match the document’s Document-wide settings. They 
will likely all have a paragraph style named Footnote Text which you could rede-
fine in Publisher but footnotes aren’t properly formatted after importing from 
Word so it is recommended you reformat them in Publisher.

1. After importing the .docx file, choose Revert all Footnotes to Document 
Settings from the Notes panel menu .

2. The footnotes will now be formatted with the document-wide settings (which 
default to Body as the Note body style) and likely the Footnote Reference
character style imported from Word. Footnote Reference was intended for the 
note reference marker and the number in the note body and not the rest of 
the note body, so you should remove it from the note bodies. First, define a 
new character style for the note bodies named Note Body and base it on the 
Body paragraph style, you can change the attributes for it later as desired. The 
choice of name is unimportant.

3. Using the Find and Replace panel, click the Find formatting  icon for Find
and select Footnote Reference from the Character Style menu and Body from 
Paragraph Style. Click the Find formatting  icon for Replace and select the 
new Note Body style you created above. Do not enter text in the Find or 
Replace fields. This step assumes that the document-wide settings for foot-
notes uses Body as the Note body style and that the body text imported from 
Word is not formatted with Body.

4. Click Find and then click Replace All.
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Using fields
A field is variable text that you insert into your document and which Publisher 
can update. Fields are used to insert information such as page numbers, section 
names, dates, and metadata. If you insert them on a master page the information 
displayed on a document page will be relative to that page and its section.

Publisher offers three types of fields:

• Metadata: These fields store information about the document such as title, 
author, and keywords and you can edit their values. All fields can be inserted 
into document text but these fields are commonly used for PDF metadata.

• Variables: These fields display dynamic values such as page number, section 
name, and saved date. Their values cannot be edited.

• Custom variables: You can also create your own fields and edit their names 
and values.

Using the Fields panel
To display the Fields panel:

1. Choose Window > References > Fields to display the Fields panel.

2. Collapse and expand the panel’s sections by clicking the caret  icons to the 
left of their titles.

Tip: A field is not plain 
text so its value 
cannot be found with 
Find and Replace and 
is counted as one 
character and one 
word by the Word 
Count feature regard-
less of how many 
characters or words it 
displays

Tip: Fields are specific 
to a document and 
cannot be synced 
across chapters of a 
Book or imported into 
another document

Delete Insert Index UpdateInsert Mark

Panel menu
Section name

Field name Metadata field value

Edit format or set format default

Variable field value’s placeholder
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Inserting fields
Some of the common fields are available from the Text > Insert > Fields menu 
but you must use the Fields panel to access most of them.

To insert a field:

1. Using the Frame Text  tool, position the text cursor where you want the 
field to be inserted.

2. Insert the desired field by double-clicking its name in the Fields panel or by 
choosing it from Text > Insert > Fields.

3. Choose Text > Highlight Fields to add shading behind fields such as page 
numbers to make them easier to see while editing your document. This 
shading will not be printed.

To edit the value of a metadata field:

1. Click a field value in the Fields panel and then click it a second time—do not 
double-click. Enter a new value and press Return.

To delete a field:

1. Delete a field as you would any other character with Backspace or Delete. A 
field is treated as a single character so you need only press the key once.

To expand a field and convert it to regular text:

1. Using the Frame Text  tool, right-click the field in the document text and 
choose Expand Field from the context menu.

Tip: You can also 
double-click the value 
to insert non-editable 
fields such as dates 
but it’s better to 
always double-click 
the field names 
because some fields 
can be edited in the 
panel by clicking them
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Field types
All page number fields display page numbers in the numbering format defined 
for the field’s section and are relative to the section’s starting page number. If you 
haven’t used sections in the document, page numbers will be numbered 1, 2, 3…

Section Field Displays

Document Information Author User who created the document; you can change the name

 Tags Keywords, used for PDF export; use commas to separate them

 Comments Freeform text of your choice, this isn’t displayed anywhere else

 Title Freeform text for a PDF file’s title

 Subject Freeform text for a PDF file’s subject

 Revision For your own use, this isn’t displayed anywhere else

Document Statistics Last edited by User who last saved the document; you can change the name

 Created Date the document was created or last use of Save As

 Saved Date the document was last saved

 Printed/Exported Date the document was last printed or exported

 Save Count Number of times the document has been saved since creation or
  last use of Save As

 Filename Name of the .afpub file on your computer

 Path Path to the .afpub file on your computer

 Total Pages Number of pages in the document

Document Sections Name Name of the section in which the field is inserted

 Running header First or last use of styled text on a page; refer to Running headers on
page 28

 Page Number Page number on which the field is inserted; refer to Page numbering
  on page 23

 Last Page Page number of the last page in the section in which the field is
  inserted

 Run Last Page Page number of the last page before which page numbering is
  restarted

Continuation Previous Frame Page number of the page for the previous text frame the field’s frame
  is linked to; if there isn’t a previous frame then it will be blank

 Next Frame Page number of the page for the next text frame the field’s frame
  is linked to; if there isn’t a previous frame then it will be blank

General Information Date & Time Date and time when the field was inserted or last updated

Tip: To set the default 
value for Author, edit 
this field when no 
documents are open
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Section Field Displays

Data Merge Source Filename of the external data source

 Merge Index Numerical order of the merged record from the filtered index

 Unfiltered Index Numerical order of the merged record from the unfiltered index

Data Merge - filename <dynamic> Fields are generated from the external data source

Custom <user defined> Fields are defined by the user

Formatting fields
The date and Running Header fields allow you to customize their formatting.

To format a field:

1. Using the Frame Text  tool, right-click the field in the document text and 
choose Edit Field… from the context menu. You can also select the field or 
position the text cursor before or after it and then click the respective Edit
icon beside the field in the Fields panel.

2. Format the field. Refer to Running headers on page 28 for information on 
formatting a running header. For dates, select a Language if the field’s lan-
guage doesn’t match the language of the surrounding text. Choose one of the 
preset date and/or time formats or click Custom and enter a custom format 
into the Pattern field. Refer to the table on the following page for more 
information.

3. Click Close.

To set the default formatting for a field:

1. Position the text cursor away from date or Running Header fields and click 
the respective Edit  icon beside the field in the Fields panel.

2. Format the field and click Close. The formatting options are the same as for 
formatting a specific field.

Date and time formatting options:

Combine the following symbols in the Pattern field. Note that many are case 
sensitive. Plain text such as Today’s date: must be enclosed in apostrophes and its 
apostrophe repeated as ‘Today’’ date: ’. Non-alphabetic characters such as dashes, 
commas, periods and colons do not need to be enclosed in apostrophes.
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Symbol Meaning Pattern Examples for September 3, 2023

G Era G AD
  GGGG Anno Domini
  GGGGG A

y Year y 2023 
  yy 23

Q Quarter Q, QQ 2 Use QQ to prefix single digits with 0
  QQQ Q2
  QQQQ 2nd quarter

M Month in year M, MM 9, 09 Use MM to prefix single digits with 0
  MMM Sep
  MMMM September
  MMMMM S

L Standalone month in year L, LL 9, 09 Use LL to prefix single digits with 0
  LLL Sep
  LLLL September
  LLLLL S

w Week of year w, ww 36, 36 Use ww to prefix single digits with 0

W Week of month W, WW 4, 04 Use WW to prefix single digits with 0

d Day in month d, dd 3, 03 Use dd to prefix single digits with 0

D Day of year D, DD, DDD 246, 246, 246 Use DD to prefix single digits with 0 or DDD to
    prefix single digits with 00

F Day of week in month F, FF 1, 01 Example is first Sunday in September
    Use FF to prefix single digits with 0

E Day of week E Sun Example is Sunday
  EEEE Sunday
  EEEEE S
  EEEEEE Su

e Local day of week e, ee 1, 01 Varies by language
  eee Sun
  eeee Sunday
  eeeee S
  eeeeee Su

Tip: Sunday is the 1st 
day of the week for 
English US and some 
other languages but 
the 7th day of the week 
for others such as 
English UK

Tip: Use Standalone 
month in year for 
languages that spell 
the month differently 
in a full date versus 
standalone; for 
example, September 
22 in Polish is 22 
września but Septem-
ber 2023 is wrzesień 
2023
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Symbol Meaning Pattern Examples for 6:07:05 p.m. EDT

a AM or PM a varies PM (US), pm (UK, Australia), or p.m. (Canada)
  aaaaa varies p (US, UK), pm (Canada, Australia)

B Flexible day periods B varies Possible values are “in the morning”, “noon”,
    “in the afternoon”, “in the evening”, and “at
    night” (US, UK, Canada) or “morning”,
    “midday”, “afternoon”, “evening”, and “night”
    (Australia)

h Hour in day (1-12) h, hh 6, 06 Use hh to prefix single digit with 0

H Hour (0-23) H, HH 18, 18 Use HH to prefix single digit with 0

k Hour number in day (1-24) k, kk 19, 19 Use kk to prefix single digit with 0

K Hour in AM/PM (0-11) K, KK 7, 07 Use KK to prefix single digit with 0

m Minute in hour (0-59) m, mm 7, 07 Use mm to prefix single digit with 0

s Second in minute (0-59) s, ss 5, 05 Use ss to prefix single digit with 0

z Time Zone z EDT 
  zzzz Eastern Daylight Saving Time

O Time zone: localized 0 GMT-4 “O” is a letter, not a zero
  0000 GMT-04:00

V Time zone: ID V usnyc Example is New York city
  VV America/New_York
 Time zone: exemplar city VVV New York
 Time zone: generic location VVVV New York Time 

x Time zone: ISO8601 basic x -04
 Time zone: ISO8601 basic xx -0400
 Time zone: ISO8601 extended xxx -04:00
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Creating custom variables
Custom variables are fields that you create for use in your document. For exam-
ple, you might use a custom variable as a placeholder for a product or company 
name that will be finalized or revealed at a later date. Custom variables are also 
useful for customizing previously-created documents for individual clients.

To manually create a custom variable:

1. Expand the Custom section of the Fields panel.

2. Click the Create Custom Field  icon.

3. Enter a unique Name for the field and its initial Value.

4. Click Close.

To create a custom variable based on existing text:

1. If the existing text is longer than a single word, select the text.

2. Right-click the text and choose Convert Text to Field… The custom variable 
will be created immediately using the selected text or the word you right-
clicked for both the field name and value. The Custom Field Properties
window will appear to allow you to rename the field.

To change the value of a custom variable:

1. Click the field’s value in the Fields panel and then click it a second time—do 
not double-click. Enter a new value and press Return. You can also right-click 
the field in the text frame and choose Edit Field from the context menu.

To rename a custom variable:

1. Click the Edit  icon to the right of the field in the Fields panel. You can also 
right-click the field in the text frame and choose Edit Field from the context 
menu.

2. The options are the same as for creating a custom field.

To delete a custom variable:

1. Click the Edit  icon to the right of the field in the Fields panel. Click the 
Delete  icon in the popup window.

Tip: The field will be 
formatted using the 
attributes of the first 
character, so if you 
converted two words 
to a field and the 
second word was bold, 
the bold formatting 
would be removed
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To import custom variables into another document:

Custom variables are specific to a document and cannot be synced across chap-
ters of a Book or directly imported into another document. However, you can 
copy and paste custom variables to another document.

1. Using the Frame Text  tool, select a custom variable field and choose Copy 
from the context menu. You can also copy a range of text containing one or 
more custom variables or select its text frame.

2. Switch to the target document and choose Edit > Paste. The custom variables 
will be imported into the new document.
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Using anchors
An anchor is a position in a document that you can link to with a hyperlink or 
cross-reference or which you can use as a bookmark in an exported PDF file.

Anchors can be inserted between two characters of text or added to an object 
such as a shape or text frame. Text anchors will move with the text as you add 
and remove text before them in the story while object anchors will remain 
attached to the object.

It’s very easy to delete text anchors by mistake because they are non-printing 
characters. It’s recommended that you enable Show Anchors when working with 
text anchors. Object anchors are never visible and can be found only with the 
Anchors panel.

You can create text and object anchors manually and Publisher will create text 
anchors automatically when a table of contents is generated or when a cross-ref-
erence is added. The table of contents feature uses anchors to link its page num-
bers to pages while the cross-references feature uses anchors as the targets for its 
references.

Using the Anchors panel
To display the Anchors panel:

1. Choose Window > References > Anchors to display the Anchors panel.

2. Collapse or expand parent anchors by clicking the caret  icons to the left of 
their names—they won’t stay collapsed but it may help

3. Filter the list of anchors to just those on a specific page by choosing a specific 
page from the Area popup menu that defaults to All Spreads. If the document 
is a chapter of an open Book, All Spreads will be renamed to Current Chapter
and an All Chapters option will be added. Choosing All Chapters will show 
anchors in all of the Book’s chapters, allowing you to go to any of them even if 
the chapter is not open. Anchors not in the current chapter are listed with a 
Chapter  icon beside them.

Tip: While Publisher 
doesn’t allow anchors 
to be applied to a 
page like bookmarks 
in Adobe® InDesign®, 
they can be applied to 
an object for more 
flexibility

Go to anchor Add new anchor

Panel menu

Filter by area

Selected anchor

Parent anchor

Child anchor

Export as PDF bookmark

Delete

Tip: Anchors are not 
displayed in the order 
they appear in the 
document or in the 
order bookmarks will 
appear in an exported 
PDF

Definition: An anchor
is a marker in your 
document
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Inserting anchors
You can add anchors manually but Publisher will also create them automatically 
if you insert a table of contents or target paragraphs or index marks with cross-
references. If you plan to add a table of contents, it is recommended that you not 
add anchors for any headings because the table of contents feature will generate 
them automatically. You might instead consider adding the table of contents to 
your publication earlier than you need to and updating it as you work so that the 
anchors are available to you for other purposes.

If you plan to cross-reference your publication by targeting paragraphs or index 
marks, the cross-references feature will automatically insert anchors for the 
targets. But you might prefer to add anchors manually and use them as targets 
when you cross-reference your publication.

To view text anchors:

1. Choose Text > Interactive > Show Anchors to view the non-printing anchor 
symbols. These are not turned on with Text > Show Special Characters.

To insert an anchor:

1. Using the Frame Text  tool, select a word or words or position the text 
cursor before or after a word. Selected text will be used as the anchor’s default 
name.

Or to add an anchor to an object, select an object using the Move  tool.

2. Click the New Anchor  icon in the Anchors panel or choose Text > Inter-
active > Insert Anchor…

3. The Name field will be pre-filled if you selected text. If you placed the text 
cursor or selected an object, the anchor name will default to Anchor # where # 
is the next unused default anchor number. It is recommended that you enter a 
useful name if you intend to export this anchor as a PDF bookmark. A 
unique name will also avoid later confusion over the purpose of an anchor.

4. Select Export as PDF Bookmark (default) to include this anchor as a book-
mark in an exported PDF file.

An anchor symbol between two characters
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5.  From Data Merge and Field are used only for data merging which is beyond 
the scope of this manual.

To delete an anchor:

1. Select an anchor in the Anchors panel and then click the Remove Anchor
icon.

Or position the text cursor before or after a text anchor or select an object 
with an anchor and choose Text > Interactive > Delete Anchor.

You can also delete a text anchor reference as you would any other character 
with Backspace or Delete.

To rename an anchor:

1. Select an anchor in the Anchors panel and then click it a second time—do 
not double-click. Enter a new name and press Return.

Or position the text cursor before or after a text anchor or select an object 
with an anchor and choose Text > Interactive > Anchor Properties… The 
options are the same as for inserting an anchor.

To convert an anchor to a PDF bookmark:

1. Click the Bookmark  icon to the right of the anchor name in the Anchors 
panel.

Or position the text cursor before or after a text anchor or select an object 
with an anchor, choose Text > Interactive > Anchor Properties…, and select 
Export as PDF bookmark.

To move a text anchor:

You can cut and paste anchors just like any other character except that they have 
no width and can be difficult to select.

1. If text anchors are not already visible, choose Text > Interactive > Show 
Anchors to view the non-printing anchor symbols.

2. Using the Frame Text  tool, position the text cursor before or after the 
anchor. Press Shift + � or �, depending on where you placed the text cursor.

If you’re unsure if the text cursor is to the left or right of the anchor, press �
or � (Left Arrow or Right Arrow) and if the text cursor doesn’t move, you just 
moved past it in that direction.

3. If the anchor was the target of a cross-reference you will need to reselect the 
cross-reference target with the Cross-References panel.

To make an anchor a child of another anchor:

1. Drag an anchor’s name in the panel over the desired parent anchor and then 
release the mouse button when the parent anchor becomes blue. You can also 
drag the anchor between two other anchors to make it a child of those 
anchors’ parent but you can’t specify the exact position.

Tip: Don’t change the 
hierarchy of anchors 
generated by the 
Table of Contents 
feature because they 
will return to their 
original position when 
you update the table 
of contents

Tip: Don’t rename 
anchors generated by 
the Table of Contents 
feature because 
duplicate anchors will 
be created when you 
update the table of 
contents

Tip: Don’t cut and 
paste anchors gener-
ated by the Table of 
Contents because 
duplicate anchors will 
be created when you 
update the table of 
contents
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To export a document to PDF and include PDF bookmarks:

1. Choose File > Export…

2. Select PDF from the popup menu of file types.

3. Select a preset such as PDF (for digital - high quality).

4. If Advanced > Include bookmarks is not selected for the preset you chose, 
select it now

You may need to enable bookmarks if they are not visible in your PDF viewer 
software. Adobe® Acrobat® Reader displays PDF bookmarks by default but if 
they’re not visible choose View > Show/Hide > Navigation Panes > Bookmarks. 
Apple Preview does not display PDF bookmarks by default so choose View > 
Table of Contents.
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Using hyperlinks
A hyperlink allows the reader of a PDF or eBook to jump to another location in 
the same publication, another file, a website, or to start an email with their 
device’s default mail application. A hyperlink can be applied to a range of text or 
to an object.

Using the Hyperlinks panel
To display the Hyperlinks panel:

1. Choose Window > References > Hyperlinks to display the Hyperlinks panel.

2. Filter the list of hyperlinks to just those on a specific page by choosing a 
specific page from the Area popup menu that defaults to All Spreads.

3. Filter the list of hyperlinks by choosing a single type of hyperlink from the 
Type popup menu that defaults to All Types.

Inserting hyperlinks
Page and Section are most useful for objects since you can’t CR an object

File is just for relative links, the file isn’t incorporated

To insert a hyperlink:

1. Using the Frame Text  tool, select a range of text. The selected text will be 
used as the default URL if you choose the URL type.

Or to add a hyperlink to an object, select an object using the Move  tool.

2. Click the Add Hyperlink  icon in the Hyperlinks panel or choose Text > 
Interactive > Insert Hyperlink…

Tip: Unlike the 
Anchors panel, the 
Hyperlinks panel
cannot list hyperlinks 
in other chapters for a 
Book

Tip: The table of 
contents, index, and 
cross-references can 
be hyperlinked 
automatically but their 
links are not listed in 
this panel

Tip: While you could 
use a hyperlink and an 
anchor to create a 
cross-reference, it’s 
easier to do this with 
the cross-references 
feature which can also 
automatically update 
a page number or the 
link text

Go to Source Go to Target Edit Hyperlink Add Hyperlink

Panel menu

Filter by area
Filter by type

Toggle sort

Child anchor

Selected hyperlink

Delete hyperlink
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3. Choose the Type of the hyperlink:

• Anchor: Select a text or object anchor from the Anchor list. If the 
document is a chapter in an open Book, the Chapter popup menu will 
allow you to select an anchor in a different chapter. Refer to Using anchors
on page 205 for information on creating anchors.

• Email: Enter an email address so that when the reader clicks the hyper-
link, a new email will be started using the reader’s default mail application. 
Do not include mailto: in the field but you can use the standard ?subject=
syntax, as long as you escape the spaces in the subject with %20.

• File: Click the More  icon to browse to a PDF file on your computer, 
which if you select the additional option to Include file on export will be 
linked with a relative URL in the exported PDF file so they can be 
uploaded together. If you don’t select Include file on export then an 
absolute URL to the file on your computer will be used.

• Page: Select a page number in the current document—the target is to a 
page number so if you add or remove pages the content of the target page 
number might be different. Use Anchor if you want the target to move as 
pages are added and removed.

• Section: Select a section in the current document.

• URL: Enter an absolute URL for a website page or file. Use File if you 
need a relative URL; inclusion of http/https is optional.

4.  From Data Merge and Field are available for all but Page and Section and are 
used only for data merging which is beyond the scope of this manual.

5.  Character Style: Select a character style to apply to the hyperlink. Publisher 
will create a default style named Hyperlink if you select Hyperlink from the list 
for a document that lacks this style.

6. Click OK.

Tip: Although you can 
select any type of file, 
the File feature works 
reliably only with PDF 
files; you may get an 
error when attempting 
to export a document 
that includes a link to 
a different type of file
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To delete a hyperlink:

1. Select a hyperlink in the Hyperlinks panel and then click the Delete Hyper-
link  icon.

Or position the text cursor before or after a hyperlink or select an object to 
which a hyperlink is applied and choose Text > Interactive > Delete Hyper-
link. Or select a range of text that includes the hyperlink or the object to 
which a hyperlink is applied and delete it.

To edit a hyperlink:

1. Position the text cursor in, before, or after a hyperlink or select an object with 
a hyperlink and choose Text > Interactive > Edit Hyperlink…, or double-
click the hyperlink in the Hyperlinks panel. The options are the same as for 
inserting a hyperlink.

To rename a hyperlink:

1. Select a hyperlink in the Hyperlinks panel and then click it a second time—
do not double-click. Enter a new name and press Return. The name has no 
impact on the hyperlink but is helpful for keeping track of the hyperlinks in a 
document

To find a hyperlink in the document:

1. Select a hyperlink in the Hyperlinks panel and click the Go to Source  icon.

To view the target of a hyperlink:

1. Select a hyperlink in the Hyperlinks panel and click the Go to Target  icon.

Or position the text cursor before or after a hyperlink or select an object to 
which a hyperlink is applied and choose Text > Interactive > Go to Hyper-
link Target.

To fix a broken hyperlink:

1. If you delete the target of an Anchor, Page, or Section hyperlink, Publisher 
will display a Broken Hyperlink  icon in the Hyperlinks panel. Delete the 
hyperlink or edit it to select a new target.
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Although you can use Publisher for almost any visual project, 
most users of Publisher use it to print directly to a local printer, to 
prepare a PDF file to be printed at a large-format or high-volume 
digital printing press, or to prepare a PDF file to be converted to 
film for printing on a commercial press.

Printing a document on a commercial press used to mean print-
ing colour separations to a PostScript file for delivery to a print 
partner, also referred to as a service bureau or service provider. 
The commercial operator would send the PostScript file to an 
Imagesetter for conversion to film. All of the work was done up 
front on your computer so you had complete control of the final 
product, but also the responsibility to get it right. This some-
times led to poor colour because the publishing application 
wasn’t optimized for the specific printing press and type of 
paper.

With newer applications such as Publisher, documents are 
exported to a PDF file and the print partner handles the colour 
separations to ensure colour fidelity with the printing press and 
paper.

Not every document will be printed and Publisher allows you to 
export to a PDF file suitable for digital distribution. It doesn’t 
include optimized workflows for generating ebooks but a stan-
dard PDF can be converted to an ebook with specialized soft-
ware.

In this chapter
Preflighting documents ...........................................................................214
Printing directly to a printer ...................................................................220
Exporting to PDF for digital distribution ...........................................224
Printing on a commercial press .............................................................228
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Preflighting documents
Preflight helps you avoid mistakes before printing or exporting a document. It 
can alert you to errors including spelling, overset text, broken cross-references, 
out-of-date indices and tables of contents, missing fonts and images, and much 
more.

Publisher can preflight a document live as you work and on demand before you 
print or export. Publisher defaults to live checking for all documents, except for 
those opened from PDF, Designer’s .afdesign, and Photo’s .afphoto files.

The Preflight settings can be individually disabled or configured as a warning or 
error to indicate its severity to you and saved as a profile preset to use for differ-
ent types of documents. The profile preset includes when the Preflight check 
should be completed and is saved with a document for consistent preflight 
checking. You can also add a Preflight comment to any object to remind you to 
review it before printing or exporting. 

You can Preflight an entire Book at once but only if the Book and its chapters are 
all open. Refer to Preflight a Book on page 147 for more information.

Using the Preflight panel
To display the Preflight panel:

1. Choose Window > Preflight or click the Preflight icon at the bottom of the 
document window to the right of the page navigation controls. The icon’s 
appearance will depend on whether there are errors, warnings, or no issues.

Status Description

 Preflight not completed because Check is set to Never

 All Preflight tests passed

 One or more Preflight warnings

 One or more Preflight errors and possibly one or more warnings

Tip: The profile preset 
selection is saved with 
the document but the 
profile is not embed-
ded in the document 
so if you send the 
document to some-
body else for review or 
open it on another 
device and you want 
the same Preflight 
settings, export your 
presets to a file that 
can be imported

Definition: Preflight
refers to the automatic 
comparison of a 
document to a check-
list and is named after 
the preflight checks 
that pilots do before 
take off

Panel menu

Preset menu

Page number of issue (M if master page)

Check now

Selected profile

Check when

Error icon

Warning icon

Fix issue
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2. The issues are sorted by page number by default but you can change that by 
choosing Sort by error type from the panel menu.

3. Select the profile preset to use from the Profile popup menu and choose when 
to Check from the three options. Click Check Now to perform a check if Live
is not selected.

Changing Preflight settings
To change Preflight settings:

1. Create or open a document—you cannot change Preflight settings without an 
open document.

2. Click the menu  icon to the right of the Profile popup menu and choose 
Edit profile… from the popup menu.

3. Choose an issue type from the left pane and configure its options.

4. You can select a Warning Level for each issue type. Select Disabled to ignore 
this issue type, Warning for it to be flagged with the yellow icon, and Error for 
it to be flagged with the Red icon. With the default settings, Error is reserved 
for issues that will impact the successful printing or exporting of the docu-
ment but you can change them as you see fit.

5. You can select Look inside placed documents for some issue types to check 
for that type of Preflight issue in a linked or embedded document

6. The specific options for each issue type vary:

• Index: No specific options, alerts you if outdated.

• TOC: No specific options, alerts you if outdated.

• Sections: No specific options, alerts you if all sections have Include on 
export disabled.

• Overflowing Text: No specific options, alerts you if text is overflowing.

• Hyperlinks: No specific options, alerts you if a link is invalid.

Tip: Preflight does not 
check for issues on 
hidden layers because 
they don’t affect 
printing or exporting

Tip: Preflight cannot 
be restricted to a page 
range and you cannot 
limit how many of 
each issue are 
reported
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• Cross-References: Alerts you for invalid cross-references. Select Check for 
empty values to report if a cross-reference targets a blank paragraph.

• Linked Resources: No specific options, alerts you if a linked resource is 
missing or the version in the document needs to be updated.

• Image Resolution: Set the minimum and maximum thresholds below and 
above which you want to be alerted to avoid low-resolution images that 
won’t print well or images that have such high resolution that it might 
affect performance.

• Proportional Scaling: Set the threshold value above which you want to be 
alerted for a distorted image.

• Hidden Objects: Set to be alerted to a hidden layer. This option is useful in 
case you hide layers while working and forgot to un-hide them.

• Image Colour: Set to be alerted if the colour space (format) or colour 
profile of a placed image or document doesn’t match this document.

• Bleed Hazard: If Bleed is set in Document Setup, select the Safe Zone 
Edge for which you want to be alerted. Mirror Bleed (default) will set the 
safe zone to the inverse of the bleed which is a useful amount, Trim Box
will set the safe zone to the edges of the page, and Custom allows you to 
define your own safe zone boundaries.

• Minimum Stroke Width: Because thin lines don’t print well—white lines 
disappear when neighbouring ink bleeds into them and colour lines can 
have multiple component strokes if the CMYK plates are misaligned—you 
can set the minimum widths for white, single ink, and multiple ink lines.

• Missing Fonts: No specific options, alerts you if a font is missing.

• PDF/X ICC Profile Check: No specific options, alerts you if the document 
cannot be exported as a valid PDF/X file.

• Missing Glyphs: No specific options, alerts you if a font lacks a character 
you used set in that font.

• Text Patterns: Set to be alerted for common issues such as multiple spaces, 
consecutive breaks, straight quotes, and more; you can set each option 
independently.

• Spelling: No specific options, alerts you of spelling mistakes and if a 
dictionary is missing for the language used.

• User Comment: No specific options, alerts you if you entered a user 
comment for any object.

Important text and objects should be fully 
within the Safe Zone to avoid being trimmed

The Trim Box is enclosed by the page edges 
and approximates where trimming will occur

Objects must extend to the edge of the Bleed 
Zone when Bleed is set in Document Setup
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• PDF Passthrough: Set the PDF compatibility level for PDF files placed in 
the document below which you will be alerted. For example, placing a 
PDF 1.4 file with a signature into a document with this option set to 
PDF/X-1a:2003 would alert you of the incompatibility.

• Alt Text: Alerts you if alt text is missing for placed images and documents, 
and for vector (path) objects.

• Data Merge Update: No specific options, alerts you if a data merge source 
has been updated.

• Data Merge Fields: No specific options, alerts you if there are mismatched 
text field and picture frame links.

• Colours and Inks: Set to be alerted if any part of the document would 
exceed the specified Maximum Ink or Maximum Rich Black thresholds. 
Your print partner will tell you the values you should use for their printing 
press.

Refer to the Preflight help page for a complete list of the warning and error 
messages that are associated with the above settings.

To save a Preflight profile preset:

1. Click the menu  icon to the right of the Profile list and choose Create 
preset… from the popup menu.

2. Enter a preset name and click OK.

To update a Preflight profile preset:

1. Click the menu  icon to the right of the Profile list and choose Create 
preset… from the popup menu.

2. Enter the preset’s exact name and click OK. Publisher will prompt you to 
confirm that the existing preset should be replaced.

To organize, import/export, or rename or delete a Preflight profile preset:

1. Click the menu  icon to the right of the Profile list and choose Manage 
presets… from the popup menu.

Tip: It is recom-
mended that the 
option for Vector 
Objects be disabled 
because it will gener-
ate a Preflight warning 
or error for every line 
drawn with the Pen 
tool

Tip: The Preset Man-
ager is shared with 
other parts of Affinity 
and includes linked 
categories, linking to 
the other applications 
in the suite, which 
don’t apply to Pre-
flight because it is 
specific to Publisher

https://affinity.help/publisher2/English.lproj/index.html?page=pages/Publishing/preflight.html?title=Preflight
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2. To rename or delete a preset, select a preset and click Rename or Delete.

3. To organize presets into categories, click Create Category…, enter a category 
name, and then click OK. Then drag presets into the category—a blue line 
will appear to indicate where the preset will be moved. If you have many 
presets, you can collapse and expand the categories by clicking their caret 
icon.

4. To rename a category, click the menu  icon to the right of the category list 
and choose Rename Category… from the popup menu. To delete a category, 
delete all of its presets or move them to another category and then click the 
menu  icon to the right of the category name and choose Delete Cate-
gory… from the popup menu.

5. To export profile presets to share them with another user or device, click 
Export User Presets… to export all presets, or to export just those in one 
category, click the menu  icon to the right of the category name and choose 
Export User Presets… from the popup menu. Both options will create an 
.afpreflightpresets file.

6. To import profile presets from an .afpreflightpresets file, click Import Pre-
sets… to import them exactly as they were exported. To import profile pre-
sets directly into a category, click the menu  icon to the right of the category 
name and choose Import Presets to Category… from the popup menu.
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Viewing and resolving Preflight issues
To enable or disable live Preflighting:

1. Click Live to enable live Preflighting, Never to disable Preflight entirely, or 
Export to Preflight only before printing or exporting a document. Although 
the button is labeled Export it works for printing, too.

This feature is saved with a profile preset and with the document.

2. Click Check Now to perform a check if Live is not selected.

To change profile presets:

1. Select the profile preset to use from the Profile list.

To review Preflight issues:

1. Hover the mouse pointer over an issue to see more information in a popup 
tip.

2. Double-click an issue to view the page with the issue; the object or text will be 
selected as appropriate.

3. If the issue has a Fix button, such as an outdated index, click it to resolve the 
issue. For certain types of issues such as missing fonts, the Fix button will 
open another window for you to resolve the issue.

Tip: Preflight reports 
can be viewed only 
within the panel and 
cannot be exported
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Printing directly to a printer
You can print directly from Publisher to any printer connected to your printer or 
network.

To print directly to a printer:

1. Choose File > Print. The options are laid out slightly differently for macOS 
and Windows due to the differences between the operating systems.

2. Adjust the printing options:

• Printer: Select a printer if you have more than one available.

• Preset: If you’ve created a preset, you can select it from the list below.

• Copies: Enter the number of copies.

• Paper size: Select a paper size.

• Range and Scale:

• Range: Choose from Entire document, Odd pages, Even pages, Current 
page, or Selection (selected object).

• Pages: Enter a custom page range to print; for example, 10-25.

• Fit type and Scale: Select Scale and enter a scale percentage, the default 
is 100% (actual size), or select Fit to Printable or Shrink to Printable to 
enlarge or shrink the document page to match the printable area of the 
paper.

• Orientation: Select Portrait or Landscape to change the Automatic
orientation of the page on the paper.

macOS Windows
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• Document Layout:

• Model: Choose from:

Model Description

Single prints one page per sheet

Tiled prints each page over multiple sheets when the page is larger
 than the paper; you can specify the amount of overlap to
 make it easier to join sheets together

N-Up prints multiple pages or copies in rows and/or columns; for
 example, a sheet of address labels

Book facing-pages are printed side-by-side on each sheet as they
 are shown on screen

Booklet facing-pages are imposed (flipped and reordered) so they can
 be folded into a booklet

• Bleed and Marks:

• Include bleed: Select if your document has images or text that bleed off 
the page and you defined a bleed when creating the document or 
changing its layout. Always select Include printers marks when includ-
ing bleed.

• Include printers marks: Select if you want to crop a printed document 
with a paper cutter.

Printers marks Description

Include crop marks Places trim lines to indicate the trim box
 borders

Include registration marks Places target symbols at the corners and mid-
 points outside of the crop area

Include colour bars Places greyscale and colour bars below crop
 area to help adjust ink density during printing

Include page information Places the document name, page number, date,
 and time above the crop area

• The remainder of the options will vary depending on your version of 
macOS and the selected printer.

3. Click Print.

Tip: Refer to Book and 
booklet printing on 
page 223

Tip: Refer to N-Up 
printing on page 222
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N-Up printing
The N-Up option in the Print window allows you to print multiple pages or 
copies of the same page in rows and columns on a single sheet to save paper. This 
is useful for printing address labels, business cards, and archival records. You 
would print labels and cards at actual size but archival records might be printed 
pages at a reduced size.

When you choose the N-Up model, additional options are shown:

• Across/Down: Enter how many pages should be printed across a sheet 
(columns) and down a sheet (rows).

• Repeat: Enter how many copies should be made. While you can make 
additional copies with the normal Copies setting, this option makes copies 
of a page on a sheet before the next page.

• Skip: Enter how many pages to leave blank at the start of the N-Up impo-
sition. If Across and Down were both set to 3 for a 3x3 grid, setting Skip
to 3 would leave the first row on the first sheet blank.

• Left/Top: Enter the offset from the left and top edges of the sheet. N-Up
printing aligns the pages to the left and top of sheets.

• HGap/VGap: Enter the horizontal and vertical gaps between the pages on 
a sheet. Use these options with Left/Top to align pages or copies to a grid, 
such as on a sheet of labels.

A 6-page document 
printed N-Up with 
landscape orientation 
and Across set to 5, 
Down set to 4, Repeat
set to 3, Skip set to 0, 
and Fill last page
selected

1 1 1 1 1
2 3 3 3 4
1 1 1 2 2

4 4 5 5 5
6 6 6 1 1
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• Fill last page: Select this option to avoid wasting paper at the end of the 
document. If the number of pages and copies would result in blank col-
umns or rows, this option will repeat the start of the document until the 
last page is filled.

Book and booklet printing
The Book and Booklet options in the Print window don’t refer to printing a 
Publisher Book but to the printing layout. These options are generally used to 
print pages onto sheets twice as large, such as two US Letter pages on a Ledger 
sheet or two A4 pages on an A3 sheet. It is recommended that you use multiples 
of four pages for best results.

Pages are normally printed individually in sequence, one page per sheet, but the 
Book option prints single-sheet signatures. When printed double-sided, a single-
sheet signature would have four pages that could be folded for binding into a 
book or for side stapling, screw binding, or bound in another manner on the 
side.

The Booklet option imposes pages so the sheets of paper can be folded together 
into a booklet that could be stapled at the centre. Thick booklets will have uneven 
outer edges unless they are trimmed.

54367218
An 8-page document 
printed using Booklet
would be printed on 2 
sheets folded together

Sheet Sheet

Tip: Books are typically 
made up of signatures 
of more than one 
sheet but the Book
printing layout is 
limited to single 
sheets

76583214
An 8-page document 
printed using Book would 
be printed on 2 signatures, 
folded separately

Signature Signature

Definition: A signature
is a group of sheets 
folded in half that are 
bound into a book

Definition: Imposition
refers to the flipping 
and reordering of 
pages on a sheet to 
simplify binding
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Exporting to PDF for digital distribution
To share a Publisher document with others online, an Adobe® PDF file is often 
the best format. While your computer may allow you to print to a PDF file, it is 
better to export to PDF to take advantage of the options Publisher offers.

Creating a PDF for digital distribution is similar to exporting to PDF for printing 
on a commercial press but the settings are somewhat different.

To export a publication for digital distribution:

1. Preflight your document and resolve any issues. Refer to Preflighting docu-
ments on page 214. Exporting your document will run preflight automatically 
unless you’ve disabled it, but it’s a best practice to resolve any issues and 
resave the document before exporting.

2. Choose File > Export.

The preview of the first page and the estimated size of the exported PDF file 
may take some time to appear, especially for long documents, and it’s not 
necessary to wait. The preview and file size will also be recalculated as you 
change options in the window.

3. Select the export options, click Export, and then enter a filename. The 
number of options can be intimidating but the most important are File 
format, Preset, and Area. You can leave the other options unchanged until 
you’re more familiar with the range of options.
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• File format: Select PDF from the list of formats at the top of the window.

• Preset: Select PDF (digital - high quality) unless you need to reduce the file 
size in which case select PDF (digital - small size) to reduce the quality of 
the document’s images.

Preset Downsample Resamples JPEG quality

PDF (high quality) 375 dpi  300 dpi  98

PDF (small size) 90 dpi  72 dpi  85

• Raster DPI: Select the resolution at which effects should be rasterized. 
Leave this unchanged if you’re unsure which value to use.

• Preview export when complete: Select to open the PDF in your com-
puter’s default PDF viewing application.

• Area: Select All Pages unless your document is a single page in which case 
you would select Whole Document. Optional: enter a page range below to 
limit the pages that will be exported.

• Rasterize: Select Unsupported properties (default, recommended) to 
rasterize only the objects that aren’t compatible with the selected PDF 
format. Select Everything to rasterize all objects or Nothing to omit objects 
that aren’t compatible with the PDF format.

• Downsample images: Select and enter a resolution above which raster 
(bitmapped) images will be downsampled to that resolution.

• Resample: Select the resampling method to use if an image is up- or 
downsampled on export.

Resample options Description

Nearest Neighbour Fast but lower quality; use for hard-edge images

Bilinear Use when scaling images smaller (default)

Bicubic Use when scaling images larger

Lanczos 3 (separable) Very high quality but slower than the above
 options

Lanczos 3 (non-separable) Marginally-higher quality than Lanczos 3
 (separable) but slightly slower

• Use document resolution/Use DPI: Select Use document resolution to 
export the document at its native resolution, or select Use DPI to enter a 
custom resolution. Leave this unchanged if you’re unsure which to use.

• Allow JPEG compression: Select to compress raster (bitmapped) elements 
to reduce file size but some quality may be lost (default, recommended). 
Deselect to export uncompressed. Enter a JPEG quality level to specify the 
level of compression (default is 98 for high quality, 85 for small size).

Tip: Don’t select All 
Spreads for a facing-
pages document 
because this will make 
on-screen viewing of 
the PDF more difficult

Tip: You cannot zoom 
in and out of the 
preview when export-
ing to PDF, SVG, EPS, 
or PSD

Tip: The All Pages
setting is not sticky so 
you must ensure that 
you select it each type 
you export



226 Publishing

• Compatibility: Select the version of PDF to export. This will default to 
PDF 1.6 (Acrobat 7) and in general there is no need to change this unless 
you are creating a custom preset.

• Colour space: Select RGB (default, recommended) because the PDF will 
be viewed on a monitor. You can also select As document to use the docu-
ment’s defined colour space (format) or select a different colour space.

• Profile: Select sRGB IEC61966-2.1 (default, recommended) because the 
PDF will be viewed on a monitor.

• Embed profiles: Select to embed the colour profiles in the PDF file.

• Convert image colour spaces: Select to convert all images to the colour 
space of the exported file or deselect to allow images to use a different 
colour space. For example, a CMYK image should be converted to RGB 
for on-screen viewing.

• Honour spot colours: Select to export spot colours as spot colours instead 
of converting them to an equivalent colour in the colour space. This is not 
important for digital distribution.

• Include hyperlinks: Select to include clickable links in the PDF if you have 
added hyperlinks to the document.

• Include bookmarks: Select to include bookmarks in the PDF to make it 
easier for readers to navigate the document.

• Include layers: Select to not flatten the document. Select Include invisible 
layers to also include hidden layers that have non-hidden child layers.

• Include printers marks: Do not select this option for digital distribution.

• Embed fonts: Select All Fonts to ensure the document can be viewed 
without installing the fonts used in the document. You can also select 
Uncommon Fonts to reduce the file size by not embedding the basic Post-
Script fonts or No Fonts. Do not select Text as Curves for a long publica-
tion because it will convert all text to paths and increase the file size.

• Subset fonts: Select to include only the glyphs (characters) used in the 
document rather than the entire font.

• Allow advanced features: Deselect this to ensure that the PDF can be 
viewed by PDF viewers that don’t support advanced features, including 
stretched art text, stroked text, linear and radial gradients, and non-solid 
transparencies.

• Tagged PDF: Select to include Alt Text that you’ve added to images to 
improve the accessibility of the exported PDF.

Tip: This option does 
not change the 
appearance of hyper-
links; it is up to you to 
format them to appear 
clickable

Tip: Refer to Colour on 
page 241 for a descrip-
tion of colour formats 
(spaces) and profiles
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• Password Protection: Select options to protect your document from being 
opened and/or modified and printed by others. The encryption method 
will be selected automatically based on the Compatibility option you 
selected above. Password Protection requires PDF 1.6 (Acrobat 7) or 
higher.

Option Description

Require password to open Select and enter a password below to prevent
  others from opening the exported PDF without
  the password

Require password for Select and enter a password below to:
modification and printing

No document printing prevent others from printing

No content modification prevent others from modifying the PDF in an
  application such as Publisher or Adobe®
  Acrobat®

 No content copying prevent others from copying text and images in
  an application such as Publisher or Adobe®
  Acrobat®
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Printing on a commercial press
To send a publication to a printer for printing on a commercial press, you need 
to convert your Publisher document and all of its resources and fonts to a PDF 
file.

To export a publication for commercial printing:

1. Preflight your document and resolve any issues. Refer to Preflighting docu-
ments on page 214. Exporting your document will run preflight automatically 
unless you’ve disabled it, but it’s a best practice to resolve any issues and 
resave the document before exporting.

2. Choose File > Export.

The preview of the first page and the estimated size of the exported PDF file 
may take some time to appear, especially for long documents, and it’s not 
necessary to wait. The preview and file size will also be recalculated as you 
change options in the window.

3. Select the export options, click Export, and then enter a filename.

• File format: Select PDF from the list of formats at the top of the window.

• Preset: Select a PDF preset based on your print partner’s requirements.

Tip: You cannot zoom 
in and out of the 
preview when export-
ing to PDF, SVG, EPS, 
or PSD



Expert Guide to Affinity Publisher 229

Preset Description

PDF/X-4 can be used by a wide range of presses; includes device-
 independent colour spaces (formats) and live transparency

PDF/X-3 similar to PDF/X-4 but does not support live transparency

PDF/X-1a colours are separated into CMYK and spot colours in the file

PDF (press ready) exports to PDF 1.7 (Acrobat 8) unlike PDF/X which is based
 on PDF 1.6; use if the document has passthrough PDF files
 based on PDF 1.7

• Raster DPI: Select the resolution at which effects should be rasterized. 
Leave this unchanged if you’re unsure which value to use.

• Include bleed: Select if your document has images or text that bleed off 
the page and you defined a bleed when creating the document or changing 
its layout. Always select Include printers marks when including bleed.

• Preview export when complete: Select to open the PDF in your com-
puter’s default PDF viewing application.

• Area: Select All Pages unless your document is a single page in which case 
you would select Whole Document. Optional: enter a page range below to 
limit the pages that will be exported. For example, 10-25.

• Rasterize: Select Unsupported properties (default, recommended) to 
rasterize only the objects that aren’t compatible with the selected PDF 
format. Select Everything to rasterize all objects or Nothing to omit objects 
that aren’t compatible with the PDF format.

• Downsample images: Select and enter a resolution above which raster 
(bitmapped) images will be downsampled to that resolution.

• Resample: Select the resampling method to use if an image is up- or 
downsampled on export.

Resample options Description

Nearest Neighbour Fast but lower quality; use for hard-edge images

Bilinear Use when scaling images smaller (default)

Bicubic Use when scaling images larger

Lanczos 3 (separable) Very high quality but slower than the above
 options

Lanczos 3 (non-separable) Marginally-higher quality than Lanczos 3
 (separable) but slightly slower

Tip: The All Pages
setting is not sticky so 
you must ensure that 
you select it each type 
you export

Tip: Don’t select All 
Spreads for a facing-
pages document 
because your com-
mercial printer will 
need the pages 
exported as individual 
pages and not as 
readers spreads 
(layout spreads)



230 Publishing

• Use document resolution/Use DPI: Select Use document resolution to 
export the document at its native resolution, or select Use DPI to enter a 
custom resolution. Leave this unchanged if you’re unsure which to use.

• Allow JPEG compression: Select to compress raster (bitmapped) elements 
to reduce file size but some quality may be lost (default, recommended). 
Deselect to export uncompressed. Enter a JPEG quality level to specify the 
level of compression (default is 98).

• Compatibility: Select the version of PDF to export. This will be set appro-
priately by the preset and there is no need to change this unless you are 
creating a custom preset.

• Colour space: Select As document to use the document’s defined colour 
space (format) or select a different colour space. For PDF/X the only other 
option will be CMYK.

• Profile: Select Use document profile to use the document’s defined colour 
profile, or select a different colour profile.

• Embed profiles: Select to embed the colour profiles in the PDF file; this 
cannot be disabled for PDF/X.

• Convert image colour spaces: Select to convert all images to the colour 
space of the exported file or deselect to allow images to use a different 
colour space. For example, an RGB image in a CMYK document would be 
converted to CMYK when this option is selected. This cannot be disabled 
for PDF/X-1a.

• Honour spot colours: Select to export spot colours as spot colours instead 
of converting them to an equivalent colour in the colour space. Select only 
if your printer will print a separate plate for each spot colour.

• Overprint black: Select to print black over CMYK elements instead of 
knocking out the CMYK colour below to avoid registration issues.

• Include hyperlinks: Hyperlinks serve no purpose when printing on a 
press and this option cannot be selected for PDF/X although it’s available 
for PDF (Press Ready).

• Include bookmarks: PDF bookmarks serve no purpose when printing on 
a press but you can select this option so the file can also be used for other 
purposes.

• Include layers: Select to not flatten the document. Select Include invisible 
layers to also include hidden layers that have non-hidden child layers.

• Include bleed: Select if your document has images or text that bleed off 
the page and you defined a bleed when creating the document or changing 
its layout. Always select Include printers marks when including bleed.

Tip: This option does 
not change the 
appearance of hyper-
links; it is up to you to 
remove hyperlink 
formatting that you 
may have applied for 
an online version of 
the document

Tip: There are two 
Include bleed options 
they are selected and 
deselected together

Tip: Refer to Colour on 
page 241 for a descrip-
tion of colour formats 
(spaces) and profiles
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• Include printers marks: Select to include printers marks around the page 
edges to aid in trimming the pages. You can select each type of printers 
marks independently.

Printers marks Description

Crop marks Places trim lines to indicate the trim box borders

Registration marks Places target symbols at the corners and mid-points
 outside of the crop area to help align the colour plates

Colour bars Places greyscale and colour bars below crop area to help
 adjust ink density during printing

Page information Places the document name, page number, date, and time
 above the crop area

• Embed fonts: Select All Fonts to ensure the document will print correctly. 
For PDF (press ready), you can also select Uncommon Fonts to reduce the 
file size by not embedding the basic PostScript fonts or No Fonts. Do not 
select Text as Curves for a long publication because it will convert all text 
to paths and increase the file size.

• Subset fonts: Select to include only the glyphs (characters) used in the 
document rather than the entire font.

• Allow advanced features: Select to use advanced PDF features supported 
by the selected PDF format but which might not be supported by all PDF 
viewers, including stretched art text, stroked text, linear and radial gradi-
ents, and non-solid transparencies. Select this option for printing to a 
commercial press or deselect it if the PDF will also be distributed digitally 
and you aren’t sure of the viewers that will be used.

Tip: Don’t use Subset 
fonts if you think you 
might ever need to 
directly edit the PDF in 
Publisher, instead of 
editing the .afpub file
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We all have different ways of working and it’s important to cus-
tomize our tools to the way we work to increase efficiency. 
Publisher provides many ways to customize the application but 
the best approach for you will depend on your computer and 
monitor setup, your keyboard and pointing device, and your 
personal preferences.

Publisher allows you to customize the interface by moving, scal-
ing, and hiding the toolbars and panels and you can save your 
preferred configurations as Studio presets. You can also change 
many options and keyboard shortcuts and install additional 
spelling and hyphenation dictionaries.

In this chapter
Customizing the interface .......................................................................234
Changing settings or preferences ........................................................241
Installing additional dictionaries ..........................................................255

Customizing 7
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Customizing the interface
Publisher’s features are accessed through a combination of menu commands, 
tools, and panels. Tools and panels are windows that remain open while you 
work and you can choose which ones to open and where they are displayed.

You can customize the Toolbar, Context Toolbar, Tools, various panels, and 
Studios independently and then save the interface at any time as a studio preset 
that you can load in the future to restore the interface to your preferred setup.

Customizing the Toolbar
The Toolbar contains many commonly-used controls. You can choose which 
controls are shown in it and you can hide it entirely but note the Toolbar’s Status
control provides the main indication of the current magnification level so it’s 
recommended that you keep it open.

On macOS, the Close, Minimize, and Maximize buttons (red, yellow, and green 
controls) are located in the Toolbar so closing it will also leave you without access 
to these standard controls. The background of the Toolbar also provides the 
main way to drag the document window but if you close it you can drag an 
empty part of the Tools panel or the Status Bar at the bottom of the screen to 
move the window.

To open or close the Toolbar:

1. Choose View > Show Toolbar.

To customize the Toolbar:

1. Choose View > Customize Toolbar to view all the icons that can be added to 
the toolbar.
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2. Drag icons you don’t use frequently out of the Toolbar and release them 
anywhere to remove them. Drag icons you want to add from the Customize
window onto the Toolbar between other icons—use the space icons to 
arrange the icons in the Toolbar.

3. To restore the Toolbar icons to their default state, drag the default set to the 
Toolbar.

4. Choose Icon and Text from Show to display labels below the icon groups.

5. You can save the Toolbar state as part of a Studio preset. Refer to Using Studio 
presets on page 240.

6. Click Done (macOS) or Close (Windows)

Showing the Context Toolbar
Below the main toolbar is a second toolbar named the Context Toolbar, com-
monly referred to as the Context Bar. You can only show and hide the Context 
Toolbar, you cannot choose which controls are shown in it because the controls 
change dynamically based on the tool you select and what you select in the 
document.

It is recommended that you keep the Context Toolbar open because it provides 
quick access to the most frequently-used features.

To open or close the Context Toolbar:

1. Choose View > Show Context Toolbar.

2. You can save the Context Toolbar state as part of a Studio preset. Refer to 
Using Studio presets on page 240.

Customizing Tools
The Tools panel is different from the panels shown in the Left and Right Studios
because it shown on its own outside of the Studios. It can be shown docked on 
the left side of the document window or undocked as a floating panel that you 
can position on the screen.

Like the main toolbar, you can customize the Tools panel by adding and remove 
tool icons.

To open or close the Tools panel:

1. Choose View > Show Tools to open or close the panel.

2. Choose View > Dock Tools to dock or undock the panel from the document 
window.
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To customize the Tools panel:

1. Choose View > Customize Tools to view all the tools that can be added to the 
Tools panel.

2. To remove tools you don’t use frequently, drag the tool icons out of the Tools 
panel on the left and release them anywhere else.

3. To add a new tool, drag the icon you want from the Customize window onto 
the Tools panel between other icons. Some tools are available stacked and 
unstacked—stacks group similar tools that can display a popup menu from 
which you can choose a different tool. The currently-selected tool will be 
shown in the Tools panel. Stacks are indicated with triangle cues in the bot-
tom-right corner which you can click to display the popup menu. For exam-
ple, you can add the individual shape tools or the stack of shape tools.

4. Optional: Add separator lines to divide groups of tools.

5. Click Reset to restore the Tools panel icons to their default state.

6. Choose the Number of Columns if you’d prefer to view the tool icons in 
multiple columns. This is useful if you use a large set of tools on a smaller 
screen.

7. You can save the Tool panel’s tools as part of a Studio preset, but not the 
panel’s docked or undocked state or the number of columns. Refer to Using 
Studio presets on page 240.

8. Click Done (macOS) or Close (Windows)

Tip: The Colour 
Selector control 
cannot be removed 
from the Tools panel 
and is not shown 
when customizing the 
panel 

Tip: The None swatch 
won’t be displayed for 
the Colour Selector
when tools are 
arranged in a single 
column

Tip: You can also click 
and hold on the tool 
to display the popup 
menu
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Customizing the panels
Panels are windows that remain open while you work and you can choose which 
ones to open and where they are displayed. Panels can be docked in a Studio, a 
container for panels, on the left or right side of the document window. Panels can 
also be undocked as floating windows that you can position on the screen. 
Undocked panels can be snapped to each other’s edges so that they can be moved 
as a single unit.

Publisher has many panels so the default interface displays some in the left 
Studio and some in the right Studio. You can show and hide the left and right 
Studios independently, group panels within a Studio, and collapse panel groups.

A panel group is a row of panels, and even a single panel is considered a group. If 
there are more panel tabs for a group than will fit within the Studio, Publisher 
will automatically shorten their names to save space.

A docked panel group with two panels An undocked panel group with two panels

Tip: Publisher for 
Windows can display 
two columns of panels 
in the left and right 
Studios while 
Publisher for macOS 
can display a single 
column in each

A docked panel group (top) with three 
panels and a second panel group (below) 
with three more panels
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To open or close a Studio:

1. Choose Window > Studio > Show Left/Right Studio to open or close a 
studio.

2. Or choose Window > Studio > Hide Studio to close or open both studios at 
once.

To open or close a single panel:

1. Choose the panel name from the Window menu to open or close it. When 
you open a panel, it will be docked in the left or right Studio or undocked and 
positioned on screen depending on how it was displayed before it was last 
closed.

2. Or close it by choosing Close from the panel menu . If the panel is 
undocked and not part of a panel group, you can also click its Close  icon.

To group panels:

1. To add a panel to an existing group—a row of panel tabs—drag the panel’s tab 
into the group’s row of tabs and position it between the desired tabs.

2. To create a new group—a new row of panel tabs—drag the panel’s tab above 
or below an existing panel until you see the blue highlight appear and then 
release the mouse button.

3. To merge two panel groups, drag one group’s dragger  icon into the other 
group’s row of tabs and position it between the desired tabs. If the group has 
only a few tabs you can also drag the blank area to the right of the last tab.

To expand/collapse a panel group:

You can collapse a group of panels to the height of their tabs to provide more 
space to view the panels in another group.

1. To collapse a panel group, double-click any of the group’s panel tabs.

2. To expand a panel group, click the tab you wish to make active.

Tip: The Tools panel is 
not hidden by Hide 
Studio

Tip: When adding a 
panel to a group, do 
not release the mouse 
until the blue high-
light disappears or you 
will create a new panel 
group

Tip: Some panels are 
in the Windows > 
References, Table, and 
Text sub-menus

The blue highlight indicates 
that releasing the mouse now 
will create a new panel group 
for the Fields tab that is being 
dragged into the left Studio
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To close a panel group:

1. Choose Close Panel Group from the panel menu . If the group is undocked 
you can also click its Close  icon.

To dock and undock panels:

1. To add a floating panel to a Studio, drag the panel’s tab into a Studio and add 
it to an existing panel group or above or below a panel create a new group.

2. To float a panel as a standalone window, drag the panel’s tab out of the Studio. 
To add it to an existing floating panel’s group, drag it onto that panel’s tab row.

3. To snap undocked panels to each other:

To resize panels, panel groups, and Studios:

1. To change the width of the Studios and the panels in them, position the 
mouse pointer anywhere over the panel’s interior borders. When the mouse 
pointer changes to the horizontal resize  pointer, drag the border to the 
desired width.

2. To change the height of a panel group in a Studio, position the mouse pointer 
anywhere over the group’s horizontal border. When the mouse pointer 
changes to the vertical resize  pointer, drag the border to the desired width.

3. To resize a floating panel, drag from any of its sides or corners. When the 
mouse pointer changes to the appropriate resize pointer, drag the border or 
corner to the desired width or height.

To reset the Studios and panels to the default configuration:

1. Choose Window > Studio > Reset Studio.
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Using Studio presets
Once you have the panels, Toolbar, Context Toolbar, and Tools set up the way 
you want them you should save the setup as a Studio preset so that you can easily 
restore the interface to this configuration. If you normally work on a large moni-
tor or monitors you might want to create a second preset for use on a laptop 
screen. Or you may wish to create presets for different styles of working, such as 
document layout, cross-referencing, and digital publishing.

Studio presets save the position, size, and dock status, as applicable, for the 
Toolbar, Context Toolbar, Tools, panels, and panel groups, including the active 
panel in a panel group and the vertical height of a panel group. A preset does not 
save whether a section in a panel is expanded or collapsed.

To save a Studio preset:

1. Choose Window > Studio > Add Preset…

2. Enter a name for the preset and click OK.

To load a Studio preset:

1. Choose Window > Studio > preset name. 

To rename or delete a Studio preset

1. Choose Window > Studio > Manage Studio Presets.

2. Select a preset and then click Rename or Delete, and then enter a new name 
or confirm the deletion.
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Changing settings or preferences

Colour
Publisher allows you to set the default colour profile for each colour format 
(space). The default profile is used when creating a new document.

Publisher uses the ICC colour profiles installed on your computer and you can 
install additional profiles recommended by your printer.

If you’re new to working with colour printing, you should understand that 
colours are displayed on screen in RGB (Red, Green, Blue) and printed in CMYK 
(Cyan, Magenta, Yellow, Black). LAB (Luminance, A for Green to Red, B for 
Yellow to Blue) is a three-dimensional colour model that can represent any 
colour in the range of human vision and is popular for enhancing and converting 
photographs. CMYK is the best colour format (space) for colour printing.

To install a colour profile on macOS:

Quit Publisher before installing a colour profile because it checks for profiles 
when it is started.

1. Copy the .icc file(s) to /users/<username>/Library/ColorSync/Profiles. The 
default colour profiles are stored in a similar folder for all users of your com-
puter so this folder will be empty if you haven’t previously installed a colour 
profile.

2. Restart Publisher.

To install a colour profile on Windows:

1. Open Colour Management via the Control Panel or by searching for it in the 
Settings app.

2. Select the All Profiles tab.

3. Click Add, select the .icc file, and click Add.

4. Restart Publisher.

Tip: You can also 
install a colour profile 
by switching to the 
Photo persona and 
choosing File > 
Import ICC Profile…, 
but the profile will not 
be available to other 
applications on your 
computer
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To change colour settings:

1. Choose Affinity Publisher 2 > Settings… (macOS) or Edit > Settings…
(Windows) and then click Colour in the left pane.

2. Select the default colour profile for each colour format (space).

• RGB Colour Profile: Select the default for RGB/8 and RGB/16 documents; 
not recommended for publishing

• 32bit RGB Colour Profile: Select the default for RGB/32 (HDR) docu-
ments; not recommended for publishing

• CMYK Colour Profile: Select the default for CMYK/8 and CMYK/16 
documents; refer to the list of Popular CMYK colour profiles on page 244 
for more information.

• Greyscale Colour Profile: Select the default for Grey/8 and Grey/16 
documents

• LAB Colour Profile: Select the default for LAB/16 documents; not recom-
mended for publishing

3.  Rendering Intent: Select an option for converting colours from the document 
or image’s colour gamut that are not reproducible in the output colour gamut. 
The Perceptual and Saturation rendering intents are used for re-purposing, 
such as the display or printing of photographs, while Absolute and Relative 
Colourimetric are used for proofing, such as proofing a CMYK print job on a 
6-colour inkjet printer.
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• Perceptual: Typically used to process digital and scanned photographs 
with highly saturated colours. All colours are shifted to allow out-of-
gamut colours to be shown but the relationships between colours are 
retained to preserve the overall perception.

• Saturation: Typically used for business graphics because colours are 
shifted to maximize saturation and make the image more vibrant at the 
expense of colour accuracy.

• Absolute Colourimetric: Used for side-by-side comparisons of outputs 
from different printers and when complete accuracy is required, such as 
for a logo. All colours of the original colour gamut are shifted so that the 
white points are aligned.

• Relative Colourimetric: With identical papers, Absolute and Relative will 
produce identical results but Relative accounts for differing white points, 
such as one printer using a yellowish paper.

4.  Black point compensation: Select to adjust the document’s black point for the 
current colour profile while maintaining the current contrast. Deselecting this 
may impact contrast.

5.  Convert opened files to working space: Select to automatically convert all 
opened documents with their own colour profile to the default colour profile 
set for their colour format (space). Select the And warn option so that Pub-
lisher displays a temporary alert to notify you of the conversion:

6.  Warn when assigning working profile to unprofiled photos: Documents 
without a colour profile are always converted to the default colour profile set 
for their colour format (space). Select this option so that Publisher displays a 
temporary alert to notify you of the conversion.

7.  Enable HDR/EDR by default in 32-bit RGB views: Select if you have a 
compatible HDR/EDR display and want to use the full dynamic range. You 
may not want to use this if creating images for other uses. This option is 
named HDR on Windows and EDR on macOS.

8. OpenColorIO and OpenEXR: These options aren’t relevant to publishing as 
they are intended for motion picture production. Publisher includes them 
because all three Affinity apps can open each other’s files.

Example: When opening an RGB document without a 
colour profile and Publisher’s RGB default is set to 
sRGB IEC61966-2.1, the document would be con-
verted to the default and this alert shown

Example: When opening a CMYK document set to 
U.S. Web Coated (SWOP) v2 and Publisher’s CMYK 
default is set to Coated GRACoL 2006 (ISO 12647-
2:2004), the document would be converted to the 
default and this alert shown
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Popular CMYK colour profiles

North America Description Included

U.S. Web Coated (SWOP) v2 for printing on rolls of coated paper on a web offset press; ✓
 default for most publishing applications

U.S. Web Uncoated v2 for printing on rolls of uncoated paper on a web offset press ✓

Coated GRACoL 2006 (ISO 12647-2:2004) for printing on grade 1 paper such as for a brochure on a
 sheetfed press

Web Coated SWOP 2006 Grade 3 Paper for printing on bright, glossy lightweight paper such as for
 a magazine on a web offset press

Web Coated SWOP 2006 Grade 5 Paper for printing on lower quality lightweight paper on a web
 offset press

U.S. Sheetfed Coated v2 for printing packaging and brochures ✓

U.S. Sheetfed Uncoated v2 for printing packaging and brochures ✓

US Newsprint (SNAP 2007) for printing on rolls of newsprint on a web offset press

Europe and Australia Description

Coated FOGRA27 (ISO 12647-2:2004) for printing on paper type 1 on a web offset press, super- ✓
 seded by FOGRA39; 350% total ink coverage

Coated FOGRA39 (ISO 12647-2:2004) for printing on paper type 1 on a web offset press; 350%
 total ink coverage ✓

Web Coated FOGRA28 (ISO 12647-2:2004) for printing on paper type 3 on a web offset press; 350%
 total ink coverage ✓

Uncoated FOGRA29 (ISO 12647-2:2004) for printing on paper type 4 on a web offset press; 350%
 total ink coverage ✓

Euroscale Coated v2 for printing on paper type 1 or 2 (bright white) using
 Euroscale inks on a web offset press; 350% total ink coverage

Euroscale Uncoated v2 for printing on uncoated white paper using Euroscale
 inks on a web offset press; 260% total ink coverage

Tip: Included means 
the profile is included 
with Publisher but it is 
not in a user-accessi-
ble location
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Japan Description

Japan Color 2001 Coated for printing on paper type 3 on a sheetfed press; 350%
 total ink coverage ✓

Japan Color 2001 Uncoated for printing paper type 4; 310% total ink coverage ✓

Japan Color 2002 Newspaper for printing on rolls of newsprint on a web offset press;
 240% total ink coverage ✓

Japan Color 2003 Web Coated for printing on paper type 3 on a web offset press; 350% ✓
 total ink coverage

Japan Color 2011 Coated for printing on paper type 1 on a sheetfed press

Japan Web Coated (Ad) for printing magazine advertisements

Generic Description

Generic CMYK Profile don’t use for commercial printing

Photoshop 4 Default CMYK  don’t use for commercial printing

Photoshop 5 Default CMYK  don’t use for commercial printing
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Keyboard shortcuts
Most users press keyboard shortcuts to invoke frequently-used menu commands 
and while Publisher has a standard set of shortcuts, some users are more familiar 
with other software and prefer to use the same shortcuts they’ve used for many 
years. Publisher allows you to change the keyboard shortcut for any menu com-
mand as well as for the tools, panels, and text input.

Some of the default shortcuts might not work with your keyboard. For example, 
the default shortcut to move the text cursor to the end of the story is ⌘ + End
(macOS) or Ctrl + End (Windows) but if you use a laptop you may not have an 
End key on your keyboard.

Once you have the keyboard shortcuts set the way you prefer you can save the 
shortcuts to a file that you can load again at any time in case you make changes 
you regret.

Shortcut files can generally only be opened in the same major version of Pub-
lisher for the same operating system that they were saved from. For example, a 
shortcuts file saved from Publisher 2.2.0 will work in 2.2.1 but not necessarily in 
2.1.0. If you save and load your shortcuts, it’s a good idea to save a new copy after 
upgrading Publisher to a new major version.

Publisher includes shortcuts for some of the most frequently-used menu com-
mands doesn’t have default shortcuts for some of the features used in creating 
long publications, including cross-references, indexing, and notes. If you use 
these features you should consider adding shortcuts to save time.

The symbols shown for the modifier and special keys in the shortcuts editor are:

Symbol Key Symbol Key

 Command (macOS)   Ctrl

 Shift   Option (macOS) or Alt (Windows)

 Arrow Left   Arrow Up

 Arrow Right   Arrow Down

 Home   Page Up

 End   Page Down

 Tab   Esc

 Delete   Return (macOS) or Enter (Windows)

 Function (Fn)

To change a keyboard shortcut:

1. Choose Affinity Publisher 2 > Settings… (macOS) or Edit > Settings…
(Windows) and then click Shortcuts in the left pane.

There are two unlabeled lists at the top of this window. The first is Personas

Tip: Be careful when 
editing shortcuts, 
there is no undo 
feature but you can 
restore the shortcuts 
to Serif’s defaults or 
load your own saved 
shortcuts file
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and the second is Elements which lists groups of shortcuts corresponding to 
the menus, the tools, studio panels, text input, blend modes, and some mis-
cellaneous shortcuts.

2. Choose the Persona for which you want to set shortcuts. Don’t change this if 
you want to change shortcuts for the default Publisher persona.

3. Choose the user interface Element. On macOS, the first option is Affinity 
Publisher 2 which corresponds to the application name menu while on Win-
dows the first option is the File menu.

4. Select Apply to All if you want the changes you make to apply to the same 
command in all personas, if applicable. This is on by default because it’s 
confusing to use different shortcuts for the same feature in different personas.

5. Select Ignore Modifier to create single-key shortcuts. This is off by default 
because using a single key such as N for New would make it impossible to 
type an N. Modifiers cannot be used for Tools so this option is hidden when 
editing those shortcuts.

6. To add or change a keyboard shortcut, click in the box to the right of the 
command, tool, or operation you want to change and then press the shortcut 
combination you want to use. If that shortcut is already in use a warning 
icon will appear. Mouse over that triangle to find out which shortcut is in 
conflict.

7. To delete a keyboard shortcut, click the delete  icon to the right of the 
shortcut. Do not press the Delete key to delete the shortcut or Esc to cancel 
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because that will assign the Delete or Esc keys as a shortcut for that command 
or operation.

8. On Windows, click Reset to restore all of the keyboard shortcuts for all 
personas and user interface elements to the default settings. On macOS, click 
Serif Defaults to do the same thing or Apple Defaults to use a more Mac-like 
combination. The only difference in the Apple Defaults is the Text Input 
shortcuts, but the Apple Defaults button changes all shortcuts.

9. Click Clear All Shortcuts to remove all shortcuts. This option is not recom-
mended because you will lose all the basic and most common shortcuts.

To save the current shortcuts:

1. Choose Affinity Publisher 2 > Settings… (macOS) or Edit > Settings…
(Windows) and then click Shortcuts in the left pane.

2. Click Save and enter a filename and select a location for the file. Publisher 
will save the shortcuts as an .affshortcuts (macOS) or .afshort (Windows) file 
that you can load at any time.

To load shortcuts from a file:

1. Choose Affinity Publisher 2 > Settings… (macOS) or Edit > Settings…
(Windows) and then click Shortcuts in the left pane.

2. Click Load and select an .affshortcuts (macOS) or .afshort (Windows) file 
from your computer.

Recommended shortcuts for references

Publisher doesn’t have default keyboard shortcuts for notes, cross-references, 
anchors, and hyperlinks. If you’re using the references features for a book you 
might find these shortcuts helpful but some will require changing the defaults for 
the listed commands. Windows users, substitute Ctrl for ⌘.

Command Shortcut Availability

Insert Cross-Reference ⌘ + R Used for Show Rulers

Edit Cross-Reference Shift + ⌘ + R Used for Rename Layer

Insert Anchor ⌘ + Y Used for Last Used (View Mode > Wireframe)

Anchor Properties Shift + ⌘ + Y Available

Insert Hyperlink ⌘ + K Used for Find in Layers

Hyperlink Properties Shift + ⌘ + K Available

Insert Footnote Shift + ⌘ + N Available: use this shortcut for whichever type
   of note you’re using
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AutoCorrect, Abbreviations, and Title exceptions
AutoCorrect allows you to automatically replace specified text with other text as 
you type. For example, you can convert straight quotation marks to typographic 
ones and replace teh with the. AutoCorrect can also automatically capitalize the 
first word of a sentence.

Abbreviations allows you to define exceptions to the automatic capitalization of 
text. For example, you wouldn’t want to capitalize the first word after vs. which is 
typically used within a sentence.

Title exceptions allows you to define exceptions to the capitalization of phrases 
that are formatted with the Title Case formatting option. For example, “and”
should not be capitalized with Title Case so it should be included in this excep-
tion list.

Publisher uses its own lists for each type of text replacement for every language it 
supports and doesn’t rely on the similar text replacement features built into 
macOS and Windows. This is important because while you might want the same 
corrections for basic text some of the corrections you use in Publisher may be 
more typographic and not suitable for your other applications. macOS also lacks 
separate text replacement lists for each language so Affinity’s custom feature is 
important for those who work in multiple languages.

Publisher includes default lists of AutoCorrect, Abbreviations, and Title Excep-
tions for the languages for which it provides a user interface. You must create 
your own lists for other languages. Although Publisher includes useful default 
lists for British and American English, it does not include them for Australian, 
Canadian, or other variations of English, and you cannot easily copy the British 
or American lists to use as a starting point.

On macOS, the user interface language and the language used for formatting text 
are not consistently spelled out for British and American English. On Windows, 
they are written as English (United Kingdom) and English (United States) but on 
macOS they are written as shown below:

Text language Interface language Defaults included for

English (United Kingdom) English AutoCorrect, Abbreviations, Title Exceptions

English English (United States) AutoCorrect, Abbreviations

English (Australia) n/a none

English (Canada) n/a none

German Deutsch AutoCorrect, Abbreviations

Français français AutoCorrect, Abbreviations

Español español AutoCorrect

Italiano italiano AutoCorrect

Português (Brasil) português (Brasil) none
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To add or remove AutoCorrect text:

1. Choose Affinity Publisher 2 > Settings… (macOS) or Edit > Settings…
(Windows) and then click AutoCorrect in the left pane.

2. Customize the AutoCorrect rules:

• Capitalize first letter of sentence: Select to use automatic sentence capital-
ization. You can define exceptions to this rule with Abbreviations.

• Change straight quotes to typographic quotes: Select to automatically 
change single and double quotation marks as you type, for example, "x" to 
“x” and 'x' to ‘x’. For languages other than English, this option will convert 
only double quotation marks.

• Support language-dependent single typographic quotes: Select to auto-
matically change single quotation marks as you type in languages other 
than English, for example, 'x' to ‚x‘.

• Use tab to alter paragraph level instead of inserting a tab: If the text style 
has Next Level set to another text style, pressing Tab at the start of the 
paragraph will change the text style to that defined in Next Level instead of 
inserting a tab. For example, it would change Heading 1 to Heading 2. 
Pressing Shift + Tab will change to the previous level’s text style.

• Correct two initial, consecutive capitals: Select to change this common 
typo situation, for example, THe to The.

• Superscript ordinals as they are typed: Select to automatically change 
ordinals as you type, for example, 1st to 1st.

Tip: If the font sup-
ports true ordinals, use 
those instead of the 
AutoCorrect feature to 
typeset ordinals as the 
font designer 
intended; refer to 
Ordinals on page 78
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• Automatically create bulleted lists: Select to automatically change para-
graphs starting with “* ” (an asterisk and space) to a bulleted list. Note that 
this will not apply the default Bullet 1 text style.

• Automatically create numbered lists: Select to automatically change 
paragraphs starting with “1. ” (a 1 followed by a period and space) to a 
numbered list. Note that this will not apply the default Numbered 1 text 
style.

3. Select Replace Text While Typing to replace certain text with other text as 
you type.

4. Select which Language you wish to customize.

5. Enter the word to replace in Replace, for example, teh., and the replacement 
text in With, for example, the. You are not limited to single words and can 
enter phrases in either field. Click Add to add the text replacement to the list 
below.

6. To delete an existing text replacement pair, select it from the list and click 
Remove.

To add or remove Abbreviations:

You can define exceptions to the automatic capitalization of text following com-
monly-used abbreviations.

1. Choose Affinity Publisher 2 > Settings… (macOS) or Edit > Settings…
(Windows) and then click Abbreviations in the left pane.

Tip: When editing a 
variation of English 
other than British and 
American English, 
ensure you are editing 
the right text because 
this window defaults 
to your user interface 
language, not the 
language of your text
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2. Select which Language you wish to customize.

3. Enter the abbreviation into the text field. You can enter any text string but 
only text that ends with a period will have any effect because text will not be 
automatically capitalized following abbreviations without periods. Click Add
to add the abbreviation to the list below.

4. To delete an existing abbreviation, select it from the list and click Remove.

To add or remove Title Exceptions:

You can define exceptions to the capitalization of phrases that are formatted with 
the Title Case formatting option.

1. Choose Affinity Publisher 2 > Settings… (macOS) or Edit > Settings…
(Windows) and then click Title Exceptions in the left pane.

2. Select which Language you wish to customize.

3. Enter the title exception into the text field. You can enter any text string but 
only text that ends with a period will have any effect because text will not be 
automatically capitalized following abbreviations without periods. Click Add
to add the abbreviation to the list below.

4. To delete an existing abbreviation, select it from the list and click Remove.

Tip: When editing a 
variation of English 
other than British and 
American English, 
ensure you are editing 
the right text because 
the window defaults 
to your user interface 
language, not the 
language of your text

Tip: When editing a 
variation of English 
other than British and 
American English, 
ensure you are editing 
the right text because 
the window defaults 
to your user interface 
language, not the 
language of your text
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Filler text
Filler text, also referred to as placeholder text, is used to demonstrate a layout’s 
design without using actual words that may not be ready yet and which could be 
distracting.

Designers have long used Lorem Ipsum as filler text, adapted from a Latin dia-
logue by the Roman statesman Cicero. Publisher allows you to insert filler text 
automatically by choosing Text > Insert Filler Text. The filler text will fill all the 
space in the text frame or series of linked frames without overflowing the frames. 
Publisher will select a random sentence from the filler text to avoid identical 
blocks if you inserted it into multiple frames on the same spread.

You can replace Publisher’s default filler text with your own, and use different 
filler text for various languages if the Latin text is not suitable for your purposes.

To replace Publisher’s filler text:

1. Create or open a document—you cannot set Filler Text defaults without an 
open document.

2. Choose Affinity Publisher 2 > Settings… (macOS) or Edit > Settings…
(Windows) and then click Filler Text in the left pane.

3. Select which Language you wish to customize. The text field below will be 
blank if you have not customized the filler text for this language.

4. Enter the new filler text. Use at least a few sentences or paragraphs so that 
there is sufficient text for Publisher to randomize the starting sentence.

Tip: It doesn’t matter 
which variation of 
English you choose, 
there is only one Filler 
Text default for all 
variations of English
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You can test it before saving it as the default by drawing a text frame and 
choosing Text > Insert Filler Text. If you have already done that, doing 
anything to the document including changing the zoom level or page will 
update the filler text.

5. Until you save the filler text as the default, it will remain a document-level 
setting and not a global setting and will not be available to other open docu-
ments. To save the current document’s filler text as Publisher’s default, click 
Save as Default. This command saves only the selected language’s filler text.

6. To undo changes you have made to the Filler Text for the current document, 
click Revert to Default. This command reverts only the selected language’s 
filler text.

7. To revert the Filler Text to Publisher’s original default, click Factory Reset. 
This command resets only the selected language’s filler text.

To insert filler text as text instead of as a field:

1. Choose Affinity Publisher 2 > Settings… (macOS) or Edit > Settings…
(Windows) and then click General in the left pane.

2. Click Insert filler text as text. From now on when you choose Text > Insert 
Filler Text, it will insert enough filler text as regular text to fill the frame(s).

Tip: If you insert filler 
text as a field (with 
Insert filler text as 
text disabled), you can 
convert it to regular 
text by right-clicking it 
and choosing Expand 
Field
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Installing additional dictionaries
Publisher uses the spelling and hyphenation dictionaries included with macOS 
and an equivalent list of dictionaries is installed with Affinity for Windows.

You can install additional dictionaries if the spelling or hyphenation language 
you want isn’t included listed in the Spelling and Hyphenation language lists in 
the Character panel. Publisher uses the widely-available Hunspell dictionary 
format used by many other applications.

You can download Hunspell dictionary files from many websites but Serif has 
provided a convenient list of download links on the Affinity forum. All of the 
files will be named xx_XX where xx is the language and XX is the region, for 
example, pl_PL represents Polish and Poland.

To install an additional dictionary on macOS:

1. To install a spelling dictionary, copy the downloaded xx_XX.dic and xx_XX.aff
files to /users/<username>/Library/Spelling/. Both files are required for a spell-
ing dictionary.

2. To install a hyphenation dictionary, create a folder named xx_XX in 
/users/<username>/Library/Spelling/ and copy the downloaded hyph_xx_XX.dic
file into it.

3. Restart Publisher for the changes to take effect.

To install an additional dictionary on Windows:

1. The default folder for installing additional dictionaries is 
C:\ProgramData\Affinity\Common\2.0\Dictionaries\ but you can change this if 
desired by choosing Edit > Settings…, select Tools from the left pane, and 
click Browse.

2. To install spelling and hyphenation dictionaries, create a folder named xx_XX
in C:\ProgramData\Affinity\Common\2.0\Dictionaries\ or your custom location 
and copy the downloaded xx_XX.dic and xx_XX.aff spelling dictionary files 
and/or the hyph_xx_XX.dic hyphenation dictionary file into it.

3. Restart Publisher for the changes to take effect.

Tip: Some dictionary 
files are named xx_XX
while others are 
named xx-XX with a 
hyphen instead of an 
underscore—this isn’t 
important

Tip: When changing 
the location of dictio-
naries, select the 
folder containing the 
language folder(s) and 
not the language 
folder (xx_XX) you 
created

Tip: macOS does not 
include a matching 
hyphenation dictio-
nary for every spelling 
dictionary, nor are 
they available for 
every language

https://forum.affinity.serif.com/index.php?/topic/190021-how-do-i-add-additional-dictionaries-to-affinity-v2/&do=findComment&comment=1111427
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Included and available dictionaries
This table lists all of the included spelling and hyphenation dictionaries as well as 
some other common ones but you are not limited to those listed here. Dictionar-
ies marked as ✓ are included with macOS or with Publisher for Windows.

Hyphenation dictionaries marked as auto aren’t necessary because hyphenation 
is generally the same for each regional variant of a language (for example, Span-
ish for Spain and Mexico) so Publisher will automatically use the main hyphen-
ation dictionary for that language when Language > Hyphenation is set to Auto
in the Character panel.

For all variants of English other than English (United Kingdom), setting hyphen-
ation to Auto will default to the English (United States) hyphenation dictionary.

  macOS   Windows
Locale Language Spelling Hyphen. Spelling Hyphen.

en_US English [United States]  ✓ ✓ ✓ ✓

en_GB English (United Kingdom)  ✓ ✓ ✓ ✓

en_AU English (Australia)  ✓ auto (US)    auto

en_CA English (Canada)  ✓  auto (US)    auto

en_IN English (India)  ✓  auto (US)    auto

en_SG English (Singapore)  ✓  auto (US)    auto

en_ZA English (South Africa)  ✓  auto (US)    auto

en_NZ English (New Zealand)  ✓  auto (US)    auto

en_JP English (Japan)  ✓  auto (US)    auto

de_DE Deutsch [German]  ✓  ✓ ✓  ✓

de_AT Deutsch (Österreich) [Austria]

de_CH Deutsch (Schweiz) [Switzerland]

es_ES Español [Spanish]  ✓  ✓ ✓  ✓

es_MX Español (México)    auto    auto

es_AR Español (Argentina)    auto    auto

es_BO Español (Bolivia)    auto    auto

es_CL Español (Chile)    auto    auto

es_CO Español (Colombia)    auto    auto

es_CR Español (Costa Rica)    auto    auto

es_EC Español (Ecuador)    auto    auto

es_PE Español (Perú)    auto    auto

es_PY Español (Paraguay)    auto    auto

Tip: If the de_AT or 
de_CH files you 
downloaded include 
_frami in their file-
names and you use 
macOS, remove 
_frami from the 
names so that the 
language will be listed 
correctly

Tip: On macOS, English 
(United States) is 
written as English
without United States
in parentheses
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  macOS   Windows
Locale Language Spelling Hyphen. Spelling Hyphen.

es_US Español (Estatdos Unidos)    auto    auto

es_UY Español (Uruguay)    auto    auto

es_VE Español (Venezuela)    auto    auto

fr_FR Français [French]  ✓  ✓ ✓  ✓

fr_CA Français (Canada)    auto    auto

fr_BE Français (Belgique)    auto    auto

fr_CH Français (Suisse)    auto    auto

fr_LU Français (Luxembourg)    auto    auto

it_IT Italiano [Italian]  ✓  ✓ ✓  ✓

pt_BR Português (Brasil)  ✓  ✓ ✓  ✓

pt_PT Português (Portugal)  ✓  auto    auto

cs_CZ Čeština [Czech]  ✓

da_DK Dansk [Danish]  ✓

ga_IE Gaeilge [Irish]  ✓

hu_HU Magyar [Hungarian]  ✓

nl_NL Nederlands [Dutch]  ✓

nb_NO Norsk Bokmål [Norwegian]  ✓

nn_NO Norsk Nynorsk [Norwegian]  ✓

pl_PL Polski [Polish]  ✓

ro_RO Română [Romanian]  ✓

fi_FI Suomi [Finnish]  ✓

sv_SE Svenska [Swedish]  ✓

sv_FI Svenska (Finland)

vi_VN Tiếng Việt [Vietnamese]  ✓

tk_TM Türkçe [Turkmen]  ✓

el_GR Ελληνικά [Greek]  ✓

bg_BG Български [Bulgarian]  ✓

uk_UA українська [Ukrainian]  ✓

ru_RU Руссĸий [Russian]  ✓

af_ZA Afrikaans (Suid-Afrika)

bs_BA Bosanski (Bosna | Hercegovina)

Tip: The only available 
dictionary for French is 
the main fr_FR
dictionary; if you 
import text formatted 
as Français (Canada) or 
one of the other three 
variants, download the 
fr_FR dictionary files 
from the Affinity 
forum and rename 
them as required to 
avoid seeing the 
missing dictionary 
error in Preflight
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  macOS   Windows
Locale Language Spelling Hyphen. Spelling Hyphen.

et_EE Eesti [Estonian]

gl_ES Galego (España) [Galician]

hr_HR Hrvatski (Hrvatska) [Croatian]

lv_LV Latviešu (Latvija) [Latvian]

lt_LT Lietuvių [Lithuanian]

mn_MN Mонгол [Mongolian]

sk_SK Slovenčina (Slovensko) [Slovak]

sq_AL Shqip (Shqipëri) [Albanian]

sl_SL Slovenščina (Slovenija) [Slovenian]

la_VA Latin (Vatican City)

ca Català [Catalan]

ca_valencia Català (Valencian)

gd_GB Gàidhlig (An rìoghachd Aonaichte) [Gaelic]

258 Customizing
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Appendices
Appendix A – Special characters
To type a special character:

1. Type the character’s Unicode value and choose Text > Toggle Unicode, or 
choose Text > Insert and select from the list.

2. Choose Text > View Special Characters to show the invisible symbols for 
special characters. This will not display anchors, index marks, or fields which 
you must enable separately with their respective commands.

Whitespace * Not in menu

 Space U+0020

 Em Space, non-breaking U+2003

 En Space, non-breaking (½ em) U+2002

 Third/Thick Space, non-breaking (1⁄3 em) U+2004

 Quarter/Mid Space, non-breaking (¼ em) U+2005

 Thin (Fifth) Space, non-breaking (1⁄5 em) U+2009

 Sixth Space, non-breaking (1⁄6 em) U+2006

 Hair Space, non-breaking (1⁄12 em) U+200A

 Punctuation Space, non-breaking (width of period) U+2008

 Figure Space, non-breaking (often the width of a 0) U+2007

 Medium Mathematical Space, non-breaking (4⁄18 em) U+205F*

 Non-Breaking Space U+00A0

 Narrow Non-Breaking Space (1⁄7 em) U+202F
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Whitespace, continued * Not in menu

 Tab U+0009

 Right Indent Tab

 Indent to Here

 Em Quad/Mutton – no symbol shown U+2001*

 En Quad/Nut – no symbol shown U+2000*

 Ideographic Space – no symbol shown U+3000*

Hyphens

 Automatic Hyphen-

 Soft Hyphen, inline/end of line U+00AD

 Non-Breaking Hyphen – no symbol shown U+2011

Breaks and Joiners

 Line Break U+2028

 Paragraph Break U+2029

 Column Break

 Frame Break

 Page Break U+000C

 Odd/Even Page Break

 End of Story
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Breaks and Joiners, continued * Not in menu

 Zero-Width Space (breaking, discretionary line break) U+200B

 Zero-Width Non-Breaking Space U+FEFF*

 Zero-Width Non-Joiner U+200C

 Zero-Width Joiner U+200D*

 Word Joiner U+2060*

Markers

 Anchor position

 Pinned object position

 Index Mark

 Note Mark

 Endnote brackets (type between)

 Broken endnote brackets and number

 Field (field value is shown)
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Appendix B – Clearing user data
If Publisher starts to act strangely, such as if a panel won’t display when you 
choose its menu command, you might need to clear your user data for a fresh 
start.

To clear user data:

1. Before starting Publisher:

• macOS: Start Publisher and then immediately press and hold Ctrl. Don’t 
press Ctrl before clicking the app icon or a context menu will appear.

• Windows: Press and hold Ctrl and then start Publisher.

2. Release Ctrl when the Clear User Data window appears.

3. Select which data to clear and click Clear. Your preference settings, text 
formatting defaults, and other options are grouped together as the first item, 
User Defaults, but other settings can be cleared independently.

The options are similar but slightly different for macOS and Windows.

Tip: Windows: If you 
don’t have the app 
icon pinned in the Task 
bar and the Clear User 
Data window doesn’t 
appear, wait for the 
icon to appear and 
then click it

macOS Windows

262
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Index
A
Abbreviation settings, 249, 251
Alignment (text), 83
All caps, 79
Anchoring objects, 108
Anchors, 205

Change hierarchy, 207
Delete, 207
Insert, 206
Panel, 205
Rename, 207
Show, 206

AutoCorrect, 66
AutoCorrect settings, 249–250
AutoFlow, 47
Automatic layout, 130

B
Baseline grid, 31

Independent by text 
frame, 50, 53

Baseline grid, paragraph 
override, 96
Baseline offset, 75
Bleed

Creating a document, 4
Bold, 72
Bookmarks, 205

Export as PDF, 208
Books, 130

Add chapters, 139
Anchors, 205
Chapters, 134
Close, 140
Create, 138
Cross-references, 146
Duplicate, 140
Export, 147
Hyperlinks, 210
Index, 146
Lists, 143
Notes, 143
Open, 139
Page numbering, 143

Panel, 135
Parts of, 130
Preflight, 135, 147
Print, 147
References, 146
Remove chapters, 139
Save, 140
Sections, 132
Splitting, 134
Story, 132
Stray pages, 136
Sync chapters, 142
Sync master pages, 141
Sync swatches, 141
Sync text styles and table 
formats, 141
Syncing, 141
Table of contents, 146

Breaks, Column, Frame and 
Page, 48
Bulleted lists, 92

Expand list, 92

C
Case-sensitive forms, 79
Character

Attributes, 70
Decorations, 73
Font, 71
Language, 80
Optical alignment, 81
Panel, 70
Positioning and transform, 74
Style, 73, 114
Typography, 77

Character variants, 79
Clear user data, 262
Colour

Creating a document, 3
Colour settings, 241
Context Toolbar, 235
Contextual alternates, 78
Copying text, 58
Cross-references, 150

Add, 152
Books, 146
Create preset, 154

Delete, 155
Edit, 155
Panel, 151
Share preset, 156
Update, 157

D
Decorations (character), 73
Decorations (paragraph), 102
Deleting text, 58
Dictionaries

Installing, 255
Document Setup, 5
Documents

Bleed, 4
Change options, 5
Colour, 3
Create, 2
Layout, 2
Margins, 4
Model, 5
Pages, 3
Presets, 2, 4
Scaling, 6
Setup, 5

Dot leaders, 88
Drop caps, 99

E
Endnotes, 185
Export

Books, 147
PDF (commercial press), 228
PDF (digital), 224

F
Fields, 197

Custom, 203
Date and time formats, 201
Delete, 198
Edit, 198
Expand (convert to text), 198
Format, 200
Insert, 198
Metadata, 197
Panel, 197
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Show, 198
Types, 199

Figure style, 80
Figure width, 80
Filler text, 253

Inserting, 56
Finding and replacing, 62

Regular expressions 
(GREP), 64

First line indent, 84
Float with text, 108
Flow (paragraph), 90
Flow text, 43, 130

Controls, 43
Interrupting, 48

Font, 71
Background colour, 73
Colour, 73
Outline, 73
Size, 72
Style, 72
Traits, 72

Footers, 22
Page numbering, 23

Footnotes, 185
Formatting characters, 70
Formatting paragraphs, 82
Fractions, 78

G
Glyph browser, 55

H
Hanging punctuation, 81
Headers, 22

Page numbering, 23
Running, 28

Hyperlinks, 209
Delete, 211
Insert, 209
Panel, 209

Hyphenation, 97
Installing dictionaries, 255
Language, 80

I
Import text, 68
Indents (paragraph), 84
Index, 172

Add cross-reference, 178
Add entry, 176
Add subtopic, 175
Add topic, 174
Books, 146
Change parent topic, 175
Delete, 179
Delete entry, 178
Delete topic, 175
Dot leader, 181
Format, 180
Generate, 179
Import topics, 175
Multiple, 183
Multiple occurrences, 177
Panel, 173
Topic list, 174
Update, 179

Initial words, 101
Inline in text, 108
Invisibles, 259
Italic, 72

J
Justification, 83
Justification options, 89

K
Keep together, 90
Kerning, 74

L
Language, 80
Layers

Stack order, 21
Layout

Automatic, 130
Creating a document, 2
Static, 130

Leading, 84
Leading override, 76
Ligatures, 77

Link text frames, 43
Lists

Books, 143
Lists (bulleted and numbered), 92

M
Margins

Creating a document, 4
Master pages, 7

Apply, 15
Change options, 14
Change stack order, 21
Convert page to, 17
Create, 13
Delete, 14
Edit objects, 19
Import, 18
Override, 19
Unassign from page, 18

Metadata, 197

N
No break, 76
Notes (footnotes, endnotes, 
sidenotes), 185

Add, 187
Books, 143
Convert formatting, 189
Convert type, 188
Default, document-wide, and 
custom settings, 189
Delete, 187
Edit, 187
Endnote positioning in 
Books, 145
Find, 187
Format, 192
Import from Microsoft 
Word, 196
Numbering, 191
Panel, 186
Position, 193
Set defaults, 190
Settings, 189

Numbered lists, 92
Expand list, 92
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O
OpenType, 77
Optical alignment, 81
Ordinals, 78

P
Page numbering, 23

Books, 143
Continued on, 26
Format, 24
Sections, 25

Pages, 7
Add, 10
Creating a document, 3
Delete, 11
Duplicate, 11
Import from another 
document, 11
Numbering, 23
Panel, 8
Reorder, 11
Select, 9
Size, 12
View, 10

Pages panel, 8
Panels

Customize, 237
Paragraph

Alignment (justification), 83
Attributes, 82
Background and borders, 102
Baseline grid override, 96
Bullets and numbering, 92
Decorations, 102
Drop caps, 99
Flow options, 90
Hyphenation, 97
Initial words, 101
Justification options, 89
Panel, 82
Rules above and below, 102
Spacing, 84
Style, 83, 114
Tab stops, 87

PDF, 224
PDF/X, 228

Pinning
Objects, 108

Pinning objects, 108
Place text, 68
Preferences, 241

Abbreviations, 249, 251
AutoCorrect, 249–250
Colour, 241
Filler text, 253
Shortcuts, 246
Title exceptions, 249, 252

Preflight, 214
Books, 147
Cross-references, 157
Export and import pro-
files, 217
Index, 179
Panel, 214
Presets, 215
Resolve issues, 219
Settings, 215
Table of contents, 161

Printing
Booklet, 223
Books, 147
Commercial press, 228
Direct to printer, 220
N-Up, 222

R
References

Books, 146
Regular expressions (GREP), 64
Rules above and below para-
graph, 102
Runaround text, 106
Running headers, 28

S
Sections, 22

Books, 132
Change or delete, 26
Use as chapters, 27

Selecting Text, 57
Settings, 241

Abbreviations, 249, 251
AutoCorrect, 249–250

Colour, 241
Filler text, 253
Shortcuts, 246
Title exceptions, 249, 252

Shape text, 38
Sidenotes, 185
Size handles

Change size, 44
Small caps, 79
Spacing (paragraph), 84
Special characters, 259

Choosing, 55
Typing, 55

Spelling
Check, 65
Installing dictionaries, 255
Language, 80

Static layout, 130
Story, 35, 130

Books, 132
Split, 45

Strikethrough, 73
Studio

Customize, 237
Presets, 240

Style Picker tool, 60
Stylistic sets, 79
Super/subscript, 76, 78
Swash, 79

T
Tab stops, 87
Table of contents, 158

Bookmarks, 165
Books, 146
Chapter prefixes, 167
Delete, 160
Dot leader, 164
Exclude heading, 166
Format, 162
Generate, 160
Import styles, 168
Include hidden headings, 166
Insert, 160
Multiple, 170
Panel, 159
Print and digital, 167
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Scope, 161
Text styles, 164
Update, 160

Text
AutoFlow, 47
Copying, 58
Default formatting, 44
Deleting, 58
Finding and replacing, 62
Flow, 43
Flow controls, 43
Import (Place), 68
Place (import), 68
Regular expressions 
(GREP), 64
Selecting, 57

Text cursor
Positioning, 54

Text flow, 130
Text Frame panel, 49
Text frames, 36

Balance columns, 51
Baseline grid, 50, 53
Column rules, 52
Columns, 51
Create, 36
Delete linked, 45
Fill and stroke, 50
Link, 43
Overflow, 50
Properties, 49
Scaled text, 44
Shape text, 38
Unlink, 45
Vertical alignment, 52

Text styles, 114
Apply, 118
 Based on, 122
Character, 73, 121
Clear override, 119
Create, 121
Delete, 124
Duplicate, 124
Edit, 125
Export, 127
Import, 126
 Keyboard shortcut, 122

Next level, 122
Next style, 122
Override, 119
Panel, 116
Paragraph, 83, 121
Remove, 119
Set default, 126
Show in both panels, 122
 Type, 122
Update, 125

Text wrap, 50, 106
Title exception settings, 249, 252
Toolbar

Customize, 234
Tools

Customize, 235
Tracking, 75
Typography, 77

U
Underline, 73
Unlink text frames, 45
User data

Clear, 262

V
Variables, 197

User, 203

W
Widow and orphan control, 90
Word count, 67
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