Inputting dates

Post your questions, bug reports and suggestions here for PlanMaker 2012 for Linux.

Moderator: SoftMaker Team

User avatar
Mark Davies
Posts: 202
Joined: Mon Apr 04, 2005 1:02 am
Location: Auckland , New Zealand

Inputting dates

Postby Mark Davies » Wed May 06, 2015 7:07 am

I'm using Planmaker on Cinnamon Mint 17.1. I'm in New Zealand and dates are in the format 31/12/15. However, I'm being forced to input them 12/31/15. Is this something in Planmaker or is it a setting of the OS? I've checked my that my region and language in Cinnamon's settings is NZ and English (NZ). My keyboard setting is US. Is that the cause of the problem?
Mark Davies

User avatar
Michael Uplawski
Posts: 99
Joined: Thu Dec 11, 2014 11:43 pm
Location: Canton Magny (previously Canton Carrouges), Orne, Normandy (previously Lower Normandy)

Re: Inputting dates

Postby Michael Uplawski » Fri May 08, 2015 7:15 am

Mark Davies wrote:I'm using Planmaker on Cinnamon Mint 17.1. I'm in New Zealand and dates are in the format 31/12/15. However, I'm being forced to input them 12/31/15.

With some kind of data, I do not rely on the defaults, nor the settings done in the operating system. For dates, currencies and some others, I routinely set the cell-formats by clicking right on a cell, a column, row or other region and choose “cell” from the context-menu (right-click-menu).

Here is a screen-shot from SoftMaker Free Office which should not differ much from what you see in Office 2012 and PlanMaker. I choose to define my own date-format “DD\/MM\/YY” (day/month/year) and applied it to a whole column. Now you can enter your date as you like. If PlanMaker is at all capable to identify the input with a date, it will re-format immediately all values to the set format.

Try it out and report back, if it fails. (Or works).
Image
People should go where they are not supposed to go, say what they are not supposed to say and stay, when they are told to leave.” (Howard Zinn)

User avatar
Mark Davies
Posts: 202
Joined: Mon Apr 04, 2005 1:02 am
Location: Auckland , New Zealand

Re: Inputting dates

Postby Mark Davies » Fri May 08, 2015 7:45 am

I can do that OK; I can display a date as dd/mm/yy I have to enter it as mm/dd/yy. :(
Mark Davies

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7181
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Inputting dates

Postby sven-l » Fri May 08, 2015 12:32 pm

Are your system settings in Linux set to dd/mm/yyyy? PlanMaker uses the system settings for the default date format.
Sven Leßmann
SoftMaker Software GmbH

User avatar
Michael Uplawski
Posts: 99
Joined: Thu Dec 11, 2014 11:43 pm
Location: Canton Magny (previously Canton Carrouges), Orne, Normandy (previously Lower Normandy)

Re: Inputting dates

Postby Michael Uplawski » Fri May 08, 2015 2:10 pm

Mark Davies wrote:I can do that OK; I can display a date as dd/mm/yy I have to enter it as mm/dd/yy. :(

Sorry, I have apparently misunderstood your original problem, prolly due to my missing darned cultural background. But Sven is here, fortunately. :)

[Edit: Kraut2English: Wegen dem mein Fehler / due to]
Last edited by Michael Uplawski on Sun May 10, 2015 12:04 am, edited 1 time in total.
People should go where they are not supposed to go, say what they are not supposed to say and stay, when they are told to leave.” (Howard Zinn)

User avatar
Mark Davies
Posts: 202
Joined: Mon Apr 04, 2005 1:02 am
Location: Auckland , New Zealand

Re: Inputting dates

Postby Mark Davies » Sat May 09, 2015 2:10 am

sven-l wrote:Are your system settings in Linux set to dd/mm/yyyy? PlanMaker uses the system settings for the default date format.

I'm on NZ for locale. I've googled this a bit, and one way to check is to see what Libre Office does with dates, and it certainly recognises the NZ format dd/mm/yy, so PlanMaker should too, but it doesn't.
Mark Davies

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7181
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Inputting dates

Postby sven-l » Mon May 11, 2015 7:45 am

I will refer that problem to our developers and report here as soon as we have a solution.
Sven Leßmann
SoftMaker Software GmbH

User avatar
Mark Davies
Posts: 202
Joined: Mon Apr 04, 2005 1:02 am
Location: Auckland , New Zealand

Re: Inputting dates

Postby Mark Davies » Thu Jul 30, 2015 10:40 pm

Have you found a solution to this. It's very infuriating.
Mark Davies

User avatar
Mark Davies
Posts: 202
Joined: Mon Apr 04, 2005 1:02 am
Location: Auckland , New Zealand

Re: Inputting dates

Postby Mark Davies » Mon Nov 30, 2015 8:04 am

i wonder if the problem is because I'm using a custom date format. The custom section doesn't give a language option. Default dates work, but the custom one uses the American input order for some reason.
Mark Davies


Return to “PlanMaker 2012 for Linux”

Who is online

Users browsing this forum: No registered users and 0 guests