% display settings

Post bug reports and suggestions for PlanMaker 2008 for Windows.

Moderator: SoftMaker Team

Post Reply
mshideler
Posts: 18
Joined: Sat Jan 05, 2008 11:57 pm

% display settings

Post by mshideler » Tue Jun 02, 2009 7:02 pm

Where can I change cells to display percentages as they are typed.

Example ~ if I type 5.35 I want the result to show 5.35%. Currently I have to type '.0535'.

Not that it is a huge deal but when you are typing in alot of data you end up with many wasted key-strokes. In the case of a simple number lke 5.35% having to type .0535 adds 67% more typing than needed. Do that for a hundred columns and it is a pain. Also more keys typed is more opportunities for errors in data entry.

I did search the help menu and all I could find was:

"Percentage

Displays the number as a percentage.

Apart from adding a percent sign (%) to the number, the number will also be displayed multiplied by 100. For example, 0.5 will be displayed as 50%.

Example: 42%

Hint: This number format can also be applied by clicking the icon in PlanMaker’s Formatting toolbar.
'

If there is not an option to change percentage number entry, I would like to have an enhancement request submitted to add a check box or toggle to allow for 5.35% to be entered as 5.35 and not .0535.

Thank you for any answers that you can provide.

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2814
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: % display settings

Post by martin-k » Tue Jun 02, 2009 8:36 pm

File/Properties/Options/Move by ... decimals
Martin Kotulla
SoftMaker Software GmbH

mshideler
Posts: 18
Joined: Sat Jan 05, 2008 11:57 pm

Re: % display settings

Post by mshideler » Tue Jun 02, 2009 9:52 pm

solves one problem ad creates another - the problem created is that setting appears to apply to ALL numbers within the document.

If I toggle that as suggested by your post then the % numbers are right, but then with $ figures I then have to still type extra keys to get, example, $7.00. You have to type '700'. If you type just 7 you end up with '$0.07'. That only shifts the error posibilities to the other number sets when doing data entry. More typing = more chances for errors to occur.


The issue needs to be addressed via format specific methods. Please create my enhancement request to add format based decimal placement. Could be done via couple of check boxes (currency, percentages, etc).

thank you.

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7250
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: % display settings

Post by sven-l » Wed Jun 03, 2009 8:57 am

Please try Tools/Option/Edit/ Automatic percent input.
Sven Leßmann
SoftMaker Software GmbH

mshideler
Posts: 18
Joined: Sat Jan 05, 2008 11:57 pm

Re: % display settings

Post by mshideler » Wed Jun 03, 2009 12:31 pm

Beautiful! =D>

That is the trick.

Thank you very much.

mshideler

Post Reply

Return to “PlanMaker 2008 for Windows”