Metafile Cut and Paste Completely Broken

Post bug reports and suggestions for SoftMaker Presentations 2008 for Windows.

Moderator: SoftMaker Team

tristan
Posts: 16
Joined: Wed Nov 26, 2003 12:59 pm
Location: Brisbane, Australia

Metafile Cut and Paste Completely Broken

Postby tristan » Wed Feb 06, 2008 10:49 am

Hi to all at Softmaker. I recently bought the release version after trying the very promising betas. Let me say up front that Softmaker really know how to write tight fast code - Softmaker office 2008 is just amazing.

I have noticed one real show stopping bug though. My work requires me to cut and paste data from scientific instrument software into presentations. This metafile data can be cut and pasted into Powerpoint or OpenOffice without incident. With Softmaker Presentations the data simply won't paste, regardless of whether I use "paste" or "paste as". Interestingly I can usually paste the same metafile into Textmaker.

I had previously posted this bug during the beta testing, where it was actually confirmed. Are there any plans to rectify this really fundamental problem? Otherwise, Presentations I essentially useless to me.

Tobias-L
Posts: 3423
Joined: Fri Nov 21, 2003 3:23 pm
Location: Nürnberg, Germany
Contact:

Re: Metafile Cut and Paste Completely Broken

Postby Tobias-L » Fri Feb 08, 2008 11:12 am

Please attach this meta file and the content of your clipboard.

Start :arrow2: Run :arrow2: clipbrd.exe
File :arrow2: Save as :arrow2: filename.clp
Attach this .clp file.
Tobias Leißner
SoftMaker Software GmbH


tristan
Posts: 16
Joined: Wed Nov 26, 2003 12:59 pm
Location: Brisbane, Australia

Re: Metafile Cut and Paste Completely Broken

Postby tristan » Tue Feb 12, 2008 10:39 am

Tobias, I did this for you during the beta testing, and it made no difference. It's not metafile specific, and in fact I think it's a problem with clipboard handling by presentations in general. http://www.softmaker.com/forum/viewtopic.php?f=85&t=5806 raises exactly the same issue. It's a pretty fundamental problem to have come through the beta testing.

lutz
Posts: 17
Joined: Wed Mar 21, 2007 7:59 pm

Re: Metafile Cut and Paste Completely Broken

Postby lutz » Fri Aug 15, 2008 11:45 pm

Any news on "Copy and Paste" in Presentations?

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7059
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Metafile Cut and Paste Completely Broken

Postby sven-l » Mon Aug 18, 2008 8:34 am

Hello,

I raised the priority for that problem and will inform you as soon as I have more information.
Sven Leßmann
SoftMaker Software GmbH

lutz
Posts: 17
Joined: Wed Mar 21, 2007 7:59 pm

"paste special" is working ?

Postby lutz » Mon Aug 18, 2008 8:26 pm

Hello,

actually, I believe it is somewhat working at the moment.
I did install the service pack and now I am able to paste bitmap pictures into presentations with the "Paste Special" command - the regular paste still does not work. But this is obviously a workable situation now.

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7059
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Metafile Cut and Paste Completely Broken

Postby sven-l » Wed Aug 20, 2008 9:19 am

Hello,

the problem has been solved now. In the next Service Pack you can (like in PowerPoint) directly paste images from the clipboard into a slide in Presentations without the need of "Paste Special".
Sven Leßmann
SoftMaker Software GmbH

lutz
Posts: 17
Joined: Wed Mar 21, 2007 7:59 pm

Re: Metafile Cut and Paste Completely Broken

Postby lutz » Wed Aug 20, 2008 6:03 pm

THANKS !

sounds great.


Return to “SoftMaker Presentations 2008 for Windows”

Who is online

Users browsing this forum: No registered users and 1 guest