can't save file with ä or ö in filename

Post your questions, bug reports and suggestions here for TextMaker 2018 for Linux.

Moderator: SoftMaker Team

Post Reply
kgha
Posts: 55
Joined: Sat Sep 01, 2012 6:52 pm

can't save file with ä or ö in filename

Post by kgha » Fri Jun 15, 2018 11:54 am

Makes me remember the good(?) old days of MS-DOS 3.3 :)
A minor issue, but it would be great if that could be fixed some time in the future

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7780
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: can't save file with ä or ö in filename

Post by sven-l » Mon Jun 18, 2018 9:37 am

1. Which Linux distribution are you using?
2. What is the system language of your Linux?
3. Does it work better with LibreOffice?
4. Which revision of SoftMaker Office is installed (Help=>About)?

Also, please provide the log file sminfo.txt (Help > About > Write system information).
Sven Leßmann
SoftMaker Software GmbH

kgha
Posts: 55
Joined: Sat Sep 01, 2012 6:52 pm

Re: can't save file with ä or ö in filename

Post by kgha » Tue Jun 19, 2018 7:56 am

Textmaker18 rev 931.0518 64 bit on Slackware -current, system language en-US, default document language in TM: Swedish

This issue seems to be linked to the one in this thread: viewtopic.php?f=305&t=17751

In order to get accents to work properly I've added the line export LANG=sv_SE.UTF-8 to the /usr/bin/textmaker18 file. However, if i delete that line I can save files with ä or ö in the filename.

Since the accent issue will be fixed in the next service pack, I guess everything will be sorted.

Cheers.
Attachments
sminfo.txt
(211.95 KiB) Downloaded 9 times

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2961
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: can't save file with ä or ö in filename

Post by martin-k » Tue Jun 19, 2018 9:11 am

And what happens when you save a file with a special character? An error message? Which? Or does the file name look "funny" in your file manager?
Martin Kotulla
SoftMaker Software GmbH

kgha
Posts: 55
Joined: Sat Sep 01, 2012 6:52 pm

Re: can't save file with ä or ö in filename

Post by kgha » Tue Jun 19, 2018 11:18 am

I can add most special characters to a filename, e.g. + $ # @ ( ) ? !
A few give the message "invalid filename", e.g. £

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7780
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: can't save file with ä or ö in filename

Post by sven-l » Thu Jun 21, 2018 8:45 am

Please wait for the next service pack (rev.933) and review this issue with it.
Sven Leßmann
SoftMaker Software GmbH

kgha
Posts: 55
Joined: Sat Sep 01, 2012 6:52 pm

Re: can't save file with ä or ö in filename

Post by kgha » Mon Jun 25, 2018 12:54 pm

I'm sorry having to report that after upgrading to latest buld 933, the problem still persist.
As mentioned here:
viewtopic.php?f=305&t=17751
I can't get accents to work properly without adding the line
export LANG=sv_SE.utf8
to the start script, and with that addition it is not possible to save files where the filename contains the letters å, ä, ö ("Invaldid filename"). Other special characters work, though.

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7780
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: can't save file with ä or ö in filename

Post by sven-l » Wed Jul 04, 2018 11:22 am

kgha wrote:
Mon Jun 25, 2018 12:54 pm
I'm sorry having to report that after upgrading to latest buld 933, the problem still persist.
As mentioned here:
viewtopic.php?f=305&t=17751
I can't get accents to work properly without adding the line
export LANG=sv_SE.utf8
to the start script, and with that addition it is not possible to save files where the filename contains the letters å, ä, ö ("Invaldid filename"). Other special characters work, though.
There is still a trouble ticket open (38419) for your problem. We will inform you as soon as we have more information.
Sven Leßmann
SoftMaker Software GmbH

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7780
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: can't save file with ä or ö in filename

Post by sven-l » Fri Jul 06, 2018 1:23 pm

It seems that the issue happens only on your system. No other customer reports that problem. Also, we couldn't reproduce it here with the same Linux. Something with your system is not quite right.

As a solution it would be best if you configure your system using a Swedish UTF-8 locale. These days a Linux system should always be Unicode-enabled.
Sven Leßmann
SoftMaker Software GmbH

Lihis
Posts: 7
Joined: Fri Dec 08, 2017 3:05 pm

Re: can't save file with ä or ö in filename

Post by Lihis » Fri Jul 06, 2018 9:51 pm

Saving a file with filename containing å/ä/ö letters works for me on rev 933.0619 on Arch. Can't remember have I tried to save a file with filename that contained these letters before this revision.

Code: Select all

$ locale -a
C
en_US.utf8
fi_FI.utf8
POSIX

Code: Select all

$ echo $LANG
en_US.UTF-8

kgha
Posts: 55
Joined: Sat Sep 01, 2012 6:52 pm

Re: can't save file with ä or ö in filename

Post by kgha » Tue Jul 10, 2018 6:14 pm

Setting system locale to LANG=sv_SE.utf8 doesn't solve this issue. And for various reasons I prefer English as system language. So I have to choose one of two options:
1) Running en_US as system locale and writing in Swedish on Swedish keyboard - then I can use å,ä,ö in filenames but accents won't display properly, or
2) starting Textmaker with
export LANG=sv_SE.utf8
textmaker18
which solves the accents issue but prevents me from saving a file with å,ä,ö in the filename.
Since I normally avoid these letters in filenames, I stick with the second alternative. As said in my first post, it's really a minor issue.

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2961
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: can't save file with ä or ö in filename

Post by martin-k » Tue Jul 10, 2018 6:16 pm

If you prefer English, you can replace sv_SE.utf8 with en_US.utf8 or en_UK.utf8
Martin Kotulla
SoftMaker Software GmbH

Lihis
Posts: 7
Joined: Fri Dec 08, 2017 3:05 pm

Re: can't save file with ä or ö in filename

Post by Lihis » Tue Jul 10, 2018 7:19 pm

As I didn't mention in my previous post, I have system language in English and keyboard layout is US. å,ä,ö are displayed correctly. Note that I have binded å,ä,ö (and €) via Xmodmap to the keys as they are in Finnish layout.

kgha
Posts: 55
Joined: Sat Sep 01, 2012 6:52 pm

Re: can't save file with ä or ö in filename

Post by kgha » Wed Jul 11, 2018 3:27 pm

Yes, with system language en_US and starting Textmaker with textmaker18 and nothing else, I have no problems with using ä or ö in filenames. But (as I mentioned in post #3 in this thread) this issue is linked to the one discussed in another thread: viewtopic.php?f=305&t=17751

With system language en_US, the words "crème fraîche" appears as "cr`eme fra^iche" and Düsseldorf (writing the German letter ü on a Swedish keyboard is done with " + u where the trema is a special character different from the double quotation mark) appears as Dusseldorf.

A workaround is to change locale for textmaker:

Code: Select all

export LANG=sv_SE.UTF-8
textmaker18
I've done that by adding the export LANG line to /usr/bin/textmaker18

Then accents appears correctly (which is important for me), but I can't save a file with the letters å,ä,ö in the filename (not particularly important). I can, however, open a file where the filename contains these letters, and save it under the same name.

Same or similar problems affect other programs if started with preceding "export LANG=sv_SE.UTF-8" (e.g. Avidemux and Gimp) while other works (e.g. OpenOffice, Audacity).

A month ago, sven-l wrote in the other thread that "The problem with accented characters is solved now and should no longer occur in the next service pack." I therefore expected that updating to 933 would allow me to ditch the "export LANG=sv_SE.UTF-8", but the accent problem was not solved after updating.

Lihis
Posts: 7
Joined: Fri Dec 08, 2017 3:05 pm

Re: can't save file with ä or ö in filename

Post by Lihis » Thu Jul 12, 2018 8:58 am

Sorry, I must have missed the accents issue. Them seems to be issue for me too, I'll drop a message in the thread which you linked.

However, I can save files with å,ö,ä no matter is the LANG set to en_US.UTF-8 or fi_FI.UTF-8.

Post Reply

Return to “TextMaker 2018 for Linux”