cannot enter Lithuanian letters

Help for TextMaker 2002 for Linux and FreeBSD

Moderator: SoftMaker Team

Post Reply
nerijus
Posts: 21
Joined: Wed Nov 17, 2004 1:34 am

cannot enter Lithuanian letters

Post by nerijus » Wed Nov 17, 2004 1:39 am

Hello,

I can enter only š and ž letters, i.e. those, which are also in ISO-8859-1 encoding. For other Lithuanian letters I get some junk. I can see LT letters correctly BTW.
System Fedora core 2, Xorg 6.7, I use Option "XkbLayout" "lt,lt(lt_us)" in xorg.conf.

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2892
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Post by martin-k » Wed Nov 17, 2004 8:44 am

You need to go into Extras>Preferences and set the Default Encoding to "Baltic". Also, you need Baltic fonts, but you probably have those.

This is described in more detail in the "World Languages.tmd" file in ~/Documents
Martin Kotulla
SoftMaker Software GmbH

nerijus
Posts: 21
Joined: Wed Nov 17, 2004 1:34 am

Post by nerijus » Wed Nov 17, 2004 8:44 pm

It's Baltic already. I set it up in a beta version, and this setting is still here in my newly bought version.

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2892
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Post by martin-k » Wed Nov 17, 2004 8:48 pm

So if it does not work, I need you to tell me which Lithuanian character you entered and which character appeared onscreen instead.
Martin Kotulla
SoftMaker Software GmbH

nerijus
Posts: 21
Joined: Wed Nov 17, 2004 1:34 am

Post by nerijus » Wed Nov 17, 2004 9:03 pm

I can enter only š and ž correctly. For others I get for example:
instead of ą - ¹
instead of ė - e,
instead of Ė - E
and so on.
If you use default Lithuanian keyboard in XFree/xorg, lithuanian letters are on the digits row - pressing 1234567890= should enter ąčęėįšųū„“ž.

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2892
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Post by martin-k » Wed Nov 17, 2004 9:11 pm

This looks like the fonts you are using are not encoded according to ISO-8859-4.

To check this, go to Extras>Preferences, set the code page to Baltic, then
go to Insert>Symbol, select a font of which you assume has Baltic characters, and change the font name from (say) "Arial ANSI" to just "Arial". Then check the character set. You should find:

char 192 = A ogonek
193 = I ogonek
194 = A macron
195 = C acute
198 = E ogonek
199 = E macron

etc.

If not, then this font doesn't have Baltic characters.
Martin Kotulla
SoftMaker Software GmbH

nerijus
Posts: 21
Joined: Wed Nov 17, 2004 1:34 am

Post by nerijus » Wed Nov 17, 2004 9:35 pm

Yes, I see the chars in these exact places.
Symbol file which I use (/usr/X11R6/lib/X11/xkb/symbols/pc) produces aogonek, ccaron, eogonek, etc, so it's OK IMHO.
BTW, now more common Baltic encoding is ISO-8859-13 instead of ISO-8859-4.

Post Reply

Return to “TextMaker 2002 for Linux and FreeBSD”