Weird behavior of alignments in TextMaker

Help for TextMaker 2002 for Linux and FreeBSD

Moderator: SoftMaker Team

Post Reply
astroboy
Posts: 23
Joined: Wed Feb 16, 2005 1:50 am

Weird behavior of alignments in TextMaker

Post by astroboy » Thu Feb 17, 2005 2:05 am

Since the academic pricing, we installed TextMaker in all the computers in our school. We use Textmaker in SuSE Linux 9.2.

However, from time to time, some of our students find themselves in a bugging problem. It's not always reproducible, but happens very, very frequently.

If a students chose, say, center alignment, the text in that paragraph is centered as expected. But if she/he hit enter to open a new paragraph, and chooses any other alignment, the previous paragraph does not preserve its centered state and changes alignment to whatever change happens in the second paragraph.

It sometimes get worse. Sometimes all the text in the document changes to whatever alignment is chosen in a paragraph (and yes, the text is not even selected!)

What's going on??? :cry:

Tobias-L
Posts: 3423
Joined: Fri Nov 21, 2003 3:23 pm
Location: Nürnberg, Germany
Contact:

Post by Tobias-L » Thu Feb 17, 2005 9:49 am

This really sounds strange, but we need some way to reproduce this behaviour. There are no known issues similar to this. Please tell us as soon as possible if you found a way to reproduce this problem.
Tobias Leißner
SoftMaker Software GmbH


martin-k
SoftMaker Team
SoftMaker Team
Posts: 2886
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Post by martin-k » Thu Feb 17, 2005 5:26 pm

This sounds like your users are ending paragraphs with Shift+Return instead of Return, thereby creating one huge paragraph.

This could be an effect of a recently fixed bug: If you pasted text from a web browser into TextMaker, the lines ended in Shift+Return instead of Return. But this was fixed in the last servicepack.
Martin Kotulla
SoftMaker Software GmbH

astroboy
Posts: 23
Joined: Wed Feb 16, 2005 1:50 am

Post by astroboy » Fri Feb 18, 2005 11:46 pm

Ummmh.. the users (including myself) have not pressed Shift+Return when that behavior appears.

I'm still unable to reproduce this problem, other than it appears very often out of nowhere and with no apparent reason...

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2886
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Post by martin-k » Fri Feb 18, 2005 11:52 pm

Go to Extras>Preferences>View and turn on the display of all invisible characters. Do the problem paragraphs end with a ¶ or a ¬? If the latter, the lines are ending in Shift+Returns.
Martin Kotulla
SoftMaker Software GmbH

astroboy
Posts: 23
Joined: Wed Feb 16, 2005 1:50 am

Post by astroboy » Mon Feb 21, 2005 9:55 pm

Done it! we found a way to reproduce the problem.

What's happening is that every time I press Enter WHILE the Caps Lock key is activated, TextMaker puts ¬

A workaround is to deactivate Caps Lock key, and then press Enter. That way the ¶ appear, and then we can change paragraph alignment without problems...

Of course, we'd like to be able to press Enter key without having to worry if Caps Lock is activated or not...

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2886
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Post by martin-k » Tue Feb 22, 2005 3:38 pm

This behaviour is a function of your keyboard driver. We just receive the key codes and process them accordingly. You might want to check if there are alternative keyboard drivers -- many Linux system offer multiple drivers for the same language, with different mappings and slightly different behaviour.
Martin Kotulla
SoftMaker Software GmbH

astroboy
Posts: 23
Joined: Wed Feb 16, 2005 1:50 am

Post by astroboy » Tue Feb 22, 2005 4:46 pm

Ummh... we use Spanish or LatinAmerican keyboard layouts, the ones included in X11.

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "es"
Option "XkbModel" "pc105"
Option "XkbRules" "xfree86"
EndSection

OR

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "la"
Option "XkbModel" "pc105"
Option "XkbRules" "xfree86"
EndSection

Since TextMaker is the ONLY program in our Linux boxes that shows this behavior, wouldn't be possible that there is something going on in the way TextMaker handles key codes? :o

StarOffice7/WordPerfect/KWord/AbiWord/ and all the programs that do use text editing don't have issues with Caps Lock...

Tobias-L
Posts: 3423
Joined: Fri Nov 21, 2003 3:23 pm
Location: Nürnberg, Germany
Contact:

Post by Tobias-L » Mon Apr 04, 2005 4:21 pm

Do you have the same issues with US keyboard layout?
Tobias Leißner
SoftMaker Software GmbH


Post Reply

Return to “TextMaker 2002 for Linux and FreeBSD”