Unable to Install on LM 17.3

Post here those questions, bug reports and suggestions for SoftMaker FreeOffice 2016 for Linux that do not fit in any of the application-specific subforums.

Moderator: SoftMaker Team

Post Reply
Spood
Posts: 1
Joined: Wed Oct 25, 2017 4:51 am

Unable to Install on LM 17.3

Post by Spood » Wed Oct 25, 2017 4:59 am

Hi

I have tried installing FreeOffice on two versions of Linux.

First I tried Linux Mint 18.2 which failed during installation due to dependencies resulting in a broken package which I removed.

I then tried a version that FreeOffice has been tested on - Linux Mint 17.3...
Again the installation falied, see screen output below...

sudo dpkg -i softmaker-freeoffice-2016_767-01_i386.deb[sudo] password for chris:
Selecting previously unselected package softmaker-freeoffice-2016.
(Reading database ... 162073 files and directories currently installed.)
Preparing to unpack softmaker-freeoffice-2016_767-01_i386.deb ...
Unpacking softmaker-freeoffice-2016 (2301) ...
dpkg: dependency problems prevent configuration of softmaker-freeoffice-2016:
softmaker-freeoffice-2016 depends on libidn11.

dpkg: error processing package softmaker-freeoffice-2016 (--install):
dependency problems - leaving unconfigured
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Errors were encountered while processing:
softmaker-freeoffice-2016

Appreciate any pointers and/or known workarounds?

User avatar
Michael Uplawski
Posts: 116
Joined: Thu Dec 11, 2014 11:43 pm
Location: Canton Magny (previously Canton Carrouges), Orne, Normandy (previously Lower Normandy)

Re: Unable to Install on LM 17.3

Post by Michael Uplawski » Thu Oct 26, 2017 1:31 pm

Spood wrote: softmaker-freeoffice-2016 depends on libidn11.
Appreciate any pointers and/or known workarounds?
Pointer, not to a workaround but to the solution :

softmaker-freeoffice-2016 depends on libidn11.

If other packages are missing, install them likewise, but better use the package manager that came with your distribution. Alternatively choose

Code: Select all

apt-get install [package]
People should go where they are not supposed to go, say what they are not supposed to say and stay, when they are told to leave.” (Howard Zinn)

Post Reply

Return to “SoftMaker FreeOffice 2016 for Linux (General)”