Keyboard layouts randomly switching while entering/editing duo-language test: RU-ENG

Post your questions, bug reports and suggestions here for TextMaker 2016 for Linux.

Moderator: SoftMaker Team

Post Reply
jtux270
Posts: 2
Joined: Thu Sep 21, 2017 10:14 am

Keyboard layouts randomly switching while entering/editing duo-language test: RU-ENG

Post by jtux270 » Thu Sep 21, 2017 10:22 am

Hello,
While editing/composing a text I copy-paste the text in English then start entering some RU text. During the navigation through such duo-linguistic text and using RU spell checking the keyboard layout keeps switching back to Eng everytime. How can I say TexMaker to NOT switch back and forth my langauge layouts during the work? I only need to switch it explicitly by pressing the designated key on the keyboard. Please help?

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2973
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: Keyboard layouts randomly switching while entering/editing duo-language test: RU-ENG

Post by martin-k » Mon Sep 25, 2017 4:43 pm

TextMaker itself does not change the keyboard layout at all. If the keyboard layout switches, you need to look at the keyboard settings of your operating system.
Martin Kotulla
SoftMaker Software GmbH

jtux270
Posts: 2
Joined: Thu Sep 21, 2017 10:14 am

Re: Keyboard layouts randomly switching while entering/editing duo-language test: RU-ENG

Post by jtux270 » Mon Oct 02, 2017 12:15 pm

martin-k wrote:TextMaker itself does not change the keyboard layout at all.
Not talking abt TM actually 'changing' the layout, but it still does 'switches' it randomly from one language to another. It seems to be like a compatibility bug with the window manager, bcs when I diselected the "Window Manager dialogs" option the things came back to normal. I use Linux Mint 18.2 XFCE.

Also I noticed that the middle-click behaviour is buggy, too. After selecting w the mouse and middle-clicking inside the TM document, it pastes the previous/old copy-pasted (Ctrl+C) content of the clipboard and not the content I just selected a secong ago. Very frustrating bug. I'm using revision 765.0305
TY anyways for your answer.

Post Reply

Return to “TextMaker 2016 for Linux”