SoftMaker 2016 does not start on Debian Jessie

Post your questions, bug reports and suggestions here for TextMaker 2016 for Linux.

Moderator: SoftMaker Team

Post Reply
Wakizashi
Posts: 3
Joined: Mon Sep 07, 2015 1:06 pm

SoftMaker 2016 does not start on Debian Jessie

Post by Wakizashi » Thu Dec 17, 2015 4:05 pm

Hello,

Have bought Office 2016 for Linux, but unable to use it - neither one of it's applications does not start.
System is Debian Jessie with latest (including security) updates.

Have installed package, but during start it shows following test in terminal (when started from terminal):

$ /usr/bin/textmaker16
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

and just hangs.

That is same for TextMaker, Presentations and PlanMaker.

Here are last 2 pages of strace output:

....
open("/usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("/usr/lib/i386-linux-gnu/dri/swrast_dri.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("/usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("/usr/lib/i386-linux-gnu/dri/swrast_dri.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("/usr/lib/dri/tls/swrast_dri.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("/usr/lib/dri/swrast_dri.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
write(2, "libGL error: ", 13libGL error: ) = 13
write(2, "unable to load driver: swrast_dr"..., 37unable to load driver: swrast_dri.so
) = 37
write(2, "libGL error: ", 13libGL error: ) = 13
write(2, "failed to load driver: swrast\n", 30failed to load driver: swrast
) = 30
poll([{fd=3, events=POLLIN|POLLOUT}], 1, 4294967295) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"\234\16\2\0\0\0\0\0", 8}, {NULL, 0}, {"", 0}], 3) = 8
poll([{fd=3, events=POLLIN}], 1, 4294967295) = 1 ([{fd=3, revents=POLLIN}])
recvmsg(3, {msg_name(0)=NULL, msg_iov(1)=[{"\1\0S\0 \3\0\0\24\0\0\0(\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 4096}], msg_controllen=0, msg_flags=0}, 0) = 3232
recvmsg(3, 0xfff031c4, 0) = -1 EAGAIN (Resource temporarily unavailable)
recvmsg(3, 0xfff031c4, 0) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN|POLLOUT}], 1, 4294967295) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"\234\23\3\0\0\0\0\0\3\0\0\0", 12}], 1) = 12
poll([{fd=3, events=POLLIN}], 1, 4294967295) = 1 ([{fd=3, revents=POLLIN}])
recvmsg(3, {msg_name(0)=NULL, msg_iov(1)=[{"\1\0T\0y\0\0\0\0\0\0\0\342\1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 4096}], msg_controllen=0, msg_flags=0}, 0) = 516
recvmsg(3, 0xfff03184, 0) = -1 EAGAIN (Resource temporarily unavailable)
recvmsg(3, 0xfff03184, 0) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN|POLLOUT}], 1, 4294967295) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"\234\25\2\0\0\0\0\0", 8}, {NULL, 0}, {"", 0}], 3) = 8
poll([{fd=3, events=POLLIN}], 1, 4294967295) = 1 ([{fd=3, revents=POLLIN}])
recvmsg(3, {msg_name(0)=NULL, msg_iov(1)=[{"\1\0U\0 \17\0\0,\0\0\0,\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 4096}], msg_controllen=0, msg_flags=0}, 0) = 4096
recv(3, "&\0\0\0\377\377\377\377'\0\0\0\377\377\377\377(\0\0\0\377\377\377\377$\0\0\0\0\0\0\0"..., 11424, 0) = 11424
recvmsg(3, 0xfff031d4, 0) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN|POLLOUT}], 1, 4294967295) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"\234#K\3\1\0\0\0\4\0\0\0\1\0\0\0\320\f\0\0006\0\0\0\1\0\0\0\4\0\0\0"..., 3372}], 1) = 3372
recvmsg(3, 0xfff03384, 0) = -1 EAGAIN (Resource temporarily unavailable)
mmap2(NULL, 262144, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xfffffffff69ac000
poll([{fd=3, events=POLLIN|POLLOUT}], 1, 4294967295) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"N\0\4\0\1\0\300\3\307\0\0\0!\0\0\0\1\30\v\0\2\0\300\3\307\0\0\0\0\0\0\0"..., 100}, {NULL, 0}, {"", 0}], 3) = 100
poll([{fd=3, events=POLLIN}], 1, 4294967295) = 1 ([{fd=3, revents=POLLIN}])
recvmsg(3, {msg_name(0)=NULL, msg_iov(1)=[{"\0\2Y\0\0\0\0\0\3\0\234\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 4096}], msg_controllen=0, msg_flags=0}, 0) = 64
open("/usr/share/X11/XErrorDB", O_RDONLY) = 4
fstat64(4, {st_mode=S_IFREG|0644, st_size=41532, ...}) = 0
read(4, "!\n! Copyright 1993, 1995, 1998 "..., 41532) = 41532
close(4) = 0
brk(0x9950000) = 0x9950000
gettimeofday({1450364872, 371}, {4294967116, 0}) = 0
gettimeofday({1450364872, 455}, {4294967116, 0}) = 0
futex(0xf6db4918, FUTEX_WAKE_PRIVATE, 2147483647) = 0
futex(0x98c8bf0, FUTEX_WAKE_PRIVATE, 1) = 0
gettimeofday({1450364872, 720}, {4294967116, 0}) = 0
futex(0x98c8bf0, FUTEX_WAIT_PRIVATE, 2, NULL) = ? ERESTARTSYS (To be restarted if SA_RESTART is set)
--- SIGWINCH {si_signo=SIGWINCH, si_code=SI_KERNEL} ---
futex(0x98c8bf0, FUTEX_WAIT_PRIVATE, 2, NULL

So, it hangs at this point.

PS: problem has been solved by installing appropriated i386 libraries:

apt-get install libgl1-mesa-dri:i386

I suppose, that SoftMaker now using GLX by default, and it's Debian package doesn't have required dependencies.

Also, it's strange to see both 64 and 32 bit versions for RPM packages, but only 32-bit version for Debian family (Debian, Ubuntu, etc.)
Using i386 packages on 64-bit system in Debian is not a good practice, as id duplicates amount of packages and installing lot of unneeded garbage.
Would be good to have same packages as for RPM - both 64-bit and 32-bit _compiled_, and with correct dependencies.

And it would be good to provide at least MINIMAL amount of TESTING prior to releasing commercial product.
This is what expected from commercial product in Linux world - to be TESTED and STABLE.
Not tested and unstable is LibreOffice, and this is why it's free.

Regards,
Alex

User avatar
Michael Uplawski
Posts: 128
Joined: Thu Dec 11, 2014 11:43 pm
Location: Canton Magny (previously Canton Carrouges), Orne, Normandy (previously Lower Normandy)

Re: SoftMaker 2016 does not start on Debian Jessie

Post by Michael Uplawski » Sat Dec 19, 2015 8:53 am

Wakizashi wrote: And it would be good to provide at least MINIMAL amount of TESTING prior to releasing commercial product.
Your statement is okay and your demand justified. But a lack of testing is
not the problem of SoftMaker Office for Linux or of SoftMaker. Both may
be related but the problem is a bunch of general incompatibilities with
the Linux-world which first of all concern the way, that requirements are
perceived, identified, then prioritized. Together with the implementation in
code, these steps and activities are apparently conducted in an attitude that
was common in past epochs, or may still be so in Microsoft-centered software
development.

You can access old forum discussions to see the stability of what I called
“attitude“ above for lack of english vocabulary. I can be completely wrong,
too, as all I do is interprete, albeit not in my refusal to accuse SoftMaker
of being lax with their software-tests.

Michael
running FreeOffice and 2016 Test on Debian stretch/sid rolling release.
People should go where they are not supposed to go, say what they are not supposed to say and stay, when they are told to leave.” (Howard Zinn)

Alfred
Posts: 139
Joined: Sat Jun 14, 2014 3:40 pm
Location: Scotland

Re: SoftMaker 2016 does not start on Debian Jessie

Post by Alfred » Sat Dec 19, 2015 10:21 am

Wakizashi wrote:Not tested and unstable is LibreOffice, and this is why it's free.
I'm not familiar with the Linux implementation of LibreOffice (nor, indeed, with Linux in general). However, the Windows version of LibreOffice is extensively tested and very stable, but it's also free. :-k
La perfection est atteinte non quand il ne reste rien à ajouter, mais quand il ne reste rien à enlever.
(Perfection is achieved, not when there is nothing left to add, but when there is nothing left to take away.)
- Antoine de Saint-Exupéry (1900-1944)

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7781
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: SoftMaker 2016 does not start on Debian Jessie

Post by sven-l » Tue Dec 22, 2015 5:08 pm

In your case you need to install the "Additional dependencies for certain DEB-based systems" from this page:
http://www.softmaker.com/en/tips-linux
Sven Leßmann
SoftMaker Software GmbH

Post Reply

Return to “TextMaker 2016 for Linux”