Cannot install beta on CentOS 6 due to libudev version issue

Post bug reports and suggestions here for SoftMaker Office 2016 for Linux Beta that do not fit in any of the application-specific subforums.

Moderator: SoftMaker Team

Post Reply
wvh
Posts: 3
Joined: Thu Nov 06, 2008 12:20 pm

Cannot install beta on CentOS 6 due to libudev version issue

Post by wvh » Sat Nov 21, 2015 3:35 am

The last closed beta and the new open beta of SoftMaker office require libudev.so.1, while CentOS 6 (and thus, presumably, RedHat 6) only provide libudev.so.0. This makes it impossible for me to install these betas from the RPM. I can, of course, still successfully install from the tarball, but I'd think that you'd want to encourage the use of RPMs for enterprise or multi-user scenarios. Do you really need libudev.so.1, or is this just a build configuration issue?

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2866
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: Cannot install beta on CentOS 6 due to libudev version issue

Post by martin-k » Sat Nov 21, 2015 1:59 pm

This will work with the next beta. The libudev dependency was added for openSUSE and Mageia and currently breaks CentOS 6.
Martin Kotulla
SoftMaker Software GmbH

Post Reply

Return to “General”