cannot install on ubuntu-14.04-lts

Post bug reports and suggestions here for SoftMaker Office 2016 for Linux Beta that do not fit in any of the application-specific subforums.

Moderator: SoftMaker Team

freelsjd
Posts: 5
Joined: Thu Nov 19, 2015 12:08 am

cannot install on ubuntu-14.04-lts

Postby freelsjd » Thu Nov 19, 2015 12:15 am

My Ubuntu-14.04-lts installation is current and up-to-date with all patches. I also have nvidia opengl drivers installed. The following output from my installation attempt explains the problem. When I try to issue "apt-get -f install", it wants to delete several hundred packages, which of course, I will not do, so I am stuck. I also have softmaker-2012 for linux installed and it works fine. Should I delete it ? Also, the package libgl1-mesa-glx IS installed on this system too, so why this error message. I have a 64-bit system with 32-bit packaging set up with multi-arch. Another question: why 32-bit ? Who still uses 32-bit ? Can you even purchase a 32-bit machine these days ?

root@fea9:/home/fea/Downloads# dpkg -i softmaker-office-2016_748-01_i386.deb
Selecting previously unselected package softmaker-office-2016.
(Reading database ... 647205 files and directories currently installed.)
Preparing to unpack softmaker-office-2016_748-01_i386.deb ...
Unpacking softmaker-office-2016 (2246) ...
dpkg: dependency problems prevent configuration of softmaker-office-2016:
softmaker-office-2016 depends on libgl1-mesa-glx.

dpkg: error processing package softmaker-office-2016 (--install):
dependency problems - leaving unconfigured
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Processing triggers for mime-support (3.54ubuntu1.1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Errors were encountered while processing:
softmaker-office-2016
root@fea9:/home/fea/Downloads#

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7030
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: cannot install on ubuntu-14.04-lts

Postby sven-l » Tue Nov 24, 2015 4:10 pm

I could properly install softmaker-office-2016_748-01_i386.deb in Ubuntu 14.04.2 64bit gnome via dkpg -i. I will refer your issue to our developers.
Sven Leßmann
SoftMaker Software GmbH

freelsjd
Posts: 5
Joined: Thu Nov 19, 2015 12:08 am

Re: cannot install on ubuntu-14.04-lts

Postby freelsjd » Tue Nov 24, 2015 5:49 pm

I was able to install the linux beta on a Debian/Jessie system. I then looked at what mesa packages were installed on the Debian/Jessie system, and then installed the same packages onto the Ubuntu/Trusty system. Below is a listing of the script that was created to do this.

apt-get install \
libegl1-mesa:amd64 \
libgl1-mesa-dri:amd64 \
libgl1-mesa-dri:i386 \
libgl1-mesa-glx:amd64 \
libgl1-mesa-glx:i386 \
libglapi-mesa:amd64 \
libglapi-mesa:i386 \
libglu1-mesa:amd64 \
libglu1-mesa:i386 \
libwayland-egl1-mesa:amd64 \
mesa-utils

This then resulted in a large number of additional packages that needed to be installed using the "apt-get -f install" command as recommended by the Softmaker installation instructions.

I think in addition, I will now re-install the Nvidia commercial graphics drivers which should override some of the mesa files that need to be overridden in order to use the Nvidia drivers. I should be OK now.


Return to “General”

Who is online

Users browsing this forum: No registered users and 1 guest