Startup Error

Post bug reports and suggestions here for SoftMaker Office 2016 for Linux Beta that do not fit in any of the application-specific subforums.

Moderator: SoftMaker Team

mcolligan
Posts: 4
Joined: Tue Sep 08, 2015 3:49 pm

Startup Error

Postby mcolligan » Thu Oct 08, 2015 5:07 pm

I tried to start the new SoftMaker Office 2016 on Fedora 22 and both TextMaker and PlanMaker hang here:

Couldn't dlopen libudev.so.1 or libudev.so.0, driver detection may be broken.
Couldn't dlopen libudev.so.1 or libudev.so.0, driver detection may be broken.
Couldn't dlopen libudev.so.1 or libudev.so.0, driver detection may be broken.
Couldn't dlopen libudev.so.1 or libudev.so.0, driver detection may be broken.
Couldn't dlopen libudev.so.1 or libudev.so.0, driver detection may be broken.
libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Please advise and thank you.

Michael

kingson
Posts: 2
Joined: Fri Sep 11, 2015 2:12 am

Re: Startup Error

Postby kingson » Fri Oct 09, 2015 1:22 am

I'm getting the same error on Fedora 22 x64. It seems as if SoftMaker office can't load the graphics driver.

libGL error: unable to load driver: nouveau_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: nouveau
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

@mcolligan Are you running 64-bit as well?

Try installing these packages:

Code: Select all

# dnf install mesa-dri-drivers.i686 systemd-libs.i686

Jim-J
SoftMaker Team
SoftMaker Team
Posts: 437
Joined: Fri Apr 04, 2014 8:29 am

Re: Startup Error

Postby Jim-J » Fri Oct 09, 2015 5:20 pm

Hello,

I can confirm this error message with Fedora. I informed the developers about this issue. As soon as I get response, I'll let you know.
Jim J.
SoftMaker Software GmbH

mcolligan
Posts: 4
Joined: Tue Sep 08, 2015 3:49 pm

Re: Startup Error

Postby mcolligan » Fri Oct 09, 2015 6:34 pm

I am indeed running x86_64 and...

@kingson:

dnf install mesa-dri-drivers.i686 systemd-libs.i686

fixed my startup issue. Much appreciated.

@SoftMaker:

Looks like we need to include those two packages in the depends for at least the x86_64 the rpm package.

JohnbCallander
Posts: 85
Joined: Mon Mar 01, 2010 3:31 pm

Re: Startup Error on Ubuntu on Chromebook

Postby JohnbCallander » Sun Oct 11, 2015 10:54 pm

One of the things I am/was trying out was to add it to Ubuntu 12, but sitting on my Chromebook Acer C720. I have managed to run linux 2012 version of SoftMaker on it (32 bit). However 2016 version appeared to install, but after entering the code it came up with SDL Engine initialisation failed fallback to Xrender/Xlib forced. However then when logging off it seems to have corrupted the whole Chroot and give the message Fatal error no screens found, every time I try and restart. :o I have had to re-install. It would be helpful to know if you can advise of any way to avoid this problem. [-o<

There are a large number of people using using linux by this method as it means you have very cheaply, a battery life of 6 hours, or so and the advantages of chrome and linux (allowing Skype, Netflix and the like which Chrome does not). So is quite a chunk now of Linux market.

I will also be trying to use on Ubuntu 14.04.3 on dual boot on my Windows 10 Desktop, it was just going to be much better to have a backup for my presentations from my Windows 10 laptop first. - Cannot lug my Desktop around!

Jim-J
SoftMaker Team
SoftMaker Team
Posts: 437
Joined: Fri Apr 04, 2014 8:29 am

Re: Startup Error

Postby Jim-J » Tue Oct 13, 2015 2:48 pm

Hello,

For Unbuntu 12 you have to install the libraries manually. We recommend to update to Ubuntu 14. Then the libaries will be automatically installed and it should work properly.
Jim J.
SoftMaker Software GmbH

JohnbCallander
Posts: 85
Joined: Mon Mar 01, 2010 3:31 pm

Re: Startup Error

Postby JohnbCallander » Tue Oct 13, 2015 5:20 pm

Many thanks for that information. :D I will have to look at if Crouton give full support to 14 - they had done a lot of work to remove issues when using 12. I would rather work in 14 anyway. Just wondering - use of DirectX for presentations transitions is not possible is it yet in 12 or 14? I will put that question in presentations section as well -it is looking sparse.

faferg
Posts: 2
Joined: Sun Sep 06, 2015 9:18 pm

Re: Startup Error

Postby faferg » Tue Oct 13, 2015 7:15 pm

"Error: SDL Engine initialization failed. Fallback to XRender/XLib forced."

As I opened each app, Textmaker, Planmaker, and Presentations, for the first time, I got this error message. After clicking through, each app has worked as expected. On shutdown and restart, the Errror message does not return, so this error is NOT getting in the way. Still, what does this error message mean?

ASUS EEE HE-1001 netbook, 32-bit.
Mint Linux 17.2, Mate

FA Ferguson

JohnbCallander
Posts: 85
Joined: Mon Mar 01, 2010 3:31 pm

Re: Startup Error some success

Postby JohnbCallander » Tue Oct 13, 2015 9:51 pm

I have now installed 14.04 via Crouton on Chromebook. This seems to work without the startup error. I am running LXDE and will post any issues with this version as I come across them. I logged out and in twice without crashing the chroot. :D

Jim-J
SoftMaker Team
SoftMaker Team
Posts: 437
Joined: Fri Apr 04, 2014 8:29 am

Re: Startup Error

Postby Jim-J » Fri Oct 16, 2015 9:43 am

faferg wrote:"Error: SDL Engine initialization failed. Fallback to XRender/XLib forced."

As I opened each app, Textmaker, Planmaker, and Presentations, for the first time, I got this error message. After clicking through, each app has worked as expected. On shutdown and restart, the Errror message does not return, so this error is NOT getting in the way. Still, what does this error message mean?

ASUS EEE HE-1001 netbook, 32-bit.
Mint Linux 17.2, Mate

FA Ferguson


Hello,

the SDL-libary is a cross plattform for multimedia. The message means, it couldn't be loaded properly. Often the graphic-card driver can cause this error. Check if there is a newer one available.
Don't worry, it will work without SDL.
Jim J.
SoftMaker Software GmbH

dhalgren
Posts: 57
Joined: Sat Nov 06, 2010 6:27 am

Re: Startup Error

Postby dhalgren » Thu Nov 19, 2015 12:48 am

Hi. Using debian jessie, up to date, dependencies satisfied, (etc) and receive the following error message on start up:

Code: Select all

bruce@inana:~$ textmaker16
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast


This is close enough to the errors others have experienced, but there is no solution here. Please advise

EDIT: system is 64 bit, with hybrid graphics, running nouveau and, apparently, intel drivers. Please advise any further information which may be required.

User avatar
XL-Dennis
Posts: 176
Joined: Fri Jan 25, 2013 2:02 am

Re: Startup Error

Postby XL-Dennis » Thu Nov 19, 2015 1:43 pm

Hi Folks,

I just wanted to inform that I'm running SoftMaker 2016 with Zoring x64. It works great but there are some minor weird quirks.

In PlanMaker (my main evaluation target) submenu's text disappear when pointing at them and/or the icons. The same happens in TextMaker.

As with the already reported major issues these weird quirks seems also related to how SoftMaker Office deals with Graphics and rendering.
------------------------------------------------
Kind regards,
Dennis


Return to “General”

Who is online

Users browsing this forum: No registered users and 1 guest