Annoying behaviors of registered version

Help for TextMaker 2002 for Zaurus

Moderator: SoftMaker Team

Post Reply
User avatar
ZDevil
Posts: 14
Joined: Sun May 23, 2004 2:41 pm

Annoying behaviors of registered version

Post by ZDevil » Fri Jan 21, 2005 4:48 am

Hi,

I have purchased the full version of the program for C860 (Sharp ROM). However, three annoying problems are so persistent that I can't run it normally. :cry: :cry:

Problem #1:
Everytime I ran Textmaker, a screen kept popping up asking me to fill in my Home and Business information said to be made for document templates. Even though I filled them up, the empty forms returned at startup. (The program is not "fast-loaded".)

Problem #2:
I tried to configure the panel size and layout in "Extra-->Preferences". I chose small icon size and Win 98 style (which is said to make the program run more smoothly), but my setting failed to take any effect and everything remains as the default settings.

Problem #3:
I had to uninstall the program "twice" (!?) in order to get rid of the program. I did the uninstallation with the default Add/Remove. Strangely, although the program could be removed from RAM (as seen in System Info), it remained in the remove list. I had to reboot the machine and remove it the second time and the program was finally gone for good.

Have other users experiences these problems? Your input is most appreciated. Thank you very much!

User avatar
hg
SoftMaker Team
SoftMaker Team
Posts: 171
Joined: Mon Nov 24, 2003 12:49 pm
Location: Nürnberg, Germany

Post by hg » Tue Jan 25, 2005 12:01 pm

Your first two problems seems to be caused by insufficient rights in the configuration directory. Please make sure that you have writing permission in the folder TextMaker created on the first run - this would be the folder .softmaker in your home directory.
Concerning your third problem: the install and uninstall is handled by the system, but it seems some files were still in use and insofar TMZ could not be uninstalled completely.
Heiko Gibson
SoftMaker Development

"I love deadlines. I love the whooshing noise they make as they go by." - DNA

User avatar
ZDevil
Posts: 14
Joined: Sun May 23, 2004 2:41 pm

Post by ZDevil » Wed Jan 26, 2005 9:49 am

hg wrote:Your first two problems seems to be caused by insufficient rights in the configuration directory. Please make sure that you have writing permission in the folder TextMaker created on the first run - this would be the folder .softmaker in your home directory.
Concerning your third problem: the install and uninstall is handled by the system, but it seems some files were still in use and insofar TMZ could not be uninstalled completely.
So could you tell me how to "write the permission in the folder .Textmaker"?

Also if the system uninstallation fails to remove the app completely, is there another way to do this?

Thanks again.

ZDevil

User avatar
ZDevil
Posts: 14
Joined: Sun May 23, 2004 2:41 pm

Post by ZDevil » Fri Feb 04, 2005 5:10 pm

I just wonder if somebody could tell me if these problem are being worked on, or there are solutions already, or just no solution for the moment. I have bought the app for two months but am still unable to enjoy using it... pity

clofland
Posts: 7
Joined: Wed Dec 29, 2004 3:19 pm

Post by clofland » Fri Feb 04, 2005 6:52 pm

Hi Zdevil, I recognize your name from the ZUG. You might post this question over there. It seems like more of a system issue than a TextMaker issue.

File permissions can be fun in Linux.

As for TextMaker support, you might give us a command line to try? :)

I would venture to guess something like this might work from the console:

chmod -R a+rwx /home/zaurus/.softmaker

I know that is going a bit overboard, but it should open the permisions wide up and Textmaker should be able to save the settings.

User avatar
ZDevil
Posts: 14
Joined: Sun May 23, 2004 2:41 pm

Post by ZDevil » Sat Feb 05, 2005 11:46 am

Thank you so much, clofland!

I tried your command and got this error:

chmod: /home/zaurus/.softmaker/ofl.ini: Input/output error

Anyway, i will post the problems to ZUG.

Tobias-L
Posts: 3423
Joined: Fri Nov 21, 2003 3:23 pm
Location: Nürnberg, Germany
Contact:

Post by Tobias-L » Mon Feb 07, 2005 8:30 am

Did you close TextMaker before chmod the directory?
chmod -R 777 /home/zaurus/.softmaker
Tobias Leißner
SoftMaker Software GmbH


User avatar
ZDevil
Posts: 14
Joined: Sun May 23, 2004 2:41 pm

Post by ZDevil » Mon Feb 07, 2005 2:30 pm

Tobias-L wrote:Did you close TextMaker before chmod the directory?
chmod -R 777 /home/zaurus/.softmaker
Thanks for your reply.

Still no luck with chmod. It keeps reporting that there is an Input/output error.
:(
It seems my SL-C860 encounters a strange problem with Textmaker: even though I delete the program (twice actually in order to remove the name of the app from the Add/Remove uninstallation list), when I tried to delete the folder /home/zaurus/.software in the terminal with rm -r, an error occurred:

rm: unable to stat '/home/zaurus/.software/ofl.ini' : Input/output error
rm: unable to remove '/home/zaurus/.software/ofl.ini' : Directory not empty

Well, does this mean that Textmaker is always "hanging" in the system and there is no way to get rid of it completely? :cry:

Any suggestion? Thanks again.

ZDevil

clofland
Posts: 7
Joined: Wed Dec 29, 2004 3:19 pm

Post by clofland » Mon Feb 07, 2005 3:09 pm

I posted a reply to you over in the ZUG. I'm sure others will too.

I definitely think you've got a "system" issue here and not a "TextMaker" issue, though it is obvioulsy centering around TextMaker.

If we figure this out on the ZUG, we can post the answer back here for TextMaker's benefit. :wink:

User avatar
ZDevil
Posts: 14
Joined: Sun May 23, 2004 2:41 pm

Post by ZDevil » Wed Feb 09, 2005 9:47 am

Just a little update:

Now it appears that only Textmaker has the "fail to save settings/delete/uninstall" problem on my C860 (Sharp ROM), while other programs are behaving well.

If there is a file system corruption, maybe the last resort is to flash the ROM again. Oh no... :(

User avatar
ZDevil
Posts: 14
Joined: Sun May 23, 2004 2:41 pm

Post by ZDevil » Sat Feb 12, 2005 3:42 pm

Yet another update:

I tried to remove the directory ".softmaker" under "/home/zaurus/" with TreeExplorer!QT and the but in Terminal, but to no avail. The peculiar thing is there is only one file labeled "ofl.ini" in this directory, which can't be edited un terminal or other editors. And even though I can delete ofl.ini, I still cannot delete the directory. After switching to any other location and then going back to the directory, ofl.ini mysteriously reappears.

So far only Textmaker has behaved that strangely on my device. After all these weeks of waiting, I just hope that Textmaker or the developers can give me a minimal response to acknowledge my questions. Thank you.

ZDevil

User avatar
hg
SoftMaker Team
SoftMaker Team
Posts: 171
Joined: Mon Nov 24, 2003 12:49 pm
Location: Nürnberg, Germany

Post by hg » Tue Feb 15, 2005 9:41 am

Sorry, but it seems your file system has some problems.

ofl.ini is a file that is written once by TextMaker - when it is closed. It is not written while TextMaker is running.

So either TextMaker tries all the time continuously to write to this file (which would be an indicator that something with the file system is wrong, because it shouldn't take that long) or TextMaker has nothing to do with it (which means that somehow this file is corrupt).

In addition the behaviour of the uninstall is rather strange - we had reports that TM cannot be installed because it needs a lot of space, but never anything related to uninstall. So it seems that this is a kind of memory or file system problem.
Heiko Gibson
SoftMaker Development

"I love deadlines. I love the whooshing noise they make as they go by." - DNA

User avatar
ZDevil
Posts: 14
Joined: Sun May 23, 2004 2:41 pm

Post by ZDevil » Tue Feb 15, 2005 3:07 pm

Thank you very much.

A strange thing happened.

I today re-installed Textmaker and unchecked the "Execute with root privilege (not secure)" box in the GUI before running it for the first time. And then the program works again and it can save settings now.

Would it be possible that the strange problem I came across (a bug?) was due to running it with root privilege, resulting in system file writing error?

And still I can't remove the old .softmaker file containing the ofl.ini, even though I have moved the whole directory it to another location.

ZDevil

Post Reply

Return to “TextMaker 2002 for Zaurus”