Please Wait popup after every action in large document

Post your questions, bug reports and suggestions here for TextMaker Mobile for Android.

Moderator: SoftMaker Team

Post Reply
iancboswell
Posts: 1
Joined: Sat May 30, 2015 6:19 pm

Please Wait popup after every action in large document

Post by iancboswell » Sat May 30, 2015 6:23 pm

Whenever I try to edit large documents (~1MB, .doc) with TextMaker Mobile (latest version, Android), I get a "Please wait..." popup after performing any action, such as entering or deleting text. It is very irritating and makes it pretty much impossible to use. Is this a known limitation? Is there anything I can do on my end to prevent this behavior?

Thanks,
Ian

Jim-J
SoftMaker Team
SoftMaker Team
Posts: 437
Joined: Fri Apr 04, 2014 8:29 am

Re: Please Wait popup after every action in large document

Post by Jim-J » Mon Jun 01, 2015 3:20 pm

Hello,

it depends on the device you have. How good it performs. You can contact the manufactor of the device an ask if there is a firmware update available.
Also a device reset can help.
Actually, there is not much we can do.

You can try out the free SoftMaker Office HD Basic available at the Amazon App Shop https://www.amazon.com/gp/mas/get/andro ... mas_rw_gts
Jim J.
SoftMaker Software GmbH

jjwinthorp
Posts: 6
Joined: Sun Nov 08, 2015 7:45 pm

Re: Please Wait popup after every action in large document

Post by jjwinthorp » Sun Nov 08, 2015 8:22 pm

Jim - I have the same problem as outlined in the original post, and I don't think your idea about it being the device has anything to do with it. To be more specific about the problem, it doesn't just happen on 1mb size files, I get it after the length of the document passes roughly 1 1/2 pages, which equates to less than 10k of disk space in rtf format. The same document can also be opened on my device and used without any delays in Polaris Office, Turbo Editor, QuickEdit Text Editor, Jota Text Editor, Google Docs, and a few other text editors I downloaded to test. Since I have almost no other apps loaded on my Galaxy (no games whatsoever and the only apps I have are off when not in use and use no memory in the background), and have almost 1gb of RAM free, it wouldn't seem that the device should be having a problem writing a 4kb file to storage.

Another quirk I have discovered is that this is happening when writing the file to storage, not when it is being used. I think the original poster probably has his autosave feature activated, and the app is trying to save the file every time he makes a change to it. If I turn off the autosave feature, the popup never appears on its own, but it does still pop up and remain whenever I save the file manually. To solve that problem, I have discovered that rotating the phone 90 degrees makes the "Please wait..." pop up disappear. Another thing is that the file is being saved almost instantly, regardless of what the pop up says, because I have used the app while monitoring the phone's storage by linking it to a PC, and it appears instantly upon clicking the save command.

Not sure why the pop up is appearing, but it appears to be that the app is confused, and thinks it needs to wait for something to occur, but in fact nothing is occurring, so it just waits endlessly for something which will never happen. The problem is that it locks the whole app until the pop up goes away by rotating the screen 90 degrees, or closing it and reopening.

I would have your tech support people investigate this issue with longer than one page files to see if they can duplicate it on their devices. Since it is TextMaker MOBILE, do not try to solve the issue on a PC or notebook with 8GB of ram and a 512mb video card. Try it on a Galaxy or iPhone, which would represent roughly 90% of the entire world mobile market who might be using your product.

Will be interested to see what you discover.

P.S. I also have the Open GL Acceleration option enabled, but I'm not sure what that would do in a word processor. Could that be the problem with a long file that may be using a lot of hardware video RAM, rather than software based video RAM, which would be based on the full available RAM of the device? I think that option was enabled by default on the app. I may experiment with it and try turning the app's OpenGL option off and see if that cures the problem.

Cheers,

Jay

Jim-J
SoftMaker Team
SoftMaker Team
Posts: 437
Joined: Fri Apr 04, 2014 8:29 am

Re: Please Wait popup after every action in large document

Post by Jim-J » Mon Nov 09, 2015 9:20 am

Dear Jay,

Thanks you for the detail information. Did you try the successor TextMaker HD Basic: https://play.google.com/store/apps/deta ... asic&hl=de?

With TextMaker HD this shouldn't happen. If so, let us know.

Thank you.
Jim J.
SoftMaker Software GmbH

jjwinthorp
Posts: 6
Joined: Sun Nov 08, 2015 7:45 pm

Re: Please Wait popup after every action in large document

Post by jjwinthorp » Tue Nov 10, 2015 3:37 am

Hi Jim,

I looked at it briefly a few weeks ago when researching the above problem, and its screen seemed a bit chaotic. Absorbing it unsettled me. (Let's see how many Nomad quotes I can pack into this post... lol) Since you suggested it, I have already downloaded it to my phone and feel I must reevaluate it over the next few days. There is much to be considered before I return to Start Menu.

One thing I noticed right away is that the app seems to be geared more toward PC/laptop/tablet users with large screens than mobile users with <5" screens. My screen is just over 5" (very large for a phone), and the menu text and buttons are so small they are almost unreadable. Also, there are so many toolbars, rulers, and guides loaded by default that you had to set the default font size to 10 point, which is essentially unusable on a <5" screen. Since small buttons are pretty much unusable on a phone, and small text can't be seen, I turned all of the toolbars, rulers and guides off, set the display to Continuous mode and turned the word wrap on, set the zoom to 100%, disabled all of the nonstandard fonts (not sure if that matters on Android, but in Windows it uses RAM to load dozens of unnecessary fonts), and set the default font size to 14. I am pretty sure this has increased app efficiency by 57%, and made it look almost identical to "the other" (Textmaker Mobile).

On the good side of things, I notice that you have added an automatic keyboard feature, which is very much appreciated. It was somewhat annoying on "the other" to have to go to the View menu and turn it on every time I wanted to type something.

I will continue to use this app for a few days and see how it works for me. Like "the other," it too may be imperfect, but can be adjusted. Perfection being judged by my own relentless logic. lol

I'll let you know how it is working in a few days.

Cheers,

Jay

jjwinthorp
Posts: 6
Joined: Sun Nov 08, 2015 7:45 pm

Re: Please Wait popup after every action in large document

Post by jjwinthorp » Wed Nov 18, 2015 5:40 pm

Okay Creator Jim, here is what I have discovered so far:

It appears the problem in Mobile is the file format the device is using. That would also explain why everyone isn't having the problem. Since the problem is only appearing when users are dealing with "large" documents, large being characterized by having more than a page or so of text, that makes me think that those users are not using this application to take short notes or write brief messages, they are using it for a larger purpose, such as creating/editing large manuscripts or important original compositions. If that is the case, they in all likelihood are not going to want to only store and use the document on their phone. Therefore, they are almost certainly NOT using your proprietary tmd file format, because if they are going to store and/or use the document on a PC as well, it is very unlikely they are going to be doing that with your PC app, rather than Word or some other much more common PC text editor, such as Wordpad. I like the new TextMaker PC application you recommended in your previous post, but let's face it, around 90% of the world market share for PC word processing is held by MS Word. It just isn't a practical possibility to expect users to abandon it overnight and switch to a new and unique file format, especially if they ever have to give the file to anyone else. When it was first released, even MS Word had to make the wpd file format one of their top choices in Word's file format pick list, and they took great pains to stress Word's compatibility with WordPerfect, because of the dominance WP had over them at that time.

So anyway, before I get off on a non sequitur because my facts are uncoordinated, I decided to try a test creating a file in your file format, and then creating the same file in rtf and docx file formats. Sure enough, the one in tmd worked just fine even when it became a few pages long, but after a single page or so, the ones in rtf and docx gave the "Please wait" popup window many users have mentioned. I used the same creation technique for all three files, in case you were wondering, which was to start the file, save it in the appropriate format after starting it, and then dictate the rest of the text into the app.

Since it appeared to be the file format causing the trouble, I also did an experiment to check your docx created file against my PC's in Word 2013. To do this, I transferred a TextMaker Mobile rtf file to my PC, opened it in Word, and then saved it in both compatibility mode and non-compatibility modes in docx format, and then resaved it using Word 2013 in rtf format. I then opened the same file in TextMaker Mobile on my phone and saved it in your Word 2007-2013 docx format. The resulting file sizes were as follows: PC Word 2013 file in docx with NO compatibility - 11,957 bytes, PC Word 2013 file in docx with compatibility - 11,865 bytes, TextMaker Mobile phone file in Word 2007-2013 format - 8,583 bytes. PC Word 2013 file in rtf format - 1,295 bytes, TextMaker Mobile in rtf format - 43,724 bytes.

Since the file sizes are dramatically different between identical Word 2013 and TextMaker Mobile files, and since MS invented both of those file formats, I have to assume that their own application is saving them correctly, and yours may be making an error somewhere in its save, which then gets compounded in subsequent saves, which ultimately results in the error becoming so large that it exceeds the capability of the RAM or CPU resources of the phone. The rtf file size difference jumps right out at me too, because that file was only about 14 lines long, and shouldn't be saving at 43,724 bytes in TextMaker Mobile. With the docx file format, the file size difference is smaller, but still there. I'm also not sure why your docx file would be 40% smaller than an identical Word 2013 docx in compatibility mode. Something I do notice though, is that your compatibility mode specifies Word 2007-2013, which I'm not sure is a valid file format. A big docx file format change occurred in Word 2010, so Word 2007 files would not normally be compatible. In other words, 2010 and 2013 files are naturally compatible, but 2007 and before are not. Not sure if that would have any bearing on why the app is hanging, but I thought I would mention it.

So in conclusion. it appears that one workaround for people composing original documents on TextMaker Mobile is to simply use the proprietary tmd file format by default until they are finished creating the document, and then save a copy of the file in docx or rtf format once they are ready to move it to another device. I haven't done extensive testing of this yet, but in my short week long test with a few files, it worked with no errors. You may want to do your own research on this issue and solution.

On other subjects, I decided not to switch to the TextMaker HD app you suggested. The reason was fairly simple, in that I use TextMaker Mobile because of its simplicity (lack of useless features) and ease of use. Mobile is well suited for use on a small screen like a phone, whereas HD is not. The requirement to use a tiny menu bar at the top of the screen for simple commands like saving and exiting, rather than the menu button which is built into almost every mobile app (including TextMaker Mobile) makes the HD app seem cumbersome compared to its much leaner cousin Mobile. So I am going to stay with Mobile for now.

I would still appreciate you guys fixing the hang in it though.

Let me know if you have any questions.

Cheers,

Jay

jjwinthorp
Posts: 6
Joined: Sun Nov 08, 2015 7:45 pm

Re: Please Wait popup after every action in large document

Post by jjwinthorp » Tue Dec 01, 2015 2:23 pm

Hello Creator Jim,

My previous message was in error, but I'm not going to self-destruct, so don't get excited. I have discovered that changing the file format to tmd does not eliminate the Please Wait popup, it only delays it. I have also discovered that after the popup starts appearing with the tmd file format, if the file is then saved as a new file name (I have been adding a number to the end), it eliminates the waiting popups for a substantial period of time. So by using the tmd file format, you get a long delay before the popups appear, and then by rotating the phone to clear it and saving the file as a different file name, you eliminate the popups for an additional amount of time. So, that means using those two steps gives a good long while before the Please Wait popups become problematic.

Hopes this info gives you some good leads on where to start looking for the problem. I'm still baffled by what rotating the phone for a second has to do with anything.

Cheers,

Jay

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7780
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Please Wait popup after every action in large document

Post by sven-l » Mon Dec 07, 2015 11:11 am

Could you please send us a sample file together with the sminfo.txt from Menu=>Help=>About to forum@softmaker.de referring to this thread? Thank you!
Sven Leßmann
SoftMaker Software GmbH

jjwinthorp
Posts: 6
Joined: Sun Nov 08, 2015 7:45 pm

Re: Please Wait popup after every action in large document

Post by jjwinthorp » Sun Dec 20, 2015 12:46 am

Hi Sven,

Sorry I just saw your message, but am not sure what it means. This happens with every file which is more than about a page or so long, not just certain files, so you can just download or copy and paste any large document into a Textmaker Mobile file to see it.

You're also thinking about a different Textmaker app, because there is no Help menu on Textmaker Mobile. The About screen with the program information is under Menu > Tools. I sent the file you requested to the Email address you provided with your name in the subject line.

Please remember this is a problem that is happening on PHONES, so if you are unable to duplicate it on an 8GB 10" gaming tablet, try it on an Android phone, which is what the overwhelming majority of your users have.

Good luck,

Jay

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7780
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Please Wait popup after every action in large document

Post by sven-l » Mon Jan 04, 2016 5:09 pm

Ok, I will try that and inform the developers. Thank you!
Sven Leßmann
SoftMaker Software GmbH

jjwinthorp
Posts: 6
Joined: Sun Nov 08, 2015 7:45 pm

Re: Please Wait popup after every action in large document

Post by jjwinthorp » Sat Aug 13, 2016 3:37 am

Sven and/or Jim,

I believe I have discovered what is causing this problem, but do not know why (yet). The Please Wait hang does not happen unless the keyboard is visible. Since the keyboard is almost always visible when a user is composing a document, it therefore appears to be happening all the time. After I discovered the keyboard to be the problem, I confirmed it in the following way:

First, I composed a document that was just over one page long (the document length at which it always hangs), and then attempted to save it, which caused the expected hang. After clearing the hang by rotating the device (which also restarts the keyboard for the new screen shape), I tried another save and got another hang. After the second time, I tried it a third time and got a third hang. That's three consecutive hangs on the document. Then I turned the keyboard off in TextMaker by going to View > Keyboard and unchecking it.

With the keyboard now turned off, and still having the same document open that hung three times a moment ago, I tried saving it again. No hang on the same document/ Tried it a second time, and again no hang. Third time it still didn't hang. I also tried opening a 10+ page document with the keyboard off and saving it, and it also worked flawlessly.

So basically then, whenever the default Samsung keyboard is open and the TextMaker document length is more than one page, it hangs on every menu selection (anything from saves to edits), but with the keyboard shut off, everything works as it should, regardless of document length.

I have no idea why displaying the keyboard would be causing the application to hang, but could it be that your manual way of turning the keyboard on and off is somehow causing the app to lock up when the menu is used? The reason I mention this is that all apps I have seen for mobile devices activate the keyboard automatically, not manually. When you click in a place where text can be entered, the keyboard automatically appears, and there is no way to stop it. Since your app is unique in that it can disable the keyboard, I'm wondering whether the methodology you used to disable it is interfering in some way when the menu is used. Maybe when a save or other menu command is selected, it resets the screen or the blocking method you are using, and then your manual switch is trying to restart, but can't because the program is already loaded? Just a thought.

Post Reply

Return to “TextMaker Mobile for Android”