Synchronizing files

Help for TextMaker 2002 for Handheld PCs

Moderator: SoftMaker Team

Post Reply
John.Simons
Posts: 5
Joined: Sat Sep 24, 2005 12:02 am
Location: London

Synchronizing files

Post by John.Simons » Sat Sep 24, 2005 12:37 am

I am using Textmaker for Handheld PCs on a Compaq Aero 8000 and cannot synchronize files with my desktop. I do not seem to have a connection problem. Although ActiveSync reports that files have been synchronized, they do not appear on the desktop. I have tried reinstalling Textmaker but this had no effect. I would welcome advice.

mb
SoftMaker Team
SoftMaker Team
Posts: 267
Joined: Mon Nov 24, 2003 11:54 am
Location: Nürnberg, Germany
Contact:

Post by mb » Mon Sep 26, 2005 2:56 pm

You will find the answer in the Frequently Asked Questions, topic "How do I keep my TextMaker documents synchronized between Handheld PC and desktop PC?".
Martin Baumgärtner
SoftMaker Software GmbH

John.Simons
Posts: 5
Joined: Sat Sep 24, 2005 12:02 am
Location: London

Post by John.Simons » Mon Sep 26, 2005 3:42 pm

[quote="mb"]You will find the answer in the [url=http://www.softmaker.net/forum/viewtopic.php?t=8]Frequently Asked Questions[/url], topic "How do I keep my TextMaker documents synchronized between Handheld PC and desktop PC?".[/quote]

I did exactly what is prescribed in the FAQ. Active.Sync shows the progress of synchronizing and reports that files have been synchronized, but they do not appear on the desktop PC. They do not appear where they are supposed to appear, or anywhere else (I have used the search facility to look for them). Further advice welcome.

John Simons

mb
SoftMaker Team
SoftMaker Team
Posts: 267
Joined: Mon Nov 24, 2003 11:54 am
Location: Nürnberg, Germany
Contact:

Post by mb » Mon Sep 26, 2005 4:15 pm

Just to be sure: This only works when you 1. turn on the option to also sync files in the Activesync settings (which is off by default) and 2. save the files in the documents folder of your HPC. (Maybe this folder has a name different from "My Documents" on your device).

Please note that this feature of ActiveSync is completely independent from TextMaker and should work with any file that you copy to your HPC's document folder.
Martin Baumgärtner
SoftMaker Software GmbH

John.Simons
Posts: 5
Joined: Sat Sep 24, 2005 12:02 am
Location: London

Post by John.Simons » Tue Sep 27, 2005 11:39 am

Thank you.

Yes, syncfiles is turned on in the ActiveSync settings, and I am notified (incorrectly) that files are being transferred.

I do save to My Documents on the HPC, but here there may be a problem. When I installed Texmaker I chose to put it on a flash card. I assume this is why the files actually get installed in a folder within My Documents called Softmaker. Could this be the reason for the problem? If so, does it mean I have to reinstall and avoid using the flash card?

John Simons

mb
SoftMaker Team
SoftMaker Team
Posts: 267
Joined: Mon Nov 24, 2003 11:54 am
Location: Nürnberg, Germany
Contact:

Post by mb » Tue Sep 27, 2005 2:56 pm

If you have a flash card installed, you might have *two* My Documents folders: one in main memory (e.g. \My Device\My Documents), one on the flash card (e.g. \My Device\Memory Card\My Documents). ActiveSync is syncing only one of them (usually the folder on the card).

You don't have to reinstall TextMaker for that reason -- just choose the "other" My Documents folder when you save a file, and syncing should work.
Martin Baumgärtner
SoftMaker Software GmbH

John.Simons
Posts: 5
Joined: Sat Sep 24, 2005 12:02 am
Location: London

Post by John.Simons » Wed Sep 28, 2005 5:24 pm

I did as you suggested and saved to the 'other', but nothing was transferred. Now a new folder appears when I go to 'save as' on my device - called Synchonized files'. I thought this looked promising but when I saved to that, still nothing was transferred (though as usual ActiveSync reports that files have been synchronized).

John Simons

mb
SoftMaker Team
SoftMaker Team
Posts: 267
Joined: Mon Nov 24, 2003 11:54 am
Location: Nürnberg, Germany
Contact:

Post by mb » Fri Sep 30, 2005 1:51 pm

Yes, "Synchronized Files" is exactly the folder that is synchronized.

When you use your HPC's File Explorer to create e.g. a new folder inside this folder and then sync with your PC, this folder should also appear in the "<HPC Name> Synchonized Files" folder on the PC. Does that work?

If it does not, there seems to be some general (not TextMaker-related) problem with syncing. Have you tried downloading the latest version of ActiveSync from Microsoft's website? See http://www.microsoft.com/downloads/resu ... layLang=en
Martin Baumgärtner
SoftMaker Software GmbH

John.Simons
Posts: 5
Joined: Sat Sep 24, 2005 12:02 am
Location: London

Post by John.Simons » Fri Sep 30, 2005 7:23 pm

Thank you for all your helpful advice. ActiveSync does now seem to be working correctly. This is after reformatting the storage card and reinstalling Textmaker on it and removing the latest version of ActiveSync (3.8) and installing an earlier version (3.7.1). Again, thank you very much for your help.

JS

Post Reply

Return to “TextMaker 2002 for Handheld PCs”