Compose key support is broken

Post bug reports and suggestions for SoftMaker Office2012 for Linux.

Moderator: SoftMaker Team

Post Reply
valmi
Posts: 3
Joined: Fri Feb 13, 2009 5:56 pm

Compose key support is broken

Post by valmi » Tue Aug 14, 2012 3:19 pm

I have reported this in SoftMaker 2010 (revs 596 and 600), so I am not sure whether I should report it once more for 2012. I thought it would be less invasive to post a notice on the forum than send an email to support. ;-)
I'm using SoftMaker Office 2010 for Linux revision 596 with up-to-date
Debian Squeeze (6.0.3). Both TextMaker and PlanMaker are affected by
this (I don't know about Presentations).

The "Compose" key works for some sequences, but not for others. After
some testing, I feel confident saying that it works when the composed
character is ISO-8859-1, and doesn't work in other cases.

Example 1 : Compose + ' + E, prints É
Example 2 : Compose + , + E, prints nothing
Example 3 : Compose + - + - + . prints -.

All sequences work in all other X applications where I tested them.
Actually, typing a sequence in another application then copy-pasting
it in TextMaker works.

This is very annoying, as I often work in French and thus need the
letter Œ, which is unavailable on my keyboard other than as a
"Compose" key sequence.

Thus any help solving this will be greatly appreciated. :-)
I tried that in rev 668.809 and got the same results.

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7257
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Compose key support is broken

Post by sven-l » Tue Aug 14, 2012 3:35 pm

Thank you! I informed the developers.
Sven Leßmann
SoftMaker Software GmbH

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7257
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Compose key support is broken

Post by sven-l » Tue Aug 14, 2012 4:18 pm

I sent you an PM.
Sven Leßmann
SoftMaker Software GmbH

Post Reply

Return to “Public beta: General”