.xls not recognized any more

Help for PlanMaker 2004 for Windows

Moderator: SoftMaker Team

Post Reply
Loïc
Posts: 22
Joined: Thu Jun 24, 2004 3:43 pm
Location: Paris, France

.xls not recognized any more

Post by Loïc » Fri Nov 12, 2004 8:29 am

The same day, I have upgraded for PM rev 277 and Windows XP SP2. I don't which one is at fault, but SM softs are not recognized any more. When I try to "open with" a .xls file, it does not show me SM softs any more, neither PM nor TM. If I open the remove/modify softwares window, there is only one item for "Softmaker programs" but nothing specific for PM an TM.
What shall I do?

Please help quickly


Loïc

Tobias-L
Posts: 3423
Joined: Fri Nov 21, 2003 3:23 pm
Location: Nürnberg, Germany
Contact:

Post by Tobias-L » Fri Nov 12, 2004 8:31 am

Use the open with dialog, search for C:\Program Files\SoftMaker\Programme\pmw32.exe. Use this file for opening .xls files. Please be sure to check the option to always open this file type with the application you specified.
Tobias Leißner
SoftMaker Software GmbH


Loïc
Posts: 22
Joined: Thu Jun 24, 2004 3:43 pm
Location: Paris, France

Post by Loïc » Fri Nov 12, 2004 9:19 am

I did that of course, but it does not work. After I open "pmw32.exe", PM does not appear in the list of programs!
For your information, I have also OpenOffice.org, which I don't use often, but I want to have SM softs as standards. OpenOffice is still in the list and so .xls files are opened with it.
Another comment is that the .doc files open right with TM, so the problem is only with PM.

Tobias-L
Posts: 3423
Joined: Fri Nov 21, 2003 3:23 pm
Location: Nürnberg, Germany
Contact:

Post by Tobias-L » Fri Nov 12, 2004 10:36 am

This seems to be a Windows XP issue. Well, i use WinXP, too, but i don't have this issue. You can try to reinstall PlanMaker and reassociate all spreadsheets with PlanMaker.
Tobias Leißner
SoftMaker Software GmbH


Loïc
Posts: 22
Joined: Thu Jun 24, 2004 3:43 pm
Location: Paris, France

Post by Loïc » Fri Nov 12, 2004 11:06 am

I did it, but with no further success.....
Do you use XP SP2? It is "known" that there are some incompatibilities between SP2 and non-MicroSoft softwares.
Maybe one step to the solution is to disinstall OpenOffice...

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2871
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Post by martin-k » Fri Nov 12, 2004 11:09 am

OK, step by step...

1. Log in as Administrator or with administrative rights.
2. Run our PlanMaker setup program
3. On the last page, you can check whether to associate XLS files with PlanMaker. If you use a Windows CE/Windows bundle package, there are TWO checkboxes to check - one for Windows, one for Windows CE.
4. Complete the installation

-> XLS files will be associated with PlanMaker again.
Martin Kotulla
SoftMaker Software GmbH

Loïc
Posts: 22
Joined: Thu Jun 24, 2004 3:43 pm
Location: Paris, France

Post by Loïc » Fri Nov 12, 2004 11:29 am

That's exactly what I did. I just did it again with reboot, but without success.
You didn't comment on XP SP2. You confirm SM softs are compatible with?
Thanks

Tobias-L
Posts: 3423
Joined: Fri Nov 21, 2003 3:23 pm
Location: Nürnberg, Germany
Contact:

Post by Tobias-L » Fri Nov 12, 2004 12:10 pm

I use it on WinXP SP2 and don't have any problems. PlanMaker still shows up in the list of applications when using open with.
Tobias Leißner
SoftMaker Software GmbH


Loïc
Posts: 22
Joined: Thu Jun 24, 2004 3:43 pm
Location: Paris, France

Post by Loïc » Tue Nov 16, 2004 8:27 am

No way. I have uninstalled all spreadsheet applications and re-installed only PM and it is still not recognized as a normal program by XP, it is not in the list of programs in the "open with" menu. And it is not possible to add it by searching the appropriate file from this menu.
The problem is only to have .xls recognized as PM files, because otherwise PM works fine! I now have to open files from the menu of PM, which takes more time.

Do you have any idea to solve this?

Tanks

DogBoy
Posts: 3
Joined: Fri Dec 03, 2004 4:04 am
Location: Alabama USA

Post by DogBoy » Fri Dec 03, 2004 4:14 am

I am having this exact problem. I cannot get PlanMaker to recognize Excel files properly. I finally resorted to manully adding the association using the advanced method provided by Windows XP (I am also running service pack 2). I created actions for open, print, and printto just like existed for PlanMaker files. Now when I double click an Excel file I get three error dialogs indicating three different files could not be loaded. The files are: d:\documents.pmd, d:\Documents and Settings\Eric\My Documents\and.pmd, and d:\Documents and Settings\Eric\My Documents\My.pmd. The Excel file then loads correctly. I think I am very close to solving this problem, I just need to get rid of these dialogs. Could anyone help with the rest of the solution. I would be greatly appreciative. Thanks, Eric :x

Tobias-L
Posts: 3423
Joined: Fri Nov 21, 2003 3:23 pm
Location: Nürnberg, Germany
Contact:

Post by Tobias-L » Fri Dec 03, 2004 8:12 am

The file name of the file you want to open contains spaces, therefore PlanMaker thinks there are more than one file to open.

If you use
pmw32.exe %1
use this instead
pmw32.exe "%1"

You have to quote the first paramter so PlanMaker can see this is one file, even if there are spaces in it.
Tobias Leißner
SoftMaker Software GmbH


Loïc
Posts: 22
Joined: Thu Jun 24, 2004 3:43 pm
Location: Paris, France

Post by Loïc » Fri Dec 03, 2004 9:03 am

Great!!
It solves my problem!
Thanks
Loïc

Post Reply

Return to “PlanMaker 2004 for Windows”