New picture frame openson page 1, not on page I am editing

Post bug reports and suggestions here for the beta version of TextMaker 2012 for Windows.

Moderator: SoftMaker Team

Post Reply
David.Boettcher
Posts: 63
Joined: Thu Jan 06, 2011 5:42 pm

New picture frame openson page 1, not on page I am editing

Post by David.Boettcher » Fri Oct 21, 2011 3:15 pm

I'm not sure whether this is a bug or whether I have accidentally changed something.

I am working on a 15 page documents with lots of pictures. Everything was going OK, especially after my previous question when someone showed me how to anchor pictures to paragraphs :)

But now I have a problem. If I try to insert a new picture frame on page 12, the picture appears on page 1. If I drag it to page 12, when I let go it jumps back to page 1.

The only way to get it to stick to page 12 is to either change its properties to "Fix on page", drag it to page 12, and then change its properties back to "Move with text", or cut it from page 1 and paste it on page 12 in Object Mode.

But why does the new picture appear on page 1?

Regards - David

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7471
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: New picture frame openson page 1, not on page I am editi

Post by sven-l » Tue Oct 25, 2011 10:11 am

Hard to say without an example. Are the text wrapping options for this opject correct? Could you please send us an example file to forum(at)softmaker.de referring to this thread?
Sven Leßmann
SoftMaker Software GmbH

David.Boettcher
Posts: 63
Joined: Thu Jan 06, 2011 5:42 pm

Re: New picture frame openson page 1, not on page I am editi

Post by David.Boettcher » Tue Oct 25, 2011 10:26 am

sven-l wrote:Hard to say without an example. Are the text wrapping options for this opject correct? Could you please send us an example file to forum(at)softmaker.de referring to this thread?
Hi Sven,

Will do.

Regards - David

PS: You can't set any options for an object until after you have inserted it (so far as I am aware). It is while I am inserting it that the problem occurs - as soon as I have selected the picture file that I want to appear in the frame, the frame disappears from the page that i am looking at and appears on page 1.

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7471
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: New picture frame openson page 1, not on page I am editi

Post by sven-l » Wed Oct 26, 2011 11:10 am

This will work better in the next beta.
Sven Leßmann
SoftMaker Software GmbH

David.Boettcher
Posts: 63
Joined: Thu Jan 06, 2011 5:42 pm

Re: New picture frame openson page 1, not on page I am editi

Post by David.Boettcher » Wed Oct 26, 2011 12:07 pm

sven-l wrote:This will work better in the next beta.
Hi Sven,

Per an email "SoftMaker Office 2012: The second beta is here!" I have just downloaded and installed it and now Textmaker 2012 Beta is rev 644. The exact same thing happens still. Are you thinking of a further beta?

Regards - David

I have been thinking about this and I think that it didn't start happening until I once pressed the "Default" button in the "Picture: Properties" dialogue box.

I wanted the pictures I inserted to move with the text so I selected a picture and opened the "Picture: Properties" dialogue box, set "Object: Move with text" and "Anchor: Fix to paragraph" and set "Vertical position: Relative to: Paragraph". I then pressed the "Default" button at the bottom of the dialogue box, and I think that was when the problem started.

I have just gone back to the same document, selected a picture and opened the "Picture: Properties" dialogue box, set "Object: Fix on page" and "Anchor: Move with object" and set "Vertical position: Relative to: Page". I then pressed the "Default" button at the bottom of the dialogue box and this seems to have cured the problem. I just inserted a new picture, and it stayed just where I wanted it. But strangely, when I open the "Picture: Properties" dialogue box for the new picture, the properties are set to "Object: Move with text", not "Fix on page" that I set with the existing picture. The other properties are set to "Anchor: Move with object" and set "Vertical position: Relative to: Page" as I had set with the existing picture.

There is obviously something strange and complex going on here. It seems that it may be the "Anchor: Move with object" and set "Vertical position: Relative to: Page" that was causing the problem. Maybe when I inserted a new picture with these as the defaults settings, Textmaker didn't know where to put the anchor and so was putting it on the first page.

Also, I assumed that I knew what the "Default" button would do, but I don't think it does what I expected, and I can't find its use explained in the help file.

Regards - David

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7471
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: New picture frame openson page 1, not on page I am editi

Post by sven-l » Thu Oct 27, 2011 10:47 am

David.Boettcher wrote:
sven-l wrote:This will work better in the next beta.
Hi Sven,

Per an email "SoftMaker Office 2012: The second beta is here!" I have just downloaded and installed it and now Textmaker 2012 Beta is rev 644. The exact same thing happens still. Are you thinking of a further beta?
Yes, I meant the next beta version (not the current Beta 2).
Sven Leßmann
SoftMaker Software GmbH

Post Reply

Return to “Beta: TextMaker 2012 for Windows”