Lag in typing

Post bug reports and suggestions for TextMaker 2010 for Linux.

Moderator: SoftMaker Team

Post Reply
lawrencegoodman000
Posts: 14
Joined: Thu Jun 10, 2010 10:08 pm

Lag in typing

Post by lawrencegoodman000 » Thu Jun 17, 2010 5:07 pm

There is a significant delay between the time I type a key and the time it appears on the screen. Any way to fix this? Thanks.

lawrencegoodman000
Posts: 14
Joined: Thu Jun 10, 2010 10:08 pm

Re: Lag in typing

Post by lawrencegoodman000 » Thu Jun 17, 2010 5:12 pm

I see now this is a fairly common problem. I am using Ubuntu 10.04 with kernel 2.6.34 on an HP tx2. I don't have this problem with any other word processors. Too bad because otherwise, I really like this.

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7250
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Lag in typing

Post by sven-l » Fri Jun 18, 2010 8:05 am

Hello,

are you using revision 584 (Help=>About in TextMaker) or an older revision? Does the problem occur with every file or just with specific ones.
In Tools=>Options=>System you can disable/enable SHM and XIM. Does that help a bit?
Sven Leßmann
SoftMaker Software GmbH

lawrencegoodman000
Posts: 14
Joined: Thu Jun 10, 2010 10:08 pm

Re: Lag in typing

Post by lawrencegoodman000 » Mon Jun 21, 2010 3:27 pm

i am using the current version and unchecking xim did help. it doesn't allow me to uncheck the other one. it's grayed out.

Charamei
Posts: 1
Joined: Sun Jan 16, 2011 1:57 pm

Re: Lag in typing

Post by Charamei » Sun Jan 16, 2011 2:00 pm

I'm having the same problem on Ubuntu 10.04 with the demo revision 591. Turning off XIM hasn't helped; I can't uncheck the other. Is the paid version any better?

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7250
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Lag in typing

Post by sven-l » Mon Jan 17, 2011 12:59 pm

Revision 591 is still the current (newest available) revision of TextMaker 2010 for Linux. Please try it on antoher Linux distribution or with the next revision, as soon as available.
Sven Leßmann
SoftMaker Software GmbH

urlwolf
Posts: 8
Joined: Sun Feb 14, 2010 12:58 am

Re: Lag in typing

Post by urlwolf » Sun Apr 03, 2011 10:43 pm

I also have this problem. Sabayon linux 64. Textmaker 584, the latest available as a tgz.
Fonts look horrible with and without antialiasing. Scroll is jumpy. Overall, not a good experience at all.

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7250
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Lag in typing

Post by sven-l » Mon Apr 04, 2011 11:04 am

urlwolf wrote:I also have this problem. Sabayon linux 64. Textmaker 584, the latest available as a tgz.
Fonts look horrible with and without antialiasing. Scroll is jumpy. Overall, not a good experience at all.
I wrote you an PM.
Sven Leßmann
SoftMaker Software GmbH

JesterEric
Posts: 3
Joined: Tue Nov 08, 2011 5:20 am

Re: Lag in typing

Post by JesterEric » Tue Nov 08, 2011 4:11 pm

I am having this problem as well, using rev 596 on an ASUS EEE 900 celeron running Peppermint (based off Ubuntu 10.04). Lag also appears on my other netbook, EEE 1005PEB running Kubuntu 10.10. The document is 150+ pages, but there is no lag when running W7 and MS Word on the 1005.

I clicked off XIM, but cannot do so for SHM, that feature is grayed out.

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7250
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Lag in typing

Post by sven-l » Fri Nov 11, 2011 12:54 pm

Rev. 596 is the newest avaiable revision fo SoftMaker Office 2010 for Linux. Please wait for the next service pack which will fix more problems (currently there is no known release date yet for the next service pack).
Sven Leßmann
SoftMaker Software GmbH

wcn00
Posts: 1
Joined: Mon Apr 30, 2012 7:24 pm

Re: Lag in typing

Post by wcn00 » Tue May 01, 2012 10:48 pm

I'm a me to on this. My system is Ubutu 11.10. If I start a small blank document there doesn't seem to be a problem but when I open an 5 page MS word 2007 document and start typing the Textmaker quickly falls behind (by several seconds) and I see the cpu spinning up to 100% so its in loop doing something. When I stop typing and it catches up the cpu settles back to normal.
I've installed 597 (? I think, see above) and the latest which is 600. Same problem.
I haven't had much luck figuring out whats going on with strace and frankly I shouldn't have to. I paid for this!
wcn

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7250
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Lag in typing

Post by sven-l » Mon May 07, 2012 10:26 am

wcn00 wrote:I'm a me to on this. My system is Ubutu 11.10. If I start a small blank document there doesn't seem to be a problem but when I open an 5 page MS word 2007 document and start typing the Textmaker quickly falls behind (by several seconds) and I see the cpu spinning up to 100% so its in loop doing something. When I stop typing and it catches up the cpu settles back to normal.
I've installed 597 (? I think, see above) and the latest which is 600. Same problem.
I haven't had much luck figuring out whats going on with strace and frankly I shouldn't have to. I paid for this!
wcn
In Tools=>Options=>System you can disable/enable SHM and XIM. Does that help a bit?
Sven Leßmann
SoftMaker Software GmbH

Post Reply

Return to “TextMaker 2010 for Linux”