Annoying bug

This beta forum will be closed soon. Please post in the regular forum for PlanMaker 2010 for Windows.

Moderator: SoftMaker Team

MerleOne
Posts: 22
Joined: Sat Jun 16, 2007 11:16 pm

Annoying bug

Post by MerleOne » Sun Nov 22, 2009 11:53 pm

Hi,
I found a nasty bug in the 2008 version and guess what, it's also present in the 2010 version.

In the attached file, copy or cut the D3 cell in sheet 1, go to sheet 2, for instance in E5, and paste : crash each time. It's due to the absolute address in the D3 cell from the first sheet.

It's strange I didn't found it earlier...
Test bug copy cell.xls
How to recreate the bug !
(12.5 KiB) Downloaded 214 times
I hope this get fixed in both versions !

EricC
Posts: 212
Joined: Mon Oct 01, 2007 11:40 pm

Re: Annoying bug

Post by EricC » Tue Nov 24, 2009 3:26 am

MerleOne wrote:Hi,
I found a nasty bug in the 2008 version and guess what, it's also present in the 2010 version.

In the attached file, copy or cut the D3 cell in sheet 1, go to sheet 2, for instance in E5, and paste : crash each time. It's due to the absolute address in the D3 cell from the first sheet.

It's strange I didn't found it earlier...
Test bug copy cell.xls
I hope this get fixed in both versions !
With PM2010(rev566), I am not able to reproduce the problem. Nor am I able to reproduce the problem in PM2008.

User avatar
jimjutte
SoftMaker Volunteers
SoftMaker Volunteers
Posts: 848
Joined: Sun Oct 28, 2007 9:08 pm
Location: Wenzhou, China
Contact:

Re: Annoying bug

Post by jimjutte » Tue Nov 24, 2009 8:36 am

MerleOne,

The only thing I get is that the pasted value is an error... =C5/$C$3 provides #Num!

Is this what you mean by crashing?
Cheers
Jim

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7250
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Annoying bug

Post by sven-l » Tue Nov 24, 2009 8:58 am

Does not crash for me with the current Beta (rev. 566).
Sven Leßmann
SoftMaker Software GmbH

MerleOne
Posts: 22
Joined: Sat Jun 16, 2007 11:16 pm

Re: Annoying bug

Post by MerleOne » Tue Nov 24, 2009 9:15 am

sven-l wrote:Does not crash for me with the current Beta (rev. 566).
It does on my 2 XP PC, with PlanMaker 2008 & 2010.
Crash_PM2008.png
Crash_PM2008.png (10.1 KiB) Viewed 4573 times
It's sensitive to the way it's done. Here is a sample file
Crash.xls
(12.5 KiB) Downloaded 203 times
Here is how it happens. Open the crash.xls, D3 Cell from sheet 1 is selected. Just copy it by using Ctlr-C. Click on Sheet 2 tab, Cell D3 is also selected, paste the clipboard using Ctlr-V. Planmaker 2008 crashes each time.

If you cannot reproduce it on your side, what should I do ? Reinstall ? Thanks !

MerleOne
Posts: 22
Joined: Sat Jun 16, 2007 11:16 pm

Re: Annoying bug

Post by MerleOne » Tue Nov 24, 2009 9:16 am

jimjutte wrote:MerleOne,

The only thing I get is that the pasted value is an error... =C5/$C$3 provides #Num!

Is this what you mean by crashing?
Shouldn't this value rather be something like sheet1!C5/sheet1!$C$3 ? Unless the 3 initial cells are all copied together.

User avatar
jimjutte
SoftMaker Volunteers
SoftMaker Volunteers
Posts: 848
Joined: Sun Oct 28, 2007 9:08 pm
Location: Wenzhou, China
Contact:

Re: Annoying bug

Post by jimjutte » Tue Nov 24, 2009 9:25 am

Good point on the formatting... but no, I don't get that. I just get what I wrote here.

Sven, Martin,

Perhaps this can be logged as a bug regardless. If I copy from one sheet, it does not paste or paste special with the sheet address...
Cheers
Jim

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7250
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Annoying bug

Post by sven-l » Tue Nov 24, 2009 9:32 am

MerleOne wrote:
sven-l wrote:Does not crash for me with the current Beta (rev. 566).
It does on my 2 XP PC, with PlanMaker 2008 & 2010.
Crash_PM2008.png
It's sensitive to the way it's done. Here is a sample file
Crash.xls
Here is how it happens. Open the crash.xls, D3 Cell from sheet 1 is selected. Just copy it by using Ctlr-C. Click on Sheet 2 tab, Cell D3 is also selected, paste the clipboard using Ctlr-V. Planmaker 2008 crashes each time.

If you cannot reproduce it on your side, what should I do ? Reinstall ? Thanks !
Yes, please reinstall SoftMaker Office 2008 (rev. 505) and try it again. I cannot reproduce that crash with PlanMaker 2008 or 2010 even if I do it step by step like you wrote. If PlanMaker still crashes after a new installation and reboot of your machine I will report that to our developers.
Sven Leßmann
SoftMaker Software GmbH

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7250
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Annoying bug

Post by sven-l » Tue Nov 24, 2009 9:52 am

jimjutte wrote:Good point on the formatting... but no, I don't get that. I just get what I wrote here.

Sven, Martin,

Perhaps this can be logged as a bug regardless. If I copy from one sheet, it does not paste or paste special with the sheet address...
Jim,

I've reported that behavior to our devlelopers. Thank you!
Sven Leßmann
SoftMaker Software GmbH

MerleOne
Posts: 22
Joined: Sat Jun 16, 2007 11:16 pm

Re: Annoying bug

Post by MerleOne » Tue Nov 24, 2009 10:23 am

sven-l wrote:
Yes, please reinstall SoftMaker Office 2008 (rev. 505) and try it again. I cannot reproduce that crash with PlanMaker 2008 or 2010 even if I do it step by step like you wrote. If PlanMaker still crashes after a new installation and reboot of your machine I will report that to our developers.
Thanks. Should I uninstall it before ?

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2814
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: Annoying bug

Post by martin-k » Tue Nov 24, 2009 10:26 am

Yes. Else, the setup program will simply try to repair the installation. Better to start from scratch in this situation.
Martin Kotulla
SoftMaker Software GmbH

MerleOne
Posts: 22
Joined: Sat Jun 16, 2007 11:16 pm

Re: Annoying bug

Post by MerleOne » Tue Nov 24, 2009 10:44 am

OK, I'll do that and report what happens there. I'll also remove the old 2006 version that I have also installed. I just hope it doesn't mess up file associations...

MerleOne
Posts: 22
Joined: Sat Jun 16, 2007 11:16 pm

Re: Annoying bug

Post by MerleOne » Wed Nov 25, 2009 8:39 am

OK, I have done the following :
1/ Try to remove 2008 version, the uninstaller was broken !
2/ I re-installed again the 2008, in the same folder
3/ I uninstalled it
4/ I rebooted
5/ I installed the 2008 version, then the ofw505 patch and the French dictionary
6/ it still crashes when copying the '=A2/$A$1' cell in another empty sheet.

Sorry !

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7250
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: Annoying bug

Post by sven-l » Wed Nov 25, 2009 11:47 am

Ok, can you please check it with the current Beta of SoftMaker Office 2010? You can get it here:
http://www.softmaker.com/english/ofw10betareg_en.htm

Additionally please tell us your system information: CPU, exact Windows version. Does =1/0 crash, too?
Sven Leßmann
SoftMaker Software GmbH

MerleOne
Posts: 22
Joined: Sat Jun 16, 2007 11:16 pm

Re: Annoying bug

Post by MerleOne » Wed Nov 25, 2009 9:22 pm

Will try and let you know. In the mean time, it crashes equally well when I copy the following formula '=A2/A1' on an empty sheet.

Thanks for your support.

Post Reply

Return to “Beta: PlanMaker 2010 for Windows”