High CPU Usage When Typing

Post bug reports and suggestions for TextMaker 2008 for Linux.

Moderator: SoftMaker Team

Jake
Posts: 59
Joined: Sat Jan 03, 2004 12:21 am

High CPU Usage When Typing

Postby Jake » Sun Jun 26, 2011 3:39 pm

I use purchased copies of Softmaker in my Jornada 720, Zaurus, and Windows Mobile. However, with Textmaker 2008 for Linux in Puppy Linux 4.31 on Asus EEE 900 and Sony Vaio Picturebook, I find that typing really bumps up the CPU usage.

Googling shows that Ubuntu users employ a command:

textmaker -graphicssytem raster

I can't get this command to run in Puppy Linux.

Are there any workarounds to this typing issue? Everything else works wonderfully.

Thanks,
Jake

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7059
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: High CPU Usage When Typing

Postby sven-l » Tue Jun 28, 2011 12:54 pm

Please invoke Tools=>Options=>System and enable or disable SHM and XIM. Does that help?

Edit: I think that these options only exist in TextMaker 2010 but not in TextMaker 2008. Please try it with the demo version:
http://www.softmaker.com/english/ofldemo_en.htm
Sven Leßmann
SoftMaker Software GmbH

Jake
Posts: 59
Joined: Sat Jan 03, 2004 12:21 am

Re: High CPU Usage When Typing

Postby Jake » Tue Jun 28, 2011 1:28 pm

SM 2008 has SHM enable/disable capability, but I didn't find any difference. Or if there was, disabling SHM made it a little worse.

Can you give me a list of console arguments for starting textmaker? Maybe one of those will help.

Jake

sven-l
SoftMaker Team
SoftMaker Team
Posts: 7059
Joined: Wed Apr 09, 2008 8:26 am
Location: Nuremberg
Contact:

Re: High CPU Usage When Typing

Postby sven-l » Tue Jun 28, 2011 4:32 pm

I have a list of program parameters for the Windows version but most of them should also work under Linux:

Program [parameter] [file name]

Parameter:
/q"printer name" : print file on that printer (printto)
/p : print document (print)
/debug : activate debug mode
/n : open without document
/manager : open without document and call document manager

Parameter for TextMaker:

/f : fax file

Parameter für PlanMaker:

/sep: Separator for CSV import (z.B. sep:,)
/oem: character set when using CSV-Import (e.g. oem, oem:1 oder oem:0)

Parameter for Presentations:

/s: show presentation only in presentations mode
Sven Leßmann
SoftMaker Software GmbH

Jake
Posts: 59
Joined: Sat Jan 03, 2004 12:21 am

Re: High CPU Usage When Typing

Postby Jake » Tue Jun 28, 2011 5:16 pm

Thanks for the list. In Linux, using "-" instead of "/" those commands work, but not for the typing issue.

Have you ever been able to use this command:

textmaker -graphicssytem raster


Thanks,
Jake

martin-k
SoftMaker Team
SoftMaker Team
Posts: 2712
Joined: Fri Nov 21, 2003 4:57 pm
Location: Nürnberg, Germany
Contact:

Re: High CPU Usage When Typing

Postby martin-k » Tue Jun 28, 2011 5:20 pm

Jake wrote:Thanks for the list. In Linux, using "-" instead of "/" those commands work, but not for the typing issue.

Have you ever been able to use this command:

textmaker -graphicssytem raster


Thanks,
Jake

No, this is a command-line option that is not and has never been supported by TextMaker or SoftMaker Office.
Martin Kotulla
SoftMaker Software GmbH

Jake
Posts: 59
Joined: Sat Jan 03, 2004 12:21 am

Re: High CPU Usage When Typing

Postby Jake » Tue Jun 28, 2011 5:42 pm

It must be an Ubuntu-specific command (I'm not familiar with Ubuntu):

http://evolution-systems.co.uk/?p=471

That link shows others' dilemma with typing/cpu spike.

Jake


Return to “TextMaker 2008 for Linux”

Who is online

Users browsing this forum: No registered users and 2 guests